You are on page 1of 4

GRUPO SER EDUCACIONAL

GRADUAÇÃO EAD
GABARITO
AV2-2016.2B – 03/12/2016

Disciplina PROGRAMAÇÃO DE COMPUTADORES


Professor (a) RICARDO BAUDEL

GABARITO

1 2 3 4 5 6 7 8 9 10

B C B D E D A C D D
QUESTÕES COMENTADAS

1. Considerando que o usuário informou o valor de a) 120


A como sendo 40 e o valor de B como sendo 100, b) 0
qual a resposta correta para o valor final de C no c) 50
algoritmo abaixo? d) 20
e) -140
algoritmo “A,B,C” Alternativa correta: Letra B.
var Identificação do conteúdo: estrutura de Seleçao –
A,B,C : real Guia de Estudos UNIDADE 1 página 15.
Inicio Comentário: o caminhamento da estrutura SE não
Escreval(“informe o valor de A”) carrega a variável C, que sai com o valor zero.
leia(A)
Escreval(“informe o valor de B”)
leia(B) 2. Vimos que a estrutura SE está presente em
diversas linguagens como a estrutura
se A + B > 140 então IF...THEN...ELSE.
se A – B > 20
C:= A – 2*B Analise a estrutura abaixo executada no Visualg:
senao
se B – A > 30 então Algoritmo “verificandoestruturaSE”
C:= A + B Var
senao valor: inteiro
C : = 2*A inicio
se C > 50 então Escreval(“informe um valor entre 0 e 1000”)
C := C - 10 leia(valor)
fimse se (valor<=60) então
fimse escreval(“informe um novo valor”)
fimse leia(valor)
fimse fimse
fimalgoritmo se valor>=90 então
se (valor>=100) e (valor<=200) então

Página 1 de 4
DISCIPLINA: PROGRAMAÇÃO DE COMPUTADORES PROFESSOR (A): RICARDO BAUDEL

escreval(“primeira faixa de valores”) Comentário: o caminhamento na estrutura de


senao repetição resulta no valor 300.
escreval(“segunda faixa de valores”)
fimse 4. Analise o algoritmo abaixo e depois selecione a
senao alternativa incorreta. Suponha que o usuário
escreval(“terceira faixa de valores”) informou a letra X para o time.
fimse
fimse Var
FIMALGORITMO time : literal
Inicio
Considere que no algoritmo acima o usuário Escreval(“informe a primeira letra do nome do seu
digitou o valor 20 e depois 85 para o número. Qual time”)
a mensagem que o programa vai emitir ? Leia(time)
se time = “a” entao
a) Vai emitir a mensagem “primeira faixa de valores”. escreval(“ time a ”)
b) Vai emitir a mensagem “segunda faixa de senao
valores”.
c) Vai emitir a mensagem “terceira faixa de se time = “b “ entao
valores”. escreval(“ time b”)
d) Vai emitir a mensagem “primeira faixa de valores” senão
e em seguida “terceira faixa de valores”. escreval(“ outro time”)
e) Não vai emitir mensagem. fimse
Alternativa correta: letra C. fimse
Identificação do conteúdo: Guia de Estudos fimalgoritmo
UNIDADE 1 página 15
Comentário: o caminhamento na estrutura de seleção a) Se o usuário digitar “x” para o time o programa
leva à expressão “terceira faixa de valores” exibe o texto “outro time”.
b) Se o usuário digitar “a” para o time o programa
exibe o texto “time a”.
3. Analise o programa abaixo escrito na linguagem c) Se o usuário digitar “b” para o combustível o
do visualg e depois marque a alternativa correta. programa exibe o texto “ro time b”.
d) Apenas se o usuário digitar “x” para o time o
VAR programa não exibirá nenhum texto.
i ,totalgeral : inteiro e) Não sendo a ou b para qualquer coisa que o
inicio usuário digitar o programa exibe o texto “outro
totalgeral := 0 time” .
para i := 200 ate 100 passo -20 faca Alternativa correta: letra D.
se i >= 150 entao Identificação do conteúdo: GUIA DE ESTUDOS,
totalgeral := totalgeral - 20 UNIDADE 1 , PÁG. 15.
senao Comentário: qualquer letra diferente de “a” ou “b”
totalgeral:= totalgeral + i resulta em “outro time”
fimse
fimpara 5. A construção de algoritmos segue passos, que
devem ser realizados na ordem correta. Afinal, a
Com qual valor a variável totalgeral fica ao final da sequência de passos para a construção de
execução do programa ? algoritmos é também um algoritmo. Considerando
esses passos, analise sequência abaixo e depois
a) 200 escolha a ordem correta.
b) 300
c) 400 1- Definir o processamento, ou seja, quais
d) 500 operações serão efetuadas e quais as restrições
e) 600 para essas operações. O processamento
Alternativa correta: Letra B. deve transformar os dados de entrada em dados de
Identificação do conteúdo: Guia De Estudos, saída e também verificar quais objetos são
Unidade 2 , Pág. 2. responsáveis pelas atividades.

Página 2 de 4
DISCIPLINA: PROGRAMAÇÃO DE COMPUTADORES PROFESSOR (A): RICARDO BAUDEL

2- Definir os dados de entrada, ou seja, quais dados b) Basta declarar como uma variável simples.
serão fornecidos e quais objetos fazem parte do c) É o mesmo que CHAR.
cenário do problema. d) Não há como trabalhar com strings em C.
3- Entender o problema a ser resolvido e destacar e) Basta converter de qualquer outro tipo para string.
os pontos mais importantes e os objetos que o Alternativa correta: Letra A.
compõem. Identificação do conteúdo: guia de estudos, unidade
4- Definir os dados de saída, ou seja, quais dados 4, pág 3.
serão gerados depois do processo. Comentário: a implementação de Strings é feita com
5- Testar o algoritmo realizando simulações vetores de CHAR em C.
corrigindo possíveis erros.
6- Construir o algoritmo. 8. Suponha que você queira fazer uma repetição
determinada em C, começando de 1 e indo até 40
Qual a ordem correta dos itens acima ? de 5 em 5. qual seria o comando adequado ?

a) 1,2,3,4,5,6 a) for (i=1; i<=40; i = i + 5)


b) 4,3,2,1,5,6 b) for (i=1; int i<=40; i = i + 5)
c) 3,1,2,6,5,4 c) for (int i=1; i<=40; i = i + 5)
d) 2,3,1,5,6,4 d) for (i=1; i<=40; int i = i + 5)
e) 3,2,1,4,6,5 e) for (i==40; i>=1; i == i + 5)
Alternativa correta: letra E. Alternativa correta: letra C.
Identificação do conteúdo: Guia De Estudos, Identificação do conteúdo: Guia de estudos, unidade
Unidade 1 , Pág. 6 4 , pág 4
Comentário: a ordem dos passos inicia pelo Comentário: conforme a sintaxe de C, a letra C é a
entendimento do problema, em seguida pela correta.
identificação dos dados de entrada, e assim
sucessivamente. 9. Sobre as estruturas de repetição e seleção em C,
escolha abaixo a alternativa incorreta.
6. Quanto aos operadores lógicos, é incorreto dizer
que : a) Existem 3 estruturas de repetição em C: For,
while e do.
a) o operador “E” ou && é usado quando as duas b) A estrutura IF pode ser combinada com estruturas
expressões lógicas ligadas por ele devem de repetição.
acontecer de forma simultânea. c) A estrutura While serve para repetições
b) o operador “OU” ou || é usado quando as duas determinadas ou indeterminadas.
expressões lógicas ligadas por ele devem d) não é possível colocar um IF dentro de uma
acontecer de forma simultânea ou ao menos uma estrutura While.
delas deve ser verdadeira. e) é possível encadear essas estruturas de várias
c) o operador “NAO” ou ! é usado para inverter o formas.
resultado de uma sentença lógica. Alternativa correta: Letra D.
d) o operador “E” ou && é usado sozinho, ou Identificação do conteúdo: Guia de estudos, unidade
seja, não permite combinações entre ele e 4, pág 4.
outros operadores. Comentário: as estruturas são intercaláveis, portanto a
e) no operador “OU”, a probabilidade de uma alternativa D está errada.
expressão lógica dar verdadeiro é maior do que
no operador “E”, na maioria das vezes.
Alternativa correta: Letra D.
Identificação do conteúdo: Guia de estudos, unidade
1, pág 15.
Comentário: O operador “E“ é usado com outros
operadores, se necessário.

7 . Quanto ao uso de Strings em C, escolha a


alternativa correta.

a) Deve ser declarado como um vetor de CHAR.

Página 3 de 4
DISCIPLINA: PROGRAMAÇÃO DE COMPUTADORES PROFESSOR (A): RICARDO BAUDEL

10. analise o programa abaixo na linguagem C e


depois escolha a alternativa incorreta.

#include <stdio.h>
main() {
char cidade[100];
int idade;
for (int i =1; i <= 5; i++){
printf("Informe o nome da cidade e a seguir tecle
ENTER\n");
scanf ( "%101[^\n]", cidade);
printf("O nome da cidade é foi %s \n ", cidade);
getchar();
}
}

a) O programa recebe e lista 5 nomes de cidades.


b) O programa faz uma repetição determinada.
c) O programa usa um vetor de char para armazenar
o string.
d) O programa vai travar na hora da leitura.
e) O comando de leitura da cidade coloca os
caracteres em cada posição do vetor.
Alternativa correta: letra D.
Identificação do conteúdo: Guia de estudos, unidade
4 , pág 7.
Comentário: o programa não trava.

Página 4 de 4