You are on page 1of 1

Randul 1 Randul 2

1.Structura repetitiva cu numar necunoscut de pasi cu test final. Sintaxa, 1.Structura repetitiva cu numar necunoscut de pasi cu test initial. Sintaxa,
descriere, exemplu. 1,5p descriere, exemplu. 1,5p
2.Scrieti urmatoarea expresie in forma acceptata de calculator: 1p 2.Scrieti urmatoarea expresie in forma acceptata de calculator: 1p

x 2 - 3x + 1 x 2 - 3x
2x +1 2x + 3
3.Evaluati urmatoarele expresii: 3.Evaluati urmatoarele expresii:
a) 9 mod 2 >0 and not (16 div5 = 3 ) or 3 ^ 3 < 30 1p a) 7 div 2 >0 and not (10 div3 = 3 ) or 3 ^ 3 >20 1p
b) 17 – 2 * 5 + 14 mod 3 1p b) 21 + 13 mod 3 – 3*5 1p

4.Scrieti conditiile pentru ca valoarea unei variabile a sa fie: 4.Scrieti conditiile pentru ca valoarea unei variabile a sa fie:
a) divizibila cu 3 dar nu si cu 5. 0,75p a) divizibila cu 4 sau cu 6. 0,75p
b) numar negativ sau impar 0,75p b) numar pozitiv si nedivizibil cu 3 0,75p
c) cu 2 cifre 0,75p c) cu 3 cifre 0,75p
d) numar par 0,75p d) numar impar 0,75p

5. Fie secventa de program: 5. Fie secventa de program:


citeşte a,n; citeşte a,n;
pentru i←1,n execută pentru i←1,n execută
dacă i%2=0 atunci a←a-i*i; dacă i%3=0 atunci a←a+i * 2;
altfel a←a+i*i; altfel a←a-3;
sfarsit_daca; sfarsit_daca;
sfarsit_pentru; sfarsit_pentru;
scrie a; scrie a;
a) Scrieţi valoarea care se afişează dacă pentru a se citeşte valoarea 30, c) Scrieţi valoarea care se afişează dacă pentru a se citeşte valoarea 25,
iar pentru n se citeşte valoarea 6. 1p iar pentru n se citeşte valoarea 6. 1p
b) Inlocuiti structura repetitiva pentru cu o structura repetitiva de alt tip. d) Inlocuiti structura repetitiva pentru cu o structura repetitiva de alt tip.
0,5p 0,5p