You are on page 1of 8

1.

float promedio(int valores[], int cantidad) {


2. int i;
3. float suma = 0.0;
4.
5. for (i = 0; i < cantidad; ++i)
6. suma += valores[i];
7.
8. return suma / (float) cantidad;
9. }
10.
11.
12. int main() {
13.
14. int notas[10];
15. char nombre[20];
16. char opcion[3];
17. int n, i;
18.
19. do {
20. printf("Ingrese nombre del alumno: ");
21. scanf("%s", nombre);
22.
23. printf("Cuantas notas tiene %s? ", nombre);
24. scanf("%d", &n);
25.
26. for (i = 0; i < n; ++i) {
27. printf(" Nota %d: ", i + 1);
28. scanf("%d", &notas[i]);
29. }
30.
31. printf("El promedio de %s es %.1f\n", nombre, promedio(notas, n));
32.
33. printf("Desea calcular mas promedios (si/no)? ");
34. scanf("%s", opcion);
35.
36. } while (opcion[0] == 's' || opcion[0] == 'S');
37.
38. return 0;
39. }
1. import java.util.Random;
2.
3. public class MatrizNumerosAleatorios {
4.
5. public static void main(String[] args) {
6. int[][] matrizNumeros = new int[3][3];
7. inicializar(matrizNumeros);
8. visualizar(matrizNumeros);
9. }
10.
11. static void inicializar(int[][] matriz){
12. Random r = new Random();
13. for(int i=0;i<matriz.length;i++){
14. for(int j=0;j<matriz[i].length;j++){
15. matriz[i][j] = r.nextInt(25) + 1;
16. }
17. }
18. }
19.
20. static void visualizar(int[][] matriz){
21. for(int i=0;i<matriz.length;i++){
22. for(int j=0;j<matriz[i].length;j++){
23. System.out.print(matriz[i][j] + "\t");
24. }
25. System.out.println();
26. }
27. }
28. }
1. import java.util.Scanner;
2.
3. public class Main {
4.
5. public static void main(String args[]) {
6. Scanner teclado = new Scanner(System.in);
7. double contadores[];
8. int numeros_aleatorios[];
9. int tamaño;
10. System.out.println("Escribe un numero para el tamaño del arreglo");
11. tamaño = teclado.nextInt();
12. numeros_aleatorios = new int[tamaño];
13. contadores = new double[5];
14. for (int i=0;i<tamaño;i++) {
15. int aleatorio = (int) (Math.random() * 20) + 1;
16. numeros_aleatorios[i] = aleatorio;
17. System.out.println(numeros_aleatorios[i]);
18. if (numeros_aleatorios[i]>=0 && numeros_aleatorios[i]<5) {
19. contadores[0] = contadores[0]+1;
20. } else if (numeros_aleatorios[i]>=5 && numeros_aleatorios[i]<=5) {
21. contadores[1] = contadores[1]+1;
22. } else if (numeros_aleatorios[i]>5 && numeros_aleatorios[i]<7) {
23. contadores[2] = contadores[2]+1;
24. } else if (numeros_aleatorios[i] >7 && numeros_aleatorios[i] <=9){
25. contadores[3] = contadores[3]+1;
26. } else if (numeros_aleatorios[i]>9) {
27. contadores[4] = contadores[4]+1;
28. }
29. }
30. for (int i=0;i<=4;i++) {
31. switch (i) {
32. case 0:
33. System.out.println("Deficientes (0-5): "+contadores[i]);
34. break;
35. case 1:
36. System.out.println("Regulares (6-10): "+contadores[i]);
37. break;
38. case 2:
39. System.out.println("Buenos (11-15): "+contadores[i]);
40. break;
41. case 3:
42. System.out.println("Excelentes (16-20): "+contadores[i]);
43. break;
44. }
45. }
46. }
47.
48.
49. }
Proceso arreglos_

//Constantes usadas

MINIMO = -100

MAXIMO = 100

FORMA_1 = 1

FORMA_2 = 2

//Pedimos la longitud de los arreglos

Escribir "Escribe una longitud"

leer longitud_arreglos

//Dimensiones de los arreglos

Dimension A(longitud_arreglos)

Dimension B(longitud_arreglos)

Dimension C(longitud_arreglos)

arreglo_A_rellenado = FALSO

arreglo_B_rellenado = FALSO

opcion_menu = 0

Repetir

//Menu

Escribir "1. Llenar Vector A de forma aleatoria";

Escribir "2. Llenar Vector B de forma aleatoria";

Escribir "3. Realizar C = A + B";

Escribir "4. Realizar C = B - A";

Escribir "5. Mostrar arreglo";

Escribir "6. Salir";


//elijo una opcion del menu

Escribir "Elige una opcion"

leer opcion_menu

salir = FALSO

Segun opcion_menu Hacer

//Opciones del menu

1:

//relleno el arreglo A

llenarArreglo(A, longitud_arreglos, MINIMO, MAXIMO)

arreglo_A_rellenado = VERDADERO

Escribir "el arreglo A ha sido rellenado"

2:

//relleno el arreglo B

llenarArreglo(B, longitud_arreglos, MINIMO, MAXIMO)

arreglo_B_rellenado = VERDADERO

Escribir "el arreglo B ha sido rellenado"

3:

Si arreglo_A_rellenado Y arreglo_B_rellenado Entonces

//relleno el arreglo C

rellenarC(A, B, C, longitud_arreglos, FORMA_1)

Escribir "el arreglo C ha sido rellenado"

Sino

Si no arreglo_A_rellenado Entonces

Escribir "Tienes que rellenar el arreglo A"

Fin Si

Si no arreglo_B_rellenado Entonces

Escribir "Tienes que rellenar el arreglo B"


Fin Si

Fin Si

4:

Si arreglo_A_rellenado Y arreglo_B_rellenado Entonces

//relleno el arreglo C

rellenarC(A, B, C, longitud_arreglos, FORMA_2)

Escribir "el arreglo C ha sido rellenado"

Sino

Si no arreglo_A_rellenado Entonces

Escribir "Tienes que rellenar el arreglo A"

Fin Si

Si no arreglo_B_rellenado Entonces

Escribir "Tienes que rellenar el arreglo B"

Fin Si

Fin Si

5:

//Submenu

opcion_submenu = 0

Repetir

Escribir "Escribe que arreglo quieres mostrar"

Escribir "1. A"

Escribir "2. B"

Escribir "3. C"

Escribir "4. Salir"

leer opcion_submenu

salir_submenu = FALSO

//mostrar arreglos

Segun opcion_submenu Hacer

1:
mostrarArreglo(A, longitud_arreglos)

2:

mostrarArreglo(B, longitud_arreglos)

3:

mostrarArreglo(C, longitud_arreglos)

4:

salir_submenu = Verdadero

De Otro Modo:

Escribir "Elige alguna de las opciones"

Fin Segun

Mientras Que no salir_submenu

6:

salir = VERDADERO

De Otro Modo:

Escribir "Escribe una opcion entre 1 y 6"

Fin Segun

Mientras Que no salir

FinProceso

//rellena el arreglo

Subproceso llenarArreglo ( arreglo Por Referencia, longitud_arreglos, min, max )

Para i<-0 Hasta longitud_arreglos-1 Con Paso 1 Hacer

arreglo(i) <- Aleatorio(min,max)

Fin Para

Fin subproceso

//Muestra un arreglo concreto

Subproceso mostrarArreglo ( arreglo Por Referencia, longitud_arreglos)

Para i<-0 Hasta longitud_arreglos-1 Con Paso 1 Hacer

escribir arreglo(i) , " " Sin Saltar


Fin Para

Escribir ""

Fin subproceso

//Rellena el arreglo C

subproceso rellenarC ( arregloA Por Referencia, arregloB Por Referencia,arregloC Por


Referencia,longitud_arreglos, tipo )

Si tipo = 1 Entonces

//punto 3

Para i<-0 Hasta longitud_arreglos-1 Con Paso 1 Hacer

arregloC(i) = arregloA(i) + arregloB(i)

Fin Para

Sino

//punto 4

Para i<-0 Hasta longitud_arreglos-1 Con Paso 1 Hacer

arregloC(i) = arregloB(i) - arregloA(i)

Fin Para

Fin Si

Fin subproceso