You are on page 1of 22

Configuración Básica de un Router Cisco

Configurar un router, al principio, parece una tarea complicada. Con el paso del tiempo,
aprendiendo los comandos, sus funciones y configurando, nos vamos a dar cuenta que no lo
es para nada, todo lo contrario, termina siendo un proceso simple, mecánico.
Este tutorial solo contiene la configuración básica de un router, la que deberemos realizar
siempre, sin importar que protocolos de enrutamiento o servicios configuremos después.
Comencemos.

Los routers tienen varios Modos y Submodos de configuración.

Modo Exec Usuario: Este modo solo permite ver información limitada de la configuración
del router y no permite modificación alguna de ésta.

Modo Exec Privilegiado: Este modo permite ver en detalle la configuración del router
para hacer diagnósticos y pruebas. También permite trabajar con los archivos de
configuración del router (Flash - NVRAM).

Modo de Configuración Global: Este modo permite la configuración básica de router y


permite el acceso a submodos de configuración específicos.

NOMBRAR AL ROUTER

router> enable
router# configure terminal
router(config)# hostname RouterA (nombra al router como)
RouterA(config)#

CONFIGURAR CONTRASEÑAS "ENABLE SECRET" Y "ENABLE PASSWORD"

RouterA> enable
RouterA# configure terminal
RouterA(config)# enable secret contraseña * (configura contraseña Enable Secret)
RouterA(config)# enable password contraseña (configura contraseña Enable Password)
RouterA(config)#

* Es recomendable configurar Enable Secret ya que genera una clave global cifrada en el
router.

CONFIGURAR CONTRASEÑA DE CONSOLA

RouterA> enable
RouterA# config terminal
RouterA(config)# line con 0 (ingresa a la Consola)
RouterA(config-line)# password contraseña (configura contraseña)
RouterA(config-line)# login (habilita la contraseña)
RouterA(config-line)# exit
RouterA(config)#

CONFIGURAR CONTRASEÑA VTY (TELNET)

RouterA> enable
RouterA# config terminal
RouterA(config)# line vty 0 4 (crea las 5 líneas VTY, pero podría ser una sola. Ej: line vty
0)
RouterA(config-line)# password contraseña (contraseña para las 5 líneas en este caso)
RouterA(config-line)# login (habilita la contraseña)
RouterA(config-line)# exit
RouterA(config)#

CONFIGURAR INTERFACES ETHERNET ó FAST ETHERNET

RouterA> enable
RouterA# config terminal
RouterA(config)# interface fastethernet 0/0 * (ingresa al Submodo de Configuración de
Interfaz)
RouterA(config-if)# ip address 192.168.0.1 255.255.255.0 (configura la IP en la interfaz)
RouterA(config-if)# no shutdown (levanta la interfaz)
RouterA(config-if)# description lan (asigna un nombre a la interfaz)
RouterA(config-if)# exit
RouterA(config)#

* Tener en cuenta que la interfaz puede ser Ethernet o Fast Ethernet y que el número de
interfaz puede ser 0, 1, 0/0, 0/1, etc. Esto varía según el router.

CONFIGURAR INTERFACES SERIAL COMO DTE

RouterA> enable
RouterA# config terminal
RouterA(config)# interface serial 0/0 * (ingresa al Submodo de Configuración de Interfaz)
RouterA(config-if)# ip address 10.0.0.1 255.0.0.0 (configura la IP en la interfaz)
RouterA(config-if)# no shutdown (levanta la interfaz)
RouterA(config-if)# description red (asigna un nombre a la interfaz)
RouterA(config-if)# exit
RouterA(config)#

* Tener en cuenta que el número de interfaz puede ser 0, 1, 0/0, 0/1, etc. Esto varía según el
router.
CONFIGURAR INTERFACES SERIAL COMO DCE

RouterB> enable
RouterB# config terminal
RouterB(config)# interface serial 0/1 * (ingresa al Submodo de Configuración de Interfaz)
RouterB(config-if)# ip address 10.0.0.2 255.0.0.0 (configura la IP en la interfaz)
RouterB(config-if)# clock rate 56000 (configura la sincronización entre los enlaces)
RouterB(config-if)# no shutdown (levanta la interfaz)
RouterB(config-if)# description red (asigna un nombre a la interfaz)
RouterB(config-if)# exit
RouterB(config)#

* Tener en cuenta que el número de interfaz puede ser 0, 1, 0/0, 0/1, etc. Esto varía según el
router.

También te puede interesar ver:


Comandos Cisco IOS - 1
Comandos Cisco IOS - 2
Ejercicios Resueltos en Packet Tracer

Se graba la configuración actual y que esta corriendo a la memoria nvram

- copy running-config startup-config


- wr (es forma rapida de salvar la configuracion)

En caso de que se realice una configuración se puede probar y si no funciona


se puede recuperar sin haberla salvado en nvram

- copy startup-config running-config

Se respalda la configuracion en servidor de TFTP


- copy running-config tftp
- Address or name of remote host []? 192.168.7.2
- Destination filename [RouterA]?
!!
3883 bytes copied in 1.792 secs (2167 bytes/sec)

Se recupera desde el servidor de tftp


- copy tftp running-config tftp
- Address or name of remote host []? 192.168.7.2
- Source filename []? RouterA-confg
- Destination filename [running-config]?
- Accessing tftp://192.168.7.2/RouterA-confg…..
- Loading netlearning2-confg from 192.168.7.2 (via fastEthernet0/0):!!
- [ok – 4089 bytes]
Listado Basico de comandos de configuración de routers

MODO EXEC USUARIO


Comando Descripción
connect Permite conectarse remotamente
{dirección_ip|nombre} a un host
Desconecta una sesión telnet
disconnect conexión
establecida desde el router
Ingresa al modo EXEC
enable
Privilegiado
logout Sale del modo EXEC
Envía una petición de eco para
ping
diagnosticar la conectividad
{dirección_ip|nombre}
básica de red
Resume una sesión telnet
resume conexión interrumpida con la secuencia
CTRL+SHIFT+6 y X
Muestra el intervalo entre
publicaciones CDP, tiempo de
show cdp
validez y versión de la
publicación
show cdp entry Muestra información acerca de un
[*|nombre_dispositivo] dispositivo vecino registrado en
[protocol|version]} una tabla CDP
Muestra información acerca de
show cdp interfaces
las interfaces en las que CDP está
[tipo número]
habilitado
Muestra los resultados del
show cdp neighbors
proceso de descubrimiento de
[tipo número] [detail]
CDP
show clock Muestra la hora y fecha del router
Muestra el historial de comandos
show history
ingresados
Muestra una lista en caché de los
show hosts
nombres de host y direcciones
Muestra un breve resumen de la
show ip interface brief información y del estado de una
dirección IP
Muestra el contenido de la base
show ip rip database
de datos privada de RIP
Muestra el contenido de la tabla
de enrutamiento IP. El parámetro
dirección permite acotar la
información que se desea
visualizar, exclusivamente a la
show ip route
dirección ingresada. El parámetro
[dirección |protocolo]
protocolo permite indicar la
fuente de aprendizaje de las
rutas que se desean visualizar,
como por ejemplo rip, igrp, static
y connected
Muestra las conexiones Telnet
show sessions
establecidas en el router
Muestra información sobre el
show version
Cisco IOS y la plataforma
telnet Permite conectarse remotamente
{dirección_ip|nombre} a un host
Reactiva las funciones de edición
terminal editing
avanzada
terminal history size Establece el tamaño del buffer del
numero_líneas historial de comandos
Deshabilita las funciones de
terminal no editing
edición avanzada
Muestra la ruta tomada por los
traceroute dirección_ip
paquetes hacia un destino

MODO EXEC PRIVILEGIADO


Comando Descripción
Restaura los contadores de tráfico
clear cdp counters
CDP a cero
Elimina la tabla CDP de información
clear cdp table
de los vecinos
Despeja los contadores de las
clear counters
interfaces
Carga información de configuración
configure memory
de la NVRAM
Configura la terminal manualmente
configure terminal
desde la terminal de consola
Copia la imagen del sistema desde
copy flash tftp la memoria Flash a un servidor
TFTP
copy running-config Guarda la configuración activa en la
startup-config NVRAM
copy running-config Almacena la configuración activa en
tftp un servidor TFTP
Descarga una nueva imagen desde
copy tftp flash un servidor TFTP en la memoria
Flash
Carga la información de
copy tftp runnig-
configuración desde un servidor
config
TFTP
Muestra información recibida de
debug cdp adjacency
vecinos CDP
Muestra información sobre eventos
debug cdp events
CDP
Muestra información CDP específica
debug cdp ip
de IP
Muestra información relacionada a
debug cdp packets
los paquetes CDP
Muestra todos los eventos IGRP que
debug ip igrp events se están enviando y recibiendo en
el router.
Muestra las actualizaciones IGRP
debug ip igrp
que se están enviando y recibiendo
transactions
en el router
Muestra información sobre las
debug ip rip actualizaciones de enrutamiento RIP
mientras el router las envía y recibe
Muestra las actualizaciones de
debug ip rip [events] enrutamiento RIP a medida que se
las envía y recibe
Sale del modo EXEC Privilegiado
disable
hacia el modo EXEC Usuario
Borra el contenido de la memoria
erase flash
Flash
erase startup-config Borra el contenido de la NVRAM
Desactiva todas las depuraciones
no debug all
activadas en el dispositivo
reload Reinicia el router
Entra a la facilidad de Diálogo de
setup
configuración inicial
Muestra el contenido de todas las
show access-lists ACL en el router. Para ver una lista
[Nro_ACL|Nom- específica, agregue el nombre o
bre_ACL] número de ACL como opción a este
comando
Muestra la asignación de
show arp direcciones IP a MAC a Interfaz del
router
Muestra los contadores CDP,
incluyendo el número de paquetes
show cdp traffic
enviados y recibidos, y los errores
de checksum
Muestra información importante
show controllers
como que tipo de cable se
serial [número]
encuentra conectado
Muestra información acerca de los
show debugging tipos de depuraciones que están
habilitados
Muestra la disposición y contenido
show flash
de la memoria Flash
show interfaces [tipo Muestra estadísticas para la/las
número] interfaces indicadas
show ip interface Muestra los parámetros de estado y
[tipo número] globales asociados con una interfaz
Muestra los parámetros y estado
show ip protocols
actual del proceso de protocolo de
[summary]
enrutamiento activo
Muestra estadísticas acerca de la
show memory memoria del router, incluyendo
estadísticas de memoria disponible
Muestra información acerca de los
show processes
procesos activos
Muestra los protocolos de capa 3
show protocols
configurados
Muestra la configuración actual en
show running-config
la RAM
Muestra las conexiones Telnet
show sessions
establecidas en el router
Controla el uso de la pila de
procesos y rutinas de interrupción y
show stacks
muestra la causa del último
rearranque del sistema
Muestra la configuración que se ha
show startup-config guardado, que es el contenido de la
NVRAM
Si se utiliza una sesión por telnet
para examinar el router, entonces,
terminal monitor permite redirigir el resultado y los
mensajes del sistema hacia a
terminal remota
Desactiva todas las depuraciones
undebug all
activadas en el dispositivo

MODO DE CONFIGURACIÓN GLOBAL


Comando Descripción
Crea o agrega una
sentencia de condición a la
ACL que permitirá o
access-list Nro_ACL
denegará los paquetes que
{permit|deny} Origen
llegan desde un Origen.
Este último parámetro
puede ser una dirección IP
más una máscara wildcard,
la palabra host más una
dirección IP o el wildcard
any
Crea o agrega una
sentencia de condición a la
ACL que permitirá o
denegará los paquetes que
lleguen desde un Origen y
vayan hacia un Destino.
Proto identifica el protocolo
a verificar. Origen y Destino
pueden ser una dirección IP
access-list Nro_ACL
más una máscara wildcard,
{permit|deny} Proto Origen
la palabra host más una
Destino [Operador
dirección IP o el wildcard
Nro_puerto]
any. Operador puede ser lt
[established][echo |echo-
(menor que), gt (mayor
reply]
que), eq (igual a) o neq
(distinto a). Nro_puerto
indica el puerto TCP o UDP.
El parámetro established
permite el paso de tráfico
cuando hay una sesión
establecida. En el caso del
protocolo ICMP se puede
utilizar echo o echo-reply.
Configura un cartel con un
Banner motd #mensaje del
mensaje del día. Ej: banner
día#
motd #Bienvenido#
Especifica que el router
boot system flash
cargue el IOS desde la
[nombre_imagen_IOS]
Flash
Ej: boot system flash
c2500-IOS
Especifica que el router
boot system rom
cargue el IOS desde la ROM
Especifica que el router
boot system tftp cargue el IOS desde un
nombre_imagen_IOS servidor TFTP. Ej: boot
dir_IP_server_tftp system tftp c2500-IOS
24.232.150.1
Habilita CDP globalmente
cdp run
en el router
Modificar la fecha y hora del
clock set hh : mm : ss mes
router. Ej: clock set
día año
12:31:00 July 12 2004
Cambia los valores del
config-register
registro de configuración.
valor_registro_configuración
Ej: config-register 0x2142
Establece una contraseña
local para controlar el
enable password contraseña acceso a los diversos
niveles de privilegio. Ej:
enable password class
Especifica una capa de
seguridad adicional
enable secret contraseña mediante el comando
enable password. Ej: enable
secret class
Modifica el nombre del
hostname nombre
router. Ej: hostname Lab_A
Configura un tipo de
interfaz y entra al modo de
interface tipo número
configuración de interfaz.
Ej: interface ethernet 0
Permite crear una ACL
nombrada. Se debe indicar
ip access-list el tipo. Este comando
{tandard|extended} ingresa al router al
Nombre submodo de configuración
que puede reconocerse por
el prompt
Permite que el router no
tome en cuenta los límites
con definición de clases de
ip classless las redes en su tabla de
enrutamiento y
simplemente transmita
hacia la ruta por defecto
Establece una ruta por
ip default-network
defecto. Ej: ip default-
dirección_red
network 210.32.45.0
ip domain-lookup Habilita la conversión de
nombre a dirección en el
router
Crea una entrada de
nombre a dirección estática
ip host nombre_host dir_ip1 en el archivo de
... Dir_ip8 configuración del router. Ej:
ip host Lab_A 192.168.5.1
210.110.11.1
Permite que el router actúe
ip http server como servidor Web http
limitado
Especifica las direcciones de
hasta seis servidores de
ip name-server dir_ip1 ...
nombres para su uso para
Dirip6
la resolución de nombres y
direcciones.
Ip route dirección_red Establece rutas estáticas.
máscara dir_ip_salto Ej: ip route 210.42.3.0
[distancia_administrativa] 255.255.255.0 211.1.2.1
Identifica una línea
específica para la
configuración e inicia el
line tipo número modo de reunión de
comandos de configuración.
Ej: line console 0 ó line vty
04
Inicia un proceso de
router enrutamiento definiendo en
protocolo_de_enrutamiento primer lugar un protocolo
[nro_AS] de enrutamiento IP. Ej:
router rip ó router igrp 120
Habilita la función de
service password-encryption
cifrado de la contraseña

SUBMODO DE CONFIGURACIÓN DE LÍNEA


Comando Descripción
En las líneas VTY, asigna una lista
access-class Nro_ACL
de control de acceso a las
in
conexiones establecidas via Telnet
Habilita la verificación de
login
contraseña en el momento de la
conexión.
password Asigna la contraseña a ser solicitada
[contraseña] en el momento de la conexión

SUBMODO DE CONFIGURACIÓN DE INTERFAZ


Comando Descripción
Establece un valor de ancho de
bandwidth Kbps banda para una interfaz. Ej:
bandwidth 64
Habilita Cisco Discovery Protocol en
cdp enable
una interfaz
Especifica el tiempo de espera antes
cdp holdtime
de ser enviada la siguiente
segundos
actualización CDP
Especifica la frecuencia con que son
cdp timer segundos
envíadas actualizaciones CDP
Configura la velocidad de reloj para
las conexiones de hardware en
interfaces seriales, como módulos
clock rate velocidad
de interfaz de red y procesadores
de interfaz a una velocidad de bits
aceptable. Ej: clock rate 56000
Agrega una descripción a la
description
interfaz. Ej: description Conectada
descripción
a Internet
Asigna la ACL indicada a la interfaz,
ip access-group ya sea para que verifique los
Nro_ACL [in|out] paquetes entrantes (in) o los
salientes (out)
Asigna una dirección y una máscara
ip address
de subred e inicia el procesamiento
dirección_ip
IP en una interfaz. Ej: ip address
mascara_red
192.168.52.1 255.255.255.0
Para deshabilitar el balanceo de
no ip route-cache carga por destino, que está
habilitado por defecto
Deshabilita el horizonte dividido en
no ip split-horizon la interfaz, que por defecto se
encuentra habilitado. Para volver
habilitarlo utilice el comando ip
split-horizon
no shutdown Reinicia una interfaz desactivada
shutdown Inhabilita una interfaz

SUBMODO DE CONFIG. DEL PROT. DE ENRUTAMIENTO


Comando Descripción
Permite modificar el máximo de
maximum-paths
rutas sobre las que balanceará la
valor
carga
Permite modificar los valores de las
constantes utilizadas para el cálculo
de las métricas de las rutas en el
metric weights tos k1
protocolo de enrutamiento IGRP.
k2 k3 k4 k5
Los valores por defecto son: tos
(tipo de servicio)= 0; k1= 1; k2=
0; k3= 1; k4= 0 y k5= 0
Como RIP es un protocolo de tipo
broadcast, el administrador de la
red podría tener que configurarlo
para que intercambie información
neighbor dirección_ip de enrutamiento en redes no
broadcast, como en el caso de las
redes Frame Relay. En este tipo de
redes, RIP necesita ser informado
de otros routers RIP vecinos
Asigna una dirección de rd a la cual
el router se encuentra directamente
conectado, lo que hara que se envíe
network y reciba publicaciones de
dirección_red enrutamiento a través de esa
interfaz, además de que dicha sea
publicada a los routers vecinos. Ej:
network 210.45.2.0
Regresa los temporizadores a los
no timers basic
valores por defecto
El router no enviará información de
passive-interface tipo enrutamiento por la interfaz
número indicada. Ej: passive-interface serial
0
redistribute static Si se asigna una ruta estática a una
interfaz que no está definida en el
proceso RIP o IGRP, mediante el
comando network, no será
publicada la ruta a menos que se
especifique este comando
Indica la frecuencia con la que RIP
o IGRP envían actualizaciones y los
intervalos de los temporizadores.
Actualización: intervalo en
segundos a la que se envían las
actualizaciones (RIP: 30 seg; IGRP:
90 seg).
Inválida: Intervalo de tiempo en
segundos después del cual una ruta
se declara no válida. Sin embargo,
la ruta todavía se utiliza para el
envío de paquetes (RIP: 180 seg;
timers basic IGRP: 270 seg).
Actualización Espera: Intervalo en segundos
Inválida Espera durante el cual se suprime la
Purga [Suspensión] información de enrutamiento que se
refiere a las mejores rutas (RIP:
180 seg; IGRP: 280 seg).
Purga: Intervalo de tiempo en
segundos que debe transcurrir
antes de que la ruta se elimine de
la tabla de enrutamiento (RIP: 240
seg; IGRP: 630 seg).
Suspensión: Intervalo en
milisegundos en que se posponen
las actualizaciones de enrutamiento
de cuando se produce una
actualización flash. Sólo IGRP.
El valor de variación determina si
IGRP aceptará rutas de costo
desigual. Sólo aceptará rutas
variance valor iguales a la mejor métrica local
para el destino multiplicado por el
Valor de variación. El valor puede
variar de 1 (por defecto) a 128

COMANDOS DE EDICIÓN Y OTROS


Teclas / Comando Descripción
Permite desplazarse al principio de
Ctrl+A
la línea de comandos
Permite desplazarse una palabra
Esc+B
hacia atrás
Ctrl+B (o Flecha Permite desplazarse un carácter
Izquierda) hacia atrás
Permite desplazarse hasta el final
Ctrl+E
de la línea de comandos
Ctrl+F (o Flecha Permite desplazarse un carácter
Derecha) hacia delante
Ctrl+P (o Flecha Muestra el último comando
Arriba) ingresado
Ctrl+N (o Flecha
Muestra el comando más reciente
Abajo)
Completa el comando ingresado
(tecla Tabulador)
parcialmente
Estando en cualquier modo de
Ctrl+Z (o end) configuración regresa al modo EXEC
Privilegiado
Cancela la ejecución del Dialogo de
Ctrl+C
configuración inicial o Setup
Permite interrumpir intentos de
Ctrl+Shift+6 ping, traceroute y traducciones de
nombres
Estando en el modo de
configuración global o cualquiera de
sus submodos regresa al modo
exit
anterior. Estando en los modos
EXEC Usuario o EXEC Privilegiado,
cierra la sesión
Router
Identificación de los 5 estados del comando show interfaces serial para la
solucion de fallas en interfaces seriales

Serial 1 is up, line protocol is up

Esta es la condición normal.

Serial 1 is down, line protocol is down (DTE mode)

Esto quiere decir que el router no detecta la señal de CD.

El problema esta en el proveedor de servicios

Serial 1 is up, line protocol is down (DTE mode)

El router local esta mal configurado

Serial 1 is up, line protocol is down (DCE mode)

No se ha colocado el comando clockrate


Serial 1 is up, line protocol is up (looped)

Existe un bucle en el circuito.

Serial 1 is up, line protocol is down (disabled)

Saturacion de errores

Serial 1 is administratively down, line protocol is down

Existe una ip duplicada

router

Enlaces patrocinados

Seleccionar Mes Seleccionar

Identificación de los 5 estados del comando show interfaces serial para la


solucion de fallas en interfaces seriales

Serial 1 is up, line protocol is up

Esta es la condición normal.

Serial 1 is down, line protocol is down (DTE mode)

Esto quiere decir que el router no detecta la señal de CD.

El problema esta en el proveedor de servicios

Serial 1 is up, line protocol is down (DTE mode)

El router local esta mal configurado

Serial 1 is up, line protocol is down (DCE mode)

No se ha colocado el comando clockrate

Serial 1 is up, line protocol is up (looped)

Existe un bucle en el circuito.


Serial 1 is up, line protocol is down (disabled)

Saturacion de errores

Serial 1 is administratively down, line protocol is down

Existe una ip duplicada

Troubleshoting o resolucion de los problemas caracteristicos de una


interfaz de serie en routers cisco
por Diana | No hay comentarios
Archivado en: Redes WAN Palabras Claves: cisco, router

Hay un comando que sirve para verifivar ciertos aspectos y es:

show interfaces serial

El resultado es: "Encapsulation ????"

Este comando muestra 1 de 5 estados.

Que se explican este artículo.

También existe otro comando que es:

show controllers

Permite diagnosticar problemas en las interfaces seriales.

Nos puede decir si el estado del cable es conectado o no.

Lo correcto es EIA TIA 449 o V.35

Por ejemplo si se muestra UNKNOWN como resultado entonces el cable esta conectado
incorrectamente.
Nota 1.- line protocol is down (disabled)

Los antiguos sistemas y aplicaciones de telefonía no estaban diseñadas para las necesidades comerciales actuales. No se
actualizan fácilmente, tienen problemas para soportar la movilidad y cada vez son más caras de mantener.

Ahora puede actualizar su antiguo sistema y obtener beneficios vitales gracias a la solución Cisco Unified Communications.

Actúe ahora y puede reunir los requisitos para obtener importantes ahorros cuando desee actualizar su sistema, incluyendo créditos
para canje, precios especiales para los servicios de Cisco de primer nivel y asistencia técnica.

Líder en comunicaciones de voz y video en red, Cisco Unified Communications puede ayudarlo a:

 reducir los gastos mensuales operativos y administrativos

 mejorar la experiencia de sus clientes y la productividad de su personal


Cisco Discovery Protocol (CDP)
16 08 2008

CDP es un protocolo de nivel de enlace, que permite obtener información


sobre dispositivos cisco conectados directamente, lo que es útil para troubleshooting y
documentación.

Obteniendo CDP timer y Holdtime.

Con el comando show cdp obtenemos información sobre dos parámetros que pueden
configurarse en los dispositivos Cisco:

1. CDP timer: indica cada cuanto se trasnmiten los paquetes CDP.


2. CDP holdtime: cantidad de tiempo que el dispositivo guardará los paquetes recibidos de
sus “vecinos”.

Los podemos cambiar con cdp timer/holdtime, o deshabilitar completamente con no cdp
run.

Obteniendo información de un “vecino”.

El comando show cdp neighbor nos muestra para cada interfaz de nuestro router: el
hostname del dispositivo conectado, la interfaz del mismo, información sobre si se trata de
un router, switch o repetidor y el modelo.
También disponemos de show cdp neighbors detail que además de lo anterior, nos
muestra la IP y la version de IOS de los dispositivos conectados. Con show cdp entry *
obtendremos la misma salida, pero tenemos dos opciones añadidas protocols y version,
para obtener sólo los datos que buscamos.

Con el comando show cdp traffic vemos información del trafico, incluyendo los paquetes
CDP. Y con show cdp interface vemos información para cada interfaz que esté usando
CDP (podemos deshabilitarlo con el comando no cdp enable).

Con la ayuda de estos comandos podemos documentar la topología de una red desconocida!

Comentarios : 4 Comentarios »

Categorías : Redes, Routers

Realizar un backup y restaurar Cisco IOS


14 08 2008

Antes de actualizar o restaurar la Cisco IOS, debería hacerse una copia del archivo actual, a
un host por TFTP (basta con conectar un portátil con un servidor TFTP a una interfaz
Ethernet).

1. Verificar que hay espacio suficiente en la memoria flash del router para la nueva imagen,
con el comando show flash.
2. Backup: comprobaremos conectividad con el host haciendo ping 1.1.1.2. Copiaremos la
IOS mediante copy flash tftp, entonces nos pedirá el archivo a copiar y dirección del host
remoto, ej. 1.1.1.2.
3. Restore o upgrade: primero deberemos asegurarnos que el archivo que queremos dejar
en la flash del router, se encuentra en el directorio default del TFTP (en el host).
Simplemente deberemos descargarlo mediante copy tftp flash (preguntará de nuevo la ip
y nombre del archivo).

Ya sólo queda reiniciar el router y comprobar la versión IOS con un show version.

Comentarios : Deja un Comentario »

Categorías : Redes, Routers

Recuperar password router Cisco


13 08 2008
1. El primer paso es interrumpir la secuencia de arranque con Crtl-Break, para entrar al
modo ROM monitor.
2. Cambiar el registro de configuración (según modelo):

1. Cisco ISR/2600: con el comando config-register 0×2142 y reiniciar reset.


2. Cisco 2500: entrar al menu de configuración del registro escribiendo o. A continuación
cambiarlo introduciendo o/r 0×2142. Para reiniciar escribir I.
3. De esta forma, arrancará sin usar el archivo startup-config, por lo que preguntará si
queremos entrar en modo setup, a lo que responderemos no y entraremos en modo
privilegiado con enable.
4. Ahora escribimos copy startup-config running-config. Con lo que tenemos la
configuración en RAM y estamos en modo privilegiado, pero no podemos ver el password
al estar encriptado. Para cambiarlo: config t y enable secret tunuevopassword.
5. Ahora debemos dejar el registro de configuración del router como estaba config-register
0×2102. Guardar la nueva configuración copy running-config startup-config, reiniciar con
reload y LISTO!.

Comentarios : 4 Comentarios »

Categorías : Redes, Routers

Diagnóstico de una interfaz


11 08 2008

Al ejecutar show interface veremos el estado de la línia X. El primer parámetro se refiere a


la capa física, mientras el segundo hace refecencia a la capa de enlace:

 X is up, line protocol is up: estado OK.


 X is up, line protocol is down: problemas de clocking (keepalive). Revisar keepalives en los
dos extremos y asegurarse de que coinciden, que si es necesario está configurado la clock
rate y que el tipo de encapsulamiento es el mismo. Se considera un problema de nivel de
enlace.
 X is down, line protocol is down: problema con el cableado o la interfaz. Se considera un
problema de nivel físico.
 X is administratively down, line protocol is down: verificar que la interfaz está habilitada,
con el comando no shutdown.