You are on page 1of 8

ALU PE Configuration:

*A:LAB-A8-105# configure service vpls 3007


*A:LAB-A8-105>config>service>vpls# info
----------------------------------------------
description "A8-TEST-VRF-L2VPLS"
bgp
route-distinguisher 4755:10010
route-target export target:4755:10010 import target:4755:10010
pw-template-binding 1
exit
exit
bgp-ad
vpls-id 4755:10010
no shutdown
exit
stp
shutdown
exit
sap lag-1:1005.2622 create
exit
no shutdown
----------------------------------------------

*A:LAB-A8-105# configure router bgp


*A:LAB-A8-105>config>router>bgp# info
----------------------------------------------
enable-inter-as-vpn
local-as 4755
path-mtu-discovery
router-id 100.64.0.105
best-path-selection
always-compare-med zero
exit
group "ALU-VPN-RR"
description "ALU-VPN-RR"
family ipv4 ipv6 vpn-ipv4 vpn-ipv6 l2-vpn mvpn-ipv4 mdt-safi route-
target
keepalive 60
hold-time 180
loop-detect off
min-route-advertisement 1
type internal
graceful-restart
exit
local-as 4755
peer-as 4755
enable-peer-tracking
exit
neighbor 100.64.0.102
exit
exit

CE Configuration:

lab-19xx02#show running-config interface gigabitEthernet 0/0.2622


Building configuration...

Current configuration : 138 bytes


!
interface GigabitEthernet0/0.2622
description A8-TEST-VRF-L2VPLS
encapsulation dot1Q 2622
ip address 31.31.32.1 255.255.255.252
end

***********************************************************************************
****************************************************

RR BGP Configuration:

*A:LAB-SR12-102>config>router>bgp>group# info
----------------------------------------------
family ipv4 ipv6 vpn-ipv4 vpn-ipv6 mdt-safi route-target l2-vpn
type internal
cluster 1.2.3.4
local-as 4755
peer-as 4755
local-address 100.64.0.102
neighbor 100.64.0.6
l2vpn-cisco-interop
exit
neighbor 100.64.0.105
advertise-label ipv6
exit
----------------------------------------------

***********************************************************************************
******************************************************

Cisco PE Configuration:

l2 vfi A8-TEST-VRF-VPLS-AD autodiscovery


vpn id 2602
vpls-id 4755:10010
rd 4755:10010
route-target 4755:10010

chn-gvpn-rt03#show running-config interface vlan 2622


Building configuration...

Current configuration : 107 bytes


!
interface Vlan2622
description A8-TEST-VRF-L2VPLS
no ip address
xconnect vfi A8-TEST-VRF-VPLS-AD
end

chn-gvpn-rt03#show running-config | section router bgp


router bgp 4755
bgp router-id 100.64.0.6
no bgp default route-target filter
bgp log-neighbor-changes
address-family l2vpn vpls
neighbor 100.64.0.102 activate
neighbor 100.64.0.102 send-community extended
exit-address-family

CE Configuration:

chn-lab-18xx01#show running-config interface fastEthernet 0/0.2622


Building configuration...

Current configuration : 135 bytes


!
interface FastEthernet0/0.2622
description A8-TEST-VRF-L2VPLS
encapsulation dot1Q 2622
ip address 31.31.32.2 255.255.255.252
end

***********************************************************************************
**************************************************

Verification logs:

Verifying bgp routes

*A:LAB-A8-105# show router bgp routes l2-vpn


===============================================================================
BGP Router ID:100.64.0.105 AS:4755 Local AS:4755
===============================================================================
Legend -
Status codes : u - used, s - suppressed, h - history, d - decayed, * - valid
l - leaked
Origin codes : i - IGP, e - EGP, ? - incomplete, > - best, b - backup

===============================================================================
BGP L2VPN Routes
===============================================================================
Flag RouteType Prefix MED
RD SiteId Label
Nexthop VeId BlockSize LocalPref
As-Path BaseOffset vplsLabelBa
se
-------------------------------------------------------------------------------
u*>? AutoDiscovery 100.64.0.6 - 0
4755:10010 - -
100.64.0.6 - - 100
No As-Path - -
i AutoDiscovery 100.64.0.105 - 0
4755:10010 - -
100.64.0.105 - - 100
No As-Path - -
-------------------------------------------------------------------------------
Routes : 2
===============================================================================
chn-gvpn-rt03#sh ip bgp l2 vpls all summary
BGP router identifier 100.64.0.6, local AS number 4755
BGP table version is 12, main routing table version 12
3 network entries using 417 bytes of memory
3 path entries using 180 bytes of memory
336/3 BGP path/bestpath attribute entries using 25536 bytes of memory
6 BGP rrinfo entries using 144 bytes of memory
21 BGP AS-PATH entries using 504 bytes of memory
9 BGP community entries using 232 bytes of memory
233 BGP extended community entries using 6828 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 33841 total bytes of memory
BGP activity 66912/65223 prefixes, 244694/242772 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd


100.64.0.102 4 4755 351 157 12 0 0 00:00:35 1

chn-gvpn-rt03#show ip bgp l2vpn vpls rd 4755:10010


BGP table version is 12, local router ID is 100.64.0.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path


Route Distinguisher: 4755:10010
*> 4755:10010:100.64.0.6/96
0.0.0.0 32768 ?
*>i4755:10010:100.64.0.105/96
100.64.0.105 0 100 0 i

Verifying VC status & sdp binding

*A:LAB-A8-105# show service id 3007 base

===============================================================================
Service Basic Information
===============================================================================
Service Id : 3007 Vpn Id : 0
Service Type : VPLS
Name : (Not Specified)
Description : A8-TEST-VRF-L2VPLS
Customer Id : 9001 Creation Origin : manual
Last Status Change: 09/13/2016 16:36:24
Last Mgmt Change : 09/13/2016 16:44:25
Etree Mode : Disabled
Admin State : Up Oper State : Up
MTU : 1514 Def. Mesh VC Id : 3007
SAP Count : 1 SDP Bind Count : 1
Snd Flush on Fail : Disabled Host Conn Verify : Disabled
Propagate MacFlush: Disabled Per Svc Hashing : Disabled
Allow IP Intf Bind: Disabled
Def. Gateway IP : None
Def. Gateway MAC : None
Temp Flood Time : Disabled Temp Flood : Inactive
Temp Flood Chg Cnt: 0
VSD Domain : <none>
-------------------------------------------------------------------------------
Service Access & Destination Points
-------------------------------------------------------------------------------
Identifier Type AdmMTU OprMTU Adm Opr
-------------------------------------------------------------------------------
sap:lag-1:1005.2622 qinq 9022 9022 Up Up
sdp:17407:4294967294 SB(100.64.0.6) BgpAd 0 9190 Up Up
***************************** sdp binding is through bgp
===============================================================================

*A:LAB-A8-105>show>service>id# show service id 3007 all

===============================================================================
Service Detailed Information
===============================================================================
Service Id : 3007 Vpn Id : 0
Service Type : VPLS
Name : (Not Specified)
Description : A8-TEST-VRF-L2VPLS
Customer Id : 9001 Creation Origin : manual
Last Status Change: 09/13/2016 16:36:24
Last Mgmt Change : 09/13/2016 16:44:25
Etree Mode : Disabled
Admin State : Up Oper State : Up
MTU : 1514 Def. Mesh VC Id : 3007
SAP Count : 1 SDP Bind Count : 1
Snd Flush on Fail : Disabled Host Conn Verify : Disabled
Propagate MacFlush: Disabled Per Svc Hashing : Disabled
Allow IP Intf Bind: Disabled
Def. Gateway IP : None
Def. Gateway MAC : None
Temp Flood Time : Disabled Temp Flood : Inactive
Temp Flood Chg Cnt: 0
VSD Domain : <none>

-------------------------------------------------------------------------------
BGP Information
-------------------------------------------------------------------------------
Vsi-Import : None
Vsi-Export : None
Route Dist : 4755:10010
Rte-Target Import : 4755:10010 Rte-Target Export : 4755:10010

PW-Template Id : 1 PW-Template SHG : None


Oper Group : None
Mon Oper Group : None
BFD Template : None
BFD-Enabled : no BFD-Encap : ipv4
Import Rte-Tgt : None
-------------------------------------------------------------------------------

-------------------------------------------------------------------------------
Split Horizon Group specifics
-------------------------------------------------------------------------------

-------------------------------------------------------------------------------
ETH-CFM service specifics
-------------------------------------------------------------------------------
Tunnel Faults : ignore V-Mep Extensions : Enabled

-------------------------------------------------------------------------------
Service Destination Points(SDPs)
-------------------------------------------------------------------------------
-------------------------------------------------------------------------------
Sdp Id 17407:4294967294 -(100.64.0.6)
-------------------------------------------------------------------------------
Description : (Not Specified)
SDP Id : 17407:4294967294 Type : BgpAd
PW-Template Id : 1
AGI : 4755:10010 SDP Bind Source : bgp-l2vpn
******************************** sdp binding is through bgp
Local AII : 100.64.0.105
Remote AII : 100.64.0.6
Split Horiz Grp : (Not Specified)
Etree Root Leaf Tag: Disabled Etree Leaf AC : Disabled
VC Type : Ether VC Tag : n/a
Admin Path MTU : 0 Oper Path MTU : 9190
Delivery : MPLS
Far End : 100.64.0.6
Tunnel Far End : n/a LSP Types : LDP/BGP
Hash Label : Disabled Hash Lbl Sig Cap : Disabled
Oper Hash Label : Disabled

Admin State : Up Oper State : Up


Acct. Pol : None Collect Stats : Disabled
Ingress Label : 262033 Egress Label : 2611
Ingr Mac Fltr-Id : n/a Egr Mac Fltr-Id : n/a
Ingr IP Fltr-Id : n/a Egr IP Fltr-Id : n/a
Ingr IPv6 Fltr-Id : n/a Egr IPv6 Fltr-Id : n/a
Admin ControlWord : Not Preferred Oper ControlWord : False
BFD Template : None
BFD-Enabled : no BFD-Encap : ipv4
Last Status Change : 09/13/2016 16:44:44 Signaling : TLDP
Last Mgmt Change : 09/13/2016 16:44:25
Endpoint : N/A Precedence : 4
PW Status Sig : Enabled
Force Vlan-Vc : Disabled Force Qinq-Vc : Disabled
Class Fwding State : Down
Flags : None
Time to RetryReset : never Retries Left : 3
Mac Move : Blockable Blockable Level : Tertiary
Local Pw Bits : None
Peer Pw Bits : None
Peer Fault Ip : None
Peer Vccv CV Bits : lspPing
Peer Vccv CC Bits : mplsRouterAlertLabel

Application Profile: None


Max Nbr of MAC Addr: No Limit Total MAC Addr : 1
Learned MAC Addr : 1 Static MAC Addr : 0
OAM MAC Addr : 0 DHCP MAC Addr : 0
Host MAC Addr : 0 Intf MAC Addr : 0
SPB MAC Addr : 0 Cond MAC Addr : 0
BGP EVPN Addr : 0 EVPN Static Addr : 0
MAC Learning : Enabled Discard Unkwn Srce: Disabled
MAC Aging : Enabled
BPDU Translation : Disabled
L2PT Termination : Disabled
MAC Pinning : Disabled
Ignore Standby Sig : False Block On Mesh Fail: False
Oper Group : (none) Monitor Oper Grp : (none)
Rest Prot Src Mac : Disabled
Auto Learn Mac Prot: Disabled RestProtSrcMacAct : Disable

Ingress Qos Policy : (none) Egress Qos Policy : (none)


Ingress FP QGrp : (none) Egress Port QGrp : (none)
Ing FP QGrp Inst : (none) Egr Port QGrp Inst: (none)

KeepAlive Information :
Admin State : Disabled Oper State : Disabled
Hello Time : 10 Hello Msg Len : 0
Max Drop Count : 3 Hold Down Time : 10

Statistics :
I. Fwd. Pkts. : 170 I. Dro. Pkts. : 0
I. Fwd. Octs. : 19380 I. Dro. Octs. : 0
E. Fwd. Pkts. : 170 E. Fwd. Octets : 19380

-------------------------------------------------------------------------------
Control Channel Status
-------------------------------------------------------------------------------

*A:LAB-A8-105# show service sdp-using

===============================================================================
SDP Using
===============================================================================
SvcId SdpId Type Far End Opr I.Label E.Label
State
-------------------------------------------------------------------------------
2129 2128:2129 Mesh 100.64.0.104 Up 261186 261227
2129 2129:2129 Mesh 100.64.0.5 Up 262134 126
2129 2130:1234 Spok 100.64.0.6 Down 262032 None
2129 2130:2129 Mesh 100.64.0.6 Down 262027 None
3007 17407:4294967294 Bgp* 100.64.0.6 Up 262033 2611
**********************************************
3009 2999:2600 Spok 100.64.0.6 Up 262040 18182
3111 2128:3111 Mesh 100.64.0.104 Up 261185 261226
3111 2130:3111 Mesh 100.64.0.6 Down 262025 15511
3112 2130:3112 Spok 100.64.0.6 Down 262024 14246
500083 12000:1226255 Spok 100.64.0.104 Down 262066 None
-------------------------------------------------------------------------------
Number of SDPs : 10
-------------------------------------------------------------------------------
===============================================================================

chn-gvpn-rt03#show mpls l2transport vc 2602

Local intf Local circuit Dest address VC ID Status


------------- -------------------------- --------------- ---------- ----------
VFI A8-TEST-VRF-VPLS-AD \
VFI 100.64.0.105 2602 UP

CE-CE ping response

lab-19xx02#ping 31.31.32.2 repeat 100


Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 31.31.32.2, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 1/1/4 ms

chn-lab-18xx01#ping 31.31.32.1 repeat 100


Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 31.31.32.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 1/2/20 ms