You are on page 1of 15

43 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ

2.55
Κεφάλαιο 2ο
Ποιες είναι οι δύο μορφές της δομής πολλαπλής επιλογής και ποτέ
χρησιμοποιείται;
1η Μορφή:Η πολλαπλή επιλογή εφαρμόζεται στα προβλήματα όπου μπορούν να ληφθούν
διαφορετικές αποφάσεις ανάλογα με την τιμή μιας λογικής έκφρασης:
Η πολλαπλή επιλογή επεκτείνει τη σύνθετη επιλογή.
Αν Συνθήκη 1 τότε Αρχικά ελέγχεται η Συνθήκη 1
Και αν ισχύει εκτελείται η Ομάδα Εντολών 1
Ομάδα Εντολών 1 Και συνεχίζει η εκτέλεση του αλγορίθμου μετά το τέλος_αν
Αλλιώς_αν Συνθήκη 2 τότε Αν δεν ισχύει όμως η Συνθήκη 1
Ομάδα Εντολών 2 Τότε ελέγχεται η Συνθήκη 2
Αλλιώς_αν Συνθήκη 3 τότε
Και αν ισχύει εκτελείται η Ομάδα Εντολών 2
Ομάδα Εντολών 3 Αν δεν ισχύει όμως η Συνθήκη 2

……
Τότε ελέγχεται η Συνθήκη 3
Αλλιώς
Και αν ισχύει εκτελείται η Ομάδα Εντολών 3 κ.ο.κ…..
Ομάδα Εντολών Ν
Αν δεν ισχύει καμία από τις συνθήκες.
Τέλος_αν Θα εκτελεστεί η Ομάδα Εντολών Ν
44 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.55
Κεφάλαιο 2ο
Ποιες είναι οι δύο μορφές της δομής πολλαπλής επιλογής και ποτέ
χρησιμοποιείται;
2η Μορφή:Η πολλαπλή επιλογή εφαρμόζεται στα προβλήματα όπου μπορούν να ληφθούν
διαφορετικές αποφάσεις ανάλογα με την τιμή μιας λογικής έκφρασης:
Στη δομή επιλογής Επίλεξε, υπολογίζεται η Έκφραση
Επίλεξε Έκφραση και ανάλογα με την τιμή της
εκτελούνται οι αντίστοιχες εντολές.
Περίπτωση Τιμή ή Τιμές

Ομάδα Εντολών 1 Αν η τιμή της Έκφρασης δεν ταιριάζει με καμία ,
Περίπτωση Τιμή ή Τιμές από τις τιμές που εμφανίζονται μετά τη λέξη Περίπτωση
Ομάδα Εντολών 2
Περίπτωση Τιμή ή Τιμές
Θα εκτελεστούν οι Εντολές που βρίσκονται
στην Περίπτωση Αλλιώς Ομάδα Εντολών Ν
Ομάδα Εντολών 3
……
Περίπτωση Αλλιώς

Ομάδα Εντολών Ν

Τέλος_επιλογών
45 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
Κεφάλαιο 2ο
2.56 Υπενθύμιση
Να γραφεί αλγόριθμος που θα δέχεται ως είσοδο τρεις τιμές.
Οι δύο πρώτες θα είναι αριθμητικές , ενώ η τρίτη τιμή θα είναι αλφαριθμητική.
Ο αλγόριθμος θα εμφανίζει το άθροισμα των δύο πρώτων τιμών όταν η τρίτη μεταβλητή ισούται με
ΠΡΟΣΘΕΣΗ
και τη διαφορά των δύο πρώτων σε οποιαδήποτε άλλη περίπτωση. ….

Λύση
Ο αλγόριθμος θα διαβάζει 3 τιμές, οι οποίες θα Αλγόριθμος ΑΡΙΘ_ΠΡΑΞΗ
εισάγονται σε 3 μεταβλητές.
Εμφάνισε “Δώσε τρεις τιμές”
…. πάνε πακέτο.
Διάβασε α, β, γ
Ο έλεγχος αφορά την τιμή της τρίτης μεταβλητής.
Αν γ = “ΠΡΟΣΘΕΣΗ” τότε ΠΡΟΣΘΕΣΗ

Η Τρίτη τιμή θα είναι αλφαριθμητική , εφόσον το
περιεχόμενο της είναι μια λέξη. Εμφάνισε α+β
Τις αλφαριθμητικές μεταβλητές τις διαβάζουμε όπως και Αλλιώς ! Δύο περιπτώσεις
τις υπόλοιπες μεταβλητές ,
απλά στον έλεγχο ή στην εντολή εκχώρησης Εμφάνισε α-β
χρησιμοποιούμε διπλά εισαγωγικά.
Τέλος_αν

Τέλος ΑΡΙΘ_ΠΡΑΞΗ
Άρα ο αλγόριθμος είναι :
46 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.56b Κεφάλαιο 2ο
Να γραφεί αλγόριθμος που θα δέχεται ως είσοδο τρεις τιμές.
Οι δύο πρώτες θα είναι αριθμητικές , ενώ η τρίτη τιμή θα είναι αλφαριθμητική.
Ο αλγόριθμος θα εμφανίζει
•το άθροισμα των δύο πρώτων τιμών όταν η τρίτη μεταβλητή ισούται με ΠΡΟΣΘΕΣΗ
•τη διαφορά των δύο πρώτων τιμών όταν η τρίτη μεταβλητή ισούται με ΑΦΑΙΡΕΣΗ
•το γινόμενο των δύο πρώτων τιμών όταν η τρίτη μεταβλητή ισούται με ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ
•το πηλίκο των δύο πρώτων τιμών όταν η τρίτη μεταβλητή ισούται με ΔΙΑΙΡΕΣΗ.

Λύση Αλγόριθμος ΑΡΙΘ_ΠΡΑΞΕΙΣ
Ο αλγόριθμος θα διαβάζει 3 τιμές, οι οποίες θα Εμφάνισε “Δώσε τρεις τιμές”
εισάγονται σε 3 μεταβλητές.
πάνε πακέτο.
…. Διάβασε α, β, γ
Ο έλεγχος αφορά την τιμή της τρίτης μεταβλητής,
ανάλογα με την πράξη. Αν γ = “ΠΡΟΣΘΕΣΗ” τότε ΠΡΟΣΘΕΣΗ

Εμφάνισε α+β
! ΌΧΙ Δύο περιπτώσεις
Η Τρίτη τιμή θα είναι αλφαριθμητική , εφόσον το Αλλιώς_αν γ = “ΑΦΑΙΡΕΣΗ” τότε
περιεχόμενο της είναι μια λέξη.
Εμφάνισε α-β
Τις αλφαριθμητικές μεταβλητές τις διαβάζουμε όπως και
τις υπόλοιπες μεταβλητές , Αλλιώς_αν γ = “ΠΟΛΛΑΠΛΑΣΙΑΣΜΟΣ” τότε
απλά στον έλεγχο ή στην εντολή εκχώρησης Εμφάνισε α*β
χρησιμοποιούμε διπλά εισαγωγικά. Αλλιώς_αν γ = “Διαίρεση” και β≠0 τότε
Εμφάνισε α/β
Αλλιώς
Άρα ο αλγόριθμος είναι : Εμφάνισε “ΑΠΡΟΣΔΙΟΡΙΣΤΑ”
Τέλος_αν
Τέλος ΑΡΙΘ_ΠΡΑΞΕΙΣ
47 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.57
Κεφάλαιο 2ο
Τι θα εμφανίσει ο ακόλουθος αλγόριθμος αν δοθεί σαν είσοδος η τιμή
1)-20,
2) 10 και Αλγόριθμος Παράδειγμα_Η
3)20 Διάβασε α
Αν α < 0 τότε
Εμφάνισε “Μικρότερο του 0”
Αλλιώς_αν α =< 10 τότε
Εμφάνισε “Μεταξύ του 0 και του 10”
Αλλιώς
Εμφάνισε “Μεγαλύτερο του 10”
Τέλος_αν
Τέλος Παράδειγμα_Η
1) Η εντολή Διάβασε α εκχωρεί στη μεταβλητή α την τιμή -20 -20
Μικρότερο
Η επόμενη εντολή είναι Πολλαπλή επιλογή. του 0

Ελέγχει αν η α έχει τιμή μικρότερη από την τιμή 0.
Η συνθήκη είναι αληθής
οπότε θα εμφανιστεί το μήνυμα: Μικρότερο του 0.
Κατόπιν θα συνεχιστεί η εκτέλεση του αλγορίθμου μετά το Τέλος_άν
Δηλ οι υπόλοιπες συνθήκες δε θα εκτελεστούν.
48 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.57
Κεφάλαιο 2ο
Τι θα εμφανίσει ο ακόλουθος αλγόριθμος αν δοθεί σαν είσοδος η τιμή
1)-20,
2) 10 και Αλγόριθμος Παράδειγμα_Η
3)20 Διάβασε α
Αν α < 0 τότε
Εμφάνισε “Μικρότερο του 0”
Αλλιώς_αν α =< 10 τότε
Εμφάνισε “Μεταξύ του 0 και του 10”
Αλλιώς
Εμφάνισε “Μεγαλύτερο του 10”
Τέλος_αν
Τέλος Παράδειγμα_Η
2) Η εντολή Διάβασε α εκχωρεί στη μεταβλητή α την τιμή 10 10
Μεταξύ
Ελέγχει αν η α έχει τιμή μικρότερη από την τιμή 0. του 0 και του 10

Η συνθήκη είναι Ψευδής οπότε θα γίνει έλεγχος στη δεύτερη συνθήκη.
Η συνθήκη είναι αληθής
οπότε θα εμφανιστεί το μήνυμα: Μεταξύ του 0 και του 10
Κατόπιν θα συνεχιστεί η εκτέλεση του αλγορίθμου μετά το Τέλος_άν
Δηλ η επόμενη συνθήκη δε θα εκτελεστεί.
49 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.57
Κεφάλαιο 2ο
Τι θα εμφανίσει ο ακόλουθος αλγόριθμος αν δοθεί σαν είσοδος η τιμή
1)-20,
2) 10 και Αλγόριθμος Παράδειγμα_Η
3)20 Διάβασε α
Αν α < 0 τότε
Εμφάνισε “Μικρότερο του 0”
Αλλιώς_αν α =< 10 τότε
Εμφάνισε “Μεταξύ του 0 και του 10”
Αλλιώς
Εμφάνισε “Μεγαλύτερο του 10”
Τέλος_αν
Τέλος Παράδειγμα_Η
3) Η εντολή Διάβασε α εκχωρεί στη μεταβλητή α την τιμή 20 20
Μεγαλύτερο
Ελέγχει αν η α έχει τιμή μικρότερη από την τιμή 0. του 10

Η συνθήκη είναι Ψευδής οπότε θα γίνει έλεγχος στη δεύτερη συνθήκη.
Η δεύτερη συνθήκη ελέγχει αν το α έχει τιμή μικρότερη ή ίση από το 10,
είναι όμως Ψευδής οπότε θα οδηγηθούμε στο Αλλιώς.
Και θα εμφανιστεί το μήνυμα Μεγαλύτερο του 10
Κατόπιν θα συνεχιστεί η εκτέλεση του αλγορίθμου μετά το Τέλος_άν
Και θα τερματίσει ο αλγόριθμος.
50 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.58 Κεφάλαιο 2ο
Τι θα εμφανίσει ο ακόλουθος αλγόριθμος αν δοθεί σαν είσοδος η τιμή 50 ;
Αλγόριθμος Παράδειγμα_17
Διάβασε α
Επίλεξε α
Αν α<0 τότε
Περίπτωση <0
Εμφάνισε “Μικρότερο του 0”
Δ Περίπτωση =0
Ο
Εμφάνισε “ Ίσο με 0”
Μ
η Περίπτωση Αλλιώς
Εμφάνισε “Μεγαλύτερο του 0” χή
σ ο
Τέλος_επιλογών
ο Τέλος_αν
Τέλος Παράδειγμα_17
πρ
3) Η εντολή Διάβασε α εκχωρεί στη μεταβλητή α την τιμή 50 50
Μεγαλύτερο
Ελέγχει αν η α έχει τιμή μικρότερη από την τιμή 0. Περίπτωση <0 του 0

Η συνθήκη είναι Ψευδής οπότε δεν θα εκτελεστούν οι εντολές της Περίπτωση <0.
Μεταβαίνουμε στη Περίπτωση =0.
Η συνθήκη είναι Ψευδής οπότε δεν θα εκτελεστούν οι εντολές της Περίπτωση =0.
Μεταβαίνουμε στη Περίπτωση Αλλιώς.
Ισχύει Και θα εμφανιστεί το μήνυμα Μεγαλύτερο του 0
Κατόπιν θα συνεχιστεί η εκτέλεση του αλγορίθμου μετά το Τέλος_επιλογών
Και θα τερματίσει ο αλγόριθμος.
51 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.59
Κεφάλαιο 2ο
Τι θα εμφανίσει ο ακόλουθος αλγόριθμος αν δοθεί σαν είσοδος η τιμή Πέμπτη;
Αλγόριθμος Παράδειγμα_18
Εμφάνισε “Δώσε μια ημέρα”
Διάβασε ημέρα
Επίλεξε ημέρα
Περίπτωση “Κυριακή”, “Δευτέρα”,“Τρίτη”
Εμφάνισε “Αρχή εβδομάδας”

Περίπτωση “Τετάρτη”,“Πέμπτη”
Εμφάνισε “Μέση εβδομάδας” Δώσε μια ημέρα
Δώσε μια ημέρα
Πέμπτη
Περίπτωση “Παρασκευή”,“Σάββατο”
Μέση εβδομάδος
Εμφάνισε “Τέλος εβδομάδας”
Περίπτωση_Αλλιώς
Εμφάνισε “Λάθος ημέρας”
Τέλος_επιλογών
Τέλος Παράδειγμα_18

Η πρώτη εντολή θα εμφανίσει το μήνυμα: Δώσε μια ημέρα
Αφού θα διαβαστεί η ημέρα,
Θα γίνει έλεγχος αν η μεταβλητή ημέρα έχει τιμή Κυριακή ή Δευτέρα ή Τρίτη.
Επειδή η πρώτη περίπτωση δεν είναι αληθής,
Θα γίνει έλεγχος της δεύτερης περίπτωσης
Αυτή είναι αληθής οπότε θα εμφανιστεί το μήνυμα :Μέση εβδομάδας
52 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.60
Κεφάλαιο 2ο
Να γραφεί ο παρακάτω αλγόριθμος με τη μορφή της Πολλαπλής επιλογής
Αν…Αλλιώς_αν…Αλλιώς…Τέλος_αν
Αλγόριθμος Παράδειγμα_18 Αλγόριθμος Παράδειγμα_18

Εμφάνισε “Δώσε μια ημέρα” Εμφάνισε “Δώσε μια ημέρα”

Διάβασε ημέρα Διάβασε ημέρα
Επίλεξε ημέρα
Αν ημέρα=“Κυριακή” ή ημέρα=“Δευτέρα”ή ημέρα=“Τρίτη” τότε
Περίπτωση “Κυριακή”, “Δευτέρα”,“Τρίτη”
Εμφάνισε “Αρχή εβδομάδας”
Εμφάνισε “Αρχή εβδομάδας”
Αλλιώς_αν ημέρα=“Τετάρτη” ή ημέρα=“Πέμπτη” τότε
Περίπτωση “Τετάρτη”,“Πέμπτη”
Εμφάνισε “Μέση εβδομάδας”
Εμφάνισε “Μέση εβδομάδας”
Αλλιώς_αν ημέρα=“Παρασκευή” ή ημέρα=“Σάββατο” τότε
Περίπτωση “Παρασκευή”,“Σάββατο”
Εμφάνισε “Τέλος εβδομάδας”
Εμφάνισε “Τέλος εβδομάδας”
Περίπτωση_Αλλιώς Αλλιώς

Εμφάνισε “Λάθος ημέρας” Εμφάνισε “Λάθος ημέρας”
Τέλος_επιλογών Τέλος_αν

Τέλος Παράδειγμα_18 Τέλος Παράδειγμα_18

Το πρώτο Περίπτωση μετατρέπεται σε Αν…τότε.
Από το δεύτερο ως το προτελευταίο Περίπτωση μετατρέπονται σε Αλλιώς_αν….τότε.
Το Περίπτωση Αλλιώς μετατρέπεται σε Αλλιώς . Προσοχή: Αν υπάρχει τελεστής τον χρησιμοποιούμε,
Το Τέλος_επιλογών μετατρέπεται σε Τελος_αν. αν όχι βάζουμε τον τελεστή της ισότητας(=) ~2.58.
Αν μετά το Περίπτωση υπάρχει μια ακολουθία τιμών
χρησιμοποιούμε το λογικό τελεστή ή.
53 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.61
Κεφάλαιο 2ο
Να γραφεί η παρακάτω μορφή με τη μορφή της Πολλαπλής επιλογής κάνοντας
χρήση της δομής απλής επιλογής.
Αν Σ1 τότε

Αν Σ1 τότε Ομάδα εντολών 1

Ομάδα εντολών 1 Τέλος_αν

Αλλιώς_αν Σ2 τότε Αν (όχιΣ1) και Σ2 τότε
Ομάδα εντολών 2 Ομάδα εντολών 2
Αλλιώς_αν Σ3 τότε
Τέλος_αν
Ομάδα εντολών 3
Αλλιώς Αν (όχιΣ1) και (όχιΣ2) και Σ3 τότε
Ομάδα εντολών 4 Ομάδα εντολών 3
Τέλος_αν
Τέλος_αν

Αν (όχιΣ1) και (όχιΣ2) και (όχιΣ3) τότε

Ομάδα εντολών 4

Τέλος_αν

Για να εκτελεστούν οι εντολές που βρίσκονται σε κάποιο Αλλιώς_αν
Θα πρέπει οι προηγούμενες Συνθήκες να είναι Ψευδείς
Άρα η ισοδύναμη της σύνθετης επιλογής είναι:
54 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.62
Κεφάλαιο 2ο
Να γραφεί με διάγραμμα ροής ο ακόλουθος αλγόριθμος.

Αρχή
Αλγόριθμος Παράδειγμα_11
Διάβασε α,β Διάβασε α,β
Αν α >β τότε
Εμφάνισε α Όχι Όχι
α>β
Αλλιώς_αν α <β τότε α<β

Εμφάνισε β
Αλλιώς Ναι Ναι

Εμφάνισε “Ίσοι”
Εμφάνισε Εμφάνισε Εμφάνισε
α β Ίσοι
Τέλος_αν
Τέλος Παράδειγμα_11

Τέλος
55 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.63
Κεφάλαιο 2ο
Να γραφεί αλγόριθμος που θα διαβάζει τη θέση ενός αθλητή στο αγώνισμα του στίβου. Αν η θέση ισούται
με 1 ή 2 ή 3, θα εμφανίζεται το μήνυμα “Πρώτος” ή “Δεύτερος ” ή “ Τρίτος ” αντίστοιχα” .Αν δοθεί
διαφορετική είσοδος ,θα εμφανίζεται το μήνυμα “Εκτός πρώτης τριάδας” .
Επειδή θα κάνουμε έλεγχο για διαφορετικές τιμές της μεταβλητής θα χρησιμοποιήσουμε την πολλαπλή δομή..

Αλγόριθμος Παράδειγμα_18
Αλγόριθμος Παράδειγμα_18
Εμφάνισε “Δώσε θέση του αθλητή “
Εμφάνισε “Δώσε θέση του αθλητή ”
Διάβασε θέση
Διάβασε θέση

Αν θέση=1 τότε Επίλεξε θέση

Εμφάνισε Περίπτωση 1 Περίπτωση =1
“Πρώτος”
Εμφάνισε “Πρώτος”
Αλλιώς_αν θέση=2 τότε
Περίπτωση 2
Εμφάνισε “Δεύτερος”
Αλλιώς_αν θέση=3 τότε Εμφάνισε “Δεύτερος”
Περίπτωση 3
Εμφάνισε “Τρίτος”
Αλλιώς Εμφάνισε “Τρίτος”

Εμφάνισε “Εκτός πρώτης τριάδας” Περίπτωση_Αλλιώς
Τέλος_αν Εμφάνισε “Εκτός πρώτης τριάδας”
Τέλος Παράδειγμα_18 Τέλος_επιλογών

Τέλος Παράδειγμα_18

Παρατηρούμε ότι τα Αν…τοτε και Αλλιώς_αν εκφράζονται με τη δεσμευμένη λέξη Περίπτωση.

Ενώ το Αλλιώς γίνεται Περίπτωση_Αλλιώς

Μετά το Περίπτωση το ίσον παραλείπεται
56 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.64
Κεφάλαιο 2ο
Να γραφεί αλγόριθμος που θα διαβάζει το βαθμό ενός φοιτητή στο μάθημα της Πληροφορικής. Αφού
ελέγξει σε ποιο διάστημα τιμών ανήκει ο βαθμός να εμφανίζει το κατάλληλο μήνυμα , σύμφωνα με τον
ακόλουθο πίνακα.

[0-4.5 ] Απέτυχες Αλγόριθμος Έλεγχος_βαθμού

(4.5-6.5 ] Καλώς Εμφάνισε “Δώσε το βαθμό του μαθητή“

(6.5-8.5 ] Λίαν Καλώς Διάβασε β

(8.5-10 ] Άριστα Αν β>=0 και β<=4.5 τότε ! Όχι 0=<β=<4.5 Πάντα με και

Εμφάνισε “Απέτυχες”
πο
Αφού διαβάσουμε το βαθμό του φοιτητή θα
Αλλιώς_αν β>4.5 και β<=6.5 τότε
ό λ
κ
ελέγξουμε σε ποιο διάστημα τιμών
ανήκει. Εμφάνισε “Καλώς”
Αλλιώς_αν β>6.5 και β<=8.5 τότε
π.χ. Εμφάνισε “Λίαν καλώς”
[0-4.5 ] Αλλιώς_αν β>8.5 και β<=10 τότε
Εμφάνισε “Άριστα ”
Αλλιώς
Εμφάνισε “Μη αποδεκτός βαθμός ”
Τέλος_αν

Τέλος Έλεγχος_βαθμού

Το μήνυμα στο Αλλιώς το βάζουμε για να καλύψουμε την περίπτωση λάθους.

Προσοχή για παραστάσεις α<χ<β χρησιμοποιούμε το λογικό τελεστή και.
57 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ
2.65
Κεφάλαιο 2ο
Στα εισιτήρια των τρένων υπάρχουν πέντε Ο αλγόριθμος θα διαβάζει μια τιμή που
θα αντιστοιχεί στο αντίτιμο του εισιτηρίου
κατηγορίες εισιτηρίων: και ένα γράμμα που θα αντιστοιχεί στη κατηγορία του πελάτη.
•Πολύτεκνο,
50%
•Αναπηρικό,
Αλγόριθμος Αντίτιμο_Εισιτηρίου
•Στρατιωτικό, 25% Εμφάνισε “Δώσε την αξία της διαδρομής και την κατηγορία πελάτη“
•Φοιτητικό, και ! α= αξία, κ= κατηγορία
Διάβασε α,κ
•Κανονικό. 100%
Οι δύο πρώτες κατηγορίες πληρώνουν το Αν κ=”Π” ή κ=“Α” τότε ! Για κατηγορίες Πάντα με ή
50% της αξίας του κανονικού εισιτηρίου.
Η τρίτη και η τέταρτη κατηγορία έχουν ποσό_πληρωμής← α-50/100*α

έκπτωση 25% .
Αλλιώς_αν κ=”Σ” ή κ=”Φ” τότε
Τέλος η τελευταία κατηγορία πληρώνει
ολόκληρη την αξία του εισιτηρίου. ποσό_πληρωμής← α-25/100*α
Να γραφεί αλγόριθμος που αφού διαβάσει το Αλλιώς
αντίτιμο ενός εισιτηρίου μιας διαδρομής και ποσό_πληρωμής← α
τη κατηγορία που ανήκει ο επιβάτης, να
Τέλος_αν
εμφανίζει τι πρέπει να πληρώσει.
Η πληροφορία για την κατηγορία του Τέλος Αντίτιμο_Εισιτηρίου
επιβάτη θα δίνεται με το αντίστοιχο γράμμα.

Προσοχή για κατηγορίες πχ Φοιτητές,Πολύτεκνοι κλπ χρησιμοποιούμε το λογικό τελεστή ή.