You are on page 1of 6

FUNCION BUSCARV

Esta función se utiliza para localizar un registro específico en una tabla distribuida
verticalmente, la función busca un valor específico en la primera columna más a izquierda de
una matriz y devuelve el valor en la misma fila de una columna especificada en la tabla. La V de
BUSCARV significa "Vertical

Sintaxis:
BUSCARV(valor;matriz;columna;ordenado)
Valor Es el valor que se busca en la primera columna de la matriz, Valor_buscado
puede ser un valor, una referencia o una cadena de texto.
Matriz Es la tabla de información donde se buscan los datos, puede ser un rango o un
nombre de rango, como por ejemplo Base_de_datos o Lista.
Columna Es el número de columna de la matriz desde la cual debe devolverse el valor
coincidente. El valor que se acerpta en columnas es : 1,2,3,…
Ordenado Es un valor lógico para localizar una coincidencia exacta o aproximada. Si se
omite o es VERDADERO, devolverá el siguiente valor más alto inferior a
valor_buscado. Si es FALSO, BUSCARV encontrará una coincidencia exacta.
Si ordenado es VERDADERO, los valores de la primera columna de la matriz deben colocarse en orden
ascendente
Los valores de la primera columna de matriz pueden ser texto, números o valores lógicos.

Por ejemplo:
Hoja que ubica el interes del tercer periodo

=BUSCARV(3;B3:F12;4) En este caso se busca el valor 3 en la primera


columna de la matriz B3:F12, y devuelve el valor
encontrado en la columna 4 ( Interes ), como
resultado se obtiene 21,816

=BUSCARV(6;B3:F12;2) En este caso se obtiene la sexta fecha ( columna 2 )


, como resultado se obtiene la siguiente fecha ( 15-
04-05)

=BUSCARV(1;TABLA;3) En este caso se obtiene la primera amortización


(51,852), en este caso TABLA es el nombre de la
matriz
En estos tres ejemplos se ha omitido el argumento ordenado, por lo que la búsqueda no es exacta sino
aproximada y además la primera columna de la matriz se encuentra ordenada

Hoja que ubica el ingreso de Mayo

=BUSCARV(("may";B3:F12;0) En este caso busca el texto may en la matriz


LISTA y devuelve el valor de la tercera
columna ( Ingresos ). El argumento 0, indica
búsqueda exacta.

=BUSCARV("may";B3:F12;3;FALSO) Es similar al caso anterior, en lugar de usar el


argumento 0, se usa el valor lógico FALSO

=BUSCARV("Jul";B3:F12;3) Busca Jul en la matriz B3:F12 y devuelve el


valor de la tercera columna ( Interes ), sin
embargo en este caso obtiene 18000 ( un
resultadp erroneo )
=BUSCARV("Jul";B3:F12;3;FALSO) En este caso resuelve en forma correcta el
interes de Julio, 16000. Por el argumento
FALSO, que obliga a una búsqueda exacta.

Ejemplo de BUSCARV con argumento ordenado verdadero:


En este caso vamos a calcular el Sueldo en la columna E, considerando una tabla de sueldos
como se indica en la figura hoja de datos

Hoja de datos SUELDOS

La tabla Sueldos (G4:H6), se encuentra ordenada por la categoría, por lo tanto no será necesario incluir
el argumento ordenado

Procedimiento:
1. Asignaremos a la tabla de sueldos ( G4:H6) el nombre SUELDOS ( aplicar la orden
Insertar – Nombre – Definir )
2. En la celda E3 ingresaremos la fórmula
=BUSCARV(C3;SUELDOS;2;VERDADERO) ó
=BUSCARV(C3;SUELDOS;2)

Hoja de Resultados

Ejemplo de BUSCARV para una hoja de consulta:


Con la hoja anterior SUELDOS, vamos a desarrollar una hoja de CONSULTA en base al código
que permita obtener el apellido, categoría, disrito y sueldo

Hoja CONSULTA
Procedimiento:

En la hoja SUELDOS, definiremos el rango A3:E9 con el nombre LISTADO

Hoja SUELDOS
En la hoja CONSULTA ingresamos las expresiones con BUSCARV:

Hoja CONSULTA con la función BUSCARV


Observe que todas las expresiones BUSCARV buscan el valor de la celda D1, al ingresar el
codigo en la celda D1 ( ejemplo X003), se obtendrá los resultados como se indica en la hoja
Hoja CONSULTA con resultados
La tecla F3 permite mostrar la ventana de nombres, de esta manera se podrá seleccionar en forma más
adecuada.
Al escribir =BUSCARV(D1; en este punto presione F3 y elija el nombre LISTADO, luego continue con
la función

Ejemplo de BUSCARV usando intervalos o aproximaciones:


CASO: Asignación
Existen muchos casos en los que se aplica una tabla de intervalos. Por ejemplo en el caso de la
asignación familiar, de acuerdo al número de hijos se calculará el porcentaje de asignación
familiar

Hoja de Asignación
De la tabla se interpreta lo siguiente:
Si el empleado tiene 0 ó 1 hijo la asignación será 0% del Sueldo
Si el empleado tiene 2 ó 3 hijos la asignación será 35% del Sueldo
Si el empleado tiene 4 ó 5 hijos la asignación será 50% del Sueldo
Si el empleado tiene 6 ó más de 6 hijos la asignación será 75% del Sueldo
Procedimiento:
Definir la tabla HIJOS del rango G4:H7
Ingresar la expresión con la función BUSCARV
=BUSCARV(C3;HIJOS;2)*D3

Hoja Asignación con expresión BUSCARV


Hoja de Asignación con los resultados
En este caso la función buscará en la tabla HIJOS (G4:H7), el número de hijos, si no lo encuentra la
función retornará el menor del intervalo
Por ejemplo al tener 1 hijo la tabla no contiene el valor de 1 por lo tanto la función BUSCARV toma el
menor del intervalo entre 0 y 2 considera 0
CASO: Comisión
Este es otro caso muy aplicativo donde se usa la funcion buscarv en intervalos es decir con
aproximaciones.
Para este caso la comisión de aplica de acuerdo a las ventas obtenidas, a partir de 1000 la
comisión será del 25% de dichas ventas, a partir de 4000 la comisión será del 30% de las ventas
y si el mas de 8000 la comisión será del 40% de las ventas.
Como notará

Hoja de Comisiones
Note que la primera venta de 2000 no se encuentra en la tabla de comisiones , sin enbargo al
encontrarse en el intervalo de 1000 y 4000 la función considerará el valor de 1000 ( el menor
del intervalo ) y obtendrá la comisión del 25%.
Procedimiento:
Definir la tabla COMISION del rango F4:G7
Ingresar la expresión con la función BUSCARV
=BUSCARV(C3;COMISION;2)*C3

Hoja COMISION con la expresión


Hoja COMISION con los resultados