You are on page 1of 5

República Bolivariana de Venezuela

Universidad Nacional Experimental ‘’Simón Rodríguez’’


Núcleo San Carlos
UNESR

Unidad IV Y V:
Algoritmo en estructura
repetitivas y algoritmos
en estructuras de decisión
Autores:

Rawuerd Flores CI: 25.120.511 *

Anny Guevara CI: 23.602.334

San Carlos; Noviembre 2018


1.- El Aseo Urbano de San Carlos tiene la ciudad dividida por zonas. Diseñe y desarrolle un algoritmo
que teniendo como datos de entrada: placa del camión recolector, toneladas de basura recolectada por
camión y número de zona, tenga como salida:
a) Número de camiones en cada zona
b) Toneladas de basura recolectadas en cada zona.
c) Promedio de basura recolectada por cada zona
La información viene clasificada por zona.

INICIO ALGORITMO camiones

VAR camiones1, camiones2, camiones3, camiones4, zona:entero; placa :alfanumerico; basura,


basura_zona1, basura_zona2, basura_zona3, basura_zona4:real;

camiones1 = 0;
camiones2 = 0;
camiones3 = 0;
camiones4 = 0;
basura_zona1 = 0;
basura_zona2 = 0;
basura_zona3 = 0;
basura_zona4 = 0;

ESCRIBIR (“¿Desea ingresar nueva recolección de basura? (s/n)”);


LEER (respuesta);

REPITA MIENTRAS respuesta = “s”

ESCRIBIR (“Placa del camión recolector de basura”);


LEER (placa)

ESCRIBIR (“zona del camion (1-4)”);


LEER (zona)

ESCRIBIR (“Cantidad de toneladas de basura recolectadas”);


LEER (basura);

SI zona = 1 ENTONCES;
basura_zona1 = basura_zona1 + basura;
camiones1 = camiones1 + 1;
FIN SI

SI zona = 2 ENTONCES;
basura_zona2 = basura_zona2 + basura;
camiones2 = camiones2 + 1;
FIN SI

SI zona = 3 ENTONCES;
basura_zona3 = basura_zona3 + basura;
camiones3 = camiones3 + 1;
FIN SI

SI zona = 4 ENTONCES;
basura_zona4 = basura_zona4 + basura;
camiones4 = camiones4 + 1;
FIN SI

FIN REPITA MIENTRAS;

ESCRIBIR (“Numero de camiones zona 1: ”, camiones1);


ESCRIBIR (“Toneladas de basura recolectadas en zona 1:”, basura_zona1);

ESCRIBIR (“Numero de camiones zona 2: ”, camiones2);


ESCRIBIR (“Toneladas de basura recolectadas en zona 2:”, basura_zona2);

ESCRIBIR (“Numero de camiones zona 3: ”, camiones3);


ESCRIBIR (“Toneladas de basura recolectadas en zona 3:”, basura_zona3);

ESCRIBIR (“Numero de camiones zona 4: ”, camiones4);


ESCRIBIR (“Toneladas de basura recolectadas en zona 4:”, basura_zona4);

FIN
6.- Una compañía otorga a sus vendedores la siguiente condición por venta realizada:
 5% cuando la venta es inferior a Bs 500.000
 7,5% cuando la venta está comprendida entre Bs 500.000 y Bs 1.000.000
 10% cuando la venta es superior a Bs 1.000.000
Realice un algoritmo que lea los siguientes datos por cada venta realizada: Código del vendedor, monto
de la venta,. Cada vendedor tiene varias entradas, tantas como ventas haya realizado en el mes. A su
vez, indicar comisión de la venta, monto de la venta y total de comisión de vendedor.

INICIO ALGORITMO vendedores

VAR monto_venta, comision_venta, total_comision_vendedor, acumulador, acumulador_2:real;


codigo_vendedor:alfanumerico;

acumulador = 0;
acumulador_2 =0;

ESCRIBIR (“¿Desea ingresar nueva venta? (s/n)”);


LEER (respuesta);

REPITA MIENTRAS respuesta = “s”

ESCRIBIR (“Codigo vendedor”);


LEER (“codigo_vendedor”);

ESCRIBIR(“Monto de la venta realizada”);


LEER(monto_venta);

SI monto_venta < 500.000 ENTONCES;


comision_venta = monto_venta * 0,05;
FIN SI;

SI monto_venta > 500.000 Y monto_venta > 1.000.000 ENTONCES;


comision_venta = monto_venta * 0,075;
FIN SI;

SI monto_venta > 1.000.000 ENTONCES;


comision_venta = monto_venta * 0,10;
FIN SI;

acumulador = acumulador + comision_venta;


acumulador_2 = acumulador_2 + monto_venta;

ESCRIBIR (“La comisión por la venta es un total de: ”, comision_venta);

ESCRIBIR (“¿Desea ingresar nueva venta? (s/n)”);


LEER (respuesta);
FIN REPITA MIENTRAS;

ESCRIBIR (“El monto total por todas las ventas realizadas por el vendedor de código ”,
codigo_vendedor, “es de: ”, acumulador_2);

ESCRIBIR (“El monto total de las comisiones de todas las ventas realizadas por el
vendedor de código ”, codigo_vendedor, “es de: ”, acumulador);

FIN