You are on page 1of 4

Τάξη : Γ’ Λυκείου

Ενότητα : Βασικές Δοµές Επιλογής

12ο Φυλλάδιο Ασκήσεων

Ερωτήσεις Σ-Λ
1. Η συνθήκη που ελέγχεται σε µία δοµή επιλογής µπορεί να πάρει περισσότερες από δύο
διαφορετικές τιµές (ΘΠΕ). Σ Λ
2. Στη δοµή επιλογής µπορεί µία ή περισσότερες εντολές να µην εκτελεστούν (ΘΠΕ). Σ Λ
3. Κάθε εντολή ΑΝ περιλαµβάνει πάντοτε το τµήµα ΑΛΛΙΩΣ. Σ Λ
4. Σε µία εντολή ΑΝ που περιλαµβάνει µία µόνο εντολή µπορούµε να µην γράψουµε το
ΤΕΛΟΣ_ΑΝ. Σ Λ

5. Σε µία σύνθετη επιλογή το τµήµα του ΑΛΛΙΩΣ εκτελείται όταν η συνθήκη είναι ΨΕΥΔΗΣ.
Σ Λ

Ερωτήσεις Πολλαπλής Επιλογής


1. Έστω το παρακάτω κοµµάτι κώδικα: 3. Πόσες επιλογές έχουµε µε µία σύνθετη
ΑΝ ( x = 5 ) ΤΟΤΕ
ΑΝ (ΑΝ … ΤΟΤΕ … ΑΛΛΙΩΣ …
ΤΕΛΟΣ_ΑΝ);
y8
ΤΕΛΟΣ_ΑΝ α) 1 β) 2
y2 γ) 3 δ) 4
Για ποια τιµή του x θα αποθηκευτεί στην
µεταβλητή y η τιµή 2;
4. Τι θα εµφανίσει ο παρακάτω κώδικας
α) x = 5 β) x <> 5
στην οθόνη;
γ) x > 5 δ) Για όλες τις τιµές του x. Μ_Ο  9.5
ΑΝ ( Μ_Ο < 10 ) ΤΟΤΕ

2. Η συνθήκη ελέγχου σε µία δοµή ΑΝ ΓΡΑΨΕ "Δεν πέρασες "

µπορεί να είναι: ΑΛΛΙΩΣ


ΓΡΑΨΕ "Πέρασες "
α) µία έκφραση τύπου ακεραίου ή λογικού
ΓΡΑΨΕ "την τάξη"
β) µία έκφραση τύπου λογικού ΤΕΛΟΣ_ΑΝ
γ) µία έκφραση τύπου ακεραίου α) Πέρασες
δ) µία έκφραση που µπορεί να πάρει τις β) Δεν πέρασες
τιµές 0 ή 1.
γ) Πέρασες την τάξη
δ) Δεν πέρασες την τάξη.

Σαρηµπαλίδης Ιωάννης Σελίδα 1


12ο Φυλλάδιο Ασκήσεων Βασικές Δοµές Επιλογής

5. Τι θα εµφανίσει ο παρακάτω κώδικας 7. Τι θα εµφανιστεί στην οθόνη µετά την


στην οθόνη: εκτέλεση του παρακάτω κώδικα;
ΖΑΡΙΑ  8 x5
ΑΝ ( ΖΑΡΙΑ > 7 ) ΤΟΤΕ y8
ΓΡΑΨΕ "Κέρδισες " ΑΝ ΟΧΙ ( x <> y ) ΤΟΤΕ
ΑΛΛΙΩΣ ΓΡΑΨΕ "Διαφορετικοί"
ΓΡΑΨΕ "Έχασες " ΑΛΛΙΩΣ
ΤΕΛΟΣ_ΑΝ ΓΡΑΨΕ "Ίσοι"
ΓΡΑΨΕ "το στοίχηµα" ΤΕΛΟΣ_ΑΝ
α) Κέρδισες α) Ίσοι
β) Έχασες β) Διαφορετικοί

γ) Κέρδισες το στοίχηµα γ) Διαφορετικοί Ίσοι


δ) Έχασες το στοίχηµα.
8. Τι θα εµφανιστεί στην οθόνη µετά την
εκτέλεση του παρακάτω κώδικα;
6. Πως θα πρέπει να συµπληρωθεί το κενό
αν θέλουµε να κάνουµε έκπτωση για x  10
ποσά µεγαλύτερα από 50 €; AN ΌΧΙ ( ΌΧΙ ( x = 5 ) ) TOTE

ΑΝ ( ΠΟΣΟ __ 50 ) ΤΟΤΕ ΓΡΑΨΕ x

ΓΡΑΨΕ "Δεν έχεις έκπτωση." ΑΛΛΙΩΣ

ΑΛΛΙΩΣ ΓΡΑΨΕ ΌXI( x = 10 )

ΓΡΑΨΕ "Έχεις έκπτωση." ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΑΝ α) 10 β) ΑΛΗΘΗΣ
α) = β) <= γ) 5 δ) ΨΕΥΔΗΣ
γ) >= δ) <>

Ασκήσεις
1. Γράψτε κατάλληλες προτάσεις σε ΓΛΩΣΣΑ για να πετύχετε τα παρακάτω:

• Εµφανίστε «Πέρασες» αν ο µέσος όρος ενός µαθητή είναι µεγαλύτερος ή ίσος από το 9.5
αλλιώς εµφανίστε «Απορρίπτεσαι»,
• Εµφανίστε «Ενήλικας» αν η ηλικία ενός ανθρώπου είναι µεγαλύτερη ή ίση από 18 αλλιώς
εµφανίστε «Ανήλικος»,
• Εµφανίστε «Κανονικός» αν το βάρος ενός µαθητή είναι από 65 έως 75 κιλά.

2. Γράψτε κατάλληλες προτάσεις σε ΓΛΩΣΣΑ για να πετύχετε τα παρακάτω:


• Αυξήστε την τιµή της µεταβλητής ΠΛ κατά 1 αν η τιµή της µεταβλητής ΣΥΝΟΛΟ είναι
ίση µε το 0,
• Εκχωρείστε κατάλληλη τιµή στην λογική µεταβλητή Αριστερή_Σελίδα ανάλογα µε την
τιµή της µεταβλητής Σελίδα (Αν η σελίδα είναι άρτιος αριθµός σε ΑΛΗΘΗΣ και αν είναι
περιττός αριθµός σε ΨΕΥΔΗΣ).

Σαρηµπαλίδης Ιωάννης Σελίδα 2


12ο Φυλλάδιο Ασκήσεων Βασικές Δοµές Επιλογής

• Αυξήστε την τιµή της µεταβλητής Σελίδες κατά 1 όταν η τιµή της µεταβλητής
Μέγεθος_Σελίδας είναι µικρότερη από την τιµή της µεταβλητής Πλήθος_Γραµµών,

• Εκχωρείστε στην µεταβλητή y την τιµή της µεταβλητής x µόνο αν το x είναι µεταξύ του 1
και του 20,

3. Γράψτε κατάλληλες προτάσεις σε ΓΛΩΣΣΑ για να πετύχετε τα παρακάτω:


• Εµφανίστε το µήνυµα «Παγκόσµιο Ρεκόρ» αν η επίδοση ενός αθλητή στο άλµα επί κοντώ
είναι µεγαλύτερη από 6.14,
• Εµφανίστε το µήνυµα «Έχασες» αν οι ζωές που έχει ένας παίκτης σε ένα ηλεκτρονικό
παιχνίδι είναι 1 αλλιώς µειώστε τις ζωές του κατά 1,
• Εµφανίστε το µήνυµα «Επιτυχών» αν η βαθµολογία ενός υποψηφίου σε έναν διαγωνισµό
του ΑΣΕΠ είναι ίση ή µεγαλύτερη από το 55 και στις δύο θεµατικές ενότητες που πήρε
µέρος και ο µέσος όρος των δύο θεµατικών ενοτήτων είναι µεγαλύτερος ή ίσος µε το 60.

4. Ποια τα λάθη στα παρακάτω κοµµάτια κώδικα:


α) ΑΝ ( Ι  2 ) ΕΠΑΝΑΛΑΒΕ β) ΑΝ ( x  2 ) TOTE
γ) ΑΝ ( y =< 7 ) TOTE δ) ΑΝ ( x ΚΑΙ y = 0 ) TOTE

Εκτέλεση Κώδικα
1. Έστω το παρακάτω κοµµάτι κώδικα: 3. Έστω το παρακάτω κοµµάτι κώδικα:
ΔΙΑΒΑΣΕ α α4
ΑΝ ( α > 0 ) ΤΟΤΕ β3
ΓΡΑΨΕ "ΘΕΤΙΚΟΣ" γ5
ΤΕΛΟΣ_ΑΝ x6
ΑΝ ( α < 0 ) ΤΟΤΕ ΑΝ ( ( β >= 3 ΚΑΙ γ < 5 ) Ή α = 7 ) ΤΟΤΕ
ΓΡΑΨΕ "ΑΡΝΗΤΙΚΟΣ" xx+3
ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΑΝ
Τι θα εµφανιστεί αν ο χρήστης δώσει -5, ΑΝ ( ( γ >= 3 ΚΑΙ β > 4 ) Ή α = 4 ) ΤΟΤΕ
8, 4.2 και 0. Εξηγείστε την έξοδο όταν ο xx*4
χρήστης δίνει ως είσοδο το 0.
ΤΕΛΟΣ_ΑΝ
ΑΝ ( β <> 5 Ή ( γ < 5 ΚΑΙ α = 4 ) ) ΤΟΤΕ
2. Έστω το παρακάτω κοµµάτι κώδικα: xx-2
ΔΙΑΒΑΣΕ x, y ΤΕΛΟΣ_ΑΝ
Λ1  ( x = y ) Ποια θα είναι η τιµή του x µετά την
Λ2  ( x > Τ_Ρ(y) )
εκτέλεση του παραπάνω κώδικα;

ΓΡΑΨΕ Λ1, Λ2
Τι θα εµφανιστεί αν ο χρήστης δώσει: 4. Έστω το παρακάτω κοµµάτι κώδικα :
α) x = 5, y = 2 AN x > = 10 TOTE
β) x = 4, y = 4 ΓΡΑΨΕ "ΝΑΙ"
γ) x = 10, y = 4. ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ "ΟΧΙ"

Σαρηµπαλίδης Ιωάννης Σελίδα 3


12ο Φυλλάδιο Ασκήσεων Βασικές Δοµές Επιλογής

Τι θα εµφανιστεί αν τιµές των µεταβλητών a, b, c που θα


εµφανιστούν, όταν
α) x = 5 β) x = 10
α) a = 10 και
β) a = -10
5. (ΘΠΕ) Δίνεται το παρακάτω τµήµα
αλγορίθµου:
6. Έστω το παρακάτω κοµµάτι κώδικα:
ΔΙΑΒΑΣΕ a
b2*a+1 x5

ca+b y  10

ΑΝ ( c > b ) ΤΟΤΕ ΑΝ ( x = 5 Ή y = 10 ) KAI x = y ΤΟΤΕ

bc ΓΡΑΨΕ "Δεν τα κατάφερες."

ΑΛΛΙΩΣ ΑΛΛΙΩΣ

cb ΓΡΑΨΕ "Τα κατάφερες."

ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΑΝ

ΕΜΦΑΝΙΣΕ a, b, c Τι θα εµφανιστεί στην οθόνη του


υπολογιστή;
Μετά την εκτέλεση του παραπάνω
τµήµατος αλγορίθµου, ποιες θα είναι οι

Προγράµµατα
1. Ένας δήµος δέχεται καταγγελίες για προβλήµατα στην εξυπηρέτηση των δηµοτών του.
Θέλοντας λοιπόν να διαπιστώσει αν υπάρχει πραγµατικά πρόβληµα ζήτησε να φτιαχτεί
πρόγραµµα το οποίο:

• Θα διαβάζει τον αριθµό των δηµοτών που δεν εξυπηρετήθηκαν τις τρεις τελευταίες
ηµέρες.

• Θα υπολογίζει το µέσο όρο δηµοτών που δεν εξυπηρετήθηκαν και


• Αν ο µέσος όρος είναι µεγαλύτερος από 5, να εµφανίζεται το µήνυµα «Πρόβληµα στην
εξυπηρέτηση των δηµοτών», αλλιώς να εµφανίζεται το µήνυµα «Κανένα πρόβληµα».

2. Το www.speedtest.net είναι ένα site που µας δίνει την δυνατότητα να µετρήσουµε την
ταχύτητα µας στο Internet. Στο site αυτό επιλέγουµε µέσα από έναν χάρτη µία περιοχή,
σε οποιοδήποτε µέρος του κόσµου, και αυτόµατα ξεκινάει η µέτρηση της ταχύτητας µας. Η
µονάδα µέτρησης της ταχύτητας µας είναι σε Kbps. Ο Χρήστος λοιπόν έχει σύνδεση
24Mbps και θέλει να ελέγξει αν όντως αυτή είναι η πραγµατική ταχύτητα σύνδεσης του. Να
γραφεί πρόγραµµα το οποίο:
• Θα διαβάζει τις µετρήσεις που έγιναν κατά την σύνδεση µε τους servers της Αθήνας,
του Ηρακλείου και του Λονδίνου,

• Θα υπολογίζει και θα εµφανίζει το µέσο όρο από τις παραπάνω µετρήσεις,


• Θα εµφανίζει την αντίστοιχη ταχύτητα σε Mbps και
• Αν ο µέσος όρος των µετρήσεων είναι µεγαλύτερος από το 80% της ταχύτητας του
Χρήστου να βγαίνει το µήνυµα «Ικανοποιητική ταχύτητα» αλλιώς να βγαίνει το µήνυµα
«Πρόβληµα στην ταχύτητα σύνδεσης.»
3. Να γραφεί πρόγραµµα το οποίο θα διαβάζει έναν ακέραιο αριθµό και θα αποφαίνεται αν είναι
άρτιος ή περιττός και αν είναι πολλαπλάσιος ή όχι του 5.

Σαρηµπαλίδης Ιωάννης Σελίδα 4