You are on page 1of 3

//////////// R0 //////////////

enable
configure terminal
hostname R0
interface g0/1
ip address 192.168.1.1 255.255.255.128
no shutdown
interface g0/0
ip address 200.10.10.1 255.255.255.252
no shutdown
exit
ip route 0.0.0.0 0.0.0.0 200.10.10.2

ip nat inside source static 192.168.1.2 205.5.5.1


ip nat inside source static 192.168.1.3 255.5.5.2
interface g0/1
ip nat inside
interface g0/0
ip nat outside
exit

access-list 1 permit 192.168.1.0 0.0.0.63


access-list 1 deny 192.168.1.0 0.0.0.3
ip nat pool public-access1 205.5.5.3 205.5.5.28 netmask 255.255.255.224
ip nat inside source list 1 pool public-access1

access-list 2 permit 192.168.1.64 0.0.0.63


ip nat pool public-access2 205.5.5.29 205.5.5.29 netmask 255.255.255.224
ip nat inside source list 2 pool public-access2 overload

//////////////////////////////

//////////// R1 //////////////

enable
configure terminal
hostname R1
interface g0/0
ip address 200.10.10.2 255.255.255.252
no shutdown
interface s0/0/0
ip address 200.10.10.5 255.255.255.252
no shutdown
interface s0/0/1
ip address 200.10.10.13 255.255.255.252
no shutdown
exit
ip route 0.0.0.0 0.0.0.0 200.10.10.1

router ospf 1
network 200.10.10.4 0.0.0.3 area 0
network 200.10.10.12 0.0.0.3 area 0
default-information originate
exit

//////////////////////////////
//////////// R2 //////////////

enable
configure terminal
hostname R2
interface g0/0
ip address 200.10.10.17 255.255.255.252
no shutdown
interface s0/0/1
ip address 200.10.10.6 255.255.255.252
no shutdown
interface s0/0/0
ip address 200.10.10.9 255.255.255.252
no shutdown
exit

router ospf 1
network 200.10.10.4 0.0.0.3 area 0
network 200.10.10.8 0.0.0.3 area 0
network 200.10.10.16 0.0.0.3 area 0
exit

//////////////////////////////

//////////// R3 ///////////////

enable
configure terminal
hostname R3
interface g0/0
ip address 210.2.3.1 255.255.255.0
no shutdown
interface s0/0/0
ip address 200.10.10.21 255.255.255.252
no shutdown
interface s0/0/1
ip address 200.10.10.10 255.255.255.252
no shutdown
exit

router ospf 1
network 200.10.10.8 0.0.0.3 area 0
network 200.10.10.20 0.0.0.3 area 0
network 210.2.3.0 0.0.0.255 area 0
exit

ip dhcp pool dinamic


network 210.2.3.0 255.255.255.0
default-router 210.2.3.1
ip dhcp excluded-address 210.2.3.1

//////////////////////////////

//////////// R4 //////////////

enable
configure terminal
hostname R4
interface g0/1
ip address 200.10.10.18 255.255.255.252
no shutdown
interface g0/0

ip address 200.1.2.1 255.255.255.0


no shutdown
interface s0/0/0
ip address 200.10.10.14 255.255.255.252
no shutdown
interface s0/0/1
ip address 200.10.10.22 255.255.255.252
no shutdown
exit

router ospf 1
network 200.1.2.0 0.0.0.255 area 0
network 200.10.10.12 0.0.0.3 area 0
network 200.10.10.16 0.0.0.3 area 0
network 200.10.10.20 0.0.0.3 area 0
exit

//////////////////////////////

debug ip nat
show ip nat statistics
show ip nat translations