You are on page 1of 23

Desafío OSPF

Lab. 3.5
Desafío 3.5 Lab. OSPF
1. Configurar las interfaces según el direccionamiento IP del diagrama.
2. Configurar el BW para reflejar el actual BW de todos los enlaces seriales.
3. Configurar OSPF con las interfaces y áreas según el diagrama.
4. Configurar R2 para la sumarización del área 20 con mascara lo mas especifica posible.
5. Realizar el link entre R1 y R2 con la red OSPF tipo broadcast, con R1 como el DR.
6. Configurar R1 para que siempre origine una ruta por defecto.
7. Modificar el enlace entre R2 y R3 para que los tiempos de "hello" y "dead" sean el doble de los
valores por defecto.
8. Hacer que el enlace entre R2 y R3 tenga un costo de 500.
9. Configurar el área 34 para que sea totalmente un área "Stubby"
10. Utilizar autenticación MD5 con la palabra clave "cisco" sobre el enlace entre R3 y R4.
11. Descubrir la publicación oculta en la topología que usted necesita direccionar para tener
conectividad total.
12. Hacer correr un script Tcl en todos los routers para verificar que hay conectividad entre el
direccionamiento IP en la topología.
Configuración de interfaces y bandwidth.

• R1: • R2:
!
!
interface Loopback0
interface Loopback0
ip address 172.16.2.1 255.255.255.224
ip address 172.16.1.1 255.255.255.0 !
! interface Loopback1
interface Serial0/0 ip address 172.16.2.33 255.255.255.224
bandwidth 64 !
interface Loopback2
ip address 172.16.12.1 255.255.255.0
ip address 172.16.2.65 255.255.255.224
!
!
interface Loopback3
description Router-ID Virtual-Link
ip address 172.16.2.97 255.255.255.224
!
interface Serial0/0
bandwidth 64
ip address 172.16.12.2 255.255.255.0
!
interface Serial0/1
bandwidth 64
ip address 172.16.23.2 255.255.255.0
!
• R3: • R4:
! !
interface Loopback0 interface Loopback0
description Router-ID Virtual-Link ip address 172.16.4.1 255.255.255.0
ip address 172.16.3.1 255.255.255.0 !
! interface Serial0/0
interface Serial0/0 bandwidth 64
bandwidth 64 ip address 172.16.34.4 255.255.255.0
ip address 172.16.34.3 255.255.255.0 !
!
interface Serial0/1
bandwidth 64
ip address 172.16.23.3 255.255.255.0
!
Configuración OSPF.
• R1: • R2:
! !
router ospf 1 router ospf 1
log-adjacency-changes log-adjacency-changes
passive-interface default area 20 range 172.16.2.0 255.255.255.128
no passive-interface Serial0/0 area 23 virtual-link 172.16.3.1
network 172.16.1.0 0.0.0.255 area 0 passive-interface default
network 172.16.12.1 0.0.0.0 area 0 no passive-interface Serial0/0
default-information originate always no passive-interface Serial0/1
! network 172.16.2.0 0.0.0.127 area 20
• R3: network 172.16.12.2 0.0.0.0 area 0
! network 172.16.23.2 0.0.0.0 area 23
router ospf 1 !
log-adjacency-changes
• R4:
area 23 virtual-link 172.16.2.97
!
area 34 stub no-summary
router ospf 1
area 34 stub
log-adjacency-changes
passive-interface default
area 34 stub
no passive-interface Serial0/0
passive-interface default
no passive-interface Serial0/1
no passive-interface Serial0/0
network 172.16.3.0 0.0.0.255 area 23
network 172.16.4.0 0.0.0.255 area 34
network 172.16.23.3 0.0.0.0 area 23
network 172.16.34.4 0.0.0.0 area 34
network 172.16.34.3 0.0.0.0 area 34
!
!
Proceso OSPF.
LSA 4.
Elección DR y Tipo de Red.
• R1: • R2:
! !
interface Serial0/0 interface Serial0/0
bandwidth 64 bandwidth 64
ip address 172.16.12.1 255.255.255.0 ip address 172.16.12.2 255.255.255.0
ip ospf network broadcast ip ospf network broadcast
ip ospf priority 10 !
!
Modificación de Temporizadores y Costo.
• R2: • R3:
! !
interface Serial0/1 interface Serial0/1
bandwidth 64 bandwidth 64
ip address 172.16.23.2 255.255.255.0 ip address 172.16.23.3 255.255.255.0
ip ospf cost 500 ip ospf cost 500
ip ospf hello-interval 20 ip ospf hello-interval 20
ip ospf dead-interval 80 ip ospf dead-interval 80
! !
Autenticación.
• R3: • R4:
! !
interface Serial0/0 interface Serial0/0
bandwidth 64 bandwidth 64
ip address 172.16.34.3 255.255.255.0 ip address 172.16.34.4 255.255.255.0
ip ospf authentication message-digest ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 cisco ip ospf message-digest-key 1 md5 cisco
! !
Proceso Autenticación.
IP que
origina
conversación

ID inicial en
proceso de
autenticación.
IP destino
transacción.

Sin
Autenticación.
ID establecido en
negociación.
ID establecido
en negociación.
Verificación de Conectividad.

tclsh IP’s
! !
foreach address { 172.16.1.1
! 172.16.2.1
[IP’s] 172.16.2.33
}{ 172.16.2.65
ping $address } 172.16.2.97
! 172.16.3.1
tclquit 172.16.4.1
172.16.12.1
172.16.12.2
172.16.23.2
172.16.23.3
172.16.34.3
172.16.34.4
!
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/22/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/23/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.65, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/24/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.97, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/15/32 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/53/96 ms
!
!
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/76/180 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/31/72 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/25/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/31/44 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/31/56 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.34.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/47/84 ms
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.34.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/63/88 ms