You are on page 1of 5

APUNTES DEL MÓDULO PROFESIONAL: FUNDAMENTOS DE PROGRAMACIÓN – (2

)

Página 1 de 5

ORDINOGRAMAS Y PSEUDOCÓDIGO:
Ordinogramas: Representan gráficamente paso a paso todas las instrucciones del programa a codificar reflejando la secuencia lógica de las operaciones necesarias para la resolución del problema. Muestra gráficamente el algoritmo del programa. 1. 2. 3. 4. 5. 6. 7. Debe tener un Inicio y un fin (programa propio). Deben usarse líneas rectas (no curvas). Debe diseñarse de arriba abajo y de izquierda a derecha (mayor legibilidad). Debe guardarse la mayor simetría gráfica posible. Deben usarse expresiones independientes de los lenguajes de programación (formato general). Deben intentar evitarse los cruces de líneas (porque provocan confusión). Debe utilizarse el mínimo número de instrucciones posible (simplicidad).

Pseudocódigo: Es una notación mediante la cual podemos escribir la solución a un problema dado en forma de algoritmo (pasos ordenados) utilizando palabras y frases del lenguaje natural aunque sujetas a determinadas reglas impuestas. • Instrucciones primitivas: (En pseudocódigo se escriben igual pero sin la figura geométrica) o Asignación (a una variable de un valor). número ← 5 número ← número + 3 número ← 12,5 nombre ← “Yo” resultado ← “Sí”

o Entrada de datos (por teclado). LEER nombre LEER nombre, dni

o Salida de datos (mostrar por pantalla o imprimir por la impresora): MOSTRAR nombre MOSTRAR nombre • Instrucciones de control no repetitivas: SIMPLE NO número=5 SÍ NO número=5 COMPUESTA SÍ IMPRIMIR nombre, dni IMPRIMIR nombre, “: ”, dni

APUNTES DEL MÓDULO PROFESIONAL: FUNDAMENTOS DE PROGRAMACIÓN – (2) Página 2 de 5 SWITCH (EVALUAR) 1 2 3 número 4 5 EN OTRO CASO • Instrucciones de control repetitivas: MIENTRAS HASTA NO número=5 SÍ No SÍ número=5 PARA PARA x ←1 HASTA 10 INCREMENTANDO EN 1 En pseudocódigo sería: … SI número=5 ENTONCES … FIN SI … … SI número=5 ENTONCES … SI NO … FIN SI … … EVALUAR número SI VALE 1: … … SI VALE 8: … EN OTRO CASO: … FIN EVALUAR .

ALGORITMO: MOSTRAR “Introduzca un número:” LEER número1 MOSTRAR “Introduzca otro número:” LEER número2 suma ← número1 + número2 MOSTRAR “Resultado:”. “El resultado es:”…). 4. ‘=’…). Identación (tabulación) del código para mejor legibilidad. número2. . MIENTRAS. Textos literales entre comillas dobles (“hola”. Cada carácter suelto o tecla suelta entre comillas simples (‘a’. ‘@’. suma FIN PROGRAMA. SI. INICIO…). INICIO MOSTRAR “Introduzca un número:” LEER número1 MOSTRAR “Introduzca otro número:” LEER número2 suma ← número1 + número2 MOSTRAR “Resultado:”. Números literales sin comillas (1. -23. Nombre. LEER. suma FIN En pseudocódigo sería: PROGRAMA Sumar OBJETOS: número1. Variables en minúsculas o sólo con la primera letra en mayúsculas (número. Ejemplo: Realizar el ordinograma y el pseudocódigo de un algoritmo que permita pedir 2 números por teclado y muestre la suma de ellos. valor…).25…).APUNTES DEL MÓDULO PROFESIONAL: FUNDAMENTOS DE PROGRAMACIÓN – (2) Página 3 de 5 … MIENTRAS número=5 HACER … FIN MIENTRAS … Algunas convenciones que utilizaremos: • • • • • • … HACER … HASTA QUE número=5 … … PARA x ←1 HASTA 10 INCREMENTANDO EN 1 HACER … FIN PARA … Palabras reservadas en mayúsculas (MOSTRAR. suma: Variables numéricas de tipo real. 34. “Introduzca su nombre”.

INICIO MOSTRAR “Introduzca un número entero” LEER número SÍ número < 0 NO MOSTRAR “Es negativo” MOSTRAR “No es negativo” FIN En pseudocódigo sería: PROGRAMA DetectarNegativo OBJETOS: número: Variable numérica de tipo entero. .APUNTES DEL MÓDULO PROFESIONAL: FUNDAMENTOS DE PROGRAMACIÓN – (2) Página 4 de 5 Ejemplo: ordinograma y pseudocódigo de un algoritmo que solicita un número por teclado al usuario e informa de si el número introducido es negativo (menor que cero) o no. NOTA: Las palabras reservadas deben aparecer en mayúsculas. así que las marcaremos en negrita para identificarlas claramente. ALGORITMO: MOSTRAR “Introduzca un número entero” LEER número SI número < 0 ENTONCES MOSTRAR “Es negativo” SI NO MOSTRAR “No es negativo” FIN SI FIN PROGRAMA.

*/ #include<stdio. } system(“PAUSE”).h> // system int main() { int x. /* MostrarHola10. } system(“PAUSE”). return(0). /* MostrarHola10. */ #include<stdio. x++. x++. do { printf(“hola”).c: Programa en C que muestra 10 veces en pantalla la cadena “hola” usando un bucle for.c: Programa en C que muestra 10 veces en pantalla la cadena “hola” usando un bucle while. return(0). x = 1. INICIO x←1 Usando un bucle MIENTRAS INICIO x←1 Usando un bucle HASTA INICIO Usando un bucle PARA PARA x ← 1 HASTA 10 INCREMENTANDO EN 1 MOSTRAR “hola” NO x ≤ 10 SÍ MOSTRAR “hola” x←x+1 SÍ x > 10 NO MOSTRAR “hola” x←x+1 FIN PROGRAMA MostrarHola10 OBJETOS: x: Variable numérica entera.h> // printf #include<stdlib. x = 1. ALGORITMO: x←1 HACER MOSTRAR “hola” x←x+1 HASTA QUE x>10 FIN PROGRAMA. } while( x <= 10 ). /* MostrarHola10. pseudocódigo y código fuente en lenguaje C de un algoritmo que muestra en pantalla 10 veces la cadena de caracteres “hola” usando los 3 tipos de bucles que hemos visto.h> // printf #include<stdlib. x++ ) { printf(“hola”). x <= 10 . FIN FIN PROGRAMA MostrarHola10 OBJETOS: x: Variable numérica entera. } PROGRAMA MostrarHola10 OBJETOS: x: Variable numérica entera.APUNTES DEL MÓDULO PROFESIONAL: FUNDAMENTOS DE PROGRAMACIÓN – (2) Página 5 de 5 Ejemplo: ordinograma. ALGORITMO: x←1 MIENTRAS x ≤ 10 HACER MOSTRAR “hola” x←x+1 FIN MIENTRAS FIN PROGRAMA.h> // system int main() { int x.h> // system int main() { int x. } } . */ #include<stdio. while( x <= 10 ) { printf(“hola”). return(0). for( x = 1 . system(“PAUSE”). ALGORITMO: PARA x ← 1 HASTA 10 INCREMENTANDO EN 1 MOSTRAR “hola” FIN PARA FIN PROGRAMA.c: Programa en C que muestra 10 veces en pantalla la cadena “hola” usando un bucle do-while.h> // printf #include<stdlib.