2010

ECONOMIA DE SOFTWARE
PRACTICA 4 – CASO DE PRUEBAS

Alumno:

Cáceres Pérez, Max Ivan

Realizado: Cáceres Pérez, Max

CASO
Probar el componente de facturación del sistema automatizado de ventas, cuya funcionalidad es la siguiente: a) La cajera ingresa los productos con sus correspondientes precios. b) Al finalizar la operación la maquina calcula los totales. c) Si el total es mayor o igual que 400 habrá un descuento del 15%, si el total es mayor o igual 100 y menor que 400 habrá un descuento del 10% y si el total es menor que 100 habrá un descuento de 0.5%. d) Si el cliente paga con tarjeta de crédito habrá un descuento del 2%, si paga en efectivo habrá un descuento del 1%. Realizar lo siguiente:
1. 2. 3. 4.

Diagrama de flujo de datos. Pseudocódigo. Diseñar grafo y hallar los caminos. Realizar pruebas.

Aplicación

VENTA DE PRODUCTOS

Ingrese Nombre cliente: Producto Cant.

Escriba texto
Precio Total ¿Sigue Ing?

Forma de Pago Tarjeta Efectivo

Total: Descuento: Total Pagar:

0.0 0.0 0.0

ACEPTAR

Realizado: Cáceres Pérez, Max | Confidencial

1. Diagrama de flujo de datos
Inicio

Nombre del Cliente Leer NC

¿Ingresar otro producto?

A=’S’ P=0 C=0 AC=0 ST=PRE*C AC=AC+ST

Ingresar: Nombre producto, NP Cantidad, C Precio, PRE ¿A=’S’ ? SI

NO

¿AC>=400?

SI

DSCTO=AC*0.15

NO

¿AC>=100 y AC<400?

SI

DSCTO=AC*0.10

NO

DSCTO=AC*0.05

TP=AC-DSCTO

¿PAGO=’E’?

SI

DA=TP*0.01

NO

DA=TP*0.02 PT=ST-DA DSCTOTAL=DA+DSCTO

TOTAL , AC DESCUENTO, DSCTO TOTAL A PAGAR, TP

Realizado: Cáceres Pérez, Max | Confidencial

2. Pseudocódigo. ALGORITMO VENTAS VARIABLES CADENA: NP CARÁCTER: A, PAGO REAL: PRE, C, AC, DA, PT, ST, DSCTO, DSCTOTOTAL INICIO A=’S’ P=0 1 C=0 AC=0 HACER MIENTRAS (A=’S’) 2 IMPRIMIR “Ingrese Nombre del Producto” LEER NP IMPRIMIR “Cantidad” LEER C IMPRIMIR “Ingrese Precio” 3 LEER PRE ST=PRE*C 6 AC= AC+ST IMPRIMIR “¿Desea Continuar S/N?” LEER A 4 FIN MIENTRAS SI (AC>=400) ENTONCES 5 DSCTO=AC*0.15 8 SINO SI (AC>=100 Y AC<400) ENTONCES 9 DSCTO=AC*0.1 7 SINO 10 DSCTO=AC*0.05 FIN SI ST=AC-DSCTO 11 IMPRIMIR “¿INGRESE TIPO DE PAGO?” LEER PAGO 12 SI (PAGO=’E’) ENTONCES 13 DA=ST*0.01 SINO 14 DA=ST*0.02 FIN SI PT=ST-DA DSCTOTOTAL=DA+DSCTO 15 IMPRIMIR “Total”, ST IMPRIMIR “Descuento”, DSCTOTOTAL IMPRIMIR “Total a Pagar”, PT FIN

Realizado: Cáceres Pérez, Max | Confidencial

3. Grafos De Flujo
1
a1

2
a2 a4

Región 1
a3

3

Región 2
4
a5

a7

5
a8

a6

7
a9 a11

6

Región 4
a10

Región 3
A13

8

Región 5
10
a12

9
a14

11
a15

a=18 n=14
a16

12
A17

V (G)= 19-14+2=7 Reg. Cerradas V (G)=5+1=6 Condiciones

Región 6
14 13

a19

a18

Caminos 1, 2, 3, 2, 4, 5, 6, 11, 12, 13, 15 1, 2, 3, 2, 4, 5, 6, 11, 12, 14, 15 1, 2, 3, 2, 4, 5, 7, 8, 9, 11, 12, 13, 15 1, 2, 3, 2, 4, 5, 7, 8, 9, 11, 12, 14, 15 1, 2, 3, 2, 4, 5, 7, 8, 10, 11, 12, 14, 15 1, 2, 3, 2, 4, 5, 7, 8, 10, 11, 12, 13, 15 1, 2, 3, 2, 4, 5, 7, 11, 12, 13, 15

15

Realizado: Cáceres Pérez, Max | Confidencial

4. Pruebas Usando el camino: 1, 2, 3, 2, 4, 5, 6, 11, 12, 13, 15
INGR. Nro. Pr. Nombre Cliente Nombre PRODUCTO Cant. Precio ¿Cont? AC CALCULO DSCTO TP INGR. ¿T.Pago? CALCULO DA PT CALC DSCTOTAL Res. Prueba

1

Juan

jabón Lejía

1 2

300 51

S N

300 102 402 60,3 341,7 402-60,3 E Verdad 'E'='E' 3,42 341,7*0,01 338,28 341,7-3,42 63,72 60,3+3,42 OK

CONDICIONES 2 Miguel hernandez Vino Rose Ron Papel Suave Cerveza 1 2 5 2 300 20 30 51 S S S N

402>=400 402*0,15 300 40 150 102 592 88,8

E 503,2 592-88,8 Verdad 'E'='E' 5,03 503,2*0,01 498,17 503,2-5,03 93,83 88,8+5,90

OK

CONDICIONES 2 Miguel hernandez Vino Rose Ron Papel Suave Cerveza 1 2 5 2 300 20 30 51 S S S N

592>=400 592*0,15 300 40 150 102 592 88,8

e 503,2 592-88,8 FALSO 'e'='E' 10,06 503,2*0,02 493,14 503,2-10,06

Error - El tipo de pago no es el adecuado, se debe verificar las mayusculas 98,86 y minusculas

CONDICIONES

592>=400 592*0,15

88,8+10,06