You are on page 1of 3

Τάξη : Γ’ Λυκείου

Ενότητα : Δοµή Επανάληψης ΓΙΑ

20ο Φυλλάδιο Ασκήσεων

Ασκήσεις
1. Γράψτε κώδικα ο οποίος θα εµφανίζει:
• το τετράγωνο όλων των αριθµών από το 1 µέχρι το 20.

• την τετραγωνική ρίζα και την απόλυτη τιµή όλων των αριθµών από το 3 µέχρι το 30 (οι
αριθµοί πρέπει να είναι πολλαπλάσια του 3).
• το επώνυµο σας 10 φορές και το όνοµα σας 5 φορές (να γίνει χρήση µόνο µίας ΓΙΑ)

• την τιµή της συνάρτησης ηµ(x) από 0ο έως 360ο µε διάστηµα 10ο.

2. Γράψτε κώδικα ο οποίος θα υπολογίζει:


• το άθροισµα όλων των ακεραίων αριθµών από το 5 µέχρι το 15.

• για έναν δοσµένο ακέραιο αριθµό Ν το άθροισµα:


1 * ( Ν – 1 ) + 2 * ( Ν – 2 ) + …. + ( Ν – 2 ) * 2 + ( Ν – 1 ) * 1
• για έναν δοσµένο ακέραιο αριθµό Ν το άθροισµα:
2 2 2 2
1 / 1 + 1 / 2 + …. + 1 / ( Ν – 1 ) + 1 / Ν

3. Δίνεται η παρακάτω εντολή:


ΓΙΑ Α ΑΠΟ Β ΜΕΧΡΙ Γ ΜΕ_ΒΗΜΑ Δ
ΕΜΦΑΝΙΣΕ "ΚΑΛΗΣΠΕΡΑ"
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Να γράψετε στο τετράδιο σας πόσες φορές εκτελείται η εντολή ΕΜΦΑΝΙΣΕ για καθένα από
τους παρακάτω συνδυασµούς των τιµών των µεταβλητών Β, Γ και ∆:
α) Β = 2, Γ = 5, Δ = 1 β) Β = -1, Γ = 1, Δ = 0,5

γ) Β = -7, Γ = -6, Δ = -5 δ) Β = 5, Γ = 5, Δ = 1

4. Έστω το παρακάτω κοµµάτι κώδικα που εµφανίζει τους αριθµούς από το 1 µέχρι το 10:
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
ΓΡΑΨΕ Ι
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Τι αλλαγές πρέπει να κάνετε για να:
• Εµφανίζονται οι αριθµοί ανάποδα (δηλαδή 10, 9, 8, … 1),
• Εµφανίζονται µόνο οι άρτιοι αριθµοί (δηλαδή 2, 4, 6, 8, 10),

Σαρηµπαλίδης Ιωάννης Σελίδα 1


20ο Φυλλάδιο Ασκήσεων Δοµή Επανάληψης ΓΙΑ

• Υπολογίζεται το άθροισµα των παραπάνω αριθµών και στο τέλος να εµφανίζεται.

5. Γράψτε κώδικα ο οποίος:

• θα διαβάζει το ύψος των µαθητών µίας τάξης 20 µαθητών και θα εµφανίζει µηνύµατα
της µορφής «Ο 1ος µαθητής έχει ύψος 1.75 µέτρα.»

• θα διαβάζει το βάρος των 36 δεµάτων µίας ταχυδροµικής αποστολής και θα εµφανίζει


µηνύµατα της µορφής «Το βάρος του 15ου δέµατος είναι 5.55 κιλά.»

• θα διαβάζει τον µισθό των 15 υπαλλήλων µία εταιρείας και θα εµφανίζει µηνύµατα της
µορφής «Ο µισθός του 5ου υπαλλήλου είναι µεγαλύτερος ή ίσος από 1000€» ή µηνύµατα
της µορφής «Ο µισθός του 5ου υπαλλήλου είναι µικρότερος από 1000€»

6. Να αναπτύξετε αλγόριθµο που να διαβάζει από το πληκτρολόγιο 100 ακεραίους αριθµούς,


να υπολογίζει το γινόµενο τους και να το εµφανίζει.

Ερωτήσεις Σωστού - Λάθους


1. Οι εντολές που περιέχονται στο σώµα της εντολής επανάληψης ΓΙΑ µπορεί να µην
εκτελεστούν ποτέ.
2. Στην εντολή επανάληψης ΓΙΑ µπορούµε να παραλείψουµε το βήµα της επανάληψης.

3. Η εντολή επανάληψης ΓΙΑ απαιτεί την αρχικοποίηση του µετρητή των επαναλήψεων πριν
την επανάληψη.

4. Το βήµα επανάληψης σε µία εντολή επανάληψης ΓΙΑ µπορεί να είναι αρνητικός αριθµός.
5. Το βήµα επανάληψης σε µία εντολή επανάληψης ΓΙΑ µπορεί να είναι µηδέν.

6. Σε µία εντολή επανάληψης ΓΙΑ όταν παραλείπουµε το βήµα επανάληψης αυτό σηµαίνει ότι
το βήµα επανάληψης είναι 1.
7. Η εντολή επανάληψης ΓΙΑ εκτελείται όσο η µεταβλητή που ακολουθεί την λέξη ΓΙΑ έχει
τιµή µικρότερη ή ίση από την τελική τιµή.

8. Ο βρόχος Για Κ από 5 µέχρι 1 εκτελείται 5 φορές.

9. Στην εντολή επανάληψης ΓΙΑ πρέπει να υπάρχει µέσα στην επανάληψη µία εντολή που να
αλλάζει την τιµή του µετρητή.
10. Σε µία εντολή επανάληψης ΓΙΑ η αρχική τιµή της µεταβλητής ελέγχου πρέπει να είναι
πάντα µικρότερη από την τελική τιµή.
11. Στην επαναληπτική δοµή Για … από … µέχρι … µε_βήµα οι τιµές από, µέχρι και µε_βήµα δεν
είναι απαραίτητο να είναι ακέραιες.
12. Ο βρόχος Για Κ από 5 µέχρι 5 δεν εκτελείται καµία φορά.

13. Στην εντολή ΓΙΑ ο βρόχος επαναλαµβάνεται για προκαθορισµένο αριθµό επαναλήψεων.

14. Ο βρόχος Για Κ από -4 µέχρι -3 εκτελείται ακριβώς 2 φορές.


15. Δεν επιτρέπεται να έχω εµφωλευµένο βρόχο ΟΣΟ µέσα σε µία εντολή ΓΙΑ

Σαρηµπαλίδης Ιωάννης Σελίδα 2


20ο Φυλλάδιο Ασκήσεων Δοµή Επανάληψης ΓΙΑ

Ερωτήσεις Πολλαπλής Επιλογής


1. Τι θα εµφανίσει ο παρακάτω κώδικας ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

στην οθόνη του υπολογιστή; ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Α1 Πόσες φορές θα εκτελεστεί η εντολή


ΓΙΑ Ι ΑΠΟ 0 ΜΕΧΡΙ 3 ΓΡΑΨΕ;
ΑΑ*Ι α) 180 β) 360
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
γ) 720 δ) 2160
ΓΡΑΨΕ Α

α) 0 β) 1 Αιτιολογήστε την απάντηση σας.

γ) 2 δ) 6
5. Πόσες φορές θα εµφανιστεί ο αριθµός 5
στην οθόνη του υπολογιστή;
2. Πόσες φορές θα εκτελεστεί η εντολή
ΓΙΑ Ι ΑΠΟ 5 ΜΕΧΡΙ 9 ΜΕ_ΒΗΜΑ 2
ΓΡΑΨΕ στο παρακάτω κοµµάτι κώδικα;
ΓΡΑΨΕ Ι
Α1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΟΣΟ Α <= 10 ΕΠΑΝΑΛΑΒΕ
α) 0 β) 1
ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 5 ΜΕ_ΒΗΜΑ 2
ΑΑ+I γ) 2 δ) 3
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ Α
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 6. Ο βρόχος
α) 10 β) 2 ΓΙΑ Ι ΑΠΟ 5 ΜΕΧΡΙ 5
ΓΡΑΨΕ Ι
γ) 9 δ) 3
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

θα εκτελεστεί
3. Σε µία δοµή επανάληψης ΓΙΑ ο έλεγχος α) 0 φορές β) 1 φορά
της µεταβλητής γίνεται:
γ) 5 φορές δ) άπειρες φορές
α) µόνο στην αρχή της επαναληπτικής
διαδικασίας

β) στην αρχή κάθε επανάληψης 7. Πόσες φορές θα εκτελεστεί ο βρόχος


ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 2 ΜΕ_ΒΗΜΑ 0.01
γ) στο τέλος κάθε επανάληψης
ΓΡΑΨΕ Ι
δ) πριν την επαναληπτική διαδικασία. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

α) 1 φορά β) 10 φορές

4. Έστω ο κώδικας: γ) 101 φορές δ) δεν ορίζεται


ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 6
ΓΙΑ J ΑΠΟ 2 ΜΕΧΡΙ 10 ΜΕ_ΒΗΜΑ 2
8. Έστω ο αριθµός 10010100. Αν
ΓΙΑ K ΑΠΟ 3 ΜΕΧΡΙ 12 ΜΕ_ΒΗΜΑ 3
εφαρµοστεί ολίσθηση προς τα αριστερά
ΓΙΑ L ΑΠΟ 4 ΜΕΧΡΙ 6
κατά 1 θέση θα προκύψει ο αριθµός
ΓΡΑΨΕ "Εξετάσεις"
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ α) 00101001 β) 00101000
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ γ) 01001010 δ) 00010100

Σαρηµπαλίδης Ιωάννης Σελίδα 3