You are on page 1of 72

ENTERPRISED NETWORK

SIX WEEK INDUSTRIAL TRAINING REPORT

SUBMITTED IN PARTIAL FULFILLMENT OF THE REQUIREMENT

FOR THE

AWARD OF THE DEGREE OF B.TECH (I.T)

SUBMITTED BY:

HARISH NISCHAL

90210873728

INFORMATION TECHNOLOGY

CT INSTITIUTE OF TECHNOLOGY, SHAHPUR,

JALANDHAR

TABLE OF CONTENTS

Page 1
Sr. No. CONTENTS PAGE NO. REMARKS

1 Acknowledgement 3

2 Certificate of the Company/Organization 4

3 Preferences 5

4 Company/Organization Profile 6

5 Introduction 7

6 Requirements Analysis Phase 35

7 Design Phase 41

8 Implementation Phase 47

9 Operations and Maintenance Phase 49

10 Limitations and scope of improvement 67

11 Conclusion 70

12 Bibliography/References 72

ACKNOWELDGEMENT

To us and also to those who have helped us directly or Indirectly in bringing out this
project report satisfactorily. With deep sense of gratitude I express my thanks , for
the guidance provided to me , by my respected sir SANAMJEET SINGH,
encouragement has been of immense help to me. Also we would like to thank our

Page 2
Project Coordinator, Mrs SANDEEP BASSI, for her useful comments. We also
take this opportunity to give thanks to all other who gave us support for the project
or in other aspects of our study at Lyallpur Khalsa College ,JALANDHAR.

DECLARATION

Page 3
I hereby declare that this project submitted for the M.Sc degree is my
original work and the project has not formed the basis for the award of
any degree, associate ship, fellowship or any other similar titles

Signature of Student :

Place: ________________ ________________

PREFACE

Page 4
The world is shrinking. New era is going to be an era of great technology and
only those who will have the ability to move along with fast paced technology
are going to survive. To move along with technology a Student must be
equipped with the practical knowledge of work. Now the quality of knowledge
is more important than the quantity. So a person without practical knowledge
is nil no matter how many books he has read.

The practical training is highly conducive for the development of:

• Solid foundation of knowledge and technical skill.


• Interpersonal skills and Confidence.
• Excellence and Self-discipline.

It was my pleasure that I got an opportunity to undergo my six-month


industrial training in Labs n Racks, JALANDHAR. When I joined I was
associated with the CCNA for the six months training period.

In this report, I tried to sum up the technical knowledge that I had gained
during this valuable training period of six months.

Page 5
1. COMPANY PROFILE

Company Profile
Labs N Racks
Labs N Racks is the first and only professional CISCO training institute around Haryana, Punjab,
Uttaranchal, HP, J & K, and Rajasthan which is providing CCIE training, led by a team of highly

Page 6
qualified CISCO trainers. Labs N Racks was born when experts from the field of
internetworking who had significant experience both in industry as well as educational training
came together to start their own institute.

Labs N Racks is providing CISCO training from the basic level to the advanced level, so the
students who want to enter into the field of IT do not find any difficulty in acquiring and
developing the required expertise. Our motto is to train students from around the world who are
looking forward to excel in the field of Internetworking.

Labs N Racks has one of the best networking equipment in this region complete in all respects.
There is a tremendous dearth of qualified human resource in the internetworking service
industry. Even the huge number of academic institutions offering Degrees and Diplomas do not
fill this ever widening gap. Labs N Racks has been founded to fill this wide gap by preparing an
individual to best fit the industry requirements. We have a highly qualified team for our
integration business, which enables us to provide to our students best of real life training in the
industrial world.

The leadership of Labs N Racks possesses sound technical knowledge to ensure that Labs N
Racks trainers are masters in the internetworking technologies in general and are SMEs (Subject
Matter Experts) for the courses they deliver. It is the only institute in the region which has CCIE
trainers having a past experience of more than 8 years in the training industry.

Labs N Racks aims to strategize relations with global IT majors which set the trends and raise
our bar to internationally acclaimed IT power house. Association with the standard setters will
facilitate the students getting hands on experience and ready resources for complete all round IT
training to excel in any of the large list of fields the IT industry has.

We had envisaged being the leading provider of CISCO certification training in Mohali when we
stared operations and we achieved this in just a few months. We now have our sights set on
establishing an international presence through strategically chosen partners who can meet the
standards we have set to ascertain the quality we are known & respected for.

Page 7
2. INTRODUCTION

INTRODUCTION

Whether you already work in the computer technology industry, or you are trying to enter the
field as a newcomer, it is important in this day and age to back up your resume with a vendor

Page 8
specific certification. If you search job postings on the Internet, it is commonplace for hiring
companies today to require or recommend that an applicant have at least one vendor
certification. Other companies ask that their current employees obtain certifications as a way to
meet goals for advancement. Regardless of the underlying reason, studying for the CCNA is a
smart move. The CCNA certification was developed by Cisco to test your knowledge of
networking at a beginner’s level. Cisco wants to identify individuals capable of installing,
configuring, and maintaining small-scale networks, which include Local Area Networks (LANs)
and Wide Area Networks (WANs). The purpose of this first chapter is to provide a general
overview of the concepts that will ultimately be the foundation for the rest of this book. To start
this chapter, the first step is to define the term internetwork. It then reviews the general concepts
that pertain to LAN and WAN internetworks, as well as the Metropolitan Area Network (MAN),
Storage Area Network (SAN), and Virtual Private Network (VPN). Later chapters go into more
detail regarding the technologies that are related to both LAN and WAN. This chapter also gives
an in-depth look at the three networking reference models that are likely to be tested on the
CCNA exam. These are the Open Systems Interconnection (OSI), Transmission Control
Protocol/Internet Protocol (TCP/IP), and Cisco 3-Layer Hierarchical models. Being familiar with
these models is fundamental to understanding how networks operate, as well as how various
devices and protocols fit into their structure. By using these models, you can design an
infrastructure based on a given organization’s specific requirements.

What Is an Internetwork?

Simply put, an internetwork is the connection of more than one network. These networks are
linked together by an internetworking device to provide communication between the networks.
Internetworks may also be referred to as an internet. Notice the lower case i at the beginning of

Page 9
the word internet—this differentiates it from the Internet. The Internet is considered to be the
largest internet in the world. I know the phrase sounds odd, but it is a great example of how
thousands of smaller networks are joined together to form one large global internetwork. Another
example of an internet would be the connection of individual LANs to form a WAN. The term
internetworking signifies the industry, products, and processes that are required to handle the
challenges of network interoperability. Such issues can be quite complex because of the
existence of multiple vendors and protocols.

Types of Internetworks
There are various types of internetworks discussed in greater detail. I already mentioned LAN
and WANs, which are the most common types of internetworks. Other important internetworks
include MANs, SANs, and VPNs, which are also reviewed in this section.

Page 10
Local Area Network (LAN)
Like the name suggests, LANs are limited to a local or small geographical area. An example of a
LAN would be a network of individual computers or workstations that are connected in a single
department. These users have shared access to resources such as data and network devices. Users
on a LAN segment can share a network printer and communicate with one another via email.
Also, they are governed by one authoritative administrator. LAN is the smallest network in
geographical size.

N Given the size constraints, downsides of a LAN network are limited


distance that data can travel and a limited number of computers that can be connected. An upside
of a LAN is fast data transfer with data speed that can reach up to 10Gbps. Xerox Corporation
worked in collaboration with DEC and Intel to create Ethernet, which is the most pervasive LAN
architecture used today. Ethernet has evolved and has seen significant improvements in regard to
speed and efficiency. Other significant LAN technologies are Fiber Distributed Data Interface
(FDDI) and token ring.

Page 11
Metropolitan Area Network (MAN)
A MAN is larger than a LAN but smaller than or equal in size to a WAN. Think of it as the size
of a city or college campus network, which can range anywhere from 5 to 50km in diameter.
MANs are typically owned and managed by a single entity. This could be an ISP or
telecommunications company that sells its services to end-users in that metropolitan area. For all
intents and purposes, a MAN has the same characteristics as a WAN with distance constraints.

Wide Area Network (WAN)


WANs cover more than one geographical area. This is ideal for a company that has offices in
different cities around the country or even the world. Each office can connect to the other sites in
the WAN via a router. Connectivity from router to router is a circuit leased from a telephone or
communications company, such as AT&T to name one. The larger the circuit a company needs
to transmit data, the more it costs to lease. The company also needs to pay close attention to the
performance of its WAN connection because that cost can directly impact its ability to do
business. It is important to keep an eye on the amount of traffic that is going over each circuit to
ensure that you have sufficient throughput. Throughput refers to the amount of data transferred
in a specified timeframe..

Page 12
Storage Area Network (SAN)
SAN may be referred to as a subnetwork or special purpose network. Its special purpose is to
allow users on a larger network to connect various data storage devices with clusters of data
servers. Cisco offers this service with its Cisco MDS 9000 Series Multilayer SAN Switches.
These switches provide scalable storage solutions for the end user.

Virtual Private Network (VPN)


VPN is a private network that can access public networks remotely. VPN uses encryption and
security protocols to retain privacy while it accesses outside resources. When employed on a
network, VPN enables an end user to create a virtual tunnel to a remote location. Typically,
telecommuters use VPN to log in to their company networks from home.

Page 13
 OSI REFERENCE MODEL

One of the greatest functions of the OSI specifications is to assist in data transfer between
disparate hosts—meaning, for example, that they enable us to transfer data between a Unix host
and a PC or a Mac.

Page 14
The OSI reference model has seven layers:

• Application layer (layer 7)


• Presentation layer (layer 6)
• Session layer (layer 5)

Page 15
• Transport layer (layer 4)
• Network layer (layer 3)
• Data Link layer (layer 2)
• Physical layer (layer 1)

FUNCTIONS OF SEVEN LAYERS

Page 16
Layers of OSI model: Different layers of OSI model are the basic building blocks of any data
communication. These layers are as follows.

• PHYSICAL LAYER ( LAYER 1 )

Page 17
It describe the nature of the network's hardware elements and also describe about what kind of
network interface adapter must be installed in each computer and what kind of hubs (if any) to
use.The of individual bits from one hop to the next.Physical layer is also defines about the type

transmission medium we used. Physical layer is responsible for movements

• DATA LINK LAYER( LAYER 2 ):

Network layer protocols pass their outgoing data down to the data-link layer protocol, which
packages it for transmission over the network. When the other systems on the network receive
the transmitted data, their data-link layer protocols process it and pass it up to the network
layer.The data link layer is responsible from one hop to the next.The data link layer works on
MAC and LLC address. Data link layer devices are SWITCH and BRIDGE which works on
MAC address. Some of the layer 2 protocols are Ethernet,Token Ring,ISDN,PPP and Frame
relay.

Page 18
• NETWORK LAYER ( LAYER 3 ):

The network layer is a complex layer that provides connectivity and path selection between two
host systems that might be located on geographically separated networks.The network layer is
concerned with logical addressing. The network layer protocol header contains source address
and destination address.Network layer device is router because it works on IP address. Network
layer protocols are IP,IPX and Apple Talk.

• TRANSPORT LAYER ( LAYER 4 ):

The Transport layer can be either connectionless or connection oriented. The connectionless
transport layer treats each segment as an independent packet and delivers it to the transport
layer at the destination machine. The connection oriented first establishes connection then
sends the data. Transport is responsible for error control. Protocols used in Transport layer are
TCP, UDP and SPX.

• SESSION LAYER ( LAYER 5 ):

The Session layer is the network dialog controller. It establishes maintains and synchronizes the
interaction among communicating systems..Protocols used in Session layer are Network File
System (NFS), X-Window System, Apple Talk Session Protocol (ASP)

• PRESENTATION LAYER ( LAYER 6 ):

The Presentation layer is concerned with a syntax and semantics of the information exchanged
between two systems. The common layer 6 graphic standards are PICT, JPEG, TIFF and for
sound and videos are MIDI and MPEG.

Page 19
• APPLICATION LAYER ( LAYER 7 ):

The Application layer is responsible for providing services to user. It also provides user
interfaces and supports for services such as e-mail, remote file access and transfer, data base
managemet and other types of distributed services. Most application layer protocols provide
services that programs use to access the network, such as the Simple Mail Transfer Protocol
(SMTP), which most e-mail programs use to send e-mail messages.

Page 20
 TCP/IP MODEL

Page 21
Telnet

It allows a user on a remote client machine, called the Telnet client, to access the resources of
another machine, the Telnet server. Telnet achieves this by pulling a fast one on the Telnet server
and making the client machine appear as though it were a terminal directly attached to the local
network.

The name Telnet comes from “telephone network,” which is how


most Telnet sessions used to occur.

File Transfer Protocol (FTP)

File Transfer Protocol (FTP) is the protocol that actually lets us transfer files, and it can
accomplish this between any two machines using it. But FTP isn’t just a protocol; it’s also a
program. Operating as a protocol, FTP is used by applications.

Trivial File Transfer Protocol (TFTP)

Trivial File Transfer Protocol (TFTP) is the stripped-down, stock version of FTP, but it’s the
protocol of choice if you know exactly what you want and where to find it, plus it’s so easy to
use and it’s fast too! It doesn’t give you the abundance of functions that FTP does, though. TFTP
has no directory-browsing abilities; it can do nothing but send and receive files.

Network File System (NFS)

Network File System (NFS) is a jewel of a protocol specializing in file sharing. It allows two
different types of file systems to interoperate.

Simple Mail Transfer Protocol (SMTP)

Page 22
Simple Mail Transfer Protocol (SMTP) , answering our ubiquitous call to e-mail, uses a spooled,
or queued, method of mail delivery. Once a message has been sent to a destination, the message
is spooled to a device—usually a disk.

Line Printer Daemon (LPD)

The Line Printer Daemon (LPD) protocol is designed for printer sharing. The LPD, along with
the LPR (Line Printer) program, allows print jobs to be spooled and sent to the network’s
printers using TCP/IP.

X Window

Designed for client-server operations, X Window defines a protocol for writing client/server
applications based on a graphical user interface (GUI). The idea is to allow a program, called a
client, to run on one computer and have it display things through a window server on another
computer.

Simple Network Management Protocol (SNMP)

Simple Network Management Protocol (SNMP) collects and manipulates this valuable network
information. It gathers data by polling the devices on the network from a management station at
fixed or random intervals, requiring them to disclose certain information.

Domain Name Service (DNS)

Page 23
Domain Name Service (DNS) resolves hostnames—specifically, Internet names, such as
www.routersim.com . You don’t have to use DNS; you can just type in the IP address of any
device you want to communicate with

Dynamic Host Configuration Protocol (DHCP)/BootP

(Bootstrap Protocol)

Dynamic Host Configuration Protocol (DHCP) gives IP addresses to hosts. It allows easier
administration and works well in small-to-even-very-large network environments. All types of
hardware can be used as a DHCP server, including a Cisco router.

Transmission Control Protocol (TCP)

Transmission Control Protocol (TCP) takes large blocks of information from an application and
breaks them into segments. It numbers and sequences each segment so that the destination’s TCP
protocol can put the segments back into the order the application intended. After these segments
are sent, TCP (on the transmitting host) waits for an acknowledgment of the receiving end’s TCP
virtual circuit session, retransmitting those that aren’t acknowledged.

User Datagram Protocol (UDP)

If you were to compare User Datagram Protocol (UDP) with TCP, the former is basically the
scaled-down economy model that’s sometimes referred to as a thin protocol, it does do a
fabulous job of transporting information that doesn’t require reliable delivery—and it does so
using far fewer network resources.

Page 24
Routing Basics
This chapter introduces the underlying concepts widely used in routing protocols. Topics
summarized here include routing protocol components and algorithms. In addition, the role of
routing protocols is briefly contrasted with the role of routed or network protocols. Subsequent
chapters in Part VII, "Routing Protocols," address specific routing protocols in more detail, while
the network protocols that use routing protocols are discussed in Part VI, "Network Protocols."

What Is Routing?

Routing is the act of moving information across an internetwork from a source to a destination.
Along the way, at least one intermediate node typically is encountered. Routing is often
contrasted with bridging, which might seem to accomplish precisely the same thing to the casual
observer. The primary difference between the two is that bridging occurs at Layer 2 (the link
layer) of the OSI reference model, whereas routing occurs at Layer 3 (the network layer). This
distinction provides routing and bridging with different information to use in the process of
moving information from source to destination, so the two functions accomplish their tasks in
different ways.

The topic of routing has been covered in computer science literature for more than two decades,
but routing achieved commercial popularity as late as the mid-1980s. The primary reason for this
time lag is that networks in the 1970s were simple, homogeneous environments. Only relatively
recently has large-scale internetworking become popular.

Routing Components

Routing involves two basic activities: determining optimal routing paths and transporting
information groups (typically called packets) through an internetwork. In the context of the
routing process, the latter of these is referred to as packet switching. Although packet switching
is relatively straightforward, path determination can be very complex.

Path Determination

Routing protocols use metrics to evaluate what path will be the best for a packet to travel. A
metric is a standard of measurement, such as path bandwidth, that is used by routing algorithms
to determine the optimal path to a destination. To aid the process of path determination, routing
algorithms initialize and maintain routing tables, which contain route information. Route
information varies depending on the routing algorithm used.

Routing algorithms fill routing tables with a variety of information. Destination/next hop
associations tell a router that a particular destination can be reached optimally by sending the
packet to a particular router representing the "next hop" on the way to the final destination. When

a router receives an incoming packet, it checks the destination address and attempts to associate
this address with a next hop. Figure 5-1 depicts a sample destination/next hop routing table.

Page 25
Figure 5-1 Destination/Next Hop Associations Determine the Data's Optimal Path

Routing tables also can contain other information, such as data about the desirability of a path.
Routers compare metrics to determine optimal routes, and these metrics differ depending on the
design of the routing algorithm used. A variety of common metrics will be introduced and
described later in this chapter.

Routers communicate with one another and maintain their routing tables through the
transmission of a variety of messages. The routing update message is one such message that
generally consists of all or a portion of a routing table. By analyzing routing updates from all
other routers, a router can build a detailed picture of network topology. A link-state
advertisement, another example of a message sent between routers, informs other routers of the
state of the sender's links. Link information also can be used to build a complete picture of
network topology to enable routers to determine optimal routes to network destinations.

Switching

Switching algorithms is relatively simple; it is the same for most routing protocols. In most
cases, a host determines that it must send a packet to another host. Having acquired a router's
address by some means, the source host sends a packet addressed specifically to
a router's physical (Media Access Control [MAC]-layer) address, this time with the protocol
(network layer) address of the destination host.

As it examines the packet's destination protocol address, the router determines that it either
knows or does not know how to forward the packet to the next hop. If the router does not know
how to forward the packet, it typically drops the packet. If the router knows how to forward the
packet, however, it changes the destination physical address to that of the next hop and transmits
the packet.

The next hop may be the ultimate destination host. If not, the next hop is usually another router,
which executes the same switching decision process. As the packet moves through the
internetwork, its physical address changes, but its protocol address remains constant, as
illustrated in Figure 5-2.

The preceding discussion describes switching between a source and a destination end system.
The International Organization for Standardization (ISO) has developed a hierarchical

Page 26
terminology that is useful in describing this process. Using this terminology, network devices
without the capability to forward packets between subnetworks are called end systems (ESs),
whereas network devices with these capabilities are called intermediate systems (ISs). ISs are
further divided into those that can communicate within routing domains (intradomain ISs) and
those that communicate both within and between routing domains (interdomain ISs). A routing
domain generally is considered a portion of an internetwork under common administrative
authority that is regulated by a particular set of administrative guidelines. Routing domains are
also called autonomous systems. With certain protocols, routing domains can be divided into
routing areas, but intradomain routing protocols are still used for switching both within and
between areas.

Figure 5-2 Numerous Routers May Come into Play During the Switching Process

Routing Algorithms

Routing algorithms can be differentiated based on several key characteristics. First, the particular
goals of the algorithm designer affect the operation of the resulting routing protocol. Second,
various types of routing algorithms exist, and each algorithm has a different impact on network
and router resources. Finally, routing algorithms use a variety of metrics that affect calculation of
optimal routes. The following sections analyze these routing algorithm attributes.

Page 27
Design Goals

Routing algorithms often have one or more of the following design goals:

• Optimality

• Simplicity and low overhead

• Robustness and stability

• Rapid convergence

• Flexibility

Optimality refers to the capability of the routing algorithm to select the best route, which depends
on the metrics and metric weightings used to make the calculation. For example, one routing
algorithm may use a number of hops and delays, but it may weigh delay more heavily in the
calculation. Naturally, routing protocols must define their metric calculation algorithms strictly.

Routing algorithms also are designed to be as simple as possible. In other words, the routing
algorithm must offer its functionality efficiently, with a minimum of software and utilization
overhead. Efficiency is particularly important when the software implementing the routing
algorithm must run on a computer with limited physical resources.

Routing algorithms must be robust, which means that they should perform correctly in
the face of unusual or unforeseen circumstances, such as hardware failures, high load conditions,
and incorrect implementations. Because routers are located at network junction points, they can
cause considerable problems when they fail. The best routing algorithms are often those that
have withstood the test of time and that have proven stable under a variety of network
conditions.

In addition, routing algorithms must converge rapidly. Convergence is the process of agreement,
by all routers, on optimal routes. When a network event causes routes to either go down or
become available, routers distribute routing update messages that permeate networks, stimulating
recalculation of optimal routes and eventually causing all routers to agree on these routes.
Routing algorithms that converge slowly can cause routing loops or network outages.

In the routing loop displayed in Figure 5-3, a packet arrives at Router 1 at time t1. Router 1
already has been updated and thus knows that the optimal route to the destination calls for Router
2 to be the next stop. Router 1 therefore forwards the packet to Router 2, but because this router
has not yet been updated, it believes that the optimal next hop is Router 1. Router 2 therefore
forwards the packet back to Router 1, and the packet continues to bounce back and forth between
the two routers until Router 2 receives its routing update or until the packet has been switched
the maximum number of times allowed.

Figure 5-3 Slow Convergence and Routing Loops Can Hinder Progress

Page 28
Routing algorithms should also be flexible, which means that they should quickly and accurately
adapt to a variety of network circumstances. Assume, for example, that a network segment has
gone down. As many routing algorithms become aware of the problem, they will quickly select
the next-best path for all routes normally using that segment. Routing algorithms can be
programmed to adapt to changes in network bandwidth, router queue size, and network delay,
among other variables.

Algorithm Types

Routing algorithms can be classified by type. Key differentiators include these:

• Static versus dynamic

• Single-path versus multipath

• Flat versus hierarchical

• Host-intelligent versus router-intelligent

• Intradomain versus interdomain

Page 29
• Link-state versus distance vector

Static Versus Dynamic

Static routing algorithms are hardly algorithms at all, but are table mappings established by the
network administrator before the beginning of routing. These mappings do not change unless the
network administrator alters them. Algorithms that use static routes are simple to design and
work well in environments where network traffic is relatively predictable and where network
design is relatively simple.

Because static routing systems cannot react to network changes, they generally are considered
unsuitable for today's large, constantly changing networks. Most of the dominant routing
algorithms today are dynamic routing algorithms, which adjust to changing network
circumstances by analyzing incoming routing update messages. If the message indicates that a
network change has occurred, the routing software recalculates routes and sends out new routing
update messages. These messages permeate the network, stimulating routers to rerun their
algorithms and change their routing tables accordingly.

Dynamic routing algorithms can be supplemented with static routes where appropriate. A router
of last resort (a router to which all unroutable packets are sent), for example, can be designated

Page 30
to act as a repository for all unroutable packets, ensuring that all messages are at least handled in
some way.

Single-Path Versus Multipath

Some sophisticated routing protocols support multiple paths to the same destination. Unlike
single-path algorithms, these multipath algorithms permit traffic multiplexing over multiple
lines. The advantages of multipath algorithms are obvious: They can provide substantially better
throughput and reliability. This is generally called load sharing.

Flat Versus Hierarchical

Some routing algorithms operate in a flat space, while others use routing hierarchies. In a flat
routing system, the routers are peers of all others. In a hierarchical routing system, some routers
form what amounts to a routing backbone. Packets from nonbackbone routers travel to the
backbone routers, where they are sent through the backbone until they reach the general area of
the destination. At this point, they travel from the last backbone router through one or more
nonbackbone routers to the final destination.

Routing systems often designate logical groups of nodes, called domains, autonomous systems,
or areas. In hierarchical systems, some routers in a domain can communicate with routers in
other domains, while others can communicate only with routers within their domain. In very
large networks, additional hierarchical levels may exist, with routers at the highest hierarchical
level forming the routing backbone.

The primary advantage of hierarchical routing is that it mimics the organization of most
companies and therefore supports their traffic patterns well. Most network communication
occurs within small company groups (domains). Because intradomain routers need to know only
about other routers within their domain, their routing algorithms can be simplified, and,
depending on the routing algorithm being used, routing update traffic can be reduced
accordingly.

Host-Intelligent Versus Router-Intelligent

Some routing algorithms assume that the source end node will determine the entire route. This is
usually referred to as source routing. In source-routing systems, routers merely act as store-and-
forward devices, mindlessly sending the packet to the next stop.

Other algorithms assume that hosts know nothing about routes. In these algorithms, routers
determine the path through the internetwork based on their own calculations. In the first system,
the hosts have the routing intelligence. In the latter system, routers have the routing intelligence.

Page 31
Intradomain Versus Interdomain

Some routing algorithms work only within domains; others work within and between domains.
The nature of these two algorithm types is different. It stands to reason, therefore, that an optimal
intradomain-routing algorithm would not necessarily be an optimal interdomain-routing
algorithm.

Link-State Versus Distance Vector

Link-state algorithms (also known as shortest path first algorithms) flood routing information to
all nodes in the internetwork. Each router, however, sends only the portion of the routing table
that describes the state of its own links. In link-state algorithms, each router builds a picture of
the entire network in its routing tables. Distance vector algorithms (also known as Bellman-Ford
algorithms) call for each router to send all or some portion of its routing table, but only to its
neighbors. In essence, link-state algorithms send small updates everywhere, while distance
vector algorithms send larger updates only to neighboring routers. Distance vector algorithms
know only about their neighbors.

Because they converge more quickly, link-state algorithms are somewhat less prone to routing
loops than distance vector algorithms. On the other hand, link-state algorithms require more CPU
power and memory than distance vector algorithms. Link-state algorithms, therefore, can be
more expensive to implement and support. Link-state protocols are generally more scalable than
distance vector protocols.

Routing Metrics

Routing tables contain information used by switching software to select the best route. But how,
specifically, are routing tables built? What is the specific nature of the information that they
contain? How do routing algorithms determine that one route is preferable to others?

Routing algorithms have used many different metrics to determine the best route. Sophisticated
routing algorithms can base route selection on multiple metrics, combining them in a single
(hybrid) metric. All the following metrics have been used:

• Path length

• Reliability

• Delay

• Bandwidth

• Load

• Communication cost

Page 32
Path length is the most common routing metric. Some routing protocols allow network
administrators to assign arbitrary costs to each network link. In this case, path length is the sum
of the costs associated with each link traversed. Other routing protocols define hop count, a
metric that specifies the number of passes through internetworking products, such as routers, that
a packet must take en route from a source to a destination.

Reliability, in the context of routing algorithms, refers to the dependability (usually described in
terms of the bit-error rate) of each network link. Some network links might go down more often
than others. After a network fails, certain network links might be repaired more easily or more
quickly than other links. Any reliability factors can be taken into account in the assignment of
the reliability ratings, which are arbitrary numeric values usually assigned to network links by
network administrators.

Routing delay refers to the length of time required to move a packet from source to destination
through the internetwork. Delay depends on many factors, including the bandwidth of
intermediate network links, the port queues at each router along the way, network congestion on
all intermediate network links, and the physical distance to be traveled. Because delay is a
conglomeration of several important variables, it is a common and useful metric.

Bandwidth refers to the available traffic capacity of a link. All other things being equal, a 10-
Mbps Ethernet link would be preferable to a 64-kbps leased line. Although bandwidth is a rating
of the maximum attainable throughput on a link, routes through links with greater bandwidth do
not necessarily provide better routes than routes through slower links. For example, if a faster
link is busier, the actual time required to send a packet to the destination could be greater.

Load refers to the degree to which a network resource, such as a router, is busy. Load can be
calculated in a variety of ways, including CPU utilization and packets processed per second.
Monitoring these parameters on a continual basis can be resource-intensive itself.

Communication cost is another important metric, especially because some companies may not
care about performance as much as they care about operating expenditures. Although line delay
may be longer, they will send packets over their own lines rather than through the public lines
that cost money for usage time.

Network Protocols

Routed protocols are transported by routing protocols across an internetwork. In general, routed
protocols in this context also are referred to as network protocols. These network protocols
perform a variety of functions required for communication between user applications in source
and destination devices, and these functions can differ widely among protocol suites. Network
protocols occur at the upper five layers of the OSI reference model: the network layer, the
transport layer, the session layer, the presentation layer, and the application layer.

Confusion about the terms routed protocol and routing protocol is common. Routed protocols
are protocols that are routed over an internetwork. Examples of such protocols are the Internet
Protocol (IP), DECnet, AppleTalk, Novell NetWare, OSI, Banyan VINES, and Xerox Network

Page 33
System (XNS). Routing protocols, on the other hand, are protocols that implement routing
algorithms. Put simply, routing protocols are used by intermediate systems to build tables used in
determining path selection of routed protocols. Examples of these protocols include Interior
Gateway Routing Protocol (IGRP), Enhanced Interior Gateway Routing Protocol (Enhanced
IGRP), Open Shortest Path First (OSPF), Exterior Gateway Protocol (EGP), Border Gateway
Protocol (BGP), Intermediate System-to-Intermediate System (IS-IS), and Routing Information
Protocol (RIP).

3. SOFTWARE
AND

Page 34
HARDWARE
REQUIREMENTS

Software Requirement:-

Following software are required for Routing:

 Operating System : Windows XP, Window 7, Linux etc.


 Front end : Wire shark, Packet Tracer,GNS3,Secure CRT
Monitor Program,
 Back End Tools : Cisco IOS on live Cisco routers & switches
Cisco Router Hardware platform emulated by GNS3.

Hardware Requirement:-

Page 35
It’s a network based project so a robust hardware configuration is required. The hardware
requirements are

 Processor: Pentium 4 2.00 GHz and above like Intel (R) Core ( TM ) i3 M 330

2.13 GHz

 Motherboard : Intel 845 and above

 RAM : 2 to 4 GB

 Hard disk : 2.5 GB for Routers images

 Routers : 2600 series, 3600 series, 7200 series.

4. FEASIBILITY STUDY

Page 36
FEASIBILITY STUDY

Meaning of Feasibility Study:-

Feasibility study is an evaluation of a proposal designed to determine the difficulty in


carrying out a designated task. Generally, a feasibility study precedes technical development
and project implementation. In other words, a feasibility study is an evaluation or analysis of
the potential impact of a proposed project.

Feasibility study is used to measure how the development of a system should be benificial
to organizations. Feasibility study should be performed throughout the development of the
system.Feasibility study involves making a preliminary determination of end user needs and
to determine the feasibility, that system is satisfied goal of project or not. The goal of
feasibility study is to evaluate alternative system and to provide most feasible and desirable
system for development.

A feasibility study should provide enough information to decide:

 Whether the project can be done?


 Whether the final system will benefit its intended users?
 What are the alternatives among which a solution will be chosen?
 Is there a preferred alternative?

The key consideration in feasibility analysis are :

1. Economic Feasibility

2. Technical Feasibility

3. Operational Feasibility

Meaning Of Technical Feasibility:-

Page 37
In Technical feasibility, analyst identifies the existing computer systems (hardware, software
etc.) and determines whether these technical resources are sufficient for the proposed system
or not. If these resources are not sufficient for the proposed system, analyst suggests the
configuration of the computer systems that are required. Developing a particular system may
be technically possible but it may require huge investments and benefits may be less.

 Is the proposed technology or solution practical?


 Do we possess the necessary technical expertise, and is the schedule reasonable?
 Is relevant technology mature enough to be easily applied to our problem?
 Some firms like to use state-of-the-art technology, but most firms prefer to use mature
and proven technology.
 Assuming that required technology is practical, is it available in the information
systems shop? If the technology is available, does it have the capacity to handle the
solution?
 If the technology is not available, can it be acquired?

Technical Feasibility For The Project:-

The proposed system uses Wire shark , Packet Tracer , GNS3, Secure CRT Monitor
Program , Solar Winds TFTP Server front-end tool and Cisco IOS on live Cisco
routers & switches Cisco Router Hardware platform emulated by GNS3 as back-end
tool.

Hardware used in this project are- Intel (R) Core (TM) i3 M 330 @ 2.13 GHz
Processor and, 2 or 3 MB RAM, 2.5 GB hard disk for router images.These hardware
were already available on the existing computer system. The software like operating
system WINDOWS-XP ,WINDOW 7 used were already installed on the existing
computer system. So no additional hardware and software were required to purchase
and it is technically feasible. The technical feasibility is in employing computers to the
organization.

Page 38
Meaning Of Operational Feasibility:-

It is a measure of how well a proposed system solves the problems, and takes advantage of
the opportunities identified during scope definition and how it satisfies the requirements
identified in the requirements analysis phase of system development.

During operational feasibility, it is determined whether the system will operate in the way
that user wants or not. Operational feasibility must determines how the proposed system will
fit in with the current operations and what, if any, job reconstruction and training will be
needed to implement the system. It is a measure of how well the solutions of the problem or
specific alternative solutions will work in the organizations. It deals with the operations
performed within the network.The essential questions that help in testing the operational
feasibility of a system are following:

1. Does management support the project?


2. Are the users not happy with current business practices? Will it reduce the time
(operation) considerably? If yes, then they will welcome the change and the new
system.
3. Have the users been involved in the planning and development of the project? Early
involvement reduces the probability of resistance towards the new system.
4. Will the proposed system really benefit the organization? Does the overall response
increase? Will accessibility of information be lost? Will the system effect the
customers in considerable way?

Operational Feasibility Of The Project:-

Page 39
Configure a routing as per the diagram in Full Mesh Topology. Used only physical
interfaces to configure a routing .traffic from R1 destined for R3 should transit R2 and
vice versa. Use only the interfaces specified. Configure EIGRP on the routers. Send
EIGRP packets out any other interfaces; use the passive-interface command to accomplish
this.

Meaning Of Economic Feasibility:-

Economical feasibility determines the cost and benefits of the proposed system and compare
with the budget. The system that is made must also be economical. Economic analysis
commonly known as cost/benefit analysis. The cost of the project includes the cost of
hardware, software development and implementation. If benefits are found more than costs
then the decision is made to design and implement the network. The cost should be consistent
according to the operations being performed within the network.

Cost Based Study:-

It is important to identify cost and benefit factors, which can be categorized as follows:

1. Development costs: Development costs that are incurred during the development of the

system are one time investment.

2. Operating costs: operational costs are the cost of operations performed to achieve the
operations required.

Page 40
SYSTEM DESIGN

SYSTEM DESIGN

Page 41
Meaning Of System Design:-

Systems design is the process or art of defining the architecture, components, modules,
interfaces, and data for a system to satisfy specified requirements. the process of system
design starts with the logical design to physical design. logical design identifies the user
requirements and made a system to satisfies these requirements. physical design produces the
working system by defining the design specification which tell what the system must do.

A logical data flow diagram shows the flow of data through a transaction processing system
without regard to the time period when the data flows or the processing procedures occur.

The main network model of this project can be represented as or main system design of
frame relay project

Page 42
Database Tables:-

IP EIGRP topology table:-

Page 43
Routes And Neighbours Table:-

Page 44
Page 45
SYSTEM
IMPLEMENTATION

SYSTEM IMPLEMENTATION

Page 46
Meaning Of System Implementation:-

Implementation is putting a planned system into action. The purpose of System


Implementation is to take all possible steps to ensure that the upcoming system deployment and
transition occurs smoothly, efficiently, and flawlessly.

Implementation can be done in following ways:

1. New system is implemented and old system is completely dropped.


2. New system is implemented and both old system and new system are operated in
parallel.
3. New system is implemented in many phases. Each phase is carried out only after
successful implementation of previous phase.

Designing:-

Major objective of designing is to identify user requirements and to built the system that satisfies
these requirements. it is known as the logical design. Main activities of this phase are :

1. Identify requirements.

2. Changes made in the organizational structure are outlined.

Coding :-

Page 47
Coding is the process in which we do all the essential configurations on all the routers so that the
required system can be developed and all the requirements of the client are Coding fulfilled. the
configurations which are made on routers are give below

Router R1 Configuration:-

Show run configuration:

Current configuration : 907 bytes

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

hostname Router

Page 48
!

ip name-server 0.0.0.0

interface FastEthernet0/0

ip address 192.168.1.254 255.255.255.0

duplex auto

speed auto

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

Page 49
interface Serial0/0/0

ip address 30.0.0.2 255.255.255.0

clock rate 64000

interface Serial0/1/0

ip address 80.0.0.1 255.0.0.0

clock rate 64000

interface Serial0/2/0

no ip address

shutdown

interface Serial0/3/0

no ip address

shutdown

interface Vlan1

no ip address

shutdown

router eigrp 1

Page 50
network 192.168.1.0

network 30.0.0.0 0.0.0.255

network 210.0.0.0

network 80.0.0.0

no auto-summary

router rip

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0/0/0

line con 0

line vty 0 4

login

Page 51
!

End

Router R2 Configuration:-

Show run configuration:

Current configuration : 1042 bytes

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

hostname Router

Page 52
!

interface FastEthernet0/0

ip address 10.0.0.1 255.0.0.0

duplex auto

speed auto

interface FastEthernet0/1

ip address 40.0.0.2 255.0.0.0

duplex auto

speed auto

Page 53
interface Serial1/0

ip address 50.0.0.1 255.0.0.0

interface Serial1/1

ip address 30.0.0.1 255.0.0.0

interface Serial1/2

ip address 60.0.0.2 255.0.0.0

interface Serial1/3

no ip address

shutdown

interface Serial1/4

no ip address

shutdown

interface Serial1/5

ip address 90.0.0.1 255.0.0.0

clock rate 64000

Page 54
interface Serial1/6

no ip address

shutdown

interface Serial1/7

no ip address

shutdown

interface Vlan1

no ip address

shutdown

router eigrp 1

network 10.0.0.0

network 60.0.0.0

network 50.0.0.0

network 30.0.0.0

network 90.0.0.0

network 40.0.0.0

network 220.20.0.0

no auto-summary

Page 55
!

ip classless

line con 0

line vty 0 4

login

End

Router R3 Configuration:-

Show run configuration:

Current configuration : 804 bytes

version 12.4

Page 56
no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

hostname Router

ip name-server 0.0.0.0

Page 57
!

interface FastEthernet0/0

ip address 172.16.10.254 255.255.0.0

duplex auto

speed auto

interface FastEthernet0/1

ip address 172.30.10.254 255.255.0.0

duplex auto

speed auto

interface Serial0/0/0

ip address 60.0.0.1 255.0.0.0

clock rate 64000

interface Serial0/1/0

no ip address

shutdown

Page 58
interface Serial0/2/0

no ip address

shutdown

interface Serial0/3/0

no ip address

shutdown

interface Vlan1

no ip address

shutdown

router eigrp 1

network 172.16.0.0

network 60.0.0.0

no auto-summary

ip classless

Page 59
no cdp run

line con 0

line vty 0 4

login

End

Router R4 Configuration:-

Show run configuration:

Current configuration : 960 bytes

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

Page 60
!

hostname Router

interface FastEthernet0/0

Page 61
ip address 70.0.0.1 255.0.0.0

duplex auto

speed auto

interface FastEthernet0/1

ip address 3.255.255.254 255.0.0.0

duplex auto

speed auto

interface Serial1/0

ip address 205.0.0.2 255.255.255.0

clock rate 64000

interface Serial1/1

no ip address

shutdown

interface Serial1/2

no ip address

shutdown

Page 62
interface Serial1/3

no ip address

shutdown

interface Serial1/4

no ip address

shutdown

interface Serial1/5

no ip address

shutdown

interface Serial1/6

no ip address

shutdown

interface Serial1/7

no ip address

shutdown

interface Vlan1

Page 63
no ip address

shutdown

router eigrp 1

network 205.0.0.0

network 3.0.0.0

network 70.0.0.0

no auto-summary

ip classless

line con 0

line vty 0 4

login

Page 64
!

End

Testing:-

Meaning Of Testing:-

Page 65
Testing is the process of checking the system whether it is properly working or not. for
this the complete system should be tested in a systematic way. Testing observe the failures
of the system, from which the presence of faults can be deduced.

System Testing is a crucial step in Management Process.

 System Testing is the first level where the System is tested as a whole.

 The System is tested to verify if it meets the functional and technical requirements.

 The application/System is tested in an environment that closely resembles the


.production environment where the application will be finally deployed.

 The System Testing enables us to test, verify and validate both the Business
requirements as well as the Application Architecture.

Steps needed to do System Testing:-

The following steps are important to perform System Testing:


........Step 1: Create a System Test Plan
........Step 2: Create Test Cases
........Step 3: Carefully Build Data used as Input for System Testing
........Step 3: If applicable create scripts to
..................- Build environment and
..................- to automate Execution of test cases
........Step 4: Execute the test cases
........Step 5: Fix the faults if any and repeat the test cycle as necessary.
In case of networks, testing is the actual measurement and recording of a network's state
of operation over a period of time.

Test Cases Of The Project:-

A Test Case describes exactly how the test should be carried out.

Page 66
The System test cases help us verify and validate the system.
The System Test Cases are written such that:
........- They cover all the use cases and scenarios
........- The Test cases validate the technical Requirements and Specifications
........- The Test cases verify if the application/System meet the Business
...........Requirements specified
........- The Test cases may also verify if the System meets the performance standards

After configuring your network, it’s considered to verify that your configuration is
working. To find a Frame Relay problem, the process should start with some pings.
Optimally, pings from an end-user host on a LAN, to another host on a remote LAN, can
quickly determine if the network currently can meet the true end goal of delivering packets
between computers. If that ping fails, a ping from one router to the other router’s Frame
Relay IP address is the next step. If that ping works, but the end user’s ping failed, the
problem probably has something to do with Layer 3 issues, and troubleshooting those
issues. However, if a ping from one router to another router’s Frame Relay IP address
fails, the problem is most likely related to the Frame Relay network.

Test case : 1

Input :

Router #Ping 1.1.1.1

Output :

type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 34/55/78 ms

Expected Result:

Page 67
We are expecting that we are reachable to the network 1.1.1.

Page 68
CONCLUSION

CONCLUSION

Routing is the act of moving information across an internetwork from a source to a destination.
Along the way, at least one intermediate node typically is encountered. Routing is often
contrasted with bridging, which might seem to accomplish precisely the same thing to the casual

Page 69
observer. The primary difference between the two is that bridging occurs at Layer 2 (the link
layer) of the OSI reference model, whereas routing occurs at Layer 3 (the network layer). This
distinction provides routing and bridging with different information to use in the process of
moving information from source to destination, so the two functions accomplish their tasks in
different ways.

The topic of routing has been covered in computer science literature for more than two decades,
but routing achieved commercial popularity as late as the mid-1980s. The primary reason for this
time lag is that networks in the 1970s were simple, homogeneous environments. Only relatively
recently has large-scale internetworking become popular.

Page 70
BIBLIOGRAPHY .

BIBLIOGRAPHY
SNO BOOKS AUTHORS
Books Referred:-

1. CCNA Exam 640-802 Todd Lammle

Page 71
2. CCNA ICND 2 Wendell Odom
10.1 Books Referred:

Websites Referred:-

http://www.cisco.com

http://www.w3schools.com

http://www.google.com

http://www.wikipedia.com

http://www.frforum.com

http://wiki.answers.com

Page 72