You are on page 1of 16

TRABAJO DE ALGORITMOS

SUPERVISOR: CRISTHIAN QUEZADA ASENJO
INTEGRANTES:
MANUEL LUCERO GIL (10)
KATHERINE EMPERATRIZ PEREZ POPUCHE(10)
PAOLA SANDOVAL AHUMADA(10)
TOTAL DE EJERCICIOS RESUELTOS: 30

DESARROLLO
Hacer un programa que registre 20 numeros en un array de una dimension y muest
re posteriormente los elementos que ocupan posiciones impares
INICIO
|
| Dimensionar a[100]
|
| x=1
| mientras x <= 20 Hacer
| | Leer a[x]
| | x=x+1
| fin_mientras
|
| x=1
| mientras x<=20 Hacer
| | escribe a[x]
| | x=x+2
| fin_mientras
|
FIN
Hacer un programa que registre 20 numeros en un array de una dimension y muest
re posteriormente los elementos que ocupan posiciones pares y de inversa
INICIO
|
| Dimensionar a[100]
|
| x=1
| mientras x <= 20 Hacer
| | Leer a[x]
| | x=x+1
| fin_mientras
|
| x=20
| mientras x>=2 Hacer
| | escribe a[x]
| | x=x-2
| fin_mientras
|
FIN

Hacer un programa que registre 20 numeros en un array de una dimension y muest
re posteriormente los elementos que contienen numeros multiplos de 3

INICIO | | Dimensionar a[100] | | x=1 | mientras x <= 20 Hacer | | Leer a[x] | | x=x+1 | fin_mientras | | x=1 | mientras x<20 Hacer | | Si a[x]mod3 =0 entonces | | | escribe a[x] | | Fin_si | | x=x+1 | fin_mientras | FIN Hacer un programa que registre 20 numeros en un array de una dimension y muest re posteriormente los elementos que contienen numeros multiplos de 5 y en form a inversa INICIO | | Dimensionar a[100] | | x=1 | mientras x <= 20 Hacer | | Leer a[x] | | x=x+1 | | fin_mientras | | x=20 | mientras x>=1 Hacer | | Si a[x]mod5 =0 entonces | | escribe a[x] | | Fin_si | | x=x-1 | fin_mientras | FIN Se necesita elaborar un programa donde se registren 20 notas de alumnos. si n o sladra una frase "desaprobado" INICIO | | Dimensionar a[100] | | x=1 | mientras x <= 20 Hacer | | Leer a[x] | | x=x+1 . calif icadas de 0 a 20. teniendo en cuenta que se mostraran solo los aprobados.

| fin_mientras | | x=1 | mientras x>=13 Hacer | | escribe a[x] | | Si x<=13 entonces | | escribe "Desaprobado" | | Fin_si | | x=x+1 | | Mostrar aprobados | fin_mientras | FIN Hacer un programa que registre 20 numeros enn una array de 1 dimension y luego m uestre en la pantalla los numeros ingresados en orden inverso y los que ocupen p osicion pares INICIO | | Dimensionar a[100] | x=1 | mientras x<=20 hacer | | | | leer a[x] | | x=x+1 | | | fin_mientras | | x=20 | mientras x>=1 Hacer | | | | escribe a[x] | | x=x-1 | | | fin_mientras | | x=1 | mientras x<10 hacer | | | | Si a[x]mod2=0 entonces | | | escribe a[x] | | | | | Fin_si | | x=x+1 | | | fin_mientras | FIN "SAGA FALABELLA" se encuentra de aniversario y ha programado una serie de oferta s con la finalidad de brindar facilidades a sus clientes y al a vez de increment ar sus ventas. Estas ofertas se basan especificamente en un procentaje de descue nto sobre eol total de compra el cual varia de acuerdo al monto * Por un monto mayor o igual a $500 se hara un descuento del 30% * Por un monto menor de $500 pero mayor o igual a 200 se hara un descuento d el 20% * Por un monto menor de $200 pero mayor o igual a 100 se hara un descuento d .

y sus horas trabajadas calcu lar cuantos trabajadores reciben un salario mayor o igual a S/.el 10% * Considere 100 personas INICIO | | x=x+1 | Leer Consumo | | Si consumo >=500 entonces | | | | descuento = Consumo*30/100 | | | Sino | | Si consumo >=200 entonces | | | | | | descuento = Consumo*20/100 | | | | | Sino | | | Si consumo >=100 entonces | | | | | | | | descuento = Consumo*10/100 | | | | | | | Sino | | | | Descuento=0 | | | | | | | Fin_si | | | | | Fin_si | | | Fin_si | | Totalpagar= Consumo-Descuento | Imprimir Totalpagar | | Si x<>100 entonces | | x=x+1 | | | Fin_si | FIN Dado la tarifa de pago por horas de un trabajador.500 y calcular ad emas el promedio de los salarios de todos los trabajores INICIO | | Leer N | Leer Tarifa | i=0 | C=0 | Suma=0 | mientras i<=N Hacer | | Leer horas | | salario= tarifa * horas | | Escribir salario | | Si salario >=500 entonces: | | c=c+1 .

6.2N INICIO | | Leer N | i=1 | mientras i<=2*N Hacer: | | Si i mod2 =0 entonces: | | | escribir i | | Fin_si | | | | i=i+1 . Pd | FIN Dado N.. calcular los numeros: 2.... calcular el promedio de las notras aprobadas y el promedio de las notas desaprobadas INICIO | | Leer N | i=1 | Suma1 =0 | Suma2 =0 | C=0 | S=0 | mientras i<= N Hacer | | | | Leer Nota | | Si Nota>=13 entonces: | | | Suma1= Suma1+Nota | | | C=C+1 | | | | | Sino | | | | | | Suma2= Suma2+Nota | | | S=S+1 | | | | | Fin_si | | | | i=i+1 | | | | | fin_mientras | | Pa=Suma1/C | Pd=Suma2/S | | Escribir: Pa. | | Fin_si | | Suma= suma + salario | | i=i+1 | fin_mientras | P=suma/N | Escribir: P..8.4.C | FIN Dado N notas.

escribir el producto desde 1 hasta N INICIO | | Leer N | i=1 | mult=1 | | mientras i<=N Hacer: | mult= mult*i | i=i+1 | | fin_mientras | FIN Dadas 3 longitudes.c | Si a<b+c and b<a+c and c<a+b entonces | | | | Si a=b and b=c entonces: | | | escribe: "El triangulo es equilatero" | | | | | Sino | | | Si a<>b and a<>c and b<>c entonces | | | | escribe: "El triangulo es escaleno" | | | | | | | Sino | | | | escribe: "El triangulo es isosceles" | | | | | | | Fin_si | | | | | Fin_si | | | Sino | | escribe: "No forman triangulo" | | | Fin_si | | FIN Una tienda se dedica a la venta de computadoras. Cada uno de ellos tiene un sueldo mensual pero ademas de su sueldo ganan una comision por venta . o no forman triangulo (cada lado tiene que ser menos que la suma de los otros dos) INICIO | | Leer a. | | | fin_mientras | FIN Dado N. cuenta con 10 vendedores.b. es decir mediante un mensaje si forman un triangulo: equilat ero. isosceles o escaleno.

* Si el monto de venta es mayor de 1000 la comsion sera del 15% * Si el monto de venta es mayor o igual a 500 y menor de 1000 la comision es d el 5% * Si el monto de la venta es menor que 500 no tiene comision INICIO | | x=x+1 | Leer "Sueldo".C3. Si se ingresa al menos una clave incorrecta esta imprimira "TE EQUI VOCASTE DE FIESTA" y no permitira el ingreso. "Venta" | | Si venta>=1000 entonces | | Sueldo = Venta * 15/100 | | | Sino | | | | Si venta>=500 entonces | | Sueldo = Venta * 5/100 | | | | Sino | | Comision=0 | | | | Fin_si | | | Fin_si | | Sueldototal | Si x<>10 entonces | | x=x+1 | | | Fin_si | FIN Katthy organiza una fiesta en la cual una computadora controla el ingreso median te 5 claves.C2.C4. Si las 5 claves son correctas impr imira "BIENVENIDO A LA FIESTA" Las Claves son: 1: "TIENES" 2: "QUE SER" 3: "INVITADO" 4: "PARA" 5: "INGRESAR" INICIO | | Leer Claves: C1.C5 | | Si C1<>"TIENE" entonces: | | escribir "Te Equivocaste de Fiesta" | | | Sino | | escribir "Ingrese la Clave2" | | | | Si C2<>"QUE_SER" entonces: | | | escribir "Te Equivocaste de Fiesta" | | | .

Voley INICIO | x=x+1 | Leer "Deporte" | | Si deporte= "AJ" entonces | | AJ=AJ+1 | | | Sino | | Si deporte= "AT" entonces | | | AT=AT+1 | | | | | Sino | | | Si deporte= "B" entonces | | | | B=B+1 | | | | | | | Sino | | | | Si deporte= "F" entonces | | | | | F=F+1 | | | | | | | | | Sino | | | | | Si deporte= "G" entonces | | | | | | G=G+1 | | | | | | . Natacion. Gimnasia. Karate. | | Sino | | | escribir "Ingrese la Clave3" | | | | | | Si C3<>"INVITADO" entonces: | | | | escribir "Te Equivocaste de Fiesta" | | | | | | | Sino | | | | escribir "Ingrese la Clave4" | | | | | | | | Si C4<>"PARA" entonces: | | | | | escribir "Te Equivocaste de Fiesta" | | | | | | | | | Sino | | | | | escribir "Ingrese la Clave5" | | | | | | | | | | Si C5<>"INGRESAR" entonces: | | | | | | escribir "Te Equivocaste de Fiesta" | | | | | | | | | | | Sino | | | | | | escribir "Bienvenido a la Fiesta" | | | | | | | | | | | Fin_si | | | | | | | | | Fin_si | | | | | | | Fin_si | | | | | Fin_si | | | Fin_si | FIN Hacer un programa que clasifique 400 personas segun el deporte que prcatica los deportes son: Ajedrez. Futbol. Basket. Ti ro. Atletismo.

G.AT.F.T.K. | | | | | Sino | | | | | | Si deporte= "K" entonces | | | | | | | K=K+1 | | | | | | Sino | | | | | | | Si deporte= "N" entonces | | | | | | | | N=N+1 | | | | | | | | | | | | | | | Sino | | | | | | | | Si deporte= "T" entonces | | | | | | | | | T=T+1 | | | | | | | | | | | | | | | | | Sino | | | | | | | | | Si deporte= "V" entonces | | | | | | | | | | V=V+1 | | | | | | | | | | | | | | | | | | | Sino | | | | | | | | | | Imprimir "Error" | | | | | | | | | | | | | | | | | | | Fin_si | | | | | | | | | | | | | | | | | Fin_si | | | | | | | | | | | | | | | Fin_si | | | | | | | | | | | | | Fin_si | | | | | | | | | | | Fin_si | | | | | | | | | Fin_si | | | | | | | Fin_si | | | | | Fin_si | | | Fin_si | | Si x<>400 entonces | | x=x+1 | | | Sino | | Imprimir AJ.B.N. Inicio Dimensionar a (100) x=1 mientras x <=10 hacer leer a (x) fin_mientras x=1 mientras x<=10 hacer si a (x)mod2 = 1 entonces .V | | | Fin_si FIN Hacer un programa que registre 10 números en un Array de un 1D y que muestre poste riormente los elementos que contiene N°s Impares.

entonces | | | | | P2 = 18 | | | | | Escribir (P2) | | | | | | | | | Sino | | | | | Si DES = "Lima" . escribir (x) fin_si x=x + 1 fin_mientras Fin Diseñar un formulario que permita ingresar dos notas malas y determine su promedio . entonces | | | | | | Escribir ("No hay pasajes") | | | | | Fin_si | | | | Fin_si | | | Fin_si . Inicio Leer (N1) Leer (N2) P=(N1 + N2) / 2 Escribir ("el promedio es :". entonces | | | Escribir ("No hay pasajes") | | | | | Sino | | | Si DES ="Piura". INICIO | Leer (cliente) | Leer (CAT) | | Si CAT= "económico" . entonces | | Escribir ("ingrese destino") | | | | Si DES = "Tumbes". P) Si P>= 11 y P<=20 entonces Escribir ("Aprobado") Sino Escribir ("Desaprobado") Fin_si Fin Diseñar un programa que permita controlar la venta de pasajes a los clientes según l a categoría y el destino. debe mostrar un comentario si este está aprobado o desaprobado. entonces | | | | P1 = 12 | | | | Escribir (P1) | | | | | | | Sino | | | | Si DES ="Talara".

entonces | | | | | | P5=30 | | | | | | Escribir (P5) | | | | | | | | | | | Sino | | | | | | Si DES = Lima . entonces | | | | Escribir ("Ingrese destino") | | | | | | | | Si DES = Tumbes. | | Fin_si | | | Sino | | Si CAT =Imperial. entonces | | | Escribir ("Ingrese destino") | | | | | | Si DES = Tumbes.71 con la cual empieza todos los dias dia . entonces | | | | | | | Escribir ("No hay pasajes") | | | | | | | | | | | | | Fin_si | | | | | Fin_si | | | | Fin_si | | | Fin_si | | | | | Sino | | | Si CAT = Bus cama . entonces | | | P3=80 | | | Escribir ("P3") | | | | | | Sino | | | | Si DES =Piura. entonces | | | | | | | Escribir ("No hay pasaje") | | | | | | | | | | | | | Sino | | | | | | | Si DES = Lima. entonces | | | | | | Escribir ("No hay pasaje") | | | | | | | | | | | Sino | | | | | | Si DES =Talara. entonces | | | | P6=100 | | | | Escribir ("P6") | | | | | | | | Sino | | | | | Si DES =Piura. entonces | | | | | | | P7=170 | | | | | | | Escribir(P7) | | | | | | Fin_si | | | | | Fin_si | | | | Fin_si | | | Fin_si | | Fin_si | | |Fin_si | FIN La compañia Barner posee una caja con $3. entonces | | | | | P4= 20 | | | | | Escribir (P4) | | | | | | | | | Sino | | | | | Si DES =Talara.

(el programa termina cuando se ingresa un egreso imaginario de -1) INICIO Caja=371 Egreso=0 mientras egreso <> -1 Hacer: Caja= Caja . X i=2 Suma=0 mientras i <= 2N Hacer suma= suma +(x^i)/i i=i+2 fin_mientras Escribir suma FIN Calcular la suma de los n primeros numeros enteros desde el numero 8 S=8+9+10+11+..riamente se registran egresos.....+N INICIO Leer n suma=0 desde i=8 hasta n hacer: suma=suma+1 fin_desde Escribir suma FIN Calcular la media de un conjunto de notas de alumnos. Se le ha dado un valor de -30 que detecte el fin del programa . + Xn/N INICIO Leer N. calcular los egresos de la compañia y mostrar cuanto queda en caja.Egreso Leer Egreso Fin_mientras Escribir Caja FIN Dado Ny X CALCULAR: X2/2 + X4/4 + X6/6 + .

15 Sino descuento=0 Fin_si pago=consumo-descuento escribir pago x=x+1 fin_mientras FIN Hace un programa que calcule la longitud de la circunferencia.1416 LC=2*PI*R A=PI*R^2 . el are del circul o y el volumen de la esfera para un radio ingresado por el teclado INICIO Leer "R" PI=3. INICIO Total=0 n=0 Leer nota mientras nota<>-30 Hacer: total=total+nota n=n+1 Leer nota fin_mientras media=total/n escribir media FIN Calcular todos los pagos hechos de un restaurant que lea 130 consumos y que si e l consumo ingresado excede los $130 el descuento sera del 15% INICIO x=1 mientras x<130 Hacer Leer consumo Si consumo > 130 entonces: descuento=consumo * 0.

"V" FIN Hacer un programa que calcule el valor de la hipotenusa de un triangulo rectangu lo. V=4/3*PI*R^3 Imprimir "LC".B."A".C D=B^2-4*A*C Si D<0 entonces: IMPRIMIR "ERROR" Fin_si X=(-B+D^5)/(2*A) Y=(-B+D^5)/(2*A) IMPRIMIR X.5 IMPRIMIR AT FIN Hacer un prpgrama que calcule las raices de una ecuacion cuadratica cuya forma c anonica es: Ax+By+C=0 Solo se calculara raices reales.B. ingresando por el teclado sus catetos (Teorema de Pitagoras) INICIO Leer A.C seran ingresados por la pantalla INICIO Leer A.5 Imprimir "Hipotenusa" FIN Hacer un programa que permita calcular el area de un triangulo cualquiera donde los valores de los lados son ingresados por el teclado INICIO Leer A.B. imprimir err or y volver a ingresar datos.B H=(A^2+B^2)^0.Y FIN .C S=(A+B+C)/2 AT= (S*(S-A)*S*(S-B)*S*(S-C))^0. si el discriminante en menor de 0. Los coeficientes A.

el programa debe estar confeccionado de tal manera que el proce so a efectuarse sea repetitivo.D Fin_si FIN Hacer un programa que imprima el cubo y la raiz cuadrada de un numero ingresado por la pantalla. multiplicacion y division.Hacer un programa en el que ingresados dos numeros por la pantalla se debe calcu lar la suma.M.5 IMPRIMIR C.D .R Fin_si FIN Hacer un programa que al ingresar 2 numeros por la pantalla y que se calcule la suma.B S=A+B R=A-B M=A*B D=A/B IMPRIMIR .producto y division.R.S. diferencia. resta.M. el proceso debe finalizar al ingres ar el primer numero igual a cero INICIO Leer A Si A=0 entonces escribe "Fin del programa" Sino Leer B S=A+B R=A-B M=A*B D=A/B IMPRIMIR S. Debe terminar cuando al pedir el numero se ingrese el valor 0 INICIO Leer N Si N=0 entonces: escribe "Fin del programa" Sino C=N^3 R=N^0. El proceso debe terminar cuandon se hall an realizado 10 procesos (Hacer uso de contadores) INICIO X=X+1 Leer A.R.

Si x=10 entonces: escribe "Fin del programa" Sino X=X+1 Fin_si FIN .