Γραπτές Εξετάσεις Γ’ Γυµνασίου 2009

Απαντήσεις Θεµάτων
ΘΕΜΑ 1ο
1. Αλγόριθµο ονοµάζουµε τη σαφή και ακριβή περιγραφή µίας σειράς ξεχωριστών
οδηγιών-βηµάτων, µε σκοπό την επίλυση ενός προβλήµατος.
2. Τρεις γλώσσες προγραµµατισµού υψηλού επιπέδου: Java, C++, Logo.

ΘΕΜΑ 2ο
1. Το πρόγραµµα – µεταφραστής είναι ένα πρόγραµµα που µετατρέπει τις εντολές
του προγράµµατος που έχουµε γράψει σε γλώσσα υψηλού επιπέδου σε 0 και 1
(γλώσσα µηχανής). ∆ύο κατηγορίες µεταφραστών υπάρχουν: οι µεταγλωττιστές
(compilers) και οι διερµηνείς (interpreters).
2. Η διαφορά τους είναι ότι οι µεταγλωττιστές µεταφράζουν ολόκληρο το
πρόγραµµα ενώ οι διερµηνείς µεταφράζουν µία εντολή, την εκτελούν και µετά
πηγαίνουν στην επόµενη.

ΘΕΜΑ 3ο
1.
µπ: η χελώνα µετακινείται µπροστά τόσα εικονοστοιχεία όσα έχουµε ορίσει,
δε: η χελώνα στρίβει προς τα δεξιά τόσες µοίρες όσες έχουµε ορίσει.
σβγ: σβήνει τα σχέδια που έχουµε δηµιουργήσει από την επιφάνεια εργασίας και
µεταφέρει τη χελώνα στο κέντρο της επιφάνειας εργασίας µε κατεύθυνση προς τα
πάνω.
στα: η χελώνα σταµατάει να αφήνει ίχνος όταν προχωράει.
2. επανάλαβε 10 [ δείξε “Πληροφορική ]

ΘΕΜΑ 4ο
1.
κάνε “Ύψος 170
κάνε “Επώνυµο “Γεωργιάδης

Microworlds Pro – Απαντήσεις Γραπτών Εξετάσεων 2009

Σαρηµπαλίδης Ιωάννης

2.
∆είξε ( φρ [Το όνοµα µου είναι ] :Επώνυµο [και το ύψος µου είναι] :Ύψος
“εκατοστά. )

ΘΕΜΑ 5ο
1. ανακοίνωση [Οι Ολυµπιακοί αγώνες του 2008 έγιναν στο Πεκίνο.]
2. επανάλαβε 360 [ µπ 1 δε 1 ].

ΘΕΜΑ 6ο
1. Το σχήµα θα είναι το εξής:

2. Το σχήµα θα είναι το εξής:

ΘΕΜΑ 7ο
στκ
επανάλαβε 2 [ δε 90 µπ 60 αρ 90 στα µπ 40 ]
δε 90
στκ
µπ 60
Microworlds Pro – Απαντήσεις Γραπτών Εξετάσεων 2009

Σαρηµπαλίδης Ιωάννης

ΘΕΜΑ 8ο
για ορθογώνιο
στκ
επανάλαβε 2 [ µπ 50 δε 90 µπ 100 δε 90]
τέλος

ΘΕΜΑ 9ο
για τετράγωνο
στκ
επανάλαβε 4 [µπ 100 δε 90]
τέλος
για τρίγωνο
στκ
δε 30
επανάλαβε 3 [µπ 100 δε 120]
αρ 30
τέλος
για σπίτι
σβγ
τετράγωνο
µπ 100
τρίγωνο
τέλος

Microworlds Pro – Απαντήσεις Γραπτών Εξετάσεων 2009

Σαρηµπαλίδης Ιωάννης