You are on page 1of 4

http://suropeji.

com/cara-menyetting-mikrotik-dengan-speedy/
http://nayrisahotspot.wordpress.com/2010/08/08/load-balance-3-speedy-dengan-mikr
otik-rb450-modem-adsl-billion-bipac-5112s/
http://adamonline.web.id/tutorial_mikrotik/routerboard-tutorial_mikrotik/quick-s
etup-mikrotik-rb750
seting mikrotik 2speedy
http://www.facebook.com/topic.php?uid=39125097711&topic=12919
Interface
/interface set ether1 name=speedy1
/interface set ether2 name=speedy2
/interface set ether3 name=speedy3
/interface set ether4 name=speedy4
/interface set ether5 name=local
ip address
c
/ip address add address=192.168.1.2/24 interface=speedy1
/ip address add address=192.168.3.5/24 interface=speedy3
/ip address add address=192.168.4.5/24 interface=speedy4
/ip address add address=192.168.10.1/24 interface=local comment="mikrotik 1 ke m
ikrotik 2"
ip dns
/ip dns set allow-remote-requests=yes
/ip dns set primary-dns=203.134.1.10
/ip dns set secondary-dns=202.134.0.155

IP Firewall
/ip firewall filter add chain=input action=accept protocol=icmp
/ip firewall filter add chain=input action=accept connection-state=established i
n-interface=speedy1
/ip firewall filter add chain=input action=accept connection-state=related in-in
terface=speedy1
/ip firewall filter add chain=input action=drop in-interface=speedy1
/ip firewall filter add chain=input action=accept connection-state=established i
n-interface=speedy2
/ip firewall filter add chain=input action=accept connection-state=related in-in
terface=speedy2
/ip firewall filter add chain=input action=drop in-interface=speedy2
/ip firewall filter add chain=input action=accept connection-state=established i
n-interface=speedy3
/ip firewall filter add chain=input action=accept connection-state=related in-in
terface=speedy3
/ip firewall filter add chain=input action=drop in-interface=speedy3
/ip firewall filter add chain=input action=accept connection-state=established i
n-interface=speedy4
/ip firewall filter add chain=input action=accept connection-state=related in-in
terface=speedy4
/ip firewall filter add chain=input action=drop in-interface=speedy4
Setting Buat Mangle
/ip firewall mangle add chain=prerouting action=mark-connection new-connection-m
ark=Amole1 passthrough=yes connection-state=new in-interface=local nth=2,1 comme
nt="" disabled=no
/ip firewall mangle add chain=prerouting action=mark-routing new-routing-mark=Am
ole1 passthrough=no in-interface=local connection-mark=Amole1 comment="" disable
d=no
/ip firewall mangle add chain=prerouting action=mark-connection new-connection-m
ark=Amole2 passthrough=yes connection-state=new in-interface=local nth=1,1 comme
nt="" disabled=no
/ip firewall mangle add chain=prerouting action=mark-routing new-routing-mark=Am
ole2 passthrough=no in-interface=local connection-mark=Amole2 comment="" disable
d=no
/ip firewall mangle add chain=prerouting action=mark-connection new-connection-m
ark=Athlon3 passthrough=yes connection-state=new in-interface=local nth=2,1 comm
ent="" disabled=no
/ip firewall mangle add chain=prerouting action=mark-routing new-routing-mark=At
hlon3 passthrough=no in-interface=local connection-mark=Athlon3 comment="" disab
led=no
/ip firewall mangle add chain=prerouting action=mark-connection new-connection-m
ark=Athlon4 passthrough=yes connection-state=new in-interface=local nth=1,1 comm
ent="" disabled=no
/ip firewall mangle add chain=prerouting action=mark-routing new-routing-mark=At
hlon4 passthrough=no in-interface=local connection-mark=Athlon4 comment="" disab
led=no
Setting NAT
/ip firewall nat add chain=srcnat action=masquerade out-interface=speedy1
/ip firewall nat add chain=srcnat action=masquerade out-interface=speedy2
/ip firewall nat add chain=srcnat action=masquerade out-interface=speedy3
/ip firewall nat add chain=srcnat action=masquerade out-interface=speedy4
/ip firewall nat add chain=srcnat action=masquerade src-address="192.168.88.0/24
"
Setting Routenya
/ ip route add dst-address=0.0.0.0/0 gateway=192.168.1.2 scope=255 target-scope=
10 routing-mark=Amole1 comment="" disabled=no
/ ip route add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=
10 routing-mark=Amole2 comment="" disabled=no
/ ip route add dst-address=0.0.0.0/0 gateway=192.168.3.1 scope=255 target-scope=
10 routing-mark=Athlon3 comment="" disabled=no
/ ip route add dst-address=0.0.0.0/0 gateway=192.168.4.1 scope=255 target-scope=
10 routing-mark=Athlon4 comment="" disabled=no
/ ip route add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=
10 comment="primary connection" disabled=no
tambahkan protocol=tcp dst-port=80 pada mangle

Membagi Bandwith
Local Bawah
:for x from=10 to=80 do={ /ip firewall mangle add chain=prerouting src-address="
192.168.0.$x" action=mark-packet new-packet-mark="Upload-0_$x" passthrough=no }
:for x from=10 to=80 do={ /ip firewall mangle add chain=postrouting dst-address=
"192.168.0.$x" action=mark-packet new-packet-mark="Download-0_$x" passthrough=no
}
/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-
at=0 max-limit=512000 name=ULB packet-mark="" parent=local priority=1 queue=defa
ult;
/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-
at=0 max-limit=2048000 name=DLB packet-mark="" parent=local priority=1 queue=def
ault;
:for x from=10 to=30 do={/queue tree add burst-limit=0 burst-threshold=0 burst-t
ime=0s disabled=no limit-at=64000 max-limit=128000 name="Upload0_$x" packet-mark
="Upload-0_$x" parent=ULB priority=1 queue=default }
:for x from=10 to=30 do={/queue tree add burst-limit=0 burst-threshold=0 burst-t
ime=0s disabled=no limit-at=128000 max-limit=512000 name="Download0_$x" packet-m
ark="Download-0_$x" parent=DLB priority=1 queue=default }

/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-


at=0 max-limit=512000 name=ULA packet-mark="" parent=local priority=2 queue=defa
ult;
/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-
at=0 max-limit=1536000 name=DLA packet-mark="" parent=local priority=2 queue=def
ault;
:for x from=40 to=80 do={/queue tree add burst-limit=0 burst-threshold=0 burst-t
ime=0s disabled=no limit-at=32000 max-limit=64000 name="Upload0_$x" packet-mark=
"Upload-0_$x" parent=ULA priority=2 queue=default }
:for x from=40 to=80 do={/queue tree add burst-limit=0 burst-threshold=0 burst-t
ime=0s disabled=no limit-at=64000 max-limit=256000 name="Download0_$x" packet-ma
rk="Download-0_$x" parent=DLA priority=2 queue=default }

Lokal
:for x from=59 to=62 do={ /ip firewall mangle add chain=prerouting src-address="
192.168.100.$x" action=mark-packet new-packet-mark="Upload-0_$x" passthrough=no
}
:for x from=59 to=62 do={ /ip firewall mangle add chain=postrouting dst-address=
"192.168.100.$x" action=mark-packet new-packet-mark="Download-0_$x" passthrough=
no }
/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-
at=0 max-limit=384000 name=UL1 packet-mark="" parent=lokal priority=8 queue=defa
ult;
/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-
at=0 max-limit=1024000 name=DL1 packet-mark="" parent=lokal priority=8 queue=def
ault;
:for x from=59 to=62 do={/queue tree add burst-limit=0 burst-threshold=0 burst-t
ime=0s disabled=no limit-at=0 max-limit=0 name="Upload10_$x" packet-mark="Upload
-0_$x" parent=UL1 priority=1 queue=default }
:for x from=59 to=62 do={/queue tree add burst-limit=0 burst-threshold=0 burst-t
ime=0s disabled=no limit-at=0 max-limit=0 name="Download10_$x" packet-mark="Down
load-0_$x" parent=DL1 priority=1 queue=default }