1.-Hacer un pseudocodigo que imprima los numeros del 1 al 1ôô.

PROGRAMA contador1
ENTORNO.
c ·- 0
ALGORITMO.
Borrarpantalla( )
MIENTRAS c · 101 HACER
ESCRIBIR c
c ·- c ¹ 1
FINMIENTRAS
FINPROGRAMA

--------------------------------------------------------------------------

.-Hacer un pseudocodigo que imprima los numeros del 1ôô al ô, en orden
decreciente.

PROGRAMA contador2
ENTORNO.
c ·- 100
ALGORITMO.
Borrarpantalla( )
MIENTRAS c ·÷ 0 HACER
ESCRIBIR c
c ·- c - 1
FINMIENTRAS
FINPROGRAMA

--------------------------------------------------------------------------

3.-Hacer un pseudocodigo que imprima los numeros pares entre ô v 1ôô.

PROGRAMA pares
ENTORNO.
c ·- 2
ALGORITMO.
Borrarpantalla( )
MIENTRAS c < 101 HACER
ESCRIBIR c
c ·- c ¹ 2
FINMIENTRAS
FINPROGRAMA

--------------------------------------------------------------------------

4.-Hacer un programa que imprima la suma de los 1ôô primeros numeros.

PROGRAMA suma
ENTORNO.
c ·- 1
suma ·- 0
ALGORITMO.
Borrarpantalla( )
MIENTRAS c ·÷ 100 HACER
suma ·- suma ¹ c
c ·- c ¹ 1
FINMIENTRAS
ESCRIBIR "La suma de los 100 primeros n£meros es. "
ESCRIBIR suma
FINPROGRAMA

--------------------------------------------------------------------------

5.-Hacer un pseudocódigo que imprima los numeros impares hasta el 1ôô v que
imprima cuantos impares hav.

PROGRAMA impares
ENTORNO.
c ·- 1
son ·- 0
ALGORITMO.
Borrarpantalla( )
MIENTRAS c · 100
ESCRIBIR c
c ·- c ¹ 2
son ·- son ¹ 1
FINMIENTRAS
ESCRIBIR "El n£mero de impares. "
ESCRIBIR son
FINPROGRAMA

--------------------------------------------------------------------------

Hacer un pseudocodigo que imprima
todos los numeros naturales que hay
desde la unidad hasta un numero que introducimos por teclado.

PROGRAMA natural
ENTORNO.
i ·- 0
n ·- 0
ALGORITMO.
Borrarpantalla( )
ESCRIBIR "Introduce un n£mero. "
LEER n
MIENTRAS i · n HACER
i ·- i ¹ 1
ESCRIBIR i
FINMIENTRAS
FINPROGRAMA

--------------------------------------------------------------------------

.-Introducir tantas frases como queramos v contarlas.

PROGRAMA frases
ENTORNO.
res ·- "S"
frase ·- Espacios( 30 )
c ·- 0
ALGORITMO.
Borrarpantalla( )
MIENTRAS res ÷ "S" HACER
ESCRIBIR "Frase. "
LEER frase
c ·- c ¹ 1
ESCRIBIR "Deseas introducir m s frases (S/N). "
LEER res
FINMIENTRAS
ESCRIBIR "El n£mero de frases introducidas son. "
ESCRIBIR c
FINPROGRAMA










--------------------------------------------------------------------------

8.-Hacer un pseudocodigo que solo nos permita introducir S o A.

PROGRAMA sn
ENTORNO.
res ·- " "
ALGORITMO.
Borrarpantalla( )
MIENTRAS res ·~ "S" Y res ·~ "N" HACER
ESCRIBIR "Introduce S o N"
LEER res
res ·- Convertirmav£sculas( res )
FINMIENTRAS
FINPROGRAMA

--------------------------------------------------------------------------

9.-Introducir un numero por teclado. Que nos diga si es positivo o negativo.

PROGRAMA signo
ENTORNO.
num ·- 0
ALGORITMO.
Borrarpantalla( )
ESCRIBIR "Introduce un n£mero. "
LEER num
SI num ~÷ 0 ENTONCES
ESCRIBIR "es positivo"
SINO
ESCRIBIR "es negativo"
FINSI
FINPROGRAMA

--------------------------------------------------------------------------

1ô.-Introducir un numero por teclado. Que nos diga si es par o impar.

PROGRAMA paridad
ENTORNO.
num ·- 0
ALGORITMO.
Borrarpantalla( )
ESCRIBIR "Introduce un n£mero. "
LEER num
SI num ÷ int( num / 2 ) * 2 ENTONCES
ESCRIBIR "es par"
SINO
ESCRIBIR "es impar"
FINSI
FINPROGRAMA

--------------------------------------------------------------------------

















11.-Imprimir v contar los multiplos de 3 desde la unidad hasta un numero que
introducimos por teclado.

PROGRAMA multiplo3
ENTORNO.
i ·- 3
n ·- 0
c ·- 0
ALGORITMO.
Borrarpantalla( )
ESCRIBIR "N£mero. "
LEER n
MIENTRAS i ·÷ n HACER
SI i ÷ int( i / 3 ) * 3 ENTONCES
ESCRIBIR i
c ·- c ¹ 1
FINSI
i ·- i ¹ 1
FINMIENTRAS
ESCRIBIR "El n£mero de m£ltiplos de 3 son. "
ESCRIBIR c
FINPROGRAMA

--------------------------------------------------------------------------

12Hacer un pseudocodigo que imprima
los numeros del 1 al 100 Que calcule la
suma de todos los numeros pares por un lado, v por otro, la de todos los
impares.

PROGRAMA parimpar
ENTORNO.
i ·- 1
sumapar ·- 0
sumaimp ·- 0
ALGORITMO.
Borrarpantalla( )
MIENTRAS i · 101 HACER
SI i ÷ int( i / 2 ) * 2 ENTONCES
sumapar ·- sumapar ¹ i
SINO
sumaimp ·- sumaimp ¹ i
FINSI
i ·- i ¹ 1
FINMIENTRAS
ESCRIBIR "La suma de los pares es. "
ESCRIBIR sumapar
ESCRIBIR "La suma de los impares es. "
ESCRIBIR sumaimp
FINPROGRAMA

--------------------------------------------------------------------------

13Imprimir y contar los numeros que
son multiplos de 2 o de 3 que hay entre
1 v 1ôô.
PROGRAMA multiplo23
ENTORNO.
i ·- 1
c ·- 0
ALGORITMO.
Borrarpantalla( )
MIENTRAS i · 101 HACER
SI i ÷ int( i / 2 ) * 2 O i ÷ int( i / 3 ) * 3 ENTONCES
c ·- c ¹ 1
ESCRIBIR i
FINSI
i ·- i ¹ 1
FINMIENTRAS
ESCRIBIR "El n£mero de m£ltiplos es de. "
ESCRIBIR c
FINPROGRAMA

--------------------------------------------------------------------------

14Hacer un pseudocodigo que imprima
el mayor y el menor de una serie de
cinco numeros que vamos introduciendo por teclado.

PROGRAMA mavormenor
ENTORNO.
con ·- 0
n ·- 0
maximo ·- 0
minimo ·- 99999
ALGORITMO.
Borrarpantalla( )
MIENTRAS con ·÷ 5 HACER
ESCRIBIR "N£mero. "
LEER n
SI n ~ maximo ENTONCES
maximo ÷ n
FINSI
SI n · minimo ENTONCES
minimo ·- n
FINSI
con ·- con ¹ 1
FINMIENTRAS
ESCRIBIR "El mavor de los n£meros es. "
ESCRIBIR maximo
ESCRIBIR "El menor de los n£meros es. "
ESCRIBIR minimo
FINPROGRAMA

--------------------------------------------------------------------------

15Introducir dos numeros por teclado
Imprimir los numeros naturales que
hav entre ambos numeros empezando por el m s pequeño, contar cuantos hav v
cuantos de ellos son pares. Calcular la suma de los impares.
PROGRAMA parimpar
ENTORNO.
num1 ·- 0
num2 ·- 0
aux ·- 0
son ·- 0
pares ·- 0
sumaimpa ·- 0
ALGORITMO.
Borrarpantalla( )
ESCRIBIR "N£mero. "
LEER num1
ESCRIBIR "N£mero. "
LEER num2
SI num1 ~ num2 ENTONCES
aux ·- num1
num1 ·- num2
num2 ·- aux
FINSI
MIENTRAS num1 ~÷ num2 HACER
ESCRIBIR num1
son ·- son ¹ 1
SI num1 ÷ int( num1 / 2 ) * 2 ENTONCES
pares ·- pares ¹ 1
SINO
sumaimpa ·- sumaimpa ¹ num1
FINSI
num1 ·- num1 ¹ 1
FINMIENTRAS
ESCRIBIR "N£meros visualizados. "
ESCRIBIR son
ESCRIBIR "Pares hav. "
ESCRIBIR pares
ESCRIBIR "La suma de los impares es. "
ESCRIBIR sumaimpa
FINPROGRAMA

--------------------------------------------------------------------------
%
--------------------------------------------------------------------------
ucles anidados v subprogramas
--------------------------------------------------------------------------

1ô.-Imprimir diez veces la serie de numeros del 1 al 1ô.

PROGRAMA diez
ENTORNO.
serie ·- 0
ALGORITMO.
Borrarpantalla( )
MIENTRAS serie ·÷ 10 HACER
numero ·- 1
MIENTRAS numero ·÷ 10 HACER
ESCRIBIR numero
numero ·- numero ¹ 1
FINMIENTRAS
serie ·- serie ¹ 1
FINMIENTRAS
FINPROGRAMA

--------------------------------------------------------------------------

1.-Imprimir, contar v sumar los multiplos de que hav entre una serie de
numeros, tal que el segundo sea mavor o igual que el primero.

PROGRAMA multiplo2
ENTORNO.
res ·- "S"
ALGORITMO.
Borrarpantalla( )
MIENTRAS res ÷ "S" HACER
c ·- 0
sum ·- 0
num1 ·- 0
num2 ·- -999
ESCRIBIR "N£mero. "
LEER num1
ESCRIBIR "N£mero mavor que el anterior"
MIENTRAS num1 ~÷ num2 HACER
LEER num2
FINMIENTRAS
num1 ·- num1 ¹ 1
MIENTRAS num1 ·÷ num2 - 1 HACER
SI num1 ÷ int( num1 / 2 ) * 2 ENTONCES
ESCRIBIR num1
c ·- c ¹ 1
sum ·- sum ¹ num1
FINSI
num1 ·- num1 ¹ 1
FINMIENTRAS
ESCRIBIR "N£mero de m£ltiplos de 2. "
ESCRIBIR c
ESCRIBIR "Su suma es. "
ESCRIBIR sum
res ·- Espacios( 1 )
MIENTRAS res ·~ "S" Y res ·~ "N" HACER
ESCRIBIR "Otra serie de n£meros (S/N). "
LEER res
res ·- Convertirmav£sculas( res )
FINMIENTRAS
FINMIENTRAS
FINPROGRAMA

--------------------------------------------------------------------------

18.-Hacer un pseudocodigo que cuente las veces que aparece una determinada
letra en una frase que introduciremos por teclado

PROGRAMA letra
ENTORNO.
frase ·- Espacios( 30 )
letra ·- Espacios( 1 )
longitud ·- 0
a ·- 0
res ·- "S"
ALGORITMO.
MIENTRAS res ÷ "S" HACER
Borrarpantalla( )
ESCRIBIR "Introduce una frase. "
LEER frase
longitud ·- Hallarlongitud( frase )
i ·- 1
ESCRIBIR "Letra a buscar. "
LEER letra
MIENTRAS i ·÷ longitud HACER
SI letra ÷ Caracter( frase. i. 1 ) ENTONCES
a ·- a ¹ 1
FINSI
i ·- i ¹ 1
FINMIENTRAS
Borrarpantalla( )
ESCRIBIR "El n£mero de veces que aparece la letra "
ESCRIBIR letra
ESCRIBIR " en la frase "
ESCRIBIR frase
ESCRIBIR " es de "
ESCRIBIR a
res ·- Espacios( 1 )
MIENTRAS res ·~ "S" Y res ·~ "N" HACER
ESCRIBIR "Desea introducir m&aacute,s frases (S/N). "
LEER res
res ·- Convertirmav£sculas( res )
FINMIENTRAS
FINMIENTRAS
FINPROGRAMA

--------------------------------------------------------------------------

19Hacer un pseudocodigo que simule el
funcionamiento de un reloj digital y
que permita ponerlo en hora.

PROGRAMA reloi
ENTORNO.
horas ·- 0
minutos ·- 0
segundos ·- 0
res ·- "S"
ALGORITMO.
Borrarpantalla( )
ESCRIBIR "Horas. "
LEER horas
ESCRIBIR "Minutos. "
LEER minutos
ESCRIBIR "Segundos. "
LEER segundos
MIENTRAS res ÷ "S" HACER
MIENTRAS horas · 24 HACER
MIENTRAS minutos · 60 HACER
MIENTRAS segundos · 60 HACER
ESCRIBIR horas
ESCRIBIR minutos
ESCRIBIR segundos
segundos ·- segundos ¹ 1
FINMIENTRAS
minutos ·- minutos ¹ 1
segundos ·- 0
FINMIENTRAS
horas ·- horas ¹ 1
minutos ·- 0
FINMIENTRAS
horas ·- 0
FINMIENTRAS
FINPROGRAMA

--------------------------------------------------------------------------

ô.-Calcular el factorial de un numero, mediante subprogramas.

PROGRAMA factorial
ENTORNO.
res ·- "S"
ALGORITMO.
MIENTRAS res ÷ "S" HACER
Borrarpantalla( )
factorial ·- 1
ESCRIBIR "N£mero. "
LEER numero
SI numero · 0 ENTONCES
ESCRIBIR "No tiene factorial"
SINO
HACER Calculos
FINSI
HACER Mas
FINMIENTRAS
FINPROGRAMA
------------------------------
SUBPROGRAMA Calculos
MIENTRAS numero ~ 1 HACER
factorial ·- factorial * numero
numero ·- numero - 1
FINMIENTRAS
HACER Imprimir
FINSUBPROGRAMA
------------------------------
SUBPROGRAMA Mas
res ·- " "
MIENTRAS res ·~ "S" Y res ·~ "N" HACER
ESCRIBIR "Desea calcular m&aacute,s factoriales (S/N). "
LEER res
res ·- Convertirmav£sculas( res )
FINMIENTRAS
FINSUBPROGRAMA
------------------------------
SUBPROGRAMA Imprimir
ESCRIBIR "Su factorial es. "
ESCRIBIR factorial
FINSUBPROGRAMA


--------------------------------------------------------------------------














1.-Hacer un programa que calcule independientemente la suma de los pares v
los impares de los numeros entre 1 v 1ôôô, utilizando un switch.

PROGRAMA suma
ENTORNO.
par ·- 0
impar ·- 0
sw ·- 0
i ·- 1
ALGORITMO.
Borrarpantalla( )
MIENTRAS i ·÷ 1000 HACER
SI sw ÷ 0 ENTONCES
impar ·- impar ¹ i
sw ·- 1
SINO
par ·- par ¹ i
sw ·- 0
FINSI
i ·- i ¹ 1
FINMIENTRAS
ESCRIBIR "La suma de los pares es. "
ESCRIBIR par
ESCRIBIR "La suma de los impares es. "
ESCRIBIR impar
FINPROGRAMA

--------------------------------------------------------------------------
% 3
--------------------------------------------------------------------------
!resentacion en pantalla y cabeceras
--------------------------------------------------------------------------

.-Introducir una frase por teclado. Imprimirla cinco veces en filas
consecutivas, pero cada impresion ir desplazada cuatro columnas hacia la
derecha.

PROGRAMA frase
ENTORNO.
frase ·- Espacios( 30 )
ALGORITMO.
Borrarpantalla( )
EN 5.15 ESCRIBIR "Frase. "
EN 5.22 LEER frase
fi ·- 8
co ·- 15
veces ·- 0
MIENTRAS veces ·÷ 5 HACER
EN fi.co ESCRIBIR frase
veces ·- veces ¹ 1
co ·- co ¹ 4
fi ·- fi ¹ 1
FINMIENTRAS
FINPROGRAMA

--------------------------------------------------------------------------

23Hacer un pseudocodigo que imprima
los n£meros del 0 al 100. controlando
las filas v las columnas.

PROGRAMA numeros
ENTORNO.
c ·- 0
ALGORITMO.
Borrarpantalla( )
EN 5.20 ESCRIBIR "Los n£meros del 0 al 100 son. "
fi ·- 7
col ·- 5
MIENTRAS c · 101 HACER
EN fi.col ESCRIBIR c
c ·- c ¹ 1
col ·- col ¹ 4
SI col ~ 75 ENTONCES
fi ·- fi ¹ 2
col ·- 5
FINSI
FINMIENTRAS
FINPROGRAMA

--------------------------------------------------------------------------

4.-Comprobar si un numero mavor o igual que la unidad es primo.

PROGRAMA primo
ENTORNO.
res ·- "S"
ALGORITMO.
MIENTRAS res ÷ "S" HACER
Borrarpantalla( )
numero ·- 0
sw ·- 0
MIENTRAS numero · 1 HACER
EN 8.10 ESCRIBIR "N£mero. "
EN 8.18 LEER numero
FINMIENTRAS
i ·- numero - 1
MIENTRAS i ~ 1 Y sw ·~ 1 HACER
SI numero ÷ Int( numero / i ) * i ENTONCES
sw ÷ 1
SINO
i ·- i - 1
FINSI
FINMIENTRAS
SI sw ÷ 1 ENTONCES
EN 10.10 ESCRIBIR "no es primo"
SINO
EN 10.10 ESCRIBIR "s¡ es primo"
FINSI
HACER Mas
FINMIENTRAS
FINPROGRAMA
------------------------------
SUBPROGRAMA Mas
res ·- " "
MIENTRAS res ·~ "S" Y res ·~ "N" HACER
ESCRIBIR "Desea introducir m s n£meros (S/N). "
LEER res
res ·- Convertirmavusculas( res )
FINMIENTRAS
FINSUBPROGRAMA

--------------------------------------------------------------------------

5.-Introducir un numero menor de 5ôôô v pasarlo a numero romano.

PROGRAMA romano
ENTORNO.
res ·- "S"
ALGORITMO.
MIENTRAS res ÷ "S" HACER
Borrarpantalla( )
num ·- 0
MIENTRAS num · 1 O num ~ 5000 HACER
EN 8.10 ESCRIBIR "N£mero. "
EN 8.18 ESCRIBIR num
FINMIENTRAS
col ·- 15
MIENTRAS num ~÷ 1000 HACER
EN 15.col ESCRIBIR "M"
num ·- num - 1000
col ·- col ¹ 1
FINMIENTRAS
SI num ~÷ 900 ENTONCES
EN 15.col ESCRIBIR "CM"
num ·- num - 900
col ·- col ¹ 2
FINSI
SI num ~÷ 500 ENTONCES
EN 15.col ESCRIBIR "D"
num ·- num - 500
col ·- col ¹ 1
FINSI
MIENTRAS num ~÷ 100 HACER
EN 15.col ESCRIBIR "C"
num ·- num - 100
col ·- col ¹ 1
FINMIENTRAS
SI num ~÷ 90 ENTONCES
EN 15.col ESCRIBIR "XC"
num ·- num - 90
col ·- col ¹ 2
FINSI
SI num ~÷ 50 ENTONCES
EN 15.col ESCRIBIR "L"
num ·- num - 50
col ·- col ¹ 1
FINSI
SI num ~÷ 40 ENTONCES
EN 15.col ESCRIBIR "XL"
num ·- num - 40
col ·- col ¹ 2
FINSI
MIENTRAS num ~÷ 10 HACER
EN 15.col ESCRIBIR "X"
num ·- num - 10
col ·- col ¹ 1
FINMIENTRAS
SI num ÷ 9 ENTONCES
EN 15.col ESCRIBIR "IX"
num ·- num - 9
col ·- col ¹ 2
FINSI
SI num ~÷ 5 ENTONCES
EN 15.col ESCRIBIR "J"
num ·- num - 5
col ·- col ¹ 1
FINSI
SI num ~÷ 4 ENTONCES
EN 15.col ESCRIBIR "IJ"
num ·- num - 4
col ·- col ¹ 2
FINSI
MIENTRAS num ~ 0 HACER
EN 15.col ESCRIBIR "I"
num ·- num - 1
col ·- col ¹ 1
FINMIENTRAS
HACER Mas
FINMIENTRAS
FINPROGRAMA
------------------------------
SUBPROGRAMA Mas
res ·- " "
MIENTRAS res ·~ "S" Y res ·~ "N" HACER
ESCRIBIR "Desea introducir m s n£meros (S/N). "
LEER res
res ·- Convertirmavusculas( res )
FINMIENTRAS
FINSUBPROGRAMA

--------------------------------------------------------------------------

ô.-Introducir una frase por teclado. Imprimirla en el centro de la pantalla.

PROGRAMA centro
ENTORNO.
res ·- "S"
frase ·- Espacios( 40 )
ALGORITMO.
MIENTRAS res ÷ "S" HACER
Borrarpantalla( )
EN 5.15 ESCRIBIR "Frase. "
EN 5.22 LEER frase
EN 12.40 - Int( Longitud( frase ) / 2 ) ESCRIBIR frase
HACER Mas
FINMIENTRAS
FINPROGRAMA

--------------------------------------------------------------------------

.-Realizar la tabla de multiplicar de un numero entre ô v 1ô.

PROGRAMA tabla
ENTORNO.
num ·- -1
ALGORITMO.
HACER Numero
Borrarpantalla( )
EN 5.10 ESCRIBIR "Tabla de multiplicar del n£mero. "
EN 5.40 LEER num
i ·- 0
fi ·- 8
MIENTRAS i ·÷ 10 HACER
EN fi.15 ESCRIBIR num
EN fi.19 ESCRIBIR " * "
EN fi.23 ESCRIBIR i
EN fi.25 ESCRIBIR " ÷ "
EN fi.29 ESCRIBIR num * i
fi ·- fi ¹ 1
i ·- i ¹ 1
FINMIENTRAS
FINPROGRAMA
------------------------------
SUBPROGRAMA Numero
MIENTRAS num · 0 HACER
Borrarpantalla( )
EN 10.25 ESCRIBIR "N£mero. "
EN 10.33 LEER num
FINMIENTRAS
FINSUBPROGRAMA

--------------------------------------------------------------------------
TEMA 4
--------------------------------------------------------------------------
Numeros aleatorios y menus
--------------------------------------------------------------------------

8.-Simular el lanzamiento de una moneda al aire e imprimir si ha salido cara
o cruz.

PROGRAMA moneda
ENTORNO.
res ·- "S"
ALGORITMO.
MIENTRAS res ÷ "S" HACER
Borrarpantalla( )
SI Rnd( ) ·÷ 05 ENTONCES
EN 10.35 ESCRIBIR "Cara"
SINO
EN 10.35 ESCRIBIR "Cruz"
FINSI
HACER Mas
FINMIENTRAS
FINPROGRAMA
------------------------------
SUBPROGRAMA Mas
res ·- Espacios( 1 )
MIENTRAS res ·~ "S" Y res ·~ "N" HACER
EN 20.30 ESCRIBIR "M s lanzamientos (S/N). "
EN 20.57 LEER res
res ·- Convertirmavusculas( res )
FINMIENTRAS
FINSUBPROGRAMA

--------------------------------------------------------------------------

9.-Simular cien tiradas de dos dados v contar las veces que entre los dos
suman 1ô.

PROGRAMA dado
ENTORNO.
c ·- 0
i ·- 0
ALGORITMO.
Borrarpantalla( )
MIENTRAS i · 101 HACER
SI Int( Rnd( ) * 6 ) ¹ Int( Rnd( ) * 6 ) ¹ 2 ÷ 10 ENTONCES
c ·- c ¹ 1
FINSI
i ·- i ¹ 1
FINMIENTRAS
EN 10.20 ESCRIBIR "Las veces que suman 10 son. "
EN 10.48 ESCRIBIR c
FINPROGRAMA

--------------------------------------------------------------------------

3ô.-Simular una carrera de dos caballos si cada uno tiene igual probabilidad
de ganar.

!ROGRAMA caballos
ENTORNO.
dibuio ·- "****"
col1 ·- 4
col2 ·- 4
ALGORITMO.
Borrarpantalla( )
EN 10.col1 ESCRIBIR dibuio
EN 10.col2 ESCRIBIR dibuio
MIENTRAS col1 ·÷ 75 Y col2 ·÷ 75 HACER
SI Rnd( ) ·÷ 05 ENTONCES
EN 10.col1 ESCRIBIR Espacios( 4 )
col1 ·- col1 ¹ 4
EN 10.col1 ESCRIBIR dibuio
SINO
EN 12.col2 ESCRIBIR Espacios( 4 )
col2 ·- col2 ¹ 4
EN 12.col2 ESCRIBIR dibuio
FINSI
FINMIENTRAS
EN 16.20 ESCRIBIR "El ganador es el caballo n£mero. "
SI col1 ~÷ 75 ENTONCES
EN 16.54 ESCRIBIR "1"
SINO
EN 16.54 ESCRIBIR "2"
FINSI
FINPROGRAMA

--------------------------------------------------------------------------

31.-Introducir dos nvmeros por teclado v mediante un menu, calcule su suma, su
resta, su multiplicacion o su division.

PROGRAMA menu1
ENTORNO.
op ·- 0
ALGORITMO.
EN 10.20 ESCRIBIR "N£mero. "
EN 10.29 LEER n1
EN 12.20 ESCRIBIR "N£mero. "
EN 12.29 LEER n2
MIENTRAS op ·~ 5 HACER
op ·- 0
Borrarpantalla( )
EN 6.20 ESCRIBIR "Men£ de opciones"
EN 10.25 ESCRIBIR "1- Suma"
EN 12.25 ESCRIBIR "2- Resta"
EN 14.25 ESCRIBIR "3- Multiplicaci¢n"
EN 16.25 ESCRIBIR "4- Divisi¢n"
EN 18.25 ESCRIBIR "5- Salir del programa"
EN 22.25 ESCRIBIR "Eliia opci¢n. "
EN 22.39 LEER op
Borrarpantalla( )
HACER CASO
CASO op ÷ 1
EN 10.20 ESCRIBIR "Su suma es. "
EN 10.33 ESCRIBIR n1 ¹ n2
Pausa( )
CASO op ÷ 2
EN 10.20 ESCRIBIR "Su resta es. "
EN 10.33 ESCRIBIR n1 - n2
Pausa( )
CASO op ÷ 3
EN 10.20 ESCRIBIR "Su multiplicaci¢n es. "
EN 10.33 ESCRIBIR n1 * n2
Pausa( )
CASO op ÷ 4
EN 10.20 ESCRIBIR "Su divisi¢n es. "
EN 10.33 ESCRIBIR n1 / n2
Pausa( )
FINCASO
FINMIENTRAS
FINPROGRAMA

--------------------------------------------------------------------------

3.-Hacer un programa que nos permita introducir un numero por teclado v sobre
el se realicen las siguientes operaciones: comprobar si es primo, hallar
su factorial o imprimir su tabla de multiplicar.

PROGRAMA menu2
ENTORNO.
op ·- 0
ALGORITMO.
EN 10.20 ESCRIBIR "N£mero. "
EN 10.29 LEER n
MIENTRAS op ·~ 4 HACER
op ·- 0
Borrarpantalla( )
EN 6.30 ESCRIBIR "Men£ de opciones"
EN 10.25 ESCRIBIR "1- Comprobar si es primo"
EN 12.25 ESCRIBIR "2- Hallar su factorial"
EN 14.25 ESCRIBIR "3- Tabla de multiplicar"
EN 16.25 ESCRIBIR "4- Salir del programa"
EN 22.25 ESCRIBIR "Eliia opci¢n. "
EN 22.39 LEER op
HACER CASO
CASO op ÷ 1
HACER Primo
CASO op ÷ 2
HACER Factorial
CASO op ÷ 3
HACER Tabla
FINCASO
FINMIENTRAS
FINPROGRAMA
------------------------------
SUBPROGRAMA Primo
sw ·- 0
i ·- n - 1
MIENTRAS i ~ 1 Y sw ·~ 1 HACER
SI n ÷ Int( n / i ) * i ENTONCES
sw ·- 1
SINO
i ·- i - 1
FINSI
FINMIENTRAS
Borrarpantalla( )
SI sw ÷ 1 ENTONCES
EN 10.10 ESCRIBIR "no es primo"
SINO
EN 10.10 ESCRIBIR "s¡ es primo"
FINSI
Pausa( )
FINSUBPROGRAMA
------------------------------
SUBPROGRAMA Factorial
fac ·- 1
Borrarpantalla( )
SI n · 0 ENTONCES
EN 10.10 ESCRIBIR "No tiene factorial"
SINO
MIENTRAS n ~ 1 HACER
fac ·- fac * n
n ·- n - 1
FINMIENTRAS
EN 10.10 ESCRIBIR "Su factorial es. "
EN 10.27 ESCRIBIR fac
FINSI
Pausa( )
FINSUBPROGRAMA
------------------------------
SUBPROGRAMA Tabla
i ·- 0
fi ·- 10
Borrarpantalla( )
MIENTRAS i ·÷ 10 HACER
EN 8.10 ESCRIBIR "Tabla de multiplicar"
EN fi.10 ESCRIBIR n
EN fi.15 ESCRIBIR "*"
EN fi.20 ESCRIBIR i
EN fi.25 ESCRIBIR "÷"
EN fi.30 ESCRIBIR n * i
i ·- i ¹ 1
FINMIENTRAS
Pausa( )
FINSUBPROGRAMA

--------------------------------------------------------------------------
% 4
--------------------------------------------------------------------------
Arrays unidimensionales
--------------------------------------------------------------------------

33.-Crear un arrav unidimensional de ô elementos con nombres de personas.
Jisualizar los elementos de la lista debiendo ir cada uno en una fila
distinta.

PROGRAMA nombres
ENTORNO.
DIMENSIONA datos[ 20 ]
i ·- 1
ALGORITMO.
Borrarpantalla( )
fi ·- 10
MIENTRAS i · 21 HACER
EN fi.10 ESCRIBIR "Nombre. "
EN fi. 18 LEER datos[ i ]
i ·- i ¹ 1
FINMIENTRAS
Borrarpantalla( )
i ·- 1
fi ·- 3
EN 1.20 ESCRIBIR "Elementos de la lista"
MIENTRAS i · 21 HACER
EN fi.28 ESCRIBIR datos[ i ]
fi ·- fi ¹ 1
i ·- i ¹ 1
FINMIENTRAS
FINPROGRAMA

--------------------------------------------------------------------------

34.-Hacer un programa que lea las calificaciones de un alumno en 1ô
asignaturas, las almacene en un vector v calcule e imprima su media.

PROGRAMA notamedia
ENTORNO.
DIMENSIONA notas[ 10 ]
suma ·- 0
media ·- 0
ALGORITMO.
Borrarpantalla( )
fi ·- 7
PARA i DESDE 1 HASTA 10 HACER
EN fi.15 ESCRIBIR "Nota "
EN fi.20 ESCRIBIR i
EN fi.21 ESCRIBIR ". "
EN fi.23 LEER notas[ i ]
fi ·- fi ¹ 1
FINPARA
PARA i DESDE 1 HASTA 10 HACER
suma ·- suma ¹ notas[ i ]
FINPARA
media ·- suma / 10
EN 20.20 ESCRIBIR "Nota media. "
EN 20.32 ESCRIBIR media
FINPROGRAMA

--------------------------------------------------------------------------

35.-Usando el segundo ejemplo, hacer un programa que busque una nota en el
vector.

PROGRAMA buscar
ENTORNO.
i ·- 0
num ·- 0
ALGORITMO.
Borrarpantalla( )
ESCRIBIR "Nota a buscar. "
LEER num
ITERAR
i ·- i ¹ 1
SI notas[ i ] ÷ num O i ÷ 10 ENTONCES
SALIR
FINSI
FINITERAR
SI notas[ i ] ÷ num ENTONCES
ESCRIBIR "Encontrado en posici&oacute,n. "
ESCRIBIR i
SINO
ESCRIBIR "No existe esa nota"
FINSI
FINPROGRAMA

--------------------------------------------------------------------------
% 5
--------------------------------------------------------------------------
Arrays bidimensionales
--------------------------------------------------------------------------

3ô.-Cenerar una matriz de 4 filas v 5 columnas con numeros aleatorios entre 1
v 1ôô, e imprimirla.

PROGRAMA matriz
ENTORNO.
DIMENSIONAR A[ 4. 5 ]
i ·- 1
fi ·- 10
co ·- 15

. 
. 
%#$ !# #  

  
,.07:3580:/4.4/46:02572,483:207485,70803970    !# #5,708 % #  . 
 #%  477,7*5,39,,   

%#$. # 
$##. . 
.  %#$ !# #  

  
,.07:35747,2,6:02572,,8:2,/048 57207483:20748   !# #8:2, % # 

. 
8:2,  
 #%  477,7*5,39,,   %#$. # 8:2, 
8:2, . . 
.  %#$ $##,8:2,/048 57207483U2074808 $##8:2, !# #  

  
,.07:3580:/4.O/46:02572,483:2074825,708,89,0 6:0 2572,.:,394825,708,   !# #25,708 % #  . 
843  
 #%  477,7*5,39,,   %#$.  $##.

. 
.  843 
843  %#$ $##3U2074/025,708 $##843 !# #  

  

,.07:3580:/4.4/46:02572, 94/48483:207483,9:7,086:0,
/08/0,:3/,/,89,:33:20746:03974/:.24854790.,/4   !# #3,9:7, % #    
3  
 #%  477,7*5,39,,   $##3974/:.0:33U2074 #3 %#$3#  
 $## %#$

4246:07.817.  $##080.7.80 .79.!# #     3974/:.    #%  477.48    .72817.808.248. ..808 % #  708 $ 17.80 85.83974/:.   %#$708$# $##7.7*5.808 $.39..439.39.8   !# #17.80 #17.

8843 $##.8083974/:.  #708 %#$ $##3U2074/017. !# #   ./.

.:..U8.8 708  %#$ !# #   .39.   %#$708$708# $##3974/:.7$4   !# #83 % #  708   #%  477.4/46:084434850729.           .0797*2.7*5.07:3580:/4.3974/:.0$4 #708 708 43.

7:33:207454790.7/./4 ":0348/.   $##3974/:.7   !# #5.7:33:207454790.7425.39.8085489..9.4   !# #834 % #  3:2    #%  477..8085./ % #  3:2    #%  .  3974/:.0:33U2074 #3:2 $3:2 % $ $##085489./4 ":0348/.4 $  $##0830.4430..4 $ !# #     3974/:.9.7*5.

7*5.39.   $##3974/:..477.0:33U2074 #3:2 $3:239 3:2.

  % $ $##085.7 $  $##0825.7 $ !# #                 .

24854790.89.7482:9548/0/08/0.39.7*5.   $##U2074 #3 %#$3# $39 .    25727../..    #%  477.439./4   !# #2:954 % #    3   .:33:20746:0 3974/:.:3/.

  $    %#$ $##3U2074/02U9548/0843 $##. .  % $ $## . !# # .

.25    #%  477. 8:2...39.5..07:3580:/4.    .7   8:2. ":0.7*25.7*5. 483:20748/0.:0./094/48483:207485.4/46:02572./094/4848 25.   %#$ # $39 ./4 5474974 .708547:3.708   !# #5.7 % #    8:2.

7 8:2./0485.7  $  8:2.25  $    %#$ $##.5.7 .8:2.25 8:2.5.5.70808 $##8:2.  % $ 8:2.

7*5..39./04825.03970   !# #2:954** % #    .439.$##.70808 $##8:2.7483:207486:0 8432:9548/04/06:0.25 !# #     25727.8:2.   %#$ # $39 .    #%  477.

   39 .

  $## $    %#$ $##3U2074/02U954808/0 $##. . !# # .  % $ .

2483974/:.    .243 $ $32324% $ 2324 3 $ .39.07:3580:/4.   %#$..43 .43  . 02.03/454790...8070/0 .24% $ 2.47020347/0:3.4/46:02572.24   2324   #%  477.43   3   2.43# $##U2074 #3 $32.47*20347 % #  .7*5./4   !# #2..3.43:207486:0.

708  !# #5.9:7.439.7*25.:..3948.708   8:2./04825.2-483:207480250.708 .:.%#$ $##2.39.47/0483U2074808 $##2..7 % #  3:2   3:2   .8:2.7*5..7/483:2074854790.3948/00488435.:.7. .    #%  477.25./4  25727483:207483.7.086:0 .24 $##20347/0483U2074808 $##2324 !# #     3974/:.:   843   5.   $##U2074 #3:2 .3/4547028506:0N4 .03970.

$##U2074 #3:2 $3:23:2% $ .: $ %#$3:23:2# $##3:2 843 843  $3:239 3:2.: 3:2 3:2 3:2 3:2 .

 $##5. 8:2.708  $  8:2.708. !# #  .8:2..  % $ 5./04825.25.708 $##. 3:2 $ 3:2 3:2  %#$ $##U20748.25.708 5.70808 $##8:2.25.8:./48 $##843 $##!.

  %#$8070 # 3:2074  %#$3:2074 # $##3:2074 3:2074 3:2074  %#$ 8070 8070  %#$ !# #    .7*5.08.39./488:-5747..8070/03:20748/0.3/.0.  %  :.   !# #/0 % #  8070    #%  477.8    25727/0.08.2.

78:2.6:00572074   !# #2:954 % #  708 $  #%  477.2.6:0080:3/480.439.8070/0 3:20748 9.474:.476:00.39.7*5.03970:3.7482:9548/06:0..   %#$708$# .   8:2   3:2   3:2   $##U2074 #3:2 $##U20742. 25727 .390747 %#$3:23:2# #3:2 %#$ 3:2 3:2  %#$3:23:2 # $3:239 3:2.

  8:2 8:2 3:2 .  % $ $##3:2 . .

08 $##8:2 708 85.. $##$:8:2.8070/03U20748 $.48   %#$708$708# $## 97.$ 3:2 3:2  %#$ $##U2074/02U9548/0 $##.

086:0.  #708 708 43.48   ..806:03974/:.70.:.07:3580:/4.80 85...17.8 708  %#$ %#$ !# #     ./.0:3.03:3.0.5. % #  17./090723.. 097.4/46:0.7024854790.U8.8.48    097. 85.0797*2./4   !# #097.:0390.

.   708 $  #%  %#$708$# 477.097.439:/   .80 $##08/0 $##.39. $##03.5.80 439:/ .   $##3974/:.   $##3U2074/0.  $    %#$ 477.80 #17. $##097.086:0. .80    $##097.17.0.80 $##17.7*439:/ 17.0.7*5..7...17.70.80   % $ .. .907 17.7 #097.0:3.-:8...39.7*5. %#$439:/# $097.

:90817.708 85..72 .3974/:.48   %#$708$708# $##080..808 $..

8 708  %#$ %#$ !# #     .8 . 6:050729.0797*2.8 #47.U8.43.:.  #708 708 43.   !# #704 % #  47.39.5430740347.   $##47.07:3580:/4.7*5.4/46:082:00 1:3.20394/0:3704/9..8   23:948   80:3/48   708 $  #%  477..

8 47.$##3:948 #23:948 $##$0:3/48 #80:3/48 %#$708$# %#$47.8  23:948   %#$ 47.8# %#$23:948 # %#$80:3/48 # $##47.8   %#$ !# #    .8 $##23:948 $##80:3/48 80:3/48 80:3/48  %#$ 23:948 23:948  80:3/48   %#$ 47.

8 %#$ !# #  $&!# #.  $##U2074 #3:2074 $3:2074 % $ $##490301. 3:2074 3:2074 3:2074  %#$ ... .701.8   !# #1.7*5. $  #..39.2.947..:48 %#$3:2074# 1...947.:. 1..:48 $ #../0:33:2074 20/. % #  708 $  #%  %#$708$# 477.   1.947..3908:-5747.947..947.947.

72 .#25727 $&!# #  $&!# #..:9081..8 708  %#$708$708# $##080.08 $....:.947..

. $&!# #          ..947.U8.08 $##1.:.  #708 708 43.8 708  %#$ $&!# #  $&!# #25727 $##$:1.947.0797*2.

 % #  5.07:35747..39.         .7 25.3/4:389.7  8  $  5.   %#$ # $8 % $ 25.8:2.2.6:0.7*5.   !# #8:2./0485.7   25.7 5.:03/0503/039020390..708 4825.7  .708/0483:2074803970 :9.7   8      #%  477...

...25708437/085.974.3.7 !# #   %  !708039.70808 $##25..:.08031.80 85.8    3974/:.39.8054790.4380.07.7:3.48     #%  477./0485.7 $##.:9..17..   !# #17.8:2.8.80 % #  17.-0.7*5.8 5074.4:23..././...43035.8 ..39..0. /070..70808 $##5../4 25727.8   $    %#$ $##..   ..8:2.4./04825.

08  ..0. 843 . $##7.80 .08   %#$.4  1 1  %#$ !# #     .08 .39.0.    #%  477.8.7*5.08# 1 .4  .8.     $##483U20748/0 .0.80  #17.4 .0.43974.4$##17. .3/4 .07:3580:/4. 483U20748/0 .8   !# #3:20748 % #  .80 1  ..4:23.4/46:02572.81.

4  $ %#$ !# #     42574-. .4% $ 1 1  .4 ./085724   !# #5724 % #  708 $  #%  %#$708$# 477. .   3:2074   8   .  .4  %#$.39.474:.1  . # 1 .4  $.:3/..7*5.6:0.78:33:20742.4$##.

%#$3:2074#   $##U2074  #3:2074 %#$  3:2074  %#$8# $3:207439 3:2074.

  % $ 8 $     $ %#$ $8% $   $##34085724 $    $##8 085724 $ #.3974/:.7283U20748 $.8 708  %#$708$708# $##080.8 %#$ !# #  $&!# #.

  .

7:33:207420347/0 5.:8.4  %#$3:2 #  .4 .34   !# #742.39.3:2074742.4$## 3:2 3:2   .8 708  %#$ $&!# #     3974/:.8.   3:2   %#$3:2 3:2 #   $##U2074  $##3:2 %#$ .#708 708 43.7*5.74.34 % #  708 $  #%  %#$708$# 477.4  ..0797*2.:.

4 .4 .4  $ %#$3:2 #  .4 .%#$ $3:2 % $  .4  %#$ $3:2 % $  .4  $ $3:2 % $  .4$## 3:2 3:2   .4$## 3:2 3:2   .4$## 3:2 3:2   .4 .4$## 3:2 3:2   .4 .4$## 3:2 3:2   .4  $ $3:2 % $  .4  .

4 .4$## 3:2 3:2  .4 .4 .4 .$ $3:2 % $  .4  $ $3:2% $  .4$## 3:2 3:2   .4$##' 3:2 3:2  .4  $ $3:2% $  .4  .4  %#$ $3:2% $  .4  $ %#$3:2 #  .4$## 3:2 3:2   .4 .4$##' 3:2 3:2  .

7283U20748 $.4  %#$ #.4 .3974/:.8 %#$ !# #  $&!# #.8 708  %#$708$708# $##080.$ %#$3:2 #  .4$## 3:2 3:2  .

03974/0.03974 % #  .8 708  %#$ $&!# #     3974/:.8054790.39.   !# #.  #708 708 43.17../4 25727.:8..7:3.0797*2.:.5.030.

   $##7.80 85.48     #%  %#$708$# 477.80 .7*5.80    39 439:/ 17.39..708 $ 17.80  #17..

80 #.7.-.-. % #  3:2    #%  #:2074 477..7/0:33:207403970    !# #9. $##17.39.-./02:95./02:95..8 %#$ !# #     #0...9.7*5.7/03U2074   #3:2    .     $##%.

1  %#$ # 1 $##3:2 1 $##  1 $## 1 $## 1 $##3:2  1 1     %#$ !# #  $&!# #:2074 %#$3:2 # 477.39.7*5.    $##U2074  #3:2 %#$ $&!# #   %  :20748.0.94748203:8  ..

 % #  708 $  #%  %#$708$# 477.7..8 708 85.48   %#$708$708#   $##8.7:   !# #2430/.. 4.7.70.700257278.8 %#$ !# #  $&!# #.203948 $./4.3.3.  $2:.   $#3/   % $  $##.7*5.39.20394/0:3.2430/.8... $   $##7: $ #..

8 708  .:8.0797*2.   #708 708 43.:.

8.8. !# #   .       #%  477.0397.7*5./..0.   %#$ # $39 #3/     39 #3/      % $ ./48.  $    %#$   $##./4 % #  .086:00397048/48 8:2.086:08:2.7.3   !# #/.%#$ $&!# #     $2:.0.8/0/48/.3 843  $##. .7.439.39.

48   ./ /0.4$##85.4$##/-:4 $ %#$   $##.43U2074  .7*5..  $2:..7707.3.4.4   ./47080..574-.:349030:..4$##/-:4 $   .-.4$##/-:4 %#$..48 % #  /-:4  .4   .-.-/.4  .    ../0/48../.7:3.4 .-.3.4   #%  477.4 .39.7   !# #.4$##85.4$##/-:4  ...488.48   .4# $#3/   % $  .

7*5.4308  $## $:2.7/4832074854790.:08:8:2.. 8: 7089.$.4% $  $## $   $## $ !# #     3974/:..4348:/... 8:2:95.390:3203: ./420/..     $##03U/045.39. ..843   !# #203: % #  45    #%    $##U2074  #3   $##U2074  #3 %#$45# 45   477.

 $## #089.   $ 45   $##$:2:95.   $ 45   $##$:/.T3  $## ..  $##.  $## :95.T3  #45 477...:8.:8..08  $##3 3 !.7*5.   $ 45   $##$:7089.2.   #$  $ 45   $##$:8:2.T308  $##3 3 !.:8.39.8T308  $##3..08  $##3 3 !.45.7/05747.8T3  $## $.

:8.3 !.   $  .

2.  $##..4257278:9.42574-./02:95.-.7/05747..88:039084507..78085724  $## .4308  $## 42574-.45...-./02:95.%#$ !# #     .6:034850729.7*5.39.2.947..947..7  $## $.78085724 .     $##03U/045.7:33:207454790...78:1..T3  #45 .07:35747..4308.7 8:1./484-70 08070.7   !# #203: % #  45    #%    $##U2074  #3 %#$45# 45   477.03.3974/:.  $## %.

 $  %#$ !# #  $&!# #!724 8    3  %#$8# $339 3.. $ 45 #%.-.947.#$  $ 45 #!724 $ 45 #.

7*5.  % $ 8  $     $ %#$ 477.39..   $8% $   $##34085724 $  .

39.7*5.   . 1. $  %#$3# 1.  477.947.. 3 3 3  %#$   $##$:1.   $3 % $   $##490301.  $##8 085724 $ !.:8.:8.-. 1. $ !..    1   477..39.7*5..08  $##1....   $&!# #  $&!# #.947..947.   $&!# #  $&!# #%..

 /8939.43342-708/0507843..   !# #342-708 % #  $ /.1./02:95./.:8.948 ( .08    70./0-03/47..8:3/203843.7:3.   $&!# #   %  77.-.89..77.7 1  $##3 1 $##  1  $## 1 $## 1  $##3     %#$ !.:3/203843.8  '8:.74800203948/0./0 00203948.:3403:3.%#$ #   $##%.

.83.:002572.07:35747.9:7.4308/0:3.39.2..1.   #%  477.39.2.8.     1    $##0203948/0.8 .   ..89.947..03003:3...8:20/.0..948(    %#$ 477.948( 1 1     %#$ !# #     .7*5.6:00.7*5. %#$# 1 $##/..:23403  ..   1   %#$# 1  $##42-70 1 #/..8.

8 ( 8:2..    #%  477.20/.39. 1  $## 1 $## 1 #349. 8:2.7*5.   20/. 349. % #  $ 349.8( 1 1  !# !#$$% # 8:2. 8:2.   1  !#$$% # 1 $##49.8( !# 20/..!# #349.

20/.  $##20/. !# #    .    $##49.

349.3/4080:3/400254 .39. 4. $ !# #  .349.... &8.   $##49.947   !# #-:8.7*5.-:8.4397.7 #3:2 %##    $349.030 ..8(3:2  % $ $# $ %## $349.6:0-:86:0:3.0.07:35747./403548...8(3:2% $ $##3.2.7 % #     3:2    #%  477.:903 $## $  $##4089008.

8-/203843.9474803970  025727.0.   !# #2.08    0307.97/01.4:23.97 % #  $ # (   1   .433:20748.8.7:3.2.4   .  %  77.8.

Sign up to vote on this title
UsefulNot useful