Apuntes de Excel

BUSCARV (V significa busca en vertical)

Año 2009

Busca un valor específico en la primera columna de una matriz de tabla y devuelve, en la misma fila, un valor de otra columna de dicha matriz de tabla.

SINTAXIS
BUSCARV(valor_buscado;matriz_buscar_en;indicador_columnas;ordenado) Puede ser que en vez de ; figure , para la separación de lista, esto depende de la configuración de la computadora. Valor buscado: Valor que se va a buscar en la primera columna de la matriz seleccionada. El Valor buscado puede ser un número o una celda que tenga un número, texto o fórmula que me dé un número como resultado. Matriz buscar en: la matriz son Dos o más columnas con varias filas. En los valores de la primera columna de la matriz es donde busca el valor buscado. Estos valores pueden ser texto, números o valores lógicos. Las mayúsculas y minúsculas del texto son equivalentes. Matriz: es la selección de columnas y filas, la matriz puede estar o no en la misma hoja pero si en el mismo libro (libro es el archivo que contiene varias hojas). La selección de la matriz se realiza posicionando el marcador sobre la primera celda y con clic sostenido hasta la última celda a seleccionar.

Indicador columnas: Número de columna de la matriz que debe devolverse de la fila en el valor coincidente con el buscado. Si el argumento indicador columnas es igual a 1, la función devuelve el valor de la primera columna de la matriz; si el argumento indicador columnas es igual a 2, devuelve el valor de la segunda columna de la matriz y así sucesivamente. Si indicador columnas es:   Si es inferior a 1, BUSCARV devuelve al valor de error #VALUE! Si es superior al número de columnas de la matriz, BUSCARV devuelve el valor de error #REF! Si se omite o es VERDADERO, se devolverá una coincidencia exacta o aproximada. Si no localiza ninguna coincidencia exacta, devolverá el siguiente valor más alto inferior a valor buscado.  Si es FALSO, BUSCARV sólo buscará una coincidencia exacta. Si hay dos o más valores en la primera columna de la matriz, se utilizará el primer valor encontrado. Si no se encuentra una coincidencia exacta, se devolverá el valor de error #N/A.

Ordenado Valor lógico que especifica si BUSCARV va a buscar una coincidencia exacta o aproximada: 

Ejemplo con numeros:
Se busca en la columna Densidad de una tabla de propiedades atmosféricas los valores correspondientes de las columnas Viscosidad y Temperatura (los valores se refieren a aire a 0 grados Celsius al nivel del mar, o 1 atmósfera).

A Densidad 0,457 0,525

B Viscosidad 3,55 3,25

C Temperatura 500 400

1

Apuntes de Excel
0,616 0,675 0,746 0,835 0,946 1,09 1,29 2,93 2,75 2,57 2,38 2,17 1,95 1,71 300 250 200 150 100 50 0

Año 2009

=BUSCARV(1;A2:C10;2) Utilizando una coincidencia aproximada, busca el valor 1 en la columna A, busca el mayor de los valores que sea inferior o igual a 1 en la columna A, que es 0.946, y después devuelve el valor de la columna B en la misma fila (2,17). =BUSCARV(1;A2:C10;3;VERDADERO) Utilizando una coincidencia aproximada, busca el valor 1 en la columna A, busca el mayor de los valores que sea inferior o igual a 1 en la columna A, que es 0.946, y después devuelve el valor de la columna C en la misma fila (100). =BUSCARV(0,7;A2:C10;3;FALSO) Utilizando una coincidencia exacta, busca el valor 0,7 en la columna A. Como en la columna A no hay ninguna coincidencia exacta, devuelve un error (#N/A) =BUSCARV(0,1;A2:C10;2;VERDADERO) Utilizando una coincidencia aproximada, busca el valor 0,1 en la columna A. Como 0,1 es inferior al menor de los valores de la columna A, se devuelve un error (#N/A). =BUSCARV(2;A2:C10;2;VERDADERO) Utilizando una coincidencia aproximada, busca el valor 2 en la columna A, busca el mayor de los valores que sea inferior o igual a 2 en la columna A, que es 1,29, y después devuelve el valor de la columna B en la misma fila (1,71).

Ejemplo con textos:
Se buscan valores en la columna Id. de artículo de una tabla de productos para bebés y se les asignan los valores correspondientes de las columnas Costo y Marcas para calcular los precios y las condiciones de prueba.

A Id. de artículo ST-340 BI-567

B Artículo Cochecito Babero

C Costo 145,67 $ 3,56 $

D Marcas 30% 40%

2

Apuntes de Excel
DI-328 WI-989 AS-469 Pañales Toallitas Aspirador 21,45 $ 5,12 $ 2,56 $

Año 2009
35% 40% 45%

= BUSCARV("DI-328", A2:D6, 3, FALSO) * (1 + BUSCARV("DI-328", A2:D6, 4, FALSO)) Calcula el precio minorista de los pañales agregando el porcentaje marcado al costo, busca el id y obtiene la columna 3 21,45$ y lo multiplica buscando el id y obteniendo el % de aplicación al costo 35%  21.45$*(1+0.35)=$28,96 = (BUSCARV("WI-989", A2:D6, 3, FALSO) * (1 + BUSCARV("WI-989", A2:D6, 4, FALSO))) * (1 20%) Calcula el precio de venta de las toallitas restando un descuento especificado al precio minorista, busca el id y obtiene la columna 3 5,12$ y lo multiplica buscando el id y obteniendo el % de aplicación al costo 40% y luego le aplica un decuento del 20%  5.12*(1+0.4)*(1-20%) = $5,73 = SI(BUSCARV(A2, A2:D6, 3, FALSO) >= 20, "La marca es " & BUSCARV(A2, A2:D6, 4, FALSO), "El costo es inferior a 20,00 $") Si el costo de un artículo es superior o igual a 20,00$, busca la marca y da "La marca es nn%"; en caso contrario, muestra "El costo es inferior a $20,00". La “texto”& esta combinación puede darse para cuando se quiere escribir un texto antes o después del valor buscado.

SI
Devuelve un valor si la condición especificada es VERDADERO y otro valor si dicho argumento es FALSO. Utilice SI para realizar pruebas condicionales en valores y fórmulas.

Sintaxis
SI(prueba_lógica;valor_si_verdadero;valor_si_falso) Prueba lógica: es cualquier valor o expresión que pueda evaluarse como VERDADERO o FALSO. Por ejemplo, A10=100 es una expresión lógica; si el valor de la celda A10 es igual a 100, la expresión se evalúa como VERDADERO. De lo contrario, se evaluará como FALSO. Este argumento puede utilizar cualquier operador de comparación. Valor si verdadero : es el valor que se devuelve si el argumento prueba lógica es VERDADERO. Por ejemplo, si el argumento es A1>100 y A1=105 eso es verdadero entonces se devolverá lo requerido para el caso de que sea verdadero, por ejemplo si A1>100 entonces la celda vale el mismo valor que A1 Valor si falso: es el valor que se devuelve si el argumento prueba lógica es FALSO. Por ejemplo, si el argumento es A1>100 y A1=105 eso es falso entonces se devolverá lo requerido para el caso de que sea falso, por ejemplo si A1<100 entonces la celda vale 0

A Gastos reales 1500 500 500

B Gastos previstos 900 900 925

C Analisis (1) (2)

(1)=SI(A2>B2;"Presupuesto excedido";"Aceptar Presupuesto")

3

Apuntes de Excel

Año 2009

Comprueba si la primera fila sobrepasa el presupuesto (Presupuesto excedido), o sea, la celda C2 dara como resultado el texto que se escribió entre comillas Presupuesto excedido (2)=SI(A3>B3;"Presupuesto excedido";"Aceptar Presupuesto") Comprueba si la segunda fila sobrepasa el presupuesto (Aceptar Presupuesto), o sea, la celda C3 dara como resultado el texto que se escribió entre comillas Aceptar Presupuesto

SUMA
Suma todos los números de un rango.

Sintaxis
SUMA(número1;número2; ...) Número1;número2;... Observaciones Se tienen en cuenta los números, valores lógicos y representaciones textuales de números que se escriban directamente en la lista de argumentos. Vea los dos primeros ejemplos. Si un argumento es una matriz o una referencia, sólo se considerarán los números de esa matriz o referencia. Se pasarán por alto las celdas vacías, los valores lógicos o el texto contenidos en la matriz o en la referencia. Vea el tercer ejemplo a continuación. Los argumentos que sean valores de error o texto que no se pueda traducir a números provocan errores. son de 1 a 255 argumentos cuyo valor total o suma desea obtener. Los números pueden ser números aislados, columnas de varias filas, etc.

A 1 2 3 4 5 6 Datos -5 15 30 5 A6

Los posibles resultados de la celda A6 =SUMA(A2:A4) Suma las tres primeros números = -5+15+30=40 =SUMA(A2:A4;15) Suma los tres primeros números y el valor 15 = -5+15+30+15=55 =SUMA(A4;A5;2) Suma los valores de las filas A4 y A5 y el valor 2. Puesto que los valores no numéricos de las referencias no se traducen = 30+5+2=37

4