You are on page 1of 5

Ejemplo1: 1.

- realizar el pseudocodigo y el programa que ingrese desde el teclado la base y la altura de un triangulo y luego calcule e imprima su rea correspondiente. ALGORITMO TRIANGULO VAR REAL: B, H, A INICIO ESCRIBIR ( INGRESE LA BASE ) LEER (B) ESCRIBIR ( INGRESE LA ALTURA ) LEER (H) A B*H/2 ESCRIBIR ( EL AREA DEL TRIANGULO DE BASE ,B, Y DE ALTURA ,H, ES ,A) FIN

Ejemplo 3 Realizar el Pseudocdigo y el programa que ingrese las notas del examen parcial, examen final, y promedio de prcticas de un alumno con peso 2,3y4 respectivamente, se pide calcular e imprimir su promedio final ALGORITMO NOTAS CONST PEP=2 PEF=3 PPP=4 VAR ENTERO: EP, EF, PP REAL: PF INICIO ESCRIBIR( INGRESE LA NOTA DEL EXAMEN PARCIAL ) LEER(EP) ESCRIBIR( INGRESE LA NOTA DEL EXAMEN FINAL ) LEER(EF) ESCRIBIR( INGRESE LA NOTAS DEL PROM. PRACTICA ) LEER(PP) PF (PEP*EP+PEF*EF+PPP*PP)/(PEP+PEF+PPP) ESCRIBIR( EL PROMEDIO FINAL ES ,PF) FIN #include<iostream.h> #include<conio.h> #define pep 2 #define pef 3 #define ppp 4 void main() { int ep, ef,pp; float pf;

#include<iostream.h> #include<conio.h> void main() { float B,H,A; cout<<"INGRESE LA BASE"; cin>>B; cout<<"INGRESE LA ALTURA"; cin>>H; A= B*H/2; cout<<"EL AREA DEL TRIANGULO ES " <<A<<endl; }
Ejemplo 2. Realizar el seudocdigo y el programa que ingrese los precios unitarios y cantidades 3 artculos diferentes que un cliente ha adquirido en una tienda, se pide calcular e imprimir el importe a paga por el cliente as como el vuelto que ha de recibir. ALGORITMO ARTCULO VAR REAL: P1, P2, P3, C1, C2, C3, IP, EF, V INICIO ESCRIBIR ( INGRESE PRECIO Y CANTIDAD DEL ARTICULO 1 ) LEER (P1, C1) ESCRIBIR ( INGRESE PRECIO Y CANTIDAD DEL ARTICULO 2 ) LEER (P2, C2) ESCRIBIR ( INGRESE PRECIO Y CANTIDAD DEL ARTICULO 3 ) LEER (P3, C3) IP P1*C1+P2*C2+P3*C3 ESCRIBIR ( EL IMPORTE A PAGAR ES , IP ) ESCRIBIR ( INGRESE EL EFECTIVO CON EL QUE PAGA AL CLIENTE ) LEER (EF) V EF- IP ESCRIBIR ( EL VUELTO ES , V) FIN

#include<iostream.h> #include<conio.h> #define pep 2 #define pef 3 #define ppp 4 void main() { int ep, ef,pp,PF; cout<<"INGRESE LA NOTA DEL EXAMEN PARCIAL" ; cin>>ep; cout<<"INGRESE LA NOTA DEL EXAMEN FINAL" ; cin>>ef; cout<<"INGRESE LA NOTA DEL PROMEDIO DE PRACTICA"; cin>>pp; PF=(ep*pep + ef*pef + pp*ppp)/(pep + pef + ppp); cout<<"EL PROMEDIO FINAL ES" <<PF<<endl; }

#include <iostream.h> #include <conio.h> void main() { float P1, P2, P3, C1, C2, C3, IP, EF, V; cout<<"INGRESE PRECIO Y CANTIDAD DEL ARTICULO 1"; cin>>P1>>C1; cout<<"INGRESE PRECIO Y CANTIDAD DEL ARTICULO 2"; cin>>P2>>C2; cout<<"INGRESE PRECIO Y CANTIDAD DEL ARTICULO 3"; cin>>P3>>C3; IP= P1*C1+P2*C2+P3*C3; cout<<"EL IMPORTE A PAGAR ES " <<IP<<endl; cout<<"INGRESE EL EFECTIVO CON EL QUE PAGA AL CLIENTE"; cin>>EF; V=EF- IP; cout<<"EL VUELTO ES"<<V<<endl;
}

Ejemplo 4. Realizar el pseudocodigo y el programa que ingrese desde el teclado el monto de las ventas, costo de ventas y gastos administrativos de dos empresas. Se pide calcular e imprimir su utilidad bruta y su utilidad neta de cada una de ellas. ALGORITMO VENTAS VAR REAL:V,CV,GA,UB,UN; INICIO ESCRIBIR ( INGRESE MONTOS DE VENTA ) LEER (V) ESCRIBIR ( INGRESE COSTO DE VENTAS ) LEER (CV) ESCRIBIR ( INGRESE GASTOS ADMINISTRATIVO ) LEER (GA) UB V-CV-GA; ESCRIBIR ( LA UTILIDAD BRUTA ES ,UB) UN UB- UB*19/100 ESCRIBIR ( LA UTILIDAD NETA ES ,UN) UB VENTA COSTOS VENTAS UN UB- UB*19/100 FIN GASTOS ADMINSTRATIVOS

Realizar el pseudocodigo, diagrama de flujo de datos y el programa que ingrese el sueldo bsico, bonificacin y descuento de un trabajador. se pide calcular e imprimir el sueldo neto antes de aumento y despues de aumento. si se sabe que hay un aumento del 10% del sueldo basico para aquellos trabajadores cuyo sueldo neto sea menor de 1500 nuevos soles. ALGORITMO SUELDO CONST PA=0.10 VAR REAL: SB, BON, DES, SNAA, SNDA, A INICIO ESCRIBIR( INGRESE SUELDO BASICO, BONIFICACION Y DESCUENTO ) LEER(SB,BON,DES) SNAA SB + BON DES ESCRIBIR( EL SUELDO NETO ANTES DE AUMENTO ES ,SNAA) SI SNAA<1500 ENTONCES A SB*PA SINO A 0 FIN_SI SNDA SNAA + A ESCRIBIR( EL SUELDO NETO DESPUES DE AUMENTO ES ,SNDA) FIN #include<iostream.h> #include<conio.h> #define pa 0.1 void main() { float sb, bon, des, snaa, snda, a; cout<<"Ingrese sueldo basico, bonificacion y descuento "; cin>>sb>>bon>>des; snaa=sb + bon - des; cout<<"El sueldo neto antes aumento es "<<snaa<<endl; if (snaa<1500) { a= sb*pa; } else { a=0; } snda= snaa + a; cout<<"El sueldo neto despues de aumento es "<<snda<<endl; } ALGORITMO SUELDO CONST PA=0.1 VAR REAL: SB, BON, DES, SNAA, SNDA, A

#include<iostream.h> #include<conio.h> void main() { float V1,V2,CV1,CV2,GA1,GA2,UB1,UB2,UN1,UN2; cout<<"ingrese montos de ventas de las empresas 1 y 2"; cin>>V1>>V2; cout<<"ingrese costo de ventas de las empresas 1 y 2"; cin>>CV1>>CV2; cout<<"ingrese gastos administrativo de las empresas 1 y 2"; cin>>GA1>>GA2; UB1=V1-CV1-GA1; UB2=V2-CV2-GA2; cout<<"la utilidad bruta de las empresas es"<<UB1<<UB2<<endl; UN1=UB1-UB1*19/100; UN2=UB2-UB2*19/100; cout<<"la utilidad neta de las empresas 1 y 2 es"<<UN1<<UN2; }
Ejemplo: Realizar el pseudocodigo y diagrama de flujo de datos que ingrese la base y la altura de un triangulo. Se pide calcu lar e imprimir el rea correspondiente. ALGORITMOS TRIANGULO VAR REAL: B, H, A INICIO ESCRIBIR( INGRESE LA BASE ) LEER(B) ESCRIBIR( INGRESE LA ALTURA ) LEER(H) A B*H/2 ESCRIBIR( EL AREA DEL TRIANGULO ES ,A) FIN ALGORITMO TRIANGULO VAR REAL: B, H, A ALGORITMO SUELDO VAR REAL: SB, BON, DES, SN Ejemplo 5:

Ejercicio: Realizar el pseudocdigo, diagrama de flujo de datos y el programa que ingrese los precios unitarios y cantidades de 2 artculos diferentes que un cliente ha adquirido en una tienda. Se pide calcular el importe a pagar si se sabe que hay un descuento del 20% si el importe supera los 1000 nuevos soles, del 15% si el importe esta en el rango de 500 a menos de 1000 nuevo soles y del 10% si el importe esta en el rango de 100 a menos de 500 nuevos soles. ALGORITMO PRECIOS CONST D1 = 0.20 D2 = 0.15 D3 = 0.10 VAR REAL: PC1, PC2, C1, C2, PG; INICIO ESCRIBIR ( INGRESE PRECIO Y CANTIDAD DEL ARTICULO 1 ) LEER (PC1, C1) ESCRIBIR ( INGRESE PRECIO Y CANTIDAD DEL ARTICULO 2 ) LEER (PC2, C2) ALGORITMO : PERSONA VAR ENTERO : EDAD INICIO ESCRIBIR ( INGRESE LA EDAD ) LEER (EDAD) SI EDAD >=0 Y EDAD <=5 ENTONCES ESCRIBIR ( INFANTE ) SINO SI EDAD >=6 Y EDAD <= 12 ENTONCES ESCRIBIR ( INO ) SINO SI EDAD >=13 Y EDAD <=20 ENTONCES ESCRIBIR ( ADOLECENTE ) SINO SI EDAD >=21 Y EDAD >=30 ENTONCES ESCRIBIR ( JOVEN ) SINO SI EDAD >=31 Y EDAD >=70 ENTONCES ESCRIBIR ( ADULTO ) SINO ESCRIBIR ( ADULTO MAYOR ) FIN_SI FIN_SI FIN_SI FIN_SI FIN_SI FIN 10-02-11 Bucles EJERCICIO 1: REALIZAR EL PSEUDOCODICO DIAGRAMA DE FLUJO DE DATOS Y EL PROGRAMA QUE INGRESE SU NOMBRE LOS REPITA MIL VECES EN LA PANTALLA ENUMERANDO CADA LINEA ALGORITMO NOMBRES VAR: ENTERO :I CADENA: NOM INICIO ESCRIBIR( INGRESE SU NOMBRE ) LEER(NOM) DESDE I 1 A 1000 HACER ESCRIBIR (, .- ,NOM) FIN DESDE FIN #include <iostream.h> #include <conio.h> void main () { int i; char nom[10]; cout<<"ingrese su nombre: "; cin>>nom;

for (i=1;i<=1000;i++) { cout<<i<<".-"<<nom<<endl<<endl; } } BUCLE MIENTRAS ALGORITMO NOMBRES VAR: ENTERO :I CADENA: NOM INICIO ESCRIBIR( INGRESE SU NOMBRE ) LEER(NOM) I 1 MIENTRAS I<=1000 HACER ESCRIBIR (, .- ,NOM) I I+1 FIN MIENTRAS FIN #include <iostream.h> #include <conio.h> void main () { int i; char nom[10]; cout<<"ingrese su nombre: "; cin>>nom; i=1; while (i<=1000) { cout<<i<<".-"<<nom<<endl<<endl; i++; } } BUCLE REPITIR MIENTRAS ALGORITMO NOMBRES VAR: ENTERO :I CADENA: NOM INICIO ESCRIBIR( INGRESE SU NOMBRE ) LEER(NOM) I 1 REPETIR ESCRIBIR (, .- ,NOM) I I+1 MIENTRAS I<=1000 FIN #include <iostream.h> #include <conio.h> void main () { int i; char nom[10]; cout<<"ingrese su nombre: "; cin>>nom; i=1; do { cout<<i<<".-"<<nom<<endl<<endl; i++; } while (i<=1000); } EJERCICIO 2: REALIZAR EL PSEUDOCODEIGO DIAGRAMA DE FLUJO DE DATOS Y EL PROGRAMA QUE INGRESE DESDE EL TECLADO N NMEROS ENTEROS Y LUEGO CALCULE E IMPRIMA LA SUMA Y EL PROMEDIO DE LOS NMEROS INGRESADOS ALGORITMO NUMEROS VAR: ENTERO: N,I,NUM ,SUM; REAL:PROM INICIO

ESCRIBIR( INGRESE CANTIDAD DE NUMEROS ) LEER(N) SUM O DESDE I 1 A N HACER ESCRIBIR( INGRESE NUMERO ) LEER(NUM) SUM SUM+NUM FIN DESDE PROM SUM/N ESCRIBIR ( LA SUMA DE LOS NUMEROS ES ,SUM) ESCRIBIR ( EL PROMEDIO DE LOS NUMEROS ES ,PROM) FIN

{ X=X/10; CANTCIF++; } cout<<"la cantidad de cifras de "<<NUM<<" es "<<CANTCIF<<endl; } }

Realiza en programa que ingrese n nmeros enteros se pide calcular e imprimir cuantos nmeros mltiplos de 3 y de 7 a la vez se han ingresado. Algoritmo mltiplos Var Entero: n, i , num, cantmult; Inicio Escribir( ingrse la cantidad de numeros ) Leer(n) Cantmult=0 Desde i=1 a n hacer Escribir( ingrese numero ) Leer(num) Si num mod 3=0 y num mod7=0 entonces Cantmult=cantimult+1 Fin_si Fin_desde Escribir( la cantidad de mltiplos de 3 y 7 a la vez es cantmult ) Fin

#include <iostream.h> #include <conio.h> void main () { int N, I ,NUM,SUM; float prom; cout<<"ingrese cantidad de numeros:"; cin>>N; SUM=0 for (i=1;i=N;i++) { cout<<"ingrese numero"; cin>>SUM; SUM=SUM+NUM; } PROM=SUM/N; cout<<"la suma de lo snumeros es: "<<SUM<<endl; cout<<"el promedio de los numeros es: "<<PROM<<endl; } 17/02/2011 Realizar en pseudocogio D F y en programa que ingr ese n nmeros enteros y luego calcule e imprima la cantidad de cifras que tiene cada numero ingresado. Algoritmo numero VAR ENTERO: N, I, NUM, CANTCIF, X INICIO ESCRIBIR( INGRESE LA CANTIDAD DE NUMEROS ) LEER(N) DESDE I 1 A N HACER ESCRIBIR( INGRESE NUMERO ) LEER(NUM) X NUM CANTCIF 0 MIENTRAS X>0 HACER X X DIV 10 CANTCIF CANTCIF+1 FIN_MIENTRAS ESCRIBIR( LA CANTIDAD DE CIFRAS DE ,NUM, ES CANTCIF ) FIN_DESDE FIN

#include<iostream.h> #include<conio.h> void main() { int n, i, num, cantmult=0; cout<<"ingrese la cantidad de numeros: "; cin>>n; for (i=1;i<=n;i++) { cout<<"ingrese numero: "; cin>>num; if (num % 3==0 && num % 7==0) { cantmult++; } } cout<<"la cantidad de multiplos de 3 y 7 a la vez es: "<<cantmult<<endl; }

#include<iostream.h> #include<conio.h> void main() { int N, I, NUM, CANTCIF, X; cout<<"ingrese la cantidad de numeros: "; cin>>N; for (I=1;I<=N;I++) { cout<<"ingrese numero: "; cin>>NUM; X=NUM; CANTCIF=0; while(X>0)

Escribir en pseudocidigo df y elprograma que ingrese los datos de n alumnos de un colegio: cdigo, ex parcial, examen final y promedio de practicas y sexo se pide calcular e imprimr : a.- el promedio final de cada alumno b.- la nota mas alta obtenida c.- la nota mas baja obtenida d.- el promedio por sexo algoritmo colegio var entero n, i, cadena: cod real:ep. ef, pp, pa, pf, max, min, psf, psm, sumf, summ, ch, cm carcter sex inicio escribir( ingrese cantidad de alumnos ) leer(n) desde i=1 a n hacer escribir( ingrese coigo ) leer(cod) escribir( ingreso sexo ) leer(sex) escribir( ingrese examen parcial ) leer (ep) escribir( ingrese examen final ) leer(ef) escribir( ingrese peromedio de practica ) leer(pp) pf=(ep+ef+pp)/3 escribir( el promedio de practica del amlumno es pf ) si pf>max entonces max=pf fin_si si pf=min entonces min=pf fin_si si sex=f entonces sum=sumf+pf ch=ch+1 fin_si fin_desde si cm>0 entonces psf=sumf/cm escribir( ) Realzar el prog que ingrese n nmeros entros y luego calcule e imoprima la cantidad de cifras que tiene cada numero ingresado. Algoritmo nmeros Var Entero: n, i, num, cantcif Inicio Escribir( ingrese cantidad de numeros ) Leer(n) Desde i 1 a n hacer Escribir( ingrese numero ) Leer(num) Cantcif 0 Mientras num >0 hacer Num num div 10 Cantcif cancif + 1 Fin_mientras Escribir( la cantidad de cifras es ,cantcif) Fin_desde fin

cin>>n; for(i=1;i<=n;i++) { cout<<"ingrese numero: "; cin>>num; cantcif=0; while(num>0) { num=num/10; cantcif=cantcif + 1; } cout<<"la cantidad de cifras es:"<<cantcif<<endl; } } Realizar en pseudocdigo y en programa que ingrese n nmeros enteros, se pide calcular e imprimir la cantidad de nmeros primos ingresados.

ALGORITMO PRIMOS VAR ENTERO: N, I, NUM, CANTPRIM,CONTDIV,J INICIO ESCRIBIR( INGRESE CANTIDAD DE NUMEROS ) LEER(N) CANTPRIM 0 DESDE I 1 A N HACER ESCRIBIR( INGRESE NUMERO ) LEER(NUM) CONTDIV 0 DESDE J 1 A NUM HACER SI NUM MOD J =0 ENTONCES CONDIV CONTDIV+1 FIN_SI FIN__DESDE SI CONTDIV=2 ENTONCES ESCRIBIR( PRIMO= ,NUM) CANTPRIM CANTPRIM+1 FIN_SI FIN_DESDE ESCRIBIR( LA CANTIDAD DE PRIMOS ES ,CANTPRIM) FIN
#include<iostream.h> #include<conio.h> void main() { int n, i, num, cantprim, contdiv, j; cout<<"ingrese la cantidad de numeros: "; cin>>n; cantprim=0; for (i=1;i<=n;i++) { cout<<"ingrese el numero :"; cin>>num; contdiv=0; do (j=1) if(num%j=0) { condiv=contdiv+1; } } if (contdiv=2) { cout>>"primo">>num>>endl; cantprim=cantprim+1 } } cout<<"la cantisdad de primos es: "<<cantprim<<endl; }

#include<iostream.h> #include<conio.h> void main() { int n, i, num, cantcif; cout<<"ingrese la cantidad de numeros: ";