Oracle Applications Installation and Upgrade Notes for Linux x86-64(64-bit) Release 12 (12.1.

1)

Page 1 of 18

Oracle E-Business Suite Installation and Upgrade Notes Release 12 (12.1.1) for Linux x86-64 [ID 761566.1] Modified 02-DEC-2010 Type BULLETIN Status PUBLISHED

Oracle® E-Business Suite Installation and Upgrade Notes
Release 12 (12.1.1) for Linux x86-64 December 2010 See Change Record

This document updates the following documentation with Linux x86-64-specific information for Oracle E-Business Suite (EBS) Release 12 (12.1.1). Refer to the information conta manual when you install or upgrade your system. • Oracle E-Business Suite Installation Guide: Using Rapid Install (which is supplemented by Oracle Applications Release Notes and Oracle Applications NLS Release • Oracle E-Business Suite Upgrade Guide: Release 11i to Release 12.1.1 • Oracle E-Business Suite Maintenance Pack (MP) Installation instructions These documents respectively correspond to the following install/upgrade scenarios: • New Installations of Release 12.1.1 using the EBS Rapid Install wizard • Upgrades of EBS from versions 11i to 12.1.1 using the EBS Rapid Install wizard • Upgrades of EBS from versions 12.0 (including 12.0 RUPs) to 12.1.1 using the Maintenance Pack (MP) For Linux x86-64 installation and upgrade notes corresponding to the older Release 12.0.4 version, please see the My Oracle Support Document 416305.1. Specific steps in this document may be conditional depending on the scenario and will be highlighted as such.

Rate this document

This document applies to 64-bit Linux operating systems on the x86-64 hardware architecture. For 32-bit Linux operating systems on the x86 and x86-64 hardware architectures s Installation and Upgrade Notes Release 12 (12.1.1) for Linux x86 (My Oracle Support Document 761564.1) - please note that there are separate distributions of Release 12.1.1 fo x86-64 (64-bit) platforms. For clarification on Oracle E-Business Suite on Linux x86-64, see Frequently Asked Questions: Oracle Applications Support on x86-64 (My Oracle Support Document 343917.1). Complete all operating system requirements, software requirements, and other requirements before installing or upgrading Oracle E-Business Suite. This document may be updated on a regular basis. Currently, it contains the following sections:

https://support.oracle.com/CSP/main/article?cmd=show&type=NOT&doctype=BULLETIN&id=761566.1

12/6/2010

GA.Update 4 or higher (64 -bit) 5 .com/CSP/main/article?cmd=show&type=NOT&doctype=BULLETIN&id=761566.Update 1 or higher (64 -bit) 9 . SP1 or higher (64-bit) https://support.Oracle Applications Installation and Upgrade Notes for Linux x86-64(64-bit) Release 12 (12. Operating System Supported Versions The following table lists the supported operating system versions.oracle.Update 1 or higher (64 -bit) 4 . Operating System Name Oracle Linux Oracle Linux Red Hat Enterprise Linux Red Hat Enterprise Linux SUSE Linux Enterprise Server SUSE Linux Enterprise Server Supported Version 4 .1.oracle.com Operating Systems Requirements Oracle E-Business Suite R12 is supported on Linux 64-bit operating systems running on the x86-64 hardware architecture.1) Page 2 of 18 • • • • • • • • • • Certification Information Operating Systems Requirements Software Requirements Other Requirements Before Installing or Upgrading Installing or Upgrading After Installing or Upgrading Known Issues Change Record Documentation Accessibility Certification Information The latest certification information for Oracle E-Business Suite Release 12 is available on My Oracle Support's Certification tab: http://support.Update 4 or higher (64 -bit) 5 .SP3 or higher (64-bit)* 10 .1 12/6/2010 .

4.rpm (32-bit) glibc-devel-2.1 because 11gR1 of the Database is delivered with Rapid Install and is not supported on these OS'es.6-3.x86_64.6.rpm (32-bit) compat-db-4.25.8 Required Packages The following table lists the required packages and the minimum required versions for Linux (64-bit).oracle.i386.6-3.rpm glibc-devel-2.rpm libstdc++-3.4-2.com/CSP/main/article?cmd=show&type=NOT&doctype=BULLETIN&id=761566.21-0.25-9.EL5 2.1.i686.0.rpm gcc-c++-3.x86_64.5.x86_64.90-44.4.6.0-12.Oracle Applications Installation and Upgrade Notes for Linux x86-64(64-bit) Release 12 (12.x86_64.rpm (32-bit) https://support.x86_64.i386.EL 2.0.EL5 2.EL 2.3.rpm glibc-2.3.6-3. Operating System Oracle Linux 4* Required Packages • • • • • • • • • • • • • • • • • binutils-2.9-42.6.1 12/6/2010 .rpm libgcc-3.x86_64.25.2.18-53. Additional Information: Refer to your vendor's operating system installation manual or the operating system media for information on obtaining and applying packages.3.x86_64.4.3.rpm gcc-3.i386.3.4-2.6.i386.244 2.4-2.rpm glibc-common-2.4.rpm (32-bit) libstdc++-devel-3.rpm control-center-2.4.x86_64.1.rpm libstdc++-devel-3.92.6.rpm compat-db-4.18-53.1.6-3. enter: $ uname -r): Operating System Oracle Linux 4 Oracle Linux 5 Red Hat Enterprise Linux AS/ES 4 Red Hat Enterprise Linux AS/ES 5 SUSE Linux Enterprise Server 9 SUSE Linux Enterprise Server 10 Kernel 2.rpm gnome-libs-1.8.4-2.1.25.6-3. Kernel Requirements The following table lists the required minimum kernel versions (to determine version.4.4.16.i386.9-42.6.1) Page 3 of 18 *: only supported on the application (or middle) tier for upgrade customers in a multi-node system.15.6-3.2-21.1. or for both application and database tiers if the customer is on 10gR2.4-2.4.rpm (32-bit) glibc-2.x86_64.rpm (32-bit) libstdc++-3.1.1.1.x86_64.rhel4.4.6-3.25.x86_64.25. This OS installation of 12.5-7.25-9.4.1.0.0.

rpm setarch-1.2-14.2-14.i386 libstdc++-4.x86_64.2-14.2-14.3.i386.el5.EL.1.com/CSP/main/article?cmd=show&type=NOT&doctype=BULLETIN&id=761566.rpm (32-bit) libaio-devel-0.1 12/6/2010 .2.17.el5.rpm Oracle Linux 5* Red Hat Enterprise Linux 5* (base and Advanced Platform) Update 1 (5.rpm xscreensaver-4.1) Page 4 of 18 • • • • • • • • • • libgcc-3.1.2-14.1.11.5-18.rpm libaio-0.2-14.rhel4.30-11.8.0-26.1.1.1.1.x86_64.5-18.x86_64 libaio-0.1) or higher of Oracle Linux 5 is required Update 1 (5.1.5-11.el5.5-18.0.105-2.i386 • For Update 1 or 2: ◦ binutils-2.x86_64.x86_64 libgcc-4.1.6-1.18-5.i386.1) or higher of Red Hat Enterprise Linux (RHEL) 5 is required The following packages (or versions of packages) are not part of the OS distribution media and must be downloaded separately (from http://oss.1.x86_64 glibc-2.33.0.106-3.EL5.rpm openmotif21-2.x86_64 glibc-common-2.0.x86_64.rpm pdksh-5.0.1.i386 (32-bit) glibc-devel-2.6. see workaround listed below in the 'After Installing or Upgrading' section.2.1.2-1.81-1.1.6-9.3.x86_64.x86_64 gcc-c++-4.x86_64 make-3.i386 gdbm-1.8. oracle/files/Enterprise_Linux/ for both Oracle Linux 5 and RHEL 5) and installed manually: • openmotif21-2.105-2.50.RHEL4.oracle.i686 (32-bit) glibc-2.i386 libXp-1.x86_64.1.el5.5-18.2-14.x86_64 libstdc++-4.3.el5.el5.1.0.30-11.EL4.0-8.105-2.17. The following packages must be installed from the Oracle Linux 5 or RHEL 5 distribution media: • • • • • • • • • • • • • • • • • • • gcc-4.2.oracle.6-3.x86_64.i3861 • xorg-x11-libs-compat-6.el5.x86_64 gdbm-1.1.8.2.x86_64 libXp-1.3.4.0.el5.80-6.i386 libstdc++-devel-4.x86_642 • For Update 4 (5.2-14.el5.rpm make-3.x86_64 libstdc++-devel-4.0.Oracle Applications Installation and Upgrade Notes for Linux x86-64(64-bit) Release 12 (12.1.rpm** libaio-0.x86_64.5-18.x86_64 glibc-devel-2.0-26.50.4) or higher.1.0.14-30.i386 libgcc-4.el5.rhel4.x86_642 • For Update 3: ◦ binutils-2.0-8.rpm sysstat-5.3.1.i386 https://support.6-6.

125-3.el5.2.el5.x86_64 elfutils-libelf-devel-static-0.11-7.3-10.x86_64.1.x86_64.1 release) on the database tier: • • • • • • • • • Note: 1 2 compat-libstdc++-33-3.2.rpm (32-bit) compat-db-4.EL4.3.rpm glibc-devel-2.2.i386 compat-libstdc++-33-3.rhel4.x86_64.3.14-30.el5.25.el5.92.4-2.i686.1.rpm pdksh-5.x86_64 unixODBC-2.x86_64 util-linux-2.3.x86_64 unixODBC-devel-2.x86_64.18-8.6-3.i386 Additionally.el5.x86_64.2.30 (for example.rpm gnome-libs-1.4.rpm make-3.4-2.2.6-3.6-3.1.1.oracle.i386.17 provided by Oracle is required for relinking the modules in Advanced Planning & Scheduling (MSC.com/CSP/main/article?cmd=show&type=NOT&doctype=BULLETIN&id=761566.11-7.6.x86_64.Oracle Applications Installation and Upgrade Notes for Linux x86-64(64-bit) Release 12 (12.rpm libstdc++-3.15.2-21.rpm sysstat-5.4.13-0.3.1.x86_64.0-3.5-11. MSO.3-61.106-3.6-1.3.rpm (32-bit) libstdc++-devel-3.1 12/6/2010 .4-2.25.2.rpm setarch-1.x86_64. the following RPMs are required for an 11gR1 Database (which is bundled with the 12.25-9.4.3.rpm compat-db-4.96-138.25.6-3.3.x86_64.x86_64 : The openmotif package version must be 2.125-3.0-12.rpm gcc-c++-3.1.x86_64 kernel-headers-2.rpm (32-bit) libgcc-3.x86_64.4.1.4-2.6-3.1.1) Page 5 of 18 • • • • • • libaio-0.2.0.1.106-3.rpm libstdc++-devel-3.rpm https://support.rhel4.11-7.rpm glibc-2.0.i386 unixODBC-2.11-7.2-14.i386.6-3.6-3.RHEL4.i386.1.i386 unixODBC-devel-2.x86_64 elfutils-libelf-devel-0.x86_64 libgomp-4.2.25.25.4.4.1.8.4.4.el5.x86_64.2. M (FEMCCE) Red Hat Enterprise Linux AS/ES 4* • • • • • • • • • • • • • • • • • • • • • • binutils-2.3-61.x86_64.x86_64 sysstat-7.rpm (32-bit) glibc-devel-2. : This GNU linker (ld) version 2.rpm gcc-3.4.i386. openmotif-2.3.x86_64 compat-libstdc++-296-2.80-6.90-44.rpm (32-bit) libstdc++-3.i386.x86_64.1.rpm glibc-common-2.6-3.x86_64.x86_64.2.45.rpm control-center-2.x86_64 libaio-devel-0.rpm (32-bit) glibc-2.0.rpm libgcc-3.5.2.4-2.x86_64.25-9.5 is not supported).

x86_64.rpm** libaio-0.3.6.7.x86_64.rpm) pa SLES 10 distribution media: • • • • binutils-2.x86_64.rpm compat-32bit-9-200407011229.rpm compat-sles8-1.4 binutils-32bit-2.rpm xscreensaver-4.4.rpm gcc-c++-3.x86_64.3-98.102-1.91.1-35.5-23.x86_64.105-2.16.0.rpm libaio-0.3-93.rpm gnome-libs-devel-1.3.x86_64.16-2.14-780.10.1.61.0-341.x86_64.105-2.3-43.x86_64.2.3.rpm binutils-32bit-9-200505232206.80-184.rpm glibc-2.3-43.0.rpm gnome-libs-1.x86_64.x86_64.x86_64.x86_64. The following rpms (suffix .1) Page 6 of 18 • • • • • SUSE Linux Enterprise Server 9 • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • • SUSE Linux Enterprise Server 10 xscreensaver-4.3.4.rpm (32-bit) libaio-32bit-9-200502241149.rpm glibc-32bit-9-200512100800.rpm libstdc++-devel-3.15.3-43.x86_64.3.x86_64.3.1.7.41.x86_64.1.2 compat-32bit-2006.25-11.x86_64.x86_64.7-671.x86_64.x86_64.x86_64.rpm libaio-devel-32bit-9-200502241149.18-5.2.rpm (32-bit) libaio-devel-0.rpm sysstat-5.x86_64.91.41.rpm openmotif21-2.x86_64.rpm compat-2004.7-671.x86_64.0).3.x86_64.1.1.x86_64.3.0.x86_64.rpm binutils-2.x86_64.3.1-1.rhel4.41.4 compat-2006.1.1.3-43.x86_64.rpm gnome-libs-32bit-9-200407011229.2.x86_64.rpm make-3. or SLES 10 Service Pack 1 (10.rpm General Availability (GA) version of SLES 10 (10.3.rpm XFree86-devel-32bit-9-200512021458.rpm libaio-devel-32bit-9-200407011229.41.rpm libstdc++-devel-32bit-9-200407011229.1.16.x86_64.x86_64.rpm db1-32bit-9-200407011229.41.i386.rpm (32-bit) libaio-devel-0.2.1 12/6/2010 .rpm libstdc++-3.rpm glibc-devel-32bit-9-200512100801.25-11.rpm openmotif21-libs-32bit-9-200511172351.x86_64.5-23.1) or higher is required.0.102-1.105-2.1.rpm gcc-3.i386.Oracle Applications Installation and Upgrade Notes for Linux x86-64(64-bit) Release 12 (12.x86_64.30-11.rpm libgcc-3.rpm db-32bit-9-200407011229.6.90.RHEL4.3-43.com/CSP/main/article?cmd=show&type=NOT&doctype=BULLETIN&id=761566.11.rpm pdksh-5.rpm linux32-1.3.x86_64.1.1.x86-64.rpm libaio-0.3.oracle.7.2 https://support.1-32.

2 glibc-32bit-2.17 libaio-0.3.1.sun.0-28.3.com/CSP/main/article?cmd=show&type=NOT&doctype=BULLETIN&id=761566. run ldconfig -v. Starting in SP3.85-101.5 is not supported.104-14.21 libstdc++-33.0.104-14.4. **The openmotif version must be 2.4 glibc-2.3.0-28. Additional Information: Check the Sun Web site for any updates to the JDK 6 requirements for Linux (64-bit): http://java.104-14.2 libaio-devel-32bit-0.2 glibc-devel-32bit-2.2 libcom_err-1.4-31.0-28.2 gcc-4.com/javase/6/webnotes/install/jdk/install-linux.oracle.32 libstdc++-33-32bit. SP1 (10.1.2 libaio-32bit-0.4-31.30MLI4-143.3.4 linux32-1.3.32 db1-32bit-1.1) and SP2 (10.38-25.1.3.4 libstdc++-4. openmotif-2.4 libstdc++-devel-4. JDK 6. the compat-libstdc++-5.104-14.0-28.7 package has been replaced by libstdc++ : SLES 10 SP3 (10.0.30.1.7-22.2 make-3.3-19.1.2 libaio-devel-0.3.RHEL4.3.1.Oracle Applications Installation and Upgrade Notes for Linux x86-64(64-bit) Release 12 (12.21 libgcc-4.2) only.0).1.0-349.4-31.xxx.1) Page 7 of 18 • • • • • • • • • • • • • • • • • • • • • • Note: compat-libstdc++-5.0 Requirements JDK 6 is bundled with Oracle E-Business Suite version 12.30.0-28.2 krb5-1.2 glibc-devel-2. For example.1 12/6/2010 .1.3.html#requirements https://support.3) and higher only Footnotes: *After installing these patches.4-31.80-202.2 openmotif21-libs-32bit-2.1.2.1.2 1 2 : GA (10.10.1. and the package name must be in the following format: openmotif21-2.4 gcc-c++-4.

semmsl kernel.semmns Value 2561 320001 https://support.Oracle Applications Installation and Upgrade Notes for Linux x86-64(64-bit) Release 12 (12.oracle. Kernel Settings Edit the /etc/sysctl. and their locations specified both in the PATH of the account that runs Rapid Install and in the PATH of the ac tier and application tier file systems. use the "sysctl -p" command or restart the system to invoke the new settings. After editing the file. it will re-direct be applied to both 32-bit and 64-bit Linux operating systems. The following table lists the kernel settings for Oracle Enterprise Linux 4 and 5. Patching Oracle E-Business Suite Note: When querying for Oracle E-Business Suite Release 12 patches on My Oracle Support and selecting Linux x86-64 in the Platform dropdown list. • • • • • • • • ar gcc g++ ksh ld linux32 make X Display Server Other Requirements The following are other requirements for Linux x86-64 (64-bit). Red Hat Enterprise Linux AS/ES 4 and 5.conf file to configure your kernel settings.1. and SUSE Linux Enterprise Server 9 and 10: Parameter kernel. Note: If the current value for any parameter is higher than the value listed in the following table.1 12/6/2010 . then do not change the value of that parameter.com/CSP/main/article?cmd=show&type=NOT&doctype=BULLETIN&id=761566.1) Page 8 of 18 Software Requirements The following maintenance tools must be installed on all machines.

ip_local_port_range 10000 650003 net. and at least 21474836482 4096 8192 65535 2878 131072 net.wmem_default net.sem = 256 32000 100 142 : On the server running the EBS Database.ipv4. add or update the following entries to these minimum settings in the /etc/resolv.shmmni kernel.msgmax kernel.shmall kernel.core.rmem_max net.msgmnb kernel.core.core. ensure that you set the following kernel parameter: disable_cap_mlock = 1 Domain Name System (DNS) Resolver Parameters Two Domain Name System (DNS) resolver parameters (timeout and attempts) are set by default to low values when the operating system is installed.msgmni fs.core.file-max 1001 1421 2097152 Half the size of the physical memory (in bytes).1) Page 9 of 18 kernel.Oracle Applications Installation and Upgrade Notes for Linux x86-64(64-bit) Release 12 (12. If this happens.1.1 12/6/2010 .semopm kernel.oracle.conf file: kernel. These low values an Oracle database to fail.shmmax kernel.semmni kernel. this kernel parameter must be the lesser of half the size of the physical memory (in bytes) and 4294967295 3 : values recommended for the local port range may need to be adjusted according to the specific needs of the user's environment in order to avoid port conflicts.rmem_default net. On SUSE Linux Enterprise Server 9 and 10.com/CSP/main/article?cmd=show&type=NOT&doctype=BULLETIN&id=761566.conf file on each server node: options attempts:5 options timeout:15 https://support.wmem_max 1 2 262144 4194304 262144 262144 : set using the following entry in the /etc/sysctl.

Oracle Applications Installation and Upgrade Notes for Linux x86-64(64-bit) Release 12 (12.0.localdomain localhost [ip_address] [node_name]. For SUSE Linux SLES 9 and 10: 1.0.com/CSP/main/article?cmd=show&type=NOT&doctype=BULLETIN&id=761566. Verify that the /etc/hosts file is formatted as follows: 127.0. Restart the system after making changes. Modifying the Number of Open File Descriptors Open the /etc/security/limits. restart the system. If you changed any files in the previous steps. Verify that the /etc/hosts file is formatted as follows: 127. restart the system. remove it. If the /etc/sysconfig/networking/profiles/default/network file exists.[domain_name] 3. If you changed any files in the previous step. https://support.localdomain localhost [ip_address] [node_name].conf file and change the existing values for "hard" and "soft" parameters as follows.1 localhost. 4.1 localhost.0. Verify that the /etc/sysconfig/network file is formatted as follows: HOSTNAME=[node_name].1 12/6/2010 .oracle.1) Page 10 of 18 Verifying Host Names Use the following to verify host name settings: For Oracle Linux 4 and 5.[domain_name] [node_name] 2. and Red Hat Enterprise Linux AS/ES 4 and 5: 1.1.[domain_name] [node_name] 2.

3.4' `__fprintf_chk@GLIBC_2.so.so. Before Installing or Upgrading If the Release 12. and other requirements before installing or upgrading Oracle E-Business Suite .2 Oracle Home: /usr/lib/libXtst.1. * * * * hard soft hard soft nofile 65535 nofile 4096 nproc 16384 nproc 2047 OS Library Patch for Oracle HTTP Server (on Oracle Linux 5 and RHEL 5 only) Download and apply the patch 6078836 from My Oracle Support to fix an issue with the Oracle HTTP Server (missing libdb.com/CSP/main/article?cmd=show&type=NOT&doctype=BULLETIN&id=761566.2 Application Server Oracle Home: # unlink /usr/lib/libXtst. the above link command (ln) will have to be re-issued after running the ldconfig command.6 Without this updated link.6.so. you may see the following errors during a relink of the 10.1.1) Page 11 of 18 Note: If the current value for any parameter is higher than the value listed in this document.2) bundled with the E-Business Suite technology st Note that this patch (which includes a required operating system library) must be applied before installing Oracle E-Business Suite. Release 12.6: undefined reference to /usr/lib/libXtst.1 installation or upgrade is performed with the Rapid Install wizard (either a new R12 installation or upgrade from 11i to R12).Oracle Applications Installation and Upgrade Notes for Linux x86-64(64-bit) Release 12 (12. Link to Motif library in Oracle Application Server 10. then do not change the value of that parameter. ensure you have the latest Rapid Applications Release Notes.1.6 # ln -s /usr/X11R6/lib/libXtst.1 12/6/2010 .so. software requirements.so.so. https://support.1.so.6: undefined reference to /usr/lib/libXtst.1 (My Oracle Support Document 798258.1) before you begin your installation or upgrade.oracle.4' `__sprintf_chk@GLIBC_2.2 (on Oracle Linux 5 and RHEL 5 only) Perform the following command (as root on your system) to update a required link to a Motif library prior to relinking or patching the 10.1 /usr/lib/libXtst.1.6: undefined reference to `__stack_chk_fail@GLIBC_2.1.4' Since the ldconfig command overrides this link.3. Complete all operating system requirements.

the OPMN service of the Application Server technology stack listens on port 6000 when started up during Rapid Install.1 Maintenance Pack instructions) relevant to the specific installation or upgrade scenario described above. https://support.com/CSP/main/article?cmd=show&type=NOT&doctype=BULLETIN&id=761566.1. perform the following steps before installing or upgrading: • Check if the port 6000 is being used ("netstat -a | grep 6000") • If so.1. ◦ Use "kill -9" to abort the process found in the previous step ◦ Confirm that nothing is listening at port 6000 ("netstat -a | grep 6000") ◦ Modify /etc/inittab by changing "id:5:initdefault:" to "id:3:initdefault:" ◦ Run "/sbin/init 3" to restart dtlogin Unset environment variable before installing (for SLES 10 only) Unset the ENV environment variable prior to installing (to avoid failure of the registration of the 10.1 12/6/2010 . Oracle E-Business Suite Upgrade Guide: Releas Business Suite Release 12. This can be accomplished by logging in as root and issuing the following commands: ◦ Find the process that uses port 6000 by the command "lsof -i TCP:6000".Oracle Applications Installation and Upgrade Notes for Linux x86-64(64-bit) Release 12 (12. you should disable the graphics console login process on the Linux server.1. After Installing or Upgrading Perform the following steps after installing or upgrading to Release 12.1. This can conflict with the X11 on Linux servers and prevent Rapid Install from completing. To address this issue.2 Oracle Home during install): $ unset ENV Installing or Upgrading Perform the installation or upgrade following the documentation (Oracle E-Business Suite Installation Guide: Using Rapid Install.1 and before allowing users to access the system.oracle.1) Page 12 of 18 OPMN port conflict Attention: By default.

1.1. and clicking on the 'Environments' tab): On each application tier server node: LD_LIBRARY_PATH is set in three places: https://support.sh: CPP_LDFLAGS=' -L$(ORACLE_HOME)/lib -L$(ORACLE_HOME)/lib/stubs -lclntsh' with CPP_LDFLAGS=' -L$(ORACLE_HOME)/lib -L$(ORACLE_HOME)/lib/stubs -lclntsh -Wl.4 or higher only) During the relink phase of the installation of EBS Release 12 (12. you must run the foll particular corrupted dbf file: $ sqlplus/nolog sql> connect / as sysdba sql> alter database datafile '[full path of system09.dbf]' resize 1500M.1.1. users are then required to run the adadmin utility and relink application executables.1 My Oracle Support Document 798258.--noinhibit-exec' After making this change. clicking on 'System Admi under 'Oracle Applications Manager'.9 or earlier (see Oracle Applications Release Notes.oracle. To fix this problem.1).1) on SLES 10 or Oracle Linux/RHEL 5. MSC.4 (Update 4 or higher).1) Page 13 of 18 Manually fix database dbf file If you installed 12. failures will result while relinking the Advanced executables MSO. use the Edit Parameters function of the OAM AutoConfig tool (by logging in as 'System Administrator' responsibility.Oracle Applications Installation and Upgrade Notes for Linux x86-64(64-bit) Release 12 (12.com/CSP/main/article?cmd=show&type=NOT&doctype=BULLETIN&id=761566.1 12/6/2010 . The LD_LIBRARY_PATH environment variable is used by Oracle E-Business Suite to locate the requ this variable is set by the Rapid Install wizard during the installation of EBS as well as by the Rapid Clone script (adcfgclone) when configuring the target system. sql> alter database datafile '[full path of system09. Release 12. If you need to change these values. MSR and FEM.1.1. users are required to replace the following line under the Linux section of the $AD_TOP/bin/adrelinknew.dbf]' resize 1000M. LD_LIBRARY_PATH Environment Variable Dynamic libraries are used as part of the relinking and execution processes.1 with a startCD of 12. Relink Advanced Supply Chain Planning executables (for SLES 10 and Oracle Linux/RHEL 5.

sh) to implement the changes on the application and database tiers.env. Net Service Listeners in Multi-user Installations Net Service Listeners use the /var/tmp.1. Additional Information: See AutoConfig in Oracle E-Business Suite Maintenance Utilities for more information on AutoConfig.oracle Known Issues The following are known issues for this release.com/CSP/main/article?cmd=show&type=NOT&doctype=BULLETIN&id=761566.1.3 Oracle home directory In the AutoConfig interface.env • $ORA_CONFIG_HOME/10. in the 10.1.3) LD_LIBRARY_PATH On the database server node: LD_LIBRARY_PATH is set in $ORACLE_HOME/[CONTEXT_NAME].oracle directory to store temporary files.1.2/[CONTEXT_NAME].1.env which corresponds in the AutoConfig interface to: Location Parameter db_home LD_LIBRARY_PATH After making these changes.1) Page 14 of 18 • $APPL_TOP/admin/adovars.1 12/6/2010 . in the 10. To give all users in a multi-user installation write privileges. update /var/tmp/.2) LD_LIBRARY_PATH web_home (10.env. run AutoConfig (adautocfg.Oracle Applications Installation and Upgrade Notes for Linux x86-64(64-bit) Release 12 (12.1.3/[CONTEXT_NAME].1.oracle with 777 $ chmod 777 /var/tmp/. https://support. this corresponds to: Location adovars Parameter LD_LIBRARY_PATH tools_home (10.oracle.2 Oracle home directory • $ORA_CONFIG_HOME/10.

14-Sep-2010 Added clarification of shmmax kernel parameter on the db tier 16-Jul-2010 Added Profitability Manager as a product requiring ld version 2. Users should unset this variable in th E-Business Suite administration or cloning tasks (AD utilities) with the command: $ unset LD_PRELOAD Change Record The following sections were changed in this document.Oracle Applications Installation and Upgrade Notes for Linux x86-64(64-bit) Release 12 (12.1. Date Summary of Changes 02-Dec-2010 Added Known Issue for Exalogic 15-Oct-2010 Added opmn port conflict workaround.17 for OEL/RHEL 5 https://support.so: object '/usr/lib64/libsdp.1 12/6/2010 .: No such file or directory This error is due to the LD_PRELOAD environment being set by default on Exalogic machines (in the /etc/profile file) to "/usr/lib64/libsdp.com/CSP/main/article?cmd=show&type=NOT&doctype=BULLETIN&id=761566.exe may crash when increasing the number of threads for optimization on a system with insufficient following error is observed when this occurs: **** glibc detected *** MSONWL64.so' from LD_PRELOAD cannot be preloaded: ignored.oracle.1) Page 15 of 18 Advanced Supply Chain Planning product (MSO) may crash when increasing number of threads for optimization The 64-bit Oracle Advanced Supply Chain Planning executable MSONWL64.so".exe: corrupted double-linked list: 0x00002aaaac0008b0 **** LD_PRELOAD setting on Oracle Exalogic machine incompatible with E-Business Suite Customers installing Oracle E-Business Suite on the Oracle Exalogic machine running Oracle Linux 5 may see the following error when performing administration or cloning tasks Can't open ERROR: ld.

1 12/6/2010 .dbf 27-Apr-2009 Initial publication of 12. To that end.Oracle Applications Installation and Upgrade Notes for Linux x86-64(64-bit) Release 12 (12.com/CSP/main/article?cmd=show&type=NOT&doctype=BULLETIN&id=761566. cleaned up description of LD_LIB 23-Mar-2010 Added clarification that the HTTP Server patch from AS must be applied before installing EBS.1 IUN . TTY Access to Oracle Support Services Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services within the United States of America 24 hours a day. Standards will co Oracle is actively engaged with other market-leading technology vendors to address technical obstacles so that our documentation can be accessible to all of our customers. JAWS may not always read a line of text that consists solely of a bracket or brace. and supporting documentation accessible. with good usability.for the older 12. call 80 States. 13-Oct-2009 Added workaround for OEL/RHEL 5 Update 4 (5.4 IUN changes.1) Page 16 of 18 1-Jul-2010 Clarified that LD_LIBRARY_PATH is also set by Rapid Clone when configuring the target system. and contains markup to facilitate access by the disabled community. services. Accessibility of Links to External Web Sites in Documentation This documentation may contain links to Web sites of other companies or organizations that Oracle does not own or control. may not always correctly read the code examples in this document.2479.1 Documentation Accessibility Our goal is to make Oracle products.0. Oracle neither evaluates nor makes any representati these Web sites.1. a Windows screen reader.3) 30-Jun-2009 Added the 'Manually fix a database dbf file' section to fix issue with system09. Release 12 (12.oracle. For Oracle Accessibility Program Web site at: http://www. This documentation is available in HTML format.4) to relink ASCP 03-Aug-2009 Added binutil version requirement for RHEL5/OEL5 Update 3 (5.1.458.oracle.407. For TTY support.1. The conventions for writing code require that closing braces should appear however. our documentation includes available to users of assistive technology. 7 days a week. to the disabled community. cleaned up references of 'Oracle Applications' to 'Oracle E-Business Suite'. please see My Oracle Support Document 416305. Oracle E-Business Suite Installation and Upgrade Notes. 25-Jun-2010 Added note that SLES 10 SP3 replaced compat-libstdc++ with libstdc++. call +1.com/accessibility/ Accessibility of Code Examples in Documentation JAWS.1) for Linux (64-bit) https://support.

This software is developed for general use in a variety of information management applications. redundancy and other me this software. Government customers are "commercial computer software" or "commercial tech applicable Federal Acquisition Regulation and agency-specific supplemental regulations. the additional rights set forth in FAR 52. If you find any errors. modify. Redwood City. products or services. copy. duplication. Oracle Corporation and its affiliates are not warranties of any kind with respect to third party content. broadcast. Oracle. transmit. If this software or related documentation is delivered to the U. This software and related documentation are provided under a license agreement containing restrictions on use and disclosure and are protected by intellectual property laws.S. or damages incurre third party content. costs. It is not developed or intended for use in any inherently dangerous applications. the use. As such.oracle. products and services from third parties. reproduce.1) Page 17 of 18 Copyright © 2009. to the extent applicable by the terms of the Government contract. Ex license agreement or allowed by law.S.Oracle Applications Installation and Upgrade Notes for Linux x86-64(64-bit) Release 12 (12. disclosure. Government. then you shall be responsible to take all appropriate fail-safe.com/CSP/main/article?cmd=show&type=NOT&doctype=BULLETIN&id=761566.. products and services. This software and documentation may provide access to or information on content. Related Products • Oracle E-Business Suite > Applications Technology > Lifecycle Management > Oracle Application Install Errors XP-1 https://support. perform. Inc.1 12/6/2010 . publish or display any part. disassembly.S. unless required by law for interoperability. the following notice is applicable: U. If you use this software in dangerous applications. is prohibited. backup. in a engineering. Oracle Corporation and its affiliates disclaim any liability for any damages caused by use of this software in dangerous applications. Government or anyone licensing it on behalf of the U. distribute.S. translate.227-19. software. please report them to us in writing. databases. and. GOVERNMENT RIGHTS Programs. exhibit. modification. and related documentation and technical data delivered to U. Other names may be trademarks of their respective owners. The information contained herein is subject to change without notice and is not warranted to be error-free. and adaptation shall be subject to set forth in the applicable Government contract. CA 94065.1. Oracle is a registered trademark of Oracle Corporation and/or its affiliates. 500 Oracle Parkway. Oracle Corporation and its affiliates will not be responsible for any loss. Commerci (December 2007). All rights reserved. Oracle USA. in create a risk of personal injury. or decompilation of this software. you may not use. license.

Oracle Applications Installation and Upgrade Notes for Linux x86-64(64-bit) Release 12 (12.oracle.1.1) Page 18 of 18 Back to top https://support.1 12/6/2010 .com/CSP/main/article?cmd=show&type=NOT&doctype=BULLETIN&id=761566.

Sign up to vote on this title
UsefulNot useful