You are on page 1of 10

I- La forme réduite

:

Leçon 1 : la structure de contrôle simple

Les structures de contrôle conditionnelles

Activité1 : On veut écrire un programme qui permet de vérifier et d’afficher si un entier donné est pair. 1- Combien de conditions faut-il vérifier ? La(les) quelle(s) ? Et quel est son (leur) type ? 2- Quel est le traitement à faire si la condition est vérifiée ? 3- Déduire la forme de la structure de contrôle conditionnelle.

Correction:

1- Pour vérifier si un entier est paire il faut vérifier une seule condition : s’il est divisible par 2, donc la condition est : n mod 2=0. Cette condition est une expression logique qui peut prendre soit la valeur « VRAI » soit la valeur « FAUX ». 2- Si la condition est vérifiée c.-à-d. « VRAI », alors il faut SI : mod 2=0) ». afficher le message(n « n est pair ALORS Écrire (n, “ est pair 3- la forme de cette structure est : “)
FINSI

1- Définition : La structure de contrôle conditionnelle simple est dite à forme réduite lorsque le traitement dépend d’une seule condition. Si la condition est évaluée est « VRAI », le traitement est exécuté.

2- Vocabulaire et syntaxe :
Au niveau de l’analyse ou Au niveau Pascal

“ est pair “) FINSI Si (n mod 2<>0) Alors Écrire (n.SI (n mod 2=0) ALORS Écrire (n. ……….. 3. “ est impair “) FINSI . 1.Proposer une solution en utilisant la structure de contrôle conditionnelle simple réduite. 2..La condition peut être une condition composée de plusieurs autres propositions logiques liées par les opérateurs logiques (NOT. AND).. II. OR.Que peut-on remarquer ? 3.proposer une autre solution. End.……. Correction: 1.La forme Alternative : Activité 2: On veut écrire maintenant un programme qui permet de vérifier et d’afficher si un entier donné est pair ou impair.Remarque : .algorithmique {initialisation} Si condition ALORS If condition THEN Begin instruction 1 ……….……. instruction n FinSi instruction 1. instruction n.

Pour optimiser cette solution. “ est pair “) SINON Écrire (n.Vocabulaire et syntaxe: Au niveau de l’analyse ou algorithmique Au niveau Pascal . si la condition est évaluée est « FAUX ». on peut utiliser la SI (n mod 2=0) ALORS structure de contrôle conditionnelle suivante : Écrire (n.2. le 1er traitement est exécuté. 3.La valeur « Vrai » de la condition de la 2ième structure de contrôle est la valeur « Faux » de la 1ère structure de contrôle. Si la condition est évaluée est « VRAI ». “ est impair “) FinSi 1. le 2ième traitement est exécuté 2.Définition: La structure de contrôle conditionnelle simple est dite à forme alternative lorsque le traitement dépend d’une condition à deux états.

..Remarque: • On ne met pas . FinSi End.n.1. III.1. ……….Application: • Exercice 1 et 2 de la série 3 Leçon 2 : la structure de contrôle Généralisée I-Introduction . instruction 1.n End Sinon Else instruction 2.2 ………. ……….n. après le End qui précède le Else car la structure conditionnelle n’est pas encore terminée. instruction 1.…….……..1Begin instruction 2.n instruction 2.…….……. instruction 2.{initialisation} Si condition If condition THEN ALORS Begin instruction 1..2 instruction 2..1 instruction 1. 3. instruction 1.. ……….

Activité 1 1) Ecrire une analyse. La décision « Admis » Ou « Redouble » est prise en fonction de la moyenne 2) On se propose maintenant d’afficher en plus de la décision du conseil des classes la mention dans le cas où l’élève est « admis ». on suit la démarche suivante : Si (MA<12) alors la mention est « Passable » sinon si(MA<14) alors la mention est « Assez bien » sinon si (MA<16) alors la mention est « Bien » sinon la mention est « Très bien » a)Proposer une solution algorithmique en utilisant la structure de contrôle conditionnelle simple ? b) Que peut-on constater ? Correction : Analyse: 1) Nom=Decision_Moy . Rappelons que pour déterminer la mention. un algorithme et sa traduction en Pascal d’un programme qui permet de saisir la moyenne annuelle d’un élève et d’afficher la décision du conseil des classes.

“ Decision) Decision=[] si (MA<10) alors Decision⇓ ” Redouble” sinon Decision⇓ ” Admis” FinSI MA= donnée (“donner la moyenne annuelle de l’élève “) FinDecision_Moy Algorithme 0) Debut Décision_Moy 1) Ecrire (“donner la moyenne de l’élève”) 2) Lire (MA) 3) Si (MA<10) alors Decision“Redouble” sinon Decision  “Admis” finsi 4) Ecrire(“la décision est “. Decision) 5) Fin Décision_Moy TDO Nom MA Decision Type/Nature réel Chaine de caractère Rôle La moyenne annuelle concernant un élève Permet d’afficher la décision du conseil des classes concernant un élève Pascal Program decision_moy . Uses wincrt.Résultat: ecrire (" la décision est. Var .

Mention ) 5) Fin Décision_Moy TDO Nom Type/Nature Rôle . Decision. Begin writeln(‘ donner la moyenne de l’élève’). Writeln(‘la décision est’. Readln(MA). 2) a Algorithme 0) 1) 2) 3) Debut Décision_Moy Ecrire (“donner la moyenne de l’élève”) Lire (MA) Si (MA<10) alors Decision“Redouble” Mention’’ ’’ sinon Decision  “Admis” si (MA>=10) et (MA<12) alors Mention’’Passable’’ FinSi si (MA>=12) et (MA<14) alors Mention’’Assez bien’’ FinSi si (MA>=14) et (MA<16) alors Mention’’Bien’’ FinSi si (MA>=16) alors Mention’’Très bien’’ FinSi finsi 4) Ecrire(“la décision est “.Decision : String.Decision). MA : Real. If(MA<10) then Decision:= ‘ Redouble ’ else Decision := ‘ Admis’. “la mention est”. End.

L’exécution d’un traitement entraîne automatiquement la non exécution des autres traitements III-Vocabulaire et syntaxe Au niveau de l’analyse ou Au niveau Pascal . Il serait intéressant d’économiser les tests en utilisant une autre structure : c’est la structure de contrôle conditionnelle généralisée II-Définition La structure de contrôle conditionnelle est dite généralisée lorsqu’elle permet de résoudre des problèmes comportant plus de deux traitements en fonction des conditions.MA Decision Mention réel Chaine de caractère Chaine de caractère La moyenne annuelle concernant un élève Permet d’afficher la décision du conseil des classes concernant un élève Permet d’afficher la Mention concernant un élève b) On constate que les conditions se rapportant sur la Mention obligent la machine à examiner quatre tests successifs qu’ils portent tous sur le même objet (MA).

si elle produit la valeur: vrai : le traitement2 sera exécuté puis l’exécution continue avec l’instruction qui suit le Si généralisé. .algorithmique {initialisation} Si If condition1 condition1 ALORS THEN Traitement 1 Sinon si Traitement 1 condition2 ALORS Else if traitement 2condition2 THEN ………………. FinSi Remarque: Lorsque l’évaluation de la condition1 produit la valeur vrai : le traitement1 sera exécuté puis l’exécution continue avec l’instruction qui suit le Si généralisé. traitement 2 sinon si ………………. condition N-1 ALORS Else if condition N-1 THEN traitement N-1 traitement N-1 sinon ELSE Traitement N Traitement N . Faux : la condition2 sera évaluée.

Application En utilisant la structure de contrôle conditionnelle généralisée.Faux : la condition3sera évaluée et ainsi de suite Il est préférable de mettre les évènements les plus probables en premier lieu VI. donner une solution algorithmique de la 2ième partie de l’activité 1 .