Εντολές της γλώσσας LOGO

Δείξε έκφραση Εμφανίζει στο κέντρο εντολών αυτό που ακολουθεί. Π.χ.:
Δείξε 456
Θα εμφανιστεί
456
Δείξε 15 / 5
Θα εμφανιστεί
3
Δείξε δύναμη 2 3
Θα εμφανιστεί
8
Δείξε ΤετραγωνικήΡίζα 9
Θα εμφανιστεί
3
Δείξε "Καλημέρα!
Θα εμφανιστεί
Καλημέρα!
Δείξε [Γεια σου!]
Θα εμφανιστεί
Γεια σου!
Δείξε (φρ [5 και 5 κάνει ] 5 + 5 "!) Θα εμφανιστεί
5 και 5 κάνει 10!
Ανακοίνωση έκφραση
Εμφανίζει σε παράθυρο αυτό που ακολουθεί. Ισχύει ό,τι και στη Δείξε.
Ερώτηση έκφραση
Εμφανίζει σε παράθυρο μια ερώτηση με το κείμενο που ακολουθεί. Ό,τι πληκτρολογήσει ο
χρήστης αποθηκεύεται στην απάντηση.
μπ αριθμός Μετακινεί τη χελώνα προς τα εμπρός όσα πίξελς δείχνει ο αριθμός. π.χ. μπ 50
πι αριθμός Μετακινεί τη χελώνα προς τα πίσω όσα πίξελς δείχνει ο αριθμός. π.χ. πι 30
δε αριθμός Στρέφει τη χελώνα προς τα δεξιά σε γωνία τόσες μοίρες όσες είναι ο αριθμός. π.χ. δε 90
αρ αριθμός Στρέφει την χελώνα προς τα αριστερά τόσες μοίρες όσες είναι ο αριθμός. π.χ. αρ 90
στα
Σηκώνει το στυλό της τρέχουσας χελώνας. Η χελώνα δεν αφήνει ίχνη όταν μετακινείται. Όταν δημιουργείται μια
χελώνα το στυλό είναι πάντα «άνω».
στκ
Κατεβάζει το στυλό της τρέχουσας χελώνας. Έτσι, η χελώνα αφήνει πίσω της ίχνη όταν μετακινείται, όχι όμως
και όταν τη σύρετε.
σβγ
Διαγράφει τα γραφικά της σελίδας και οδηγεί τη χελώνα στο κέντρο, με το κεφάλι της προς τα πάνω και την
τοποθετεί στο κέντρο της σελίδας.
ΘέσεΠάχοςΣτυλό αριθμός
Καθορίζει το πάχος του στυλό της χελώνας το οποίο προσδιορίζει το πάχος των γραμμών που θα σχεδιάσει. Το
πάχος του στυλό μπορεί επίσης να ρυθμιστεί αν επιλέξετε ένα σχήμα πινελιάς και το μολύβι από την καρτέλα
Γραφικά και κάνετε κλικ στη χελώνα. (Το πάχος του στυλό είναι η διάμετρος της πινελιάς.) Το αρχικό πάχος στυλό
είναι 1. Το μέγιστο πάχος στυλό είναι 100.
ΘέσεΧρώμα όνομα-ή-αριθμός
Π.χ. ΘέσεΧρώμα "Κόκκινο
Καθορίζει το χρώμα του στυλό της χελώνας. Αν η χελώνα έχει το αρχικό της σχήμα, το χρώμα της θα αλλάξει ώστε να
υποδηλώσει το χρώμα του στυλό. Ως είσοδος μπορεί να δοθεί το όνομα ενός χρώματος ή ένας αριθμός. Αν η είσοδος
είναι όνομα, πρέπει να ξεκινάει με εισαγωγικά. Το αρχικό χρώμα του στυλό είναι το μαύρο (αριθμός χρώματος 9).
Επανάλαβε Χ [ εντολή1 εντολή2 … εντολή Ν ]
Επαναλαμβάνει Χ φορές τις εντολές που βρίσκονται μέσα στις αγκύλες
για όνομα
Εντολή 1
Εντολή 2

Εντολή Ν
τέλος
Φτιάχνει μια διαδικασία που λέγεται όνομα και περιλαμβάνει τις εντολές που ακολουθούν. Για να τη
χρησιμοποιήσουμε, γράφουμε όνομα.
Κάνε "Ονομα Τιμή Φτιάχνει μια μεταβλητή με όνομα Όνομα και περιεχόμενο ό,τι υπάρχει στην Τιμή. Π.χ.
Κάνε "x 7
Φτιάχνει μια μεταβλητή με όνομα x και περιεχόμενο τον αριθμό 7
Κάνε "α "γάτα
Φτιάχνει μια μεταβλητή με όνομα α και περιεχόμενο τη λέξη γάτα
Για να χρησιμοποιήσουμε την τιμή που περιέχει η μεταβλητή χρησιμοποιούμε το σύμβολο : Π.χ.
Δείξε :x
Εμφανίζει στο κέντρο εντολών τον αριθμό 7.
Ανακοίνωση (φρ [Το κατοικίδιό μου είναι μία ] :α )
Εμφανίζει σε παράθυρο το μήνυμα Το κατοικίδιό μου είναι μία γάτα
ΑνΔιαφορετικά συνθήκη [εντολές που εκτελούνται αν ισχύει η συνθήκη] [εντολές που εκτελούνται αν δεν ισχύει η συνθήκη]
Παραδείγματα συνθηκών:
:x < 5
Αληθεύει αν η μεταβλητή x έχει τιμή μικρότερη του 5
:α = "γάτα
Αληθεύει αν η μεταβλητή α έχει τιμή τη λέξη γάτα
ανήκει? :α [μαϊμού κότα] Αληθεύει αν η μεταβλητή α έχει τιμή τη λέξη μαϊμού ή τη λέξη κότα
αγγίζει? "χ1 "χ2
Αληθεύει αν η χελώνα χ1 ακουμπάει τη χελώνα χ2
σβήσεκείμενο Διαγράφει όλους τους χαρακτήρες που υπάρχουν σε ένα πλαίσιο κειμένου.
τυ έκφραση
Τυπώνει σε ένα πλαίσιο κειμένου ότι ακολουθεί. Ισχύει ό,τι και στη Δείξε.
συνεχώς [ εντολή1 εντολή2 … εντολή Ν ]
Επαναλαμβάνει συνεχώς τις εντολές που βρίσκονται μέσα στις αγκύλες.
Σταματάει με την εντολή σταμάτησέμε.
κοίταπρος χελώνα_στόχος
αλλάζει την κατεύθυνση της χελώνας, ώστε να κοιτάει προς τη χελώνα_στόχος
όλαστοπ
Διακόπτει όλες τις εκτελούμενες διαδικασίες, συμπεριλαμβανομένων χελωνών και κουμπιών.

1/2

ΕΝΔΕΙΚΤΙΚΕΣ ΕΡΩΤΗΣΕΙΣ ΘΕΩΡΙΑΣ

Πώς λύνουμε ένα πρόβλημα; Τι πρέπει να προσέξουμε πριν ξεκινήσουμε να λύσουμε
ένα πρόβλημα; Πώς μπορούμε να λύσουμε ένα σύνθετο πρόβλημα;

Τι είναι αλγόριθμος; Δώστε ένα παράδειγμα αλγορίθμου. Ποιες ιδιότητες πρέπει να
έχει ένας αλγόριθμος για να είναι σωστός;

Τι ονομάζουμε πρόγραμμα; Από τι αποτελείται ένα πρόγραμμα; Τι κάνουν οι
προγραμματιστές;

Σε τι χρησιμεύουν οι γλώσσες προγραμματισμού; Τι είναι το αλφάβητο, λεξιλόγιο
και συντακτικό μιας γλώσσας προγραμματισμού;

Τι είναι η γλώσσα μηχανής;

Ποια είναι τα στάδια μετατροπής ενός αλγορίθμου σε εκτελέσιμο πρόγραμμα;

Πότε ένα λάθος στο πρόγραμμά μας είναι λογικό και πότε συντακτικό;

Ποια γλώσσα προγραμματισμού χρησιμοποιούμε για να φτιάχνουμε προγράμματα στο
σχολείο;

Τι πρέπει να πατάμε μετά από κάθε εντολή της Logo για να εκτελεστεί;

Πότε χρησιμοποιούμε τη φράση (φρ ……………) σε μια εντολή Δείξε ή Ανακοίνωση;

Σε τι μας χρησιμεύουν οι διαδικασίες; Πώς δημιουργούμε μια νέα διαδικασία;

Τι είναι μεταβλητή; Πόσες τιμές μπορεί να έχει μια μεταβλητή κάθε στιγμή;

Πώς δίνουμε τιμή σε μια μεταβλητή; Πώς εμφανίζουμε τα περιεχόμενα μιας
μεταβλητής;

Όταν δημιουργούμε ένα μεταβολέα τι στοιχεία πρέπει να ορίσουμε; Πώς
χρησιμοποιούμε την τιμή ενός μεταβολέα μέσα σε μια εντολή;

Πότε χρησιμοποιούμε την εντολή ΑνΔιαφορετικά; Ποια σύμβολα/λέξεις μπορούμε
να χρησιμοποιήσουμε μέσα στη συνθήκη ελέγχου; Πότε χρησιμοποιούμε το = και
πότε το ανήκει? ;
Παραδείγματα απλών αλγορίθμων

Διακεκομμένη γραμμή:
(από 4 τμήματα των 100 πίξελς)

____
50

δε 90
επανάλαβε 4 [στκ μπ 50 στα μπ 50]

Σκάλα με 3 σκαλοπάτια:

Κανονικό πολύγωνο: (με πλευρά 50 πίξελς )

____

____

____

50

επανάλαβε 3 [ μπ 50 δε 90 μπ 50 αρ 90]

Τρίγωνο:
επανάλαβε 3 [μπ 50 δε 360 / 3]
Τετράγωνο: επανάλαβε 4 [μπ 50 δε 360 / 4]
Πεντάγωνο: επανάλαβε 5 [μπ 50 δε 360 / 5]

Ν-γωνο:
επανάλαβε Ν [ μπ 50 δε 360 / Ν]

Κύκλος:

Εμφάνιση αριθμών από το 1 έως το 10:

επανάλαβε 360 [ μπ 1 δε 1]
Κάνε "α 1
επανάλαβε 10 [
Δείξε :α
Κάνε "α :α + 1
]
2/2