You are on page 1of 30

Facultad de Ingeniería Mecatrónica

Algoritmo y Estructura de Datos II
Sesión :
Estructura Condicional y Repetitiva (Practica Dirigida)
Algoritmo y Estructura de Datos Ing. Raúl Jimenez Drago

Facultad de Ingeniería Mecatrónica

Práctica Dirigida

Algoritmo y Estructura de Datos

Ing. Raúl Jimenez Drago

Facultad de Ingeniería Mecatrónica

Estructura Condicional

Algoritmo y Estructura de Datos

Ing. Raúl Jimenez Drago

Mayor INICIO LEER( A. B) Mayor ← A SI( B > A )ENTONCES Mayor ← B FIN-SI ESCRIBIR( Mayor ) FIN Algoritmo y Estructura de Datos Ing. B. ALGORITMO Ejemplo1 VARIABLES ENTERO: A.Facultad de Ingeniería Mecatrónica Estructura Condicional Simple Ingrese 2 números enteros y visualice el mayor de los 2 números ingresados. Raúl Jimenez Drago .

Mayor INICIO LEER(A. B. B) SI( A > B )ENTONCES Mayor ← A SINO Mayor ← B FIN-SI ESCRIBIR(Mayor) FIN Algoritmo y Estructura de Datos Ing. ALGORITMO Ejemplo1 VARIABLES ENTERO: A.Facultad de Ingeniería Mecatrónica Estructura Condicional Doble Calcular el mayor valor de 2 números enteros. Raúl Jimenez Drago .

Algoritmo y Estructura de Datos Ing. Si su edad es mayor a 17. sino ingresará a la Escuela de suboficiales. Ingrese por teclado el tiempo que demora en recorrer 1500 metros un atleta.Facultad de Ingeniería Mecatrónica Actividad Propuesta 2 1. Raúl Jimenez Drago . edad. una persona que postula a la Escuela deberá ingresar su nombre. Se están solicitando a la población postular a la Escuela de las FFAA. tiene una talla mínima de 1.70 y estudios superiores. talla y estudios realizados. podrá ingresar. 2. sino visualice un mensaje “Prepararse más”. visualice un mensaje “Atleta a competir en la Olimpiada” si la marca mínima es 3 minutos.

Raúl Jimenez Drago .Facultad de Ingeniería Mecatrónica Estructura Condicional Múltiple (SI-SINO-FINSI) Algoritmo y Estructura de Datos Ing.

Facultad de Ingeniería Mecatrónica Estructura Condicional Múltiple Ingrese 3 números enteros y visualice el mayor de los 3 números ingresados. Mayor INICIO LEER( A. Raúl Jimenez Drago . C) SI( A>B AND A>C ) ENTONCES Mayor ← A SINO SI( B>A AND B>C ) ENTONCES Mayor ← B SINO Mayor ← C FIN-SI ESCRIBIR( Mayor ) FIN Algoritmo y Estructura de Datos Ing. C. B. B. ALGORITMO Ejemplo1 VARIABLES ENTERO: A.

Raúl Jimenez Drago . Visualice el nuevo valor.Facultad de Ingeniería Mecatrónica Estructura Condicional Múltiple Ingrese un número entero. si es mayor a 20 elevar a potencia par. ALGORITMO Ejemplo2 VARIABLES ENTERO: N INICIO LEER( N ) SI( N < 10) ENTONCES N ← N + 10 SINO SI( N <= 20) ENTONCES N ← N *2 SINO N←N*N FIN-SI ESCRIBIR( N ) FIN Algoritmo y Estructura de Datos Ing. si está entre 11 a 20 multiplique por dos. si es menor a 10 súmele 10 unidades.

Raúl Jimenez Drago .Facultad de Ingeniería Mecatrónica Estructura Condicional Múltiple Una empresa otorga bonificaciones de su haber básico según la categoría del trabajador. otras categorías 50. categoría B: 200. categoría A: 250. categoría C: 120. ALGORITMO Ejemplo3 VARIABLES CADENA: REAL: Categoria Bonificacion LEER(Categoria) SI (Categoria = “A”) ENTONCES Bonificacion ← 250 SINO SI (Categoria = “B”) ENTONCES Bonificacion ← 200 SINO SI (Categoria = “C”) ENTONCES Bonificacion ← 120 SINO Bonificacion ← 50 FIN-SI ESCRIBIR( Bonificacion ) INICIO FIN Algoritmo y Estructura de Datos Ing.

dependiendo de su nota se ubicará en una de las siguientes categorías: PROMEDIO 18 – 20 15 – 17 11 – 14 0 -10 CATEGORÍA Excelente Bueno Regular Malo Algoritmo y Estructura de Datos Ing. Raúl Jimenez Drago .Facultad de Ingeniería Mecatrónica Actividad Propuesta 3 1. Se van a publicar la nota de un alumno.

Raúl Jimenez Drago .Facultad de Ingeniería Mecatrónica Estructura Condicional Selectiva (CASO – FIN CASO) Algoritmo y Estructura de Datos Ing.

Raúl Jimenez Drago .-. Operador) CASO ( Operador ) SEA „+‟ : Resultado ← A + B „-‟ : Resultado ← A – B „*‟ : Resultado ← A * B „/‟ : SI( B <> 0 )ENTONCES Resultado ← A DIV B SINO: Resultado ← 0 FIN-SI FIN-CASO ESCRIBIR( Resultado ) FIN Algoritmo y Estructura de Datos Ing. ALGORITMO Ejemplo2 VARIABLES ENTERO A. B. B. luego muestre el resultado de operar los 2 números.Facultad de Ingeniería Mecatrónica Estructura Condicional Selectiva Ingrese 2 números y una operación matemática realizar (+.*./). Resultado CARÁCTER Operador INICIO LEER (A.

2.etc).. Tipo de Tarjeta Recargo Visa Electron ( E ) 0% VISA ( V ) 5% MasterCard ( M ) 7% Algoritmo y Estructura de Datos Ing. sabiendo que existe un recargo según tipo de tarjeta de crédito con la que se paga la compra. martes.Facultad de Ingeniería Mecatrónica Actividad Propuesta 4 1. ( lunes... Escriba un programa que lea un número desde el teclado entre 1 y 7 e imprima el nombre del día de semana correspondiente. Raúl Jimenez Drago . Calcular el total a pagar por una compra.

Raúl Jimenez Drago .Facultad de Ingeniería Mecatrónica Estructura Repetitiva Mientras – Fin Mientras (While) Algoritmo y Estructura de Datos Ing.

Raúl Jimenez Drago .Facultad de Ingeniería Mecatrónica Estructura Mientras – Fin Mientras Ejemplo 3 : Calcule y visualice la suma de todos los números de 2 cifras positivos. SUMA INICIO N ← 10 SUMA ← 0 MIENTRAS ( N <= 99 ) HACER SUMA ← SUMA + N N←N+1 FIN-MIENTRAS ESCRIBIR(“LA SUMA ES:”. SUMA) FIN Algoritmo y Estructura de Datos Ing. ALGORITMO Ejemplo3 VARIABLES ENTERO N.

D. Raúl Jimenez Drago . ALGORITMO Ejemplo4 VARIABLES ENTERO N.Facultad de Ingeniería Mecatrónica Estructura Mientras – Fin Mientras Ejemplo 4: Calcule y visualice los divisores de un número entero. Resto INICIO LEER( N ) D←1 MIENTRAS ( D <= N ) HACER Resto ← N MOD D SI ( Resto = 0 ) ENTONCES ESCRIBIR( D ) FIN-SI D←D+1 FIN-MIENTRAS FIN Algoritmo y Estructura de Datos Ing.

Raúl Jimenez Drago Algoritmo y Estructura de Datos . SUMA) FIN Ing. SUMA  0 MIENTRAS ( N <= 9 ) HACER SUMA ← SUMA + X X ← X + (2N – 1) N←N+1 FIN-MIENTRAS ESCRIBIR(“LA SUMA ES:”. SUMA) FIN ALGORITMO Ejemplo5c VARIABLES ENTERO X. SUMA) FIN Facultad de Ingeniería Mecatrónica ALGORITMO Ejemplo5b VARIABLES ENTERO N. SUMA INICIO X ← 1 . N ← 1 . R. R. SUMA INICIO R ← 0 . N ← 2 . SUMA INICIO N ←1 SUMA  0 MIENTRAS ( N <= 10 ) HACER SUMA ← SUMA + ( N ↑ 2 ) N←N+1 FIN-MIENTRAS ESCRIBIR(“LA SUMA ES:”.Estructura Mientras Ejemplo 5: Calcular y visualizar la suma de los elementos de la siguiente serie : S ← 1 + 4 + 9 + 16 + 25 + … + 100 ALGORITMO Ejemplo5a VARIABLES ENTERO N. SUMA  0 MIENTRAS ( R <= 100 ) HACER SUMA ← SUMA + R R←R+N N←N+2 FIN-MIENTRAS ESCRIBIR(“LA SUMA ES:”.

Cifras ) FIN Algoritmo y Estructura de Datos Ing. Cifras INICIO LEER( N ) Cifras ← 0 MIENTRAS ( N <> 0 ) HACER Cifras ← Cifras + 1 N ← N DIV 10 FIN-MIENTRAS ESCRIBIR(“Numero Cifras:”. ALGORITMO Ejemplo6 VARIABLES ENTERO N.Estructura Mientras – Fin Mientras Facultad de Ingeniería Mecatrónica Ejemplo 6: Ingrese un número entero y luego visualice el número de cifras que lo componen. Raúl Jimenez Drago .

Raúl Jimenez Drago .Facultad de Ingeniería Mecatrónica Estructura Repetitiva Repetir – Hasta_Que Algoritmo y Estructura de Datos Ing.

Raúl Jimenez Drago .Facultad de Ingeniería Mecatrónica Estructura Repetir – Hasta_Que Ejemplo 1: Visualizar los 5 primeros números naturales. ALGORITMO Ejemplo1 VARIABLES ENTERO : N INICIO N ←1 REPETIR ESCRIBIR( N ) N←N+1 HASTA_QUE ( N > 5 ) FIN Algoritmo y Estructura de Datos Ing.

Raúl Jimenez Drago .Facultad de Ingeniería Mecatrónica Estructura Repetir – Hasta_Que Ejemplo 2 : Visualizar todos los números pares de 2 cifras. ALGORITMO Ejemplo2 VARIABLES ENTERO : N INICIO N ← 10 REPETIR ESCRIBIR( N ) N←N+2 HASTA_QUE N > 98 FIN Algoritmo y Estructura de Datos Ing.

Raúl Jimenez Drago .Facultad de Ingeniería Mecatrónica Estructura Repetitiva Para – Fin Para Algoritmo y Estructura de Datos Ing.

ALGORITMO Ejemplo2 VARIABLES ENTERO N INICIO PARA N ← 10 HASTA 1 DE -1 ESCRIBIR( N ) FIN-PARA FIN Algoritmo y Estructura de Datos Ing. Raúl Jimenez Drago .Facultad de Ingeniería Mecatrónica Estructura Para – Fin Para Ejemplo 2 : Imprimir los 10 primeros números naturales pero en forma descendente.

A.Facultad de Ingeniería Mecatrónica Estructura Para – Fin Para Ejemplo 3 : Visualizar todos los números de 2 cifras compuestos por cifras diferentes. B INICIO PARA N ← 10 HASTA 99 A ← N DIV 10 B ← N MOD 10 SI ( A <> B ) ENTONCES ESCRIBIR( N ) FIN-SI FIN-PARA FIN Algoritmo y Estructura de Datos Ing. Raúl Jimenez Drago . ALGORITMO Ejemplo3 VARIABLES ENTERO N.

Divisor INICIO LEER( N ) PARA Divisor ← 1 HASTA N SI N MOD Divisor = 0 Entonces ESCRIBIR( Divisor) FIN-SI FIN-PARA FIN Algoritmo y Estructura de Datos Ing.Facultad de Ingeniería Mecatrónica Estructura Para – Fin Para Ejemplo 4: Ingrese un número y luego visualice todos sus divisores. Raúl Jimenez Drago . ALGORITMO Ejemplo4 VARIABLES ENTERO N.

Raúl Jimenez Drago . Algoritmo y Estructura de Datos Ing.Facultad de Ingeniería Mecatrónica PRACTICA GRUPAL Desarrolle el pseudocodigo de los ejercicios que presenta su docente en la siguiente diapositiva.

Raúl Jimenez Drago . En una oficina de empleos categorizar a los postulantes en función al sexo y la edad de acuerdo a lo siguiente: • Si la persona es de sexo femenino: categoría FA si tiene menos de 20 años y FB caso contrario. Diseñe un programa que lea la temperatura de un día e imprima el tipo de clima de acuerdo a la siguiente tabla : Temperatura Promedio (TP) TP<=10 10<TP<=20 20<TP<=30 TP>30 Algoritmo y Estructura de Datos Tipo de Clima Frió Nublado Caluroso Trópico Ing. • Si la persona es de sexo masculino: categoría MA si tiene menos de 30 años y MB caso contrario 2. desarrolle: 1.Facultad de Ingeniería Mecatrónica Mediante el método SI_SINO-FIN-SI y CASO_FIN-CASO.

(Enero.. De acuerdo a la siguiente tabla: TIPO ENFERMEDAD COSTO 1 122 2 150 3 200 4.etc).Facultad de Ingeniería Mecatrónica 3. Escriba un programa que lea un número desde el teclado entre 1 y 12 e imprima el nombre del mes del año correspondiente.. Algoritmo y Estructura de Datos Ing. Febrero.. Raúl Jimenez Drago . el costo depende del tipo de enfermedad. Diseñe un programa que calcule el costo de un paciente.

Problema 2 : Calcular y visualizar el valor de la siguiente serie : S ← 2 + 4 + 6 + 8 + … + 98 Problema 3 : Generar y visualizar la siguiente serie : S ← 1+2+3/2+4/3+5/4+…+10/9 Problema 4 : Ingrese un número entero y calcule la suma de las cifras del número. Raúl Jimenez Drago .Facultad de Ingeniería Mecatrónica Estructura Repetitiva Problema 1: Calcule y visualice la suma de los todos los números impares de 3 cifras. Algoritmo y Estructura de Datos Ing.