You are on page 1of 19

Ethernet over

Multiprotocol Label
Switching
© 2001, Cisco Systems, Inc.
Objectives

Upon completing this lesson, you will be


able to:
• Configure EoMPLS on the 7600
• Monitor and troubleshoot EoMPLS on the
7600 platform

© 2001, Cisco Systems, Inc. SPMAP v1.0—Module 10-2


Ethernet over MPLS

© 2001, Cisco Systems, Inc. MPLS v1.0—5-3


Service Provider Market
Opportunity

Positioning:
• Small businesses to Fortune 500 customers
• Private network “metro” requirements
– Transparent LAN services
– IP services
• Ease of provisioning

© 2001, Cisco Systems, Inc. SPMAP v1.0—Module 10-4


Functional Characteristics

EoMPLS provides service providers:


• Layer 2 and Layer 3 provisioning flexibility
• Function:
– No Layer 2 destination MAC address lookup
– No Layer 2 address learning
• Similar to Frame Relay:
– VC-based
• FIB table prebuilt
• Originally based on Martini drafts
• Moving towards Vkompella draft

© 2001, Cisco Systems, Inc. SPMAP v1.0—Module 10-5


EoMPLS Services

• It has per-customer dedicated physical ports.


• It has multiple EoMPLS VCs per physical port.
• EoMPLS VCs are point-to-point and based on Martini
drafts.
• EoMPLS is moving towards point-to-multipoint, based
on the Vkompella draft.
• Each EoMPLS VC traverses the same LSP.
• LER determines FEC, so other MPLS routers have no
knowledge of the Layer 2 transport VCs.

© 2001, Cisco Systems, Inc. SPMAP v1.0—Module 10-6


Technical Requirements

• Label imposition/disposition
– Imposition: PE router that translates Layer 2
PDUs into MPLS labels
– Disposition: PE router that translates MPLS
labels to layer 2 PDUs

© 2001, Cisco Systems, Inc. SPMAP v1.0—Module 10-7


Technical Requirements (cont.)

• CoS mapping
– QOS based on 3-bit EXP field
– EXP bits set in both tunnel VC and tunnel
labels
– Tunnel label popped at PHP router
– Static EXP bits (CAR, MQC)
– Dynamic EXP bits (IP Precedence, DSCP,
802.1q/802.1p)

© 2001, Cisco Systems, Inc. SPMAP v1.0—Module 10-8


MPLS VC Setup

Targeted LDP Session

PE1 P1 P2 P3 PE2

Company X
Company X

• PE1 starts a remote directed LDP session with PE2.


• PE1 allocates a local VC label and binds it to the VC
ID configured under the ingress interface.

© 2001, Cisco Systems, Inc. SPMAP v1.0—Module 10-9


MPLS VC Setup (cont.)

1 VC Label Mapping

2 VC Label Mapping

PE1 P1 P2 P3 PE2

Company X
Company X

• PE1 sends PE2 a label mapping message for the VC label.


• PE2 replies with label mapping message including VC label.
• The process is unidirectional.

© 2001, Cisco Systems, Inc. SPMAP v1.0—Module 10-10


EoMPLS Configuration Tasks

Mandatory:
• Define VLAN and Loopback interfaces
• Enable LDP discovery through targeted
hellos
• Layer 2 transport routing command
Optional:
• MPLS router ID (advisable)
• CoS to MPLS EXP mapping
• Targeted hello access list
© 2001, Cisco Systems, Inc. SPMAP v1.0—Module 10-11
EoMPLS Configuration
Commands
Router(config-if)#
tag-switching ip

• Specify MPLS cloud ingress interface of


PE to run MPLS.
Router(config)#
mpls label protocol ldp

• Specify PE router to run LDP (default


operation is TDP).

© 2001, Cisco Systems, Inc. SPMAP v1.0—Module 10-12


EoMPLS Configuration
Commands (cont.)
Router(config)#
mpls ldp router-id loopback0

• Specify MPLS router ID.


Router(config)#
mpls ldp discovery targeted-hello accept from vlan-
edge-acl

• Configure PE router to accept a targeted


LDP hello.

© 2001, Cisco Systems, Inc. SPMAP v1.0—Module 10-13


EoMPLS Configuration
Commands (cont.)

Router(config-if)#
mpls l2transport route destination vc-id

• Create a Level 2 transport host route to


the destination PE.

Level 2 transport is unidirectional.

© 2001, Cisco Systems, Inc. SPMAP v1.0—Module 10-14


EoMPLS Example

!
mpls label protocol ldp
interface Vlan25
!
no ip address
interface Loopback0
mpls l2transport route 10.1.1.2 50
ip address 10.1.1.1
255.255.255.255 !
! interface Vlan60
interface GigabitEthernet4/1 no ip address
ip address 10.4.1.2 255.255.0.0 mpls l2transport route 10.1.1.2 1021
no negotiation auto !
tag-switching ip

© 2001, Cisco Systems, Inc. SPMAP v1.0—Module 10-15


EoMPLS Show Commands

Line card show commands


router#
show mpls l2transport [imposition | disposition] [detailed] [[<vc-id> | <vc-
id-min>] <vc-id-max>]

Control plane show commands


router#
show mpls l2transport vc [detailed] [[<vc-id> | <vc-id-
min>] <vc-id-max>]

show mpls l2transport summary

© 2001, Cisco Systems, Inc. SPMAP v1.0—Module 10-16


EoMPLS Debug Commands

• Debug control of traffic transported between Layer 2


VLAN and MPLS.
router#
debug mpls l2transport vlan control

• Debug label imposition and disposition.


router#
debug mpls l2transport vlan distributed

© 2001, Cisco Systems, Inc. SPMAP v1.0—Module 10-17


Any Transport over MPLS

• It provides the ability to transport


Layer 2 traffic across packet networks.
• It is a scalable architecture based on label
stacking—allows muxing of connections.
• A standards-based open architecture allows
extensibility to many transport types.

© 2001, Cisco Systems, Inc. SPMAP v1.0—Module 10-18


Summary

After completing this lesson, you will be


able to:
• Configure EoMPLS on the 7600
• Monitor and troubleshoot EoMPLS on the
7600 platform

© 2001, Cisco Systems, Inc. SPMAP v1.0—Module 10-19