ING. JESSICA M.

FIESTAS YARLEQUE
PROGRAMACION
DIGITAL



 1.1 ¿Qué es la programación
Es la acción de escribir programas de
computación con el fin de resolver un
determinado problema.
Antes de comenzar a programar es necesario
conocer los conceptos de dato, constante,
variable.

1.2 Datos
Un dato es la representación de un hecho, evento
o elemento del mundo real.

1.3 Tipos de Datos:
- entero
- Real
- Carácter
- Cadena de caracteres
- Lógico

1.3.1 Datos de tipo entero.- Son números que no
tienen componentes fraccionarios o decimales. Pueden ser negativos o positivos.
ejemplo: -2 25000
30 -1250

1.3.2 Datos de tipo real.- son números que tienen punto decimal y pueden ser
positivos y negativos.
ejemplo 801.3 3550.4
-3.7 -200.1

1.3.3 Datos de tipo carácter .- son simbolos que el computador reconoce. Un carácter
puede ser
una letra ( A,B,….Z, a,b,……z) un digito (1,2,…..9) o un simbolo ( !, @, #, $,%, &,+,-…)

1.3.4 Datos de tipo de cadena de caracteres .- son datos que contienen una sucesion de
caracteres delimitada por comillas.
ejemplo “Simon Bolivar”
“31 de Diciembre del 2011”

1.3.5 Datos de tipo Logico .- Son datos que solo pueden tomar uno de dos valores
verdadero o falso. Se conocen tambien como datos de tipo booleano. Este tipo de
datos se utiliza para representar las alternativas (si/no) a determinadas condiciones.



1.4 Constantes y Variables
Los datos que maneja un programa pueden ser constantes o
variables.

1.4.1 Constante.- es un valor o dato que no puede
cambiar en la ejecución de un programa. Las
constantes son valores fijos.
ejemplo:
Pi = 3.1416
mínimo = 20
Respuesta = Falso

1.4.2 Variable.- Es un valor o dato que puede cambiar
durante la ejecución de un programa. Una
variable representa una dirección o posición de
memoria donde se guarda un dato.
una variable tiene dos atributos: nombre que lo
identifica y el tipo de dato que describe su uso.



SENTENCIAS DE CONTROL

1.- SENTENCIA SI (en inglés if-then o bien IF-THEN )
SI (condicion) ENTONCES
sentencia_1
sentencia_2
:
sentencia_n
FIN SI
Si la condición es verdadera, entonces se ejecutarán en orden las sentencias
delimitadas por el FIN SI.
Si la condición es falsa o no se cumple, el punto de algoritmo ejecutará la
sentencia posterior al FIN SI.

Ejemplo : Una vez leidos b y c, si c es mayor que b, entonces asignar a b el
valor de c y a continuación asignar a c el valor del doble de b.
INICIO
leer b
leer c
SI (c > b) ENTONCES
b <-- c
c <-- 2 * b
FIN SI
FIN



2.- SENTENCIA SI - SINO

SI (condicion) ENTONCES
sentencia(s)
SINO
sentencia(s)
FIN SI

Si la condición es verdadera, entonces se ejecutarán las sentencias
anteriores al SINO.
Si la condición es falsa, el punto de algoritmo ejecutará las
sentencias posteriores al SINO.

Ejemplo :
SI (a != b) ENTONCES
imprimir("a es distinto de b")
SINO
imprimir("a es igual b ")
FIN SI

SENTENCIA DE SELECCIÓN
SELECCION (variable)
constante_1 : sentencia(s)
constante_2 : sentencia(s)
:
:
constante_n : sentencia(s)
FIN SELECCION
Para eliminar el problema de tener muchas condiciones "SI
(variable == valor_i) ENTONCES", se agrupan las
instrucciones, en función del valor que tome cierta variable.

CICLOS ITERATIVOS

SENTENCIA MIENTRAS (WHILE)
MIENTRAS (condicion) HACER
sentencia(s)
FIN MIENTRAS
Mientras se cumpla la condición, se ejecutarán las sentencias
anteriores al FIN MIENTRAS. Además se cumple, que se puede entrar al
ciclo, sólo si se cumple la condición. Finalmente, es muy importante
determinar la variación de alguna variable, para quebrar la condición y
no convertir al ciclo iterativo, en un "loop" o ciclo infinito.

SENTENCIA PARA
PARA variable <-- valorInicial HASTA valorFinal HACER
sentencia(s)
FIN PARA
Esta sentencia es útil para hacer variar el valor de una variable entera,
permitiendo su inicialización y la determinación del último valor que
puede tomar dentro del ciclo.

printf():
El enunciado printf() es una función de biblioteca que
despliega información en la
pantalla. El enunciado printf puede desplegar un simple
mensaje de texto o un mensaje y el valor de una o más
variables del programa.

Ej: printf(“este es un simple comentario”);
printf(“El cuadrado de %d es igual a %d”,a,a*a);

scanf():
El enunciado scanf() es otra función de biblioteca. Ella
lee datos desde el teclado y
asigna los datos a una o más variables del programa.
Ej: scanf(“%d”,&a);
scanf(“%d %d”,&a,&b);


VISUAL BASIC

1. Declaración de variables
Antes de utilizar un dato en nuestros programas, es necesario
declararlo. Este dato puede ser variable, con lo cual podrá cambiar de
valor a lo largo del programa, o constante, en cuyo caso su valor será el
mismo a lo largo de todo el programa y no podrá modificarse. La forma
de declarar las variables es la siguiente:
Dim| Public| Static nombre_variable As tipo

Dim: Al declarar una variable con esta palabra estamos diciendo que la
variable será local al ámbito en que se declara. Puede ser dentro de un
procedimiento o dentro de un formulario; de esta forma no será
accesible desde los demás procedimientos o formularios.
Public: Las variables declaradas serán publicas y podrán estar accesibles
desde todos los formularios de la aplicación.
Static: Con esta forma de declarar variables conseguiremos que las
variables locales no se creen y se destruyan al entrar y salir de los
procedimientos donde fueron declaradas sino que se mantenga su valor
durante todo el periodo de ejecución de la aplicación. De esta forma al
entrar en algún procedimiento las variables recuerdan el valor que
tenían cuando se salió de él.
Los tipos de variables que se pueden utilizar en Visual Basic se
muestrean en la tabla siguiente.


COMENTARIO
BOOLEAN Sólo admite 2 valores: TRUE o FALSE
BYTE admite valores enteros entre 0 y 255
INTEGER admite valores enteros entre -32768 y 32767
LONG valores enteros entre –2.147.483.648 y 2.147.483.647
SINGLE admite valores decimales con precisión simple
DOUBLE admite valores decimales de doble precisión
CURRENCY válido para valores de tipo moneda
STRING cadenas de caracteres
DATE fechas, permite operar con ellas
2. Estructuras de selección
Hay ocasiones en las que un programa debe realizar
distintas acciones dependiendo del valor de una
condición. En estos casos, disponemos de 2 tipos de
sentencias para realizar selecciones dependiendo del
valor de una expresión o de una variable:

2.1. Sentencia IF … THEN … ELSE
La estructura general de esta sentencia es la
siguiente:
If condición then
bloque de sentencias a realizar si la condición es
cierta
Else
bloque de sentencias a realizar si la condición es
falsa
End If

Supongamos que queremos crear un programa
que nos diga si somos mayores o menores de
edad. El código de dicho programa sería el
siguiente:
If edad < 18 Then
print “menor de edad”
Else
print “mayor de edad”
End If


2.2. Estructura SELECT CASE
Esta sentencia permite realizar operaciones diferentes dependiendo
del valor de una variable. Su estructura general es la siguiente:
Select Case dato
Case valor1
bloque de sentencias
case valor2
bloque de sentencias
Case valor3
bloque de sentencias
Case Else
bloque de sentencias, se ejecutan si no se cumple
ninguno
de los valores anteriores
End Select

En esta construcción, dependiendo del valor de la variable dato se
ejecutará un bloque de sentencias diferente. Los valores que
podemos colocar en lugar de valor1, valor2, valor3 no sólo se
limitan a valores constantes como números y cadenas de texto, sino
que podemos comparar con un número como podemos ver en el
siguiente ejemplo