You are on page 1of 37

Ing.

Hctor Umeres CONFIGURACIN DE ROUTER CISCO 1


CONFIGURACION DE
UN ROUTER CISCO
Autor : Ing. Hctor Umeres A.
E-mail : H_umeres@hotmail.com
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 2
Modos EXEC Usuario, Privilegiado
y Global
Press RETURN to get started!

User Access Verification

Router > Modo Usuario
Router > enable
Router # Modo Privilegiado
Router # configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config) # Modo Global
Router(config) # exit
Router # disable
Router >
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 3
Configuracin del Nombre del
Router
1) Ingreso en Modo Privilegiado:
Router > enable
Router # config terminal
Router(config) #

2) Configuracin del Nombre del Router:
Router # config terminal
Router(config) # hostname Router_A
Este comando no admite espacios en
blanco dentro del nombre del dispositivo.
Tenga en cuenta que algunas configuraciones
son sensibles a maysculas y minsculas.
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 4
Configuracin de Password
(Modo Usuario)
Router > enable
Router # configure terminal
Router(config) # line console 0
Router(config-line) # password cisco
Router(config-line) # login
Router(config-line) # exit
Router(config) # exit
Router # copy running-config startup-config
Building configuration
[OK]

Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 5
Configuracin de Password
(Modo Usuario Remoto)
Router > enable
Router # configure terminal
Router(config) # line vty 0 4
Router(config-line) # password cisco
Router(config-line) # login
Router(config-line) # exit
Router(config) # exit
Router # copy running-config startup-config
Building configuration
[OK]

Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 6
Configuracin de Password
(Modo Priveligiado)
Router # configure terminal
Router(config) # enable password class No Cifrado
Router(config) # exit
Router #

Router # configure terminal
Router(config) # enable secret class Cifrado
Router(config) # exit
Router #
Router # copy running-config startup-config
Building configuration
[OK]

Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 7
Configuracin de Password
Press RETURN to get started!

User Access Verification

Password: ****** Password Modo Usuario
Router>
Router> enable
Password: ****** Password Modo Privilegiado
Router#
Router# configure terminal
Enter configuration commands, one per line. End
with CNTL/Z.
Router(config)#
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 8
Configuracin del Puerto Eth 0 (LAN)
Router(config) # interface ethernet 0
Router(config-if) # ip address 192.168.10.1
255.255.255.0
Asigna la direccin IP y Mscara de subred
al Puerto Ethernet 0
Router(config-if) # no shutdown
Habilita Administrativamente al Puerto
Router(config-if) # exit
Router(config) # exit
Router #
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 9
Configuracin del Puerto Eth 1 (LAN)
Router(config-if) # interface ethernet 1
Router(config-if) # ip address 192.168.20.1
255.255.255.0
Asigna la direccin IP y Mscara de subred
al Puerto Ethernet 1
Router(config-if) # no shutdown
Habilita Administrativamente al Puerto
Router(config-if) # exit
Router(config) # exit
Router #

Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 10
Configuracin del Puerto Serial
(WAN)
Router(config-if) # interface serial 0
Router(config-if) # description Puerto WAN
Permite agregar un comentario del Administrador
sobre la Interfaz
Router(config-if) # ip address 200.100.11.1
255.255.255.0
Asigna la direccin IP y Mscara de subred al
PUERTO Serial 0 (WAN)

Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 11
Configuracin del Puerto Serial
(WAN)
Router(config-if) # clock rate 56000
En ste caso de Puertos Seriales que deben
cumplir tareas de DCE, es preciso configurar
el parmetro clock rate , indicando la
velocidad del Puerto en bps (Este parmetro
no se incluye en los puertos seriales DTE).
Router(config-if) # no shutdown
Router(config-if) # exit
Router(config) # exit
Router # copy running-config startup-config
Building configuration
[OK]
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 12
Router 2501
Un LAN
10 BASE-T
2 WAN
DB-60 (V.35)
Consola
RJ-45
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 13
Router 2501 / 02
Interfaces
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 14
Cable de Consola
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 15
Cable de Consola
(con adaptador RJ-45/db9)
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 16
Enlace LAN - WAN
E0
Eth 0

S0
Serial 0
200.100.11.1
IP Route
201.100.11.2

WAN
192.168.10.0/24

LAN
Red 200.100.11.0/24

192.168.10.1
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 17
Configuracin del Protocolo de
Enrutamiento
Router # config terminal
Router(config) # ip routing
Este comando habitualmente no es necesario
ya que el enrutamiento IP est habilitado por
defecto. Sin embargo, algunas versiones de
Cisco IOS no lo tienen habilitado por defecto.
Router(config) # exit
Router #
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 18
Configuracin del Protocolo de
Enrutamiento RIP
Router(config) # router rip
Router(config-router) # network 192.168.10.0
Router(config-router) # network 192.168.20.0
Router(config-router) # network 200.100.11.0
Router(config-router) # exit
Una vez activado el protocolo de enrutamiento
es preciso indicar las redes directamente conec-
tadas, es preciso que escuche para aprender rutas
a redes remotas.
Es preciso tener en cuenta que al tratarse de
protocolos classful (como es el caso de RIP, que
no transmiten las mscaras de subred al enviar
actualizaciones, slo se consideran las
direcciones de subred, no las subredes.

Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 19
Configuracin de Rutas Estticas
Router(config) #
ip route 200.100.11.0 255.255.255.0 201.100.11.2
Configura una Ruta Esttica con distancia administrativa 1
(valor por defecto). Donde, 201.100.11.0 es la RED WAN
y 201.100.11.2 es la Ruta Esttica (Gateway).
Router(config) #
ip route 200.100.11.0 255.255.255.0 201.100.11.2 30
Configura una Ruta Esttica con distancia administrativa de
30.
Router(config) # ip route 0.0.0.0 0.0.0.0 201.100.11.2
Configura una Ruta Esttica por defecto.
Router(config) # ^Z
Router # copy run start
Building configuration
[OK]
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 20
Configuracin de Rutas Estticas
172.16.1.0/24 172.16.3.0/24 172.16.5.0/24
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 21
Configuracin de Rutas Estticas
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 22
Encapsulado
Por defecto, los routers estn configurados con HDLC
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 23
Configuracin del Router 2600
Por tratarse de dispositivos modulares , la configuracin de
los Routers Cisco 2600 requiere algunas variaciones en lo
que se refiere a la configuracin y verificacin de las interfa-
ces, ya que hay que considerar la inclusin del ID del slot en
el ID del puerto.
Router # configure terminal
Router(config) # interface fast-ethernet 0/0
Router(config-if) # ip address 192.5.5.1 255.255.255.0
Router(config-if) # no shutdown
Router(config-if) # exit
Router(config) # exit
Router #
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 24
Router 2600
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 25
Interfaces Router 2600
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 26
Configuracin del Puerto Serial
(WAN)
Router # configure terminal
Router(config) # interface serial 0/0
Router(config-if) # ip address 201.100.11.1 255.255.255.0
Router(config-if) # clock rate 64000 Para el DCE
Router(config-if) # no shutdown
Router(config-if) # exit
Router(config) # exit
Router # copy running-config startup-config
Building configuration
[OK]

Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 27
Mostrar la Configuracin
Router # show interface eth 0
Muestra parmetros asociados al puerto Ethernet 0
Router # show interface serial 0
Muestra parmetros asociados al puerto Serial 0
Router # show interfaces
Muestra parmetros asociados a todos los puertos
Router # show ip route
Muestra el contenido de la Tabla de Enrutamiento
Router # show ip interface brief
Muestra parmetros asociados a todos los puertos
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 28
Mostrar la Configuracin
Router # show protocols
Muestra los protocolos aociados a los puertos
Router # show ip protocols
Muestra el protocolo de Ruteo usado
Router # show running-config
Muestra el File de Configuracin que est activo en el
Router (RAM).
Router # show startup-config
Muestra el File de Configuracin que est grabado en
la NVRAM.
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 29
Mostrar Interfaces
(Nombres de Interfaces y estados)
GAD # show ip interface brief
Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 172.16.0.1 YES manual up up

Serial0/0 172.17.0.1 YES manual up up

Serial0/1 unassigned YES administ down down

GAD#
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 30
Mostrar los estados de los Protocolos
GAD# show protocols
Global values:
Internet Protocol routing is enabled
FastEthernet0/0 is up, line protocol is up
Internet address is 172.16.0.1/16
Serial0/0 is up, line protocol is up
Internet address is 172.17.0.1/16
Serial0/1 is administratively down, line protocol is
down
GAD#
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 31
Mostrar los Protocolos de Ruteo
GAD# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 172.16.0.0/16 is directly connected, FastEthernet0/0
C 172.17.0.0/16 is directly connected, Serial0/0
R 172.18.0.0/16 [120/1] via 172.17.0.2, 00:00:22, Serial0/0
GAD#
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 32
Copy , Ping y Telnet
Router # copy runnig-config startup-config
Copia la configuracin del Router de la RAM a la
NVRAM (copy run start)
Router # ping 192.168.10.12
Verifica la conexin fsica y lgica
Router # telnet Router_B
Verifica la conexin fsica, lgica y aplicacin

Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 33
Ip host y Telnet
E0
E0
S0
S0
192.168.1.0 /24 192.168.2.0 /24
192.168.3.8 /30
Router_A
Router_B
192.168.1.1
192.168.2.1
.9
.10
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 34
Ip host y Telnet
Router_A # config term
Router_A (config) # ip host Router_A 192.168.1.1
Router_A (config) # ip host Router_A 192.168.3.9
Router_A (config) # ip host Router_B 192.168.2.1
Router_A (config) # ip host Router_B 192.168.3.10
Router_A (config) # end
Router_A # telnet Router_B

User Accesess Verification

Router_B> show hosts

Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 35
Router Cisco 805
LAN ETH 0
10BASE-T
PUERTO DE
CONSOLA
(RJ-45)
PUERTO
WAN
SERIAL 0
POWER
24V
MDI / MDI-X
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 36
Conexin WAN
Ing. Hctor Umeres CONFIGURACIN DE ROUTER CISCO 37
ING Hctor Umeres A.
E-Mail: H_umeres@hotmail.com