You are on page 1of 83

Chapter 5

RIP version 1

CIS 82 Routing Protocols and Concepts


Rick Graziani
Cabrillo College
graziani@cabrillo.edu

Last Updated: 3/10/2009


Note
 This presentation will be updated prior to March. 25, 2008
 The audio of the lecture for this presentation will be available on
my web site after March. 25, 2008

 My web site is www.cabrillo.edu/~rgraziani.


 For access to these PowerPoint presentations and other
materials, please email me at graziani@cabrillo.edu.

2
For further information
 This presentation is an
overview of what is
covered in the
curriculum/book.
 For further explanation
and details, please read
the chapter/curriculum.

 Book:
 Routing Protocols
and Concepts
 By Rick Graziani and
Allan Johnson
 ISBN: 1-58713-206-0
 ISBN-13: 978-58713-
206-3

3
Topics
 RIPv1: Distance Vector, Classful  Automatic Summarization
Routing Protocol  Modified Topology B
 Background and Perspective  Boundary Routers and
 RIPv1 Characteristics and Automatic Summarization
Message Format  Processing RIP Updates
 RIP Operation  Sending RIP Updates
 Advantages and
 Basic RIPv1 Configuration Disadvantages of Automatic
 RIPv1 Scenario A Summarization
 Enable RIP: router rip  Default Route and RIPv1
Command  Modified Topology C
 Specifying Networks  Propagating the Default Route
 Verification and Troubleshooting in RIPv1
 Verifying RIP: show ip route
 Verifying RIP: show ip
protocols
 Verifying RIP: debu ip rip
 Passive Interfaces
4
RIPv1

 Download Packet Tracer Topology: cis82-RIPv1-A-student.pkt

5
RIPv1: A Distance Vector,
Classful Routing Protocol
 Background and Perspective
 RIPv1 Characteristics and Message Format
 RIP Operation
RIPv1: Distance Vector, Classful Routing Protocol

 Why learn RIP?


 Still in use today.
 Help understand fundamental concepts and comparisons of
protocols
 Classful (RIPv1) vs classless (RIPv2)

7
Background and Perspective

 RIP is not a protocol “on the way out.”


 In fact, an IPv6 form of RIP called RIPng (next generation) is now
available..
8
Background and
Perspective

 Charles Hedrick wrote RFC 1058 in 1988, in which he documented


the existing protocol and specified some improvements.
 RFC 1058 can be found at http://www.ietf.org/rfc/rfc1058.txt
9
RIPv1 Characteristics and Message Format

 RIP characteristics:
 Distance Vector or Link State?
 Distance vector routing protocol.
 Metric?
 Hop count
 Maximum Hop count?
 Greater than 15 are considered unreachable.
 Routing table updates are broadcasted every…?
10
 30 seconds. (RIPv2 uses multicasts)
RIPv1 Characteristics and Message Format

11
RIPv1 Characteristics and Message Format

12
IP Address Classes and Classful Routing

No subnet
mask

 RIPv1:
 Classful routing protocol.
 Does not send subnet mask in update.

13
IP Address Classes and Classful Routing
Routing Table
?
Network-add/mask

RIP Update
network-add
/16

 R2 receives an RIP update with a network address.


 R2 adds the network address and mask to the routing table.
 A router either uses the subnet mask: (discussed later)
 Local interface or
 Default classful subnet mask
 Because of this limitation, RIPv1 networks cannot be discontiguous,
nor can they implement VLSM.
14
Basic RIPv1 Configuration
 RIPv1 Scenario A
 Enable RIP: router rip Command
 Specifying Networks
RIPv1 Scenario A

 RIPv1 is a classful or classless routing protocol?


 Classful
 How many classful networks are there and of what class?
 5 Class C network addresses.
 We will see that the class of the network is used by RIPv1 to determine the
subnet mask. 16
Enabling RIP: router rip Command
R1# conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)# router ?
bgp Border Gateway Protocol (BGP)
egp Exterior Gateway Protocol (EGP)
eigrp Enhanced Interior Gateway Routing Protocol (EIGRP)
igrp Interior Gateway Routing Protocol (IGRP)
isis ISO IS-IS
iso-igrp IGRP for OSI networks
mobile Mobile routes
odr On Demand stub Routes
ospf Open Shortest Path First (OSPF)
rip Routing Information Protocol (RIP)
R1(config)# router rip
R1(config-router)#

 What routing protocols does this router support? (PT is limited)


 Configure RIP… 17
Enabling RIP: router rip Command
R1# conf t
R1(config)# router rip
R1(config-router)# network 192.168.1.0
R1(config-router)# network 192.168.2.0
R1(config-router)# exit
R1(config)# no router rip

 no router rip
 To remove the RIP routing process from a device
 Stops the RIP process
 Erases all existing RIP configuration commands.

18
Specifying Networks
Router(config-router)# network
directly-connected-classful-
network-address

 To enable RIP routing for a network, use the network command in


router configuration mode
 Enter the classful network address for each directly connected
network.

19
Specifying Networks
R1(config)# router rip
R1(config-router)# network 192.168.1.0
R1(config-router)# network 192.168.2.0

RIP Update

 The network command performs the following functions:


 Enables RIP on all interfaces that belong to a specific network.
 Associated interfaces will now both send and receive RIP
updates.
 Advertises the specified network in RIP routing updates sent to
other routers every 30 seconds (no mask). 20
Specifying Networks Only directly connected classful network
addresses!
R1(config)# router rip
R1(config-router)# network 192.168.1.0
R1(config-router)# network 192.168.2.0

R2(config)# router rip


R2(config-router)# network 192.168.2.0
R2(config-router)# network 192.168.3.0
R2(config-router)# network 192.168.4.0

R3(config)# router rip


R3(config-router)# network 192.168.4.0
R3(config-router)# network 192.168.5.0

 Configure RIP for all three routers


 What happens if you enter a subnet or host IP address? (Try it)
 IOS automatically converts it to a classful network address.
 For example, if you enter the command network 192.168.1.32, the
router will convert it to network 192.168.1.0. 21
Only directly connected classful network
addresses!

22
Administrative Distance
R3# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, R = RIP
<some output omitted>
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set

R 192.168.1.0/24 [120/2] via 192.168.4.2, 00:00:13, Serial0/0/1


R 192.168.2.0/24 [120/1] via 192.168.4.2, 00:00:25, Serial0/0/1
R 192.168.3.0/24 [120/1] via 192.168.4.2, 00:00:25, Serial0/0/1
C 192.168.4.0/24 is directly connected, Serial0/0/1
C 192.168.5.0/24 is directly connected, FastEthernet0/0
R3#

 What is the administrative distance of a network route learned via


RIP?
 120

23
Administrative Distance
R3# show ip protocols
<output omitted>
Routing Protocol is “rip”
Routing Information Sources:
Gateway Distance Last Update
192.168.6.2 120 00:00:10
Distance: (default is 120)

 Where is the administrative distance displayed using this command?

24
Verification and Troubleshooting
 Verifying RIP: show ip route
 Verifying RIP: show ip protocols
 Verifying RIP: debu ip rip
 Passive Interfaces
Verifying RIP: show ip route on all three routers…
R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile,
<output omitted>
Gateway of last resort is not set

R 192.168.4.0/24 [120/1] via 192.168.2.2, 00:00:02, Serial0/0/0


R 192.168.5.0/24 [120/2] via 192.168.2.2, 00:00:02, Serial0/0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
C 192.168.2.0/24 is directly connected, Serial0/0/0
R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:02, Serial0/0/0

 The routing table, includes what kind of routes?


 Directly connected networks
 Static routes
 Dynamic routes
 Why might a RIP route not be immediately displayed in the routing table?
 Networks will take some time to converge.
26
Verifying RIP: show ip route Command
R2# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile,
<output omitted>
Gateway of last resort is not set

C 192.168.4.0/24 is directly connected, Serial0/0/1


R 192.168.5.0/24 [120/1] via 192.168.4.1, 00:00:12, Serial0/0/1
R 192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:24, Serial0/0/0
C 192.168.2.0/24 is directly connected, Serial0/0/0
C 192.168.3.0/24 is directly connected, FastEthernet0/0

 Using R2, which routes do you expect to see in our scenario?


 Directly connected networks of R2
 RIP routes for remote networks
 What routes do you expect not to see?
 Networks not in our scenario – not configured with network statements
on the routers.
 Static default route 27
Verifying RIP: show ip route Command
R3# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile,
<output omitted>
Gateway of last resort is not set

C 192.168.4.0/24 is directly connected, Serial0/0/1


C 192.168.5.0/24 is directly connected, FastEthernet0/0
R 192.168.1.0/24 [120/2] via 192.168.4.2, 00:00:08, Serial0/0/1
R 192.168.2.0/24 [120/1] via 192.168.4.2, 00:00:08, Serial0/0/1
R 192.168.3.0/24 [120/1] via 192.168.4.2, 00:00:08, Serial0/0/1

28
Verifying RIP: show ip route Command
R1# show ip route
<output omitted>
R 192.168.5.0/24 [120/2] via 192.168.2.2, 00:00:23, Serial0/0/0

29
Examine and discuss the show ip protocols Command

30
Verifying RIP: show ip protocols Command

 Verifies that RIP routing is configured and running on


Router R2
 At least one active interface with an associated network
command is needed before RIP routing will start.

31
Verifying RIP: show ip protocols Command

 These are the timers that show when the next


round of updates will be sent out from this
router—23 seconds from now, in the example.

32
Verifying RIP: show ip protocols Command

 This information relates to filtering updates and


redistributing routes, if configured on this router.
 Filtering and redistribution are both CCNP-level
topics.

33
Verifying RIP: show ip protocols Command

 Information about which RIP version is


currently configured and which interfaces are
participating in RIP updates.

34
Verifying RIP: show ip protocols Command

 Router R2 is currently summarizing at the classful network


boundary
 By default, will use up to four equal-cost routes to load-
balance.
 Automatic summarization is discussed later in this chapter.

35
Verifying RIP: show ip protocols Command

 Classful networks configured with the network


command are listed next.
 These are the networks that R2 will include in its
RIP updates. (with other learned routes)

36
Verifying RIP: show ip protocols Command

 RIP neighbors
 Gateway: Next-hop IP address of the neighbor that is sending R2 updates.
 Distance is the AD that R2 uses for updates sent by this neighbor.
 Last Update is the seconds since the last update was received from this
neighbor.

37
Use debug ip rip to view RIP updates that are sent
and received…

 The debug command is a useful tool to help diagnose and resolve


networking problems, providing real-time, continuous information. 38
RIP: received v1 update from 192.168.2.1 on Serial0/0/0
192.168.1.0 in 1 hops

 Assuming all routers have converged, why were no other routes


from R1’s routing table sent to R2?
 Split horizon rule.
 R1 is will not advertise networks back to R2 that were learned
39
from R2.
RIP: received v1 update from 192.168.4.1 on Serial0/0/1
192.168.5.0 in 1 hops

40
RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0
(192.168.3.1)
RIP: build update entries
network 192.168.1.0 metric 2
network 192.168.2.0 metric 1
network 192.168.4.0 metric 1
network 192.168.5.0 metric 2

Learned via Learned via


RIP from R1 RIP from R3

Directly
Connected

41
RIP: sending v1 update to 255.255.255.255 via Serial0/0/1
(192.168.4.2)
RIP: build update entries
network 192.168.1.0 metric 2
network 192.168.2.0 metric 1
network 192.168.3.0 metric 1

Directly
Connected

Learned via
RIP from R1

42
RIP: sending v1 update to 255.255.255.255 via Serial0/0/0
(192.168.2.2)
RIP: build update entries
network 192.168.3.0 metric 1
network 192.168.4.0 metric 1
network 192.168.5.0 metric 2
R2# undebug all
All possible debugging has been turned off
Directly
Connected

Learned via
RIP from R3

43
Passive Interfaces
Got Router?

 Does R2 need to send RIP updates out Fa 0/0? What are the
disadvantages to this?
 No, there is no RIP router or any router.
 Bandwidth is wasted transporting unnecessary updates.
 All devices on the LAN must process the RIPv1 update up to the
transport layer.
 Security risk (Authentication would is a better solution - later)
44
Passive Interfaces
Router(config-router)# passive-interface interface-type interface-
number

 What about using on R2:


R2(Config-router)# no network 192.168.3.0
 R2 would not advertise this LAN as a route in updates sent to R1
and R3.
 Correct solution is to use the passive-interface command 45
Passive Interfaces – Use it on R2…
R2(config)# router rip
R2(config-router)# passive-interface FastEthernet 0/0

46
Passive Interfaces
R2# show ip protocols
<output omitted>
Interface Send Recv Triggered RIP Key-chain
Serial0/0/0 1 1 2
FastEthernet 0/0 no longer
Serial0/0/1 1 1 2 included
Automatic network summarization is in effect
Routing for Networks:
192.168.2.0 LAN network still included in
192.168.3.0 RIP updates that are sent
192.168.4.0
Passive Interface(s):
FastEthernet 0/0 is a passive interface
FastEthernet0/0
Routing Information Sources:
Gateway Distance Last Update
192.168.2.1 120 00:00:27
192.168.4.1 120 00:00:23
Distance: (default is 120)

47
Automatic Summarization
 Modified Topology B
 Boundary Routers and Automatic Summarization
 Processing RIP Updates
 Sending RIP Updates
 Advantages and Disadvantages of Automatic
Summarization
Modified Topology: Scenario B

192.168.4.0/24

172.30.0.0/16

192.168.5.0/24

 Where is the separation of classful networks?


 Summarizing several routes into a single route is known as route
summarization or route aggregation.
 Fewer routes = smaller routing tables = faster lookups
 Some routing protocols, such as RIP, automatically summarize
routes on certain routers. 49
Modified Topology: Scenario B

192.168.4.0/24

172.30.0.0/16

192.168.5.0/24

 What are the classful  How is 172.30.0.0/16  Is 192.168.4.0/24


networks? network subnetted? subnetted?
 172.30.0.0/16  172.30.1.0/24  192.168.4.8/30.
 192.168.4.0/24  172.30.2.0/24
 192.168.5.0/24  172.30.3.0/24
50
Configuration Changes for R1
R1(config)# interface fa0/0
R1(config-if)# ip address 172.30.1.1 255.255.255.0
R1(config-if)# interface S0/0/0
R1(config-if)# ip address 172.30.2.1 255.255.255.0
R1(config-if)# no router rip
R1(config)# router rip IOS automatically corrects
R1(config-router)# network 172.30.1.0 subnet entries to classful
R1(config-router)# network 172.30.2.0 network address
R1(config-router)# passive-interface FastEthernet 0/0
R1(config-router)# end
R1# show run
<output omitted>
!
router rip
The no shutdown and
passive-interface FastEthernet0/0
clock rate commands are
network 172.30.0.0 not needed because these
! commands are still
<output omitted> configured from Scenario A.
51
Configuration Changes for R2
R2(config)# interface S0/0/0
R2(config-if)# ip address 172.30.2.2 255.255.255.0
R2(config-if)# interface fa0/0
R2(config-if)# ip address 172.30.3.1 255.255.255.0
R2(config-if)# interface S0/0/1
R2(config-if)# ip address 192.168.4.9 255.255.255.252
R2(config-if)# no router rip
R2(config)# router rip IOS automatically corrects
R2(config-router)# network 172.30.0.0 subnet entries to classful
R2(config-router)# network 192.168.4.8 network address
R2(config-router)# passive-interface FastEthernet 0/0
R2(config-router)# end
R2# show run
<output omitted>
!
router rip
passive-interface FastEthernet0/0
network 172.30.0.0
network 192.168.4.0
52
! <output omitted>
Configuration Changes for R3
R3(config)# interface fa0/0
R3(config-if)# ip address 192.168.5.1 255.255.255.0
R3(config-if)# interface S0/0/1
R3(config-if)# ip address 192.168.4.10 255.255.255.252
R3(config-if)# no router rip
R3(config)# router rip
R3(config-router)# network 192.168.4.0
R3(config-router)# network 192.168.5.0
R3(config-router)# passive-interface FastEthernet 0/0
R3(config-router)# end
R3# show run
<output omitted>
!
router rip
passive-interface FastEthernet0/0
network 192.168.4.0
network 192.168.5.0
!
53
<output omitted>
Boundary Routers and Automatic Summarization

 RIP is a classful routing protocol that automatically summarizes


classful networks across major network boundaries.
54
 Does R2 have interfaces on more than one major classful network?
 Yes, 172.30.0.0 and 192.168.4.0
 This makes R2 a boundary router in RIP.
 Boundary routers summarize RIP subnets from one major network to the
other:
 172.30.1.0, 172.30.2.0, and 172.30.3.0 networks automatically
55
summarized into 172.30.0.0 when sent out R2’s Serial 0/0/1 interface.
Processing RIP Updates

R2# show ip route


172.30.0.0/24 is subnetted, 3 subnets
R 172.30.1.0 [120/1] via 172.30.2.1, 00:00:18, Serial0/0/0
C 172.30.2.0 is directly connected, Serial0/0/0
C 172.30.3.0 is directly connected, FastEthernet0/0
192.168.4.0/30 is subnetted, 1 subnets
C 192.168.4.8 is directly connected, Serial0/0/1
R 192.168.5.0/24 [120/1] via 192.168.4.10, 00:00:16, Serial0/0/1

 Do Classful routing protocols such as RIPv1 include the subnet


mask in the routing update.
 No.
 So how does a router running RIPv1 determine what subnet mask it
should apply to a route when adding it to the routing table? 56
Rules for Processing RIPv1 Updates
Routing Update and Interface Routing Update Subnet Mask
Same Classful Major Network Use mask of interface
Different Classful Major Network Use default classful mask

 The following two rules govern RIPv1 updates:


 If a routing update and the interface on which it is received
belong to the same major network, the subnet mask of the
interface is applied to the network in the routing update.
 If a routing update and the interface on which it is received
belong to different major networks, the classful subnet mask
of the network is applied to the network in the routing update..
57
Example of RIPv1 Processing Updates
R2# debug ip rip (selected output)
RIP: received v1 update from 172.30.2.1 on Serial0/0/0
172.30.1.0 in 1 hops

R2# show ip route (selected output)


172.30.0.0/24 is subnetted, 3 subnets
R 172.30.1.0 [120/1] via 172.30.2.1, 00:00:18, Serial0/0/0

 Same classful network as the


incoming update.
 Update: 172.30.1.0 in 1 hops 172.30.2.2/24
 Interface received:
 Serial 0/0/0 - 172.30.2.2/24
 Same classful network address
172.30.1.0
(172.30.0.)
 Applies subnet mask of its S0/0/0
interface, /24.
 The 172.30.1.0 /24 subnet was
added to the routing table.
58
Sending RIP Updates
R2# debug ip rip
RIP protocol debugging is on
RIP: sending v1 update to 255.255.255.255 via Serial0/0/0 (172.30.2.2)
RIP: build update entries
network 172.30.3.0 metric 1
network 192.168.4.0 metric 1
network 192.168.5.0 metric 2
RIP: sending v1 update to 255.255.255.255 via Serial0/0/1 (192.168.4.9)
RIP: build update entries
network 172.30.0.0 metric 1

192.168.4.0/24

192.168.5.0/24

59
Sending RIP Updates
172.30.3.0
192.168.4.0
192.168.5.0 172.30.0.0

60
Determining the mask and network address
 Receiving an Update: Determining subnet mask for routing table
 What is the major classful network address of the receiving interface?
 What is the major classful network address of the network in the routing
update?
 Are they the same major classful network address?
 Yes: Apply subnet mask of the receiving interface for this network
address in the routing table.
 No: Apply classful subnet mask for this network address in the
routing table.
 Sending an Update: Determining whether or not to summarize route sent
 What is the major classful network address of the sending interface?
 What is the major classful network address of the network in the routing
update?
 Are they the same major classful network address?
 Yes: Send subnet network address
 No: Send summary address – the classful network address
61
Verifying Routing Updates
R1# show ip route
<output omitted>
Gateway of last resort is not set
172.30.0.0/24 is subnetted, 3 subnets
C 172.30.1.0 is directly connected, FastEthernet0/0
C 172.30.2.0 is directly connected, Serial0/0/0
R 172.30.3.0 [120/1] via 172.30.2.2, 00:00:17, Serial0/0/0
R 192.168.4.0/24 [120/1] via 172.30.2.2, 00:00:17, Serial0/0/0
R 192.168.5.0/24 [120/2] via 172.30.2.2, 00:00:17, Serial0/0/0

R3# show ip route


<output omitted>
Gateway of last resort is not set
R 172.30.0.0/16 [120/1] via 192.168.4.9, 00:00:15, Serial0/0/1
192.168.4.0/30 is subnetted, 1 subnets
C 192.168.4.8 is directly connected, Serial0/0/1
C 192.168.5.0/24 is directly connected, FastEthernet0/0

62
Classful routing protocols do not support VLSM

 Routers running RIPv1 are limited to using the same subnet mask
for all subnets with the same classful network.
 Classless routing protocols such as RIPv2 allow the same major
63
(classful) network to use different subnet masks (VLSM).
Advantages of Automatic Summarization
R3# show ip route
<output omitted>
Gateway of last resort is not set
R 172.30.0.0/16 [120/1] via 192.168.4.9, 00:00:15, Serial0/0/1
192.168.4.0/30 is subnetted, 1 subnets
C 192.168.4.8 is directly connected, Serial0/0/1
C 192.168.5.0/24 is directly connected, FastEthernet0/0

 Smaller routing updates

64
Disadvantage of Automatic Summarization

172.30.0.0/16 172.30.0.0/16

 Discontiguous network, two or more subnets separated by at least


one other major network.
 172.30.0.0/16 is a discontiguous network. 65
Discontiguous Networks Do Not Converge with RIPv1
R1(config)# router rip
R1(config-router)# network 172.30.0.0
R1(config-router)# network 209.165.200.0

R2(config)# router rip


R2(config-router)# network 10.0.0.0
R2(config-router)# network 209.165.200.0

R3(config)# router rip


R3(config-router)# network 172.30.0.0
R3(config-router)# network 209.165.200.0

 RIPv1 configuration is correct, but it is unable to determine all the


networks in this discontiguous topology.

66
Discontiguous Networks Do Not Converge with RIPv1

172.30.0.0
172.30.0.0

172.30.0.0/16 172.30.0.0/16

 What routing update will be sent by R1 and R3?


 172.30.0.0 major network address, a summary route to R2.
67
Discontiguous Networks Do Not Converge with RIPv1
R1# show ip route

172.30.0.0/24 is subnetted, 3 subnets


C 172.30.1.0 is directly connected, FastEthernet0/0
C 172.30.2.0 is directly connected, FastEthernet0/1

R3# show ip route

172.30.0.0/24 is subnetted, 3 subnets


C 172.30.100.0 is directly connected, FastEthernet0/0
C 172.30.200.0 is directly connected, FastEthernet0/1

 What 172.30.0.0 networks/subnets do you expect to see in R1’s routing table?


 What 172.30.0.0 networks/subnets do you expect to see in R3’s routing table?

 Note: The book/curriculum mistakenly has the following routes for R1 and R3
(Book: Figure 5-15 and 5-17). These routes are NOT in the routing tables.
R1: R 172.30.0.0 [120/2] via 209.165.200.230, 00:00:26, Serial0/0/0
R3: R 172.30.0.0 [120/2] via 209.165.200.233, 00:00:22, Serial0/0/1
68
Discontiguous Networks Do Not Converge with RIPv1
R2# show ip route

R 172.30.0.0/16 [120/1] via 209.165.200.234, 00:00:14, Serial0/0/1


[120/1] via 209.165.200.229, 00:00:19, Serial0/0/0

69
R2# show ip route

R 172.30.0.0/16 [120/1] via 209.165.200.234, 00:00:14, Serial0/0/1


[120/1] via 209.165.200.229, 00:00:19, Serial0/0/0

172.30.0.0/16 172.30.0.0/16

 R2 has two equal-cost paths to the 172.30.0.0 network.


 What will R2 do when it receives traffic for a host on a 172.30.0.0 network ie. 172.30.200.10?
 R2 will load-balance traffic destined for any subnet of 172.30.0.0.
 This means that R1 will get half of the traffic and R3 will get the other half of the traffic,
whether or not the destination of the traffic is for one of their LANs. 70
Discontiguous Networks Do Not Converge with RIPv1
R2# show ip route

R 172.30.0.0/16 [120/1] via 209.165.200.234, 00:00:14, Serial0/0/1


[120/1] via 209.165.200.229, 00:00:19, Serial0/0/0

 Classful routing protocols do not support discontiguous networks because


they do not include the subnet mask in the routing update.
 Classless routing protocols (RIPv2, EIGRP, OSPF, IS-IS, BGP) do support
discontiguous networks. 71
Default Route and RIPv1
 Modified Topology C
 Propagating the Default Route in RIPv1
Modified Topology: Scenario C
172.30.3.0/24

172.30.2.0/24

172.30.1.0/24

 Default routes are used by routers to represent all routes that are
not specifically in the routing table.
73
Default
Routes

 In today’s networks, customers:


 Do not necessarily have to exchange routing updates with their
ISP.
 Do not need a listing for every route on the Internet.
 Default route that sends all traffic to the ISP router.
 ISP configures a static route pointing to the customer router for
addresses inside the customer’s network. 74
Configuration Changes for R2 and R3
R2(config)# router rip
R2(config-router)# no network 192.168.4.0
R2(config-router)# exit
R2(config)# ip route 0.0.0.0 0.0.0.0 serial 0/0/1

R3(config)# no router rip


R3(config)# ip route 172.30.0.0 255.255.252.0 serial 0/0/1

75
Routing Table
R1# show ip route
<output omitted>
Gateway of last resort is not set
172.30.0.0/24 is subnetted, 3 subnets
C 172.30.1.0 is directly connected, FastEthernet0/0
C 172.30.2.0 is directly connected, Serial0/0/0
R 172.30.3.0 [120/1] via 172.30.2.2, 00:00:05, Serial0/0/0

 R1 has all 172.30.0.0/24 subnets, but will drop packets for all other
networks.
 No default route (coming)

76
Routing Table
R2# show ip route
<output omitted>
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
172.30.0.0/24 is subnetted, 3 subnets
R 172.30.1.0 [120/1] via 172.30.2.1, 00:00:03, Serial0/0/0
C 172.30.2.0 is directly connected, Serial0/0/0
C 172.30.3.0 is directly connected, FastEthernet0/0
192.168.4.0/30 is subnetted, 1 subnets
C 192.168.4.8 is directly connected, Serial0/0/1
S* 0.0.0.0/0 is directly connected, Serial0/0/1

 R2 has routes for 172.30.0.0/16 subnets.


 R2 has static default route for all other networks

77
Routing Table
R3# show ip route
<output omitted>
Gateway of last resort is not set
172.30.0.0/22 is subnetted, 1 subnets
S 172.30.0.0 is directly connected, Serial0/0/1
192.168.4.0/30 is subnetted, 1 subnets
C 192.168.4.8 is directly connected, Serial0/0/1
C 192.168.5.0/24 is directly connected, FastEthernet0/0

 R3 has static route for 172.30.0.0/16 network.


 Doesn’t matter if or how 172.30.0.0/16 is subnetted, R3 will forward packets
to R2.

78
Propagating the Default Route in RIPv1
R1# show ip route
<output omitted>
Gateway of last resort is not set
172.30.0.0/24 is subnetted, 3 subnets
C 172.30.1.0 is directly connected, FastEthernet0/0
C 172.30.2.0 is directly connected, Serial0/0/0
R 172.30.3.0 [120/1] via 172.30.2.2, 00:00:05, Serial0/0/0

 Can configure static default route on every router but:


 inefficient
 does not react to topology changes
 In many routing protocols, including RIP, you can use the default-
information originate command in router configuration mode to specify
that this router is to originate default information, by propagating the
static default route in RIP updates.
79
Propagating the Default Route in RIPv1
R2(config)# router rip
R2(config-router)# default-information originate
R2(config-router)# end
R2# debug ip rip
RIP: sending v1 update to 255.255.255.255 via Serial0/0/0
(172.30.2.2)
RIP: build update entries
subnet 0.0.0.0 metric 1
subnet 172.30.3.0 metric 1

80
Propagating the Default Route in RIPv1
R1# show ip route
<output omitted>
* - candidate default, U - per-user static route, o - ODR
Gateway of last resort is 172.30.2.2 to network 0.0.0.0
172.30.0.0/24 is subnetted, 3 subnets
C 172.30.2.0 is directly connected, Serial0/0/0
R 172.30.3.0 [120/1] via 172.30.2.2, 00:00:16, Serial0/0/0
C 172.30.1.0 is directly connected, FastEthernet0/0
R* 0.0.0.0/0 [120/1] via 172.30.2.2, 00:00:16, Serial0/0/0

 The static default route on R2 has been propagated to R1 in a RIP update.


 R1 has connectivity to the LAN on R3 and any destination on the Internet.

81
Topics
 RIPv1: Distance Vector, Classful  Automatic Summarization
Routing Protocol  Modified Topology B
 Background and Perspective  Boundary Routers and
 RIPv1 Characteristics and Automatic Summarization
Message Format  Processing RIP Updates
 RIP Operation  Sending RIP Updates
 Advantages and
 Basic RIPv1 Configuration Disadvantages of Automatic
 RIPv1 Scenario A Summarization
 Enable RIP: router rip  Default Route and RIPv1
Command  Modified Topology C
 Specifying Networks  Propagating the Default Route
 Verification and Troubleshooting in RIPv1
 Verifying RIP: show ip route
 Verifying RIP: show ip
protocols
 Verifying RIP: debu ip rip
 Passive Interfaces
82
Chapter 5
RIP version 1

CIS 82 Routing Protocols and Concepts


Rick Graziani
Cabrillo College
graziani@cabrillo.edu

Last Updated: 3/10/2009