You are on page 1of 127

Cisco’s Market Share

40%
CISCO 60%
D-Link
3 Com
Nortel
Cygnus
Etc..
Router is an internetworking
component, that connects networks
which are at different geographical
locations.
Diagram of 2501 series Router
Telephone

modem

Serial 1 Serial 0 AUI Console AUX
E0

V.35 modem
PC
Interfaces on a Router
1. Ethernet It is a LAN interface. Some of the models have an
RJ45 port for 10baseT or 10/100. And some other have a 15 pin
female connector AUI (Attachment Unit Interface).

2. Serial It is a 60 pin female WAN interface for leased
line
3. BRI/PRI It is a RJ45 WAN interface for ISDN
4. Async It is a 37 pin female connector for dial ups.
5. Console It is a RJ45 Connector used to configure the
Router for the first time.
6. Auxiliary RJ45 Connector for remote access
administration.
Routers

Modular Fixed
Modular Routers
These type of routers have up gradable slots, and the number
of ports can be increased just by adding cards in the slots.

Fixed Routers
These types of routers have fixed number of ports.
Cisco Router’s Series
Cisco 700, 800, 1600, 1700, 2500, 2600,
3600, 4000, 5000, 7000,10000, 12000.

Fixed Modular
700, 800,….2500 2600,….., 12000

1750 & 1751 exceptionally are Modular Routers.
Cisco’s Hierarchical Model
Access Layer
700, …, 2500

Distribution Layer
2600, …, 5000

Core Layer
7000, …, 12000
Transceiver
Internal Components of a Router
Boot ROM : It stores the mini IOS (Internet work Operating
System) image (RX Boot) with extremely limited capabilities and
POST routines and core level OS for maintenance.
FLASH : It is an EPROM chip that holds most of the IOS
Image. It maintains everything when router is turned off.
RAM : RAM holds running IOS configurations and
provides caching. RAM is a volatile memory and looses its
information when router is turned off. The configuration present
in RAM is called Running configuration.
NVRAM : It is a re-write able memory area that holds router’s
configuration file. NVRAM retains the information when ever
router is rebooted. Once configuration is saved, it will be saved in
NVRAM and this configuration is called Startup Configuration.
Configuration of a Router
Router for the first time is configured through the CONSOLE
port.COM port of a PC is connected to the console port of router
with a console cable by using a transceiver. Router is accessible by a
tool. In windows, it is called HYPER TEMINAL. As soon as the
router is powered on and accessed, the following things happen,
POST

BOOT STRAP

FLASH ROM (mini IOS)
If IOS is Corrupted
NVRAM

Setup Mode
In Setup mode, there will be a message,
“Would You Like To Enter The Initial Configuration [Y/N]” :
If “Y” then, initial configuration starts.
If “N” would you like to terminate the auto installation?
Press “RETURN” to get started……You will land on the default prompt
of the Router “ ROUTER >”.

Router>_
Working Modes Of a Router

1. User Mode (Default mode)
2. Privilege or Administrative Mode
3. Global Configuration Mode
4. Interface Configuration Mode
5. Line Configuration Mode
6. Router Mode
7. Sub-Interface Mode
USER MODE
Router> is the user mode, I,e the default prompt. It
means that when ever a router boots successfully it
lands into the user mode. Router cannot be
configured from this mode, but it is used for just
monitoring purpose. Router> en
Router #
PREVILEGE MODE
Router# it is the administrating mode, we can check
whether the settings and configurations made have been
implemented or not. Eg. “Router # Sh int e0”. If it is new
router all the interfaces are by default shut down, so the
message will be, “ Ethernet 0 is administratively down,
line protocol is down.”
Global Configuration Mode

As the name indicates, it is a global configuration mode
I,e. we can configure any interface from this mode, just
by entering into the interface mode.

Router# Config t

Router (Config)#
The “Clock” Command

The clock command is used to set the clock of Router.
Syntax.
Router# clock set hh:mm:ss Day of week Month Year
E.g.
Router#clock set 16:35:00 1 April 2003

Note* This is the only configuration which can be done from
privilege mode,every other configuration should be done at global
configuration mode only.
Some of the important show commands in privilege
mode
Router# sh clock
sh int (interface name eg e0)
Sh history
Sh memory
Sh running-config
Sh startup-config

To save configuration from RAM TO NVRAM

Router#Copy Running-config Startup-config (or)

Router#Write Memory
To configure Hostname (or) Identification of
Router over the network.
Router#conf t
Router(config)#Hostname R_2503
Router(config)#^Z
To configure Logging banner.

Router#conf t
Router(config)#Banner Motd #
Enter text message………….#
Router(config)#^Z
Router Password Configuration
1. Previlege Password
2. Virtual Terminal Password
3. Console Password
4. Auxillary Password
Previlege PASSWORDS

Enable Password Enable Secret

Enable Password:- It is global command restricts access to
the previlege mode, the password is in clear text.
Router(config)#Enable password 123

Enable Secret:-Here the password is in encrypted form.

Router(config)#Enable secret cisco
Virtual Terminal Password

 It establishes a login password on incoming Telnet

sessions.
Router#conf t
Router(config)#Line vty 0 4
Router(config-line)#Login
Router(config-line)#password cisco
Router(config-line)#^Z
Console Password

It establishes a login password on the console terminal.

Router#conf t
Router(config)#Line Console 0
Router(config-line)#Login
Router(config-line)#Password cisco
Router(config-line)#^Z
Auxillary Password

It establishes a login password to remote administration.

Router#conf t
Router(config)#Line Aux 0
Router(config-line)#Login
Router(config-line)#Password cisco
Router(config-line)#^Z
CONFIGURING INTERFACES

LAN interface (ETHERNET Port)

WAN interface (SERIAL Port)
ETHERNET
Router(config)#Interface Ethernet 0
Router(config-if)#Ip Address 200.150.1.254 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#^Z
Router#Show Int E0
SERIAL
Router(config)#Interface Serial 0
Router(config-if)#Ip Address 150.10.1.1 255.255.0.0
Router(config)#clock rate 56000
Router(Config-if)# bandwidth 64
Router(config-if)#No shutdown
Router(config-if)#^Z
Interpretring The Interface Status

Router# show int s0
Serial0 is up, line protocol is up. Is the messege if
the interface is operational.
Serial0 is up, line protocol is down….. This is if
there is any connection problem.

Serial0 is down, line protocol is down….. This is if
there is any interface problem.

Serial0 is administratively down, line protocol is
down….. This is if the interface is disabled.
The “CDP”
It’s a Cisco's proprietary protocol called the Cisco
Discovery Protocol, that gives you a summary of all the
directly connected Cisco devices. CDP is a L2 protocol,
that discovers neighbor regardless of which protocol suite
they are running. When a cisco device boots up, the CDP
is loaded by default, but can be disabled at interface level.
* The CDP is limited to the immediate neighbors only…
The summary includes Device Identifier(eg. Switch
configured name or domain name), Port Identifier (eg.
Ethernet 0 and serial 0.), Capabilities list (eg. The device
can act as a sourcr route bridge as well as a router),
Platform (eg. Cisco 2600).
CDP (Cisco’s Discovery Protocol)
Using CDP
Router# sh cdp neighbor (shows neighboring devices)
Router# sh cdp entry 192.168.10.1 (shows detailed
information about this perticular neighbor.)
Router# sh cdp interface(shows the details of the interface
of the local decive.)
Router# sh cdp traffic (shows the packet sent, received,
lost etc.)
To disable CDP….,
Router(config)#no cdp run
Router(config)#int s0
Router(config-if)#no cdp enable
Backup & Restoring Routers IOS Image
Using TFTP
(Trivial File Transfer Protocol)

TFTP Server allows you to take backup, upload and save
your IOS Image and current configuration on it. TFTP is a
software program of 1.3Mb. This should be installed on that
TFTP server i.e., (Personnel Computer).
C:\Program files\cisco systems\cisco TFTP

* Note: Always while taking Backup or Restoration TFTP
software should execute on that particular computer.
Backup Sources :

1. Through Telnet Session.
2. Through Console Session.
3. Through Auxillary Port (Remote Session)
Backup of IOS Image
Router#Copy Flash:(Press Tab key) Tftp
Address or name of the remote host [ ]? (Ip address of tftp)
Destination file name [ ] ? (Press enter key or a name)

Backup of Configuration
Router#Copy Startup-config Tftp
Address or name of the remote host [ ]? (Ip address of tftp)
Destination file name [ ] ? (Give a name)
Upgrading IOS Image
Note: This process can only be done by Console Session.
Router#Copy tftp Flash:
Address or name of remote host []?
Source file name []?
Destination file name []?
Erase Flash: before copying [confirm]?
Erasing the Flash file system will remove all files: continue?
[confirm]
Erasing device eeeeeeee……….eeeeeee.eee.eeee.ee
Loading!!!!!!!!!!!!!!!!!!!!!!!!!!!!!…….!!!!…….!!!!!!
Leased line WAN Setup

Case 1: The distance between the locations is greater than 5 Km.
Requirements
A pair of Routers, Leased line, pair of leased line modems V.35,
Pair of G.703 Modem.

Case 2: The distance between the two locations is less than 5Km.
Requirements
A pair of Routers, Leased line and pair of leased line modem.
Leased line Setup( > 5km)
Leased line
V.35 V.35
modem modem
V.35 Cable G.703 G.703
Csu/
Dsu
Mux/ Mux/
S0 Dmux Dmux
Csu – channel service unit
Dsu – data service unit S0
E0 E0
S0 – Serial port of router
E0 – Ethernet port of a router Router
Switch/hub Switch/hub

Internal Network Internal Network
Leased line Setup (< 5 km)
V.35 Leased line
modem V.35
modem
V.35 Cable Csu/
Dsu

S0

S0 E0
E0 Telephone
Exchange Router
Switch/hub Switch/hub

Internal Network Internal Network
Routing
Routing is of three types.
• Static
• Dynamic and
• Default
When the destination is known, static and dynamic
routing is done. For unknown destinations, default
routing is employed.
In dynamic routing, the path is fixed by the
protocol. The paths will be changing depending on the
length of the path. Always the shortest path is preferred.
Static routing is done by the users. These paths are stored
in the routing table.
Example:
10.0.0.1/8 10.0.0.2/8
S0
S0

E 0 192.168.1.150/24 E 0 192.168.2.150/24

Switch/hub Switch/hub
192.168.1.0/24 192.168.2.0/24

Location A Location B
Router(config)# ip routing
Router# sh ip route (it shows all the directly connected
networks).
“ C 192.168.1.0/24 directly connected to E0”
“ C 10.0.0.0/8 “ ‘ ‘ ‘ S0”
“ C “ indicates connected networks.
Static Routing
Syntax
Router(config)# ip route (dest-network) (subnet mask)
(next hop address)
Location A
Router(config)# ip routing
Router(config)# ip route 192.168.2.0 255.255.255.0 10.0.0.2
Note* if we don’t know the address of next hop, we can just
write the name of the hop.
Router(config)# ip route 192.168.2.0 255.255.255.0 S0

Location B
Router(config)# ip routing
Router(config)# ip route 192.168.1.0 255.255.255.0 10.0.0.1
Router# sh ip route
C 192.168.1.0/24 directly connected to E0
C 10.0.0.0/8 “ ‘ “ “ S0
S 192.168.2.0/24 [1/0] via 10.0.0.2
•“S” represents static. [a/b] ~ [1/0], here a=1 is the
administrative distance value and b has no significance in
static routing. For static and default routing b can be 0 or 1.
• lesser the administrative distance value, higher the
preference.
“Tracert”, “Trace Route” and “Route
print”.
C:\> tracert
C:\> route print
Router# trace route (gives the complete route)
Router# sh arp (to check MAC addresses)

Default Routing
Router(config)# ip routing
Router(config)#ip route DA (S/N mask next) (next hop
address)
Router(config)# ip route 0.0.0.0 0.0.0.0 s1
Router# sh ip route
C 192.168.1.0/24 directly connected to E0
C 10.0.0.0/8 “ “ to S0
S* 0.0.0.0/0 “ “ to S0

Dynamic Routing
It is a type of routing where routing protocols( eg. RIP and
IGRP) are used between routers to determine the path and
maintain routing table. Once the path is determined a router
can route a routed protocol(IP). Dynamic routing uses broad
casts and multicasts to communicate with other routers. The
routing metric helps routers find the best path to each network.
Classification Of Routing Protocols
 Distance Vector
 Hybrid Routing
 Link State
Distance Vector: the distance vector approach determines the
direction and the distance to any link in the internetwork.
When the topology in a distance vector routing protocol
changes, routing table updates in the router must occur. This
update process proceeds step-by-step router to router. Eg. RIP
and IGRP.
Link State : it recreates the exact topology of the entire
network(atleast the partion of the network where the router is
situated). Eg . OSPF.
Hybrid Routing : it combines aspects of the link state and the
distance vector algorithm.

Functions of a distance vector routing
protocol.
 Identification of source of information
 Discovering routes
 Select the best route
 Maintain Route information
Enabling RIP Configuration
Note:
• Maximum 6 paths (Default 4).
•“Hop count metric” selects the path
• Route updates are broadcast for every 30 seconds.
Router(config)# router rip
Router(config-router)# network (network ip)
Router# sh ip protocol (shows the current routing protocol)
Router# sh ip route
172.16.1.0
10.1.1.1 10.2.2.2 192.168.1.0
E0 S2 S2 S3 S3 E0
172.16.1.1 10.1.1.2 10.2.2.3
192.168.1.1

Router rip
Router rip
Network 172.16.0.0
Router rip
Network 10.0.0.0
Network 10.0.0.0
Network 192.168.1.0
Network 10.0.0.0
Autonomous Systems
An autonomous system is a collection of networks
under a common administrative domain. IGPs operate within
an autonomous system where as EGP connects different
autonomous systems.
Every autonomous system has a distinct number.The
Internet Assigned Numbers Authority (IANA) is responsible
for allocating this number. Eg. Autonomous system 100.
We can use any number unless the organization plans
for an EGP.
Configuring IGRP
Syntaxes.
Router(config)#router igrp autonomous number
This defines IGRP as the routing protocol.
Router(config-router)#Network network-ip
Selects directly connected networks.
Router(config-router)#variance multiplier
Configures unequal-cost load balancing by defining difference
between the best metric and the worst acceptable metric.
Router(config-router)#traffic-share (balanced/ min)
Autonomous System 100
172.16.1.0
10.1.1.1 10.2.2.2 192.168.1.0
E0 S2 S2 S3 S3 E0
172.16.1.1 10.1.1.2 10.2.2.3
192.168.1.1

Router igrp 100
Router igrp 100
Network 172.16.0.0
Router igrp 100
Network 10.0.0.0
Network 10.0.0.0
Network 192.168.1.0
Network 10.0.0.0
IP Classless Command
Router(config)# ip classless
A router by default assumes that all the subnets of a
directly connected network should be present in the
routing table. If a packet is received with a destination
address, of an unknown subnet of directly attached
network, the router assumes that the subnet does not
exists and drops the packet. This happens even if
routing table has a default route.For the above condition
if IP Classless is configured, and if any packet is
received, then the router will match it to the default
route and forword it to the next hop specified by the
default route.
EIGRP
Calculation of Wildcard Mask
WCM = BCM-SNM
1. 192.168.1.0/24
255.255.255.255
- 255.255.255. 0
0 . 0 . 0 .255
2. 192.168.1.0/27
255.255.255.255
- 255.255.255.224
0 . 0 . 0 . 31
3. 192.160.1.10 0.0.0.0
OSPF

OSPF(Open Short Path First) is of two types : 1) Single Area OSPF and
2) Multi Area OSPF.

Area0 S0

S0 Area2
IR
ABR

ABR
Internal Routers
IR
Area Border Router
Area1
OSPF under Single Area

S 0 192.168.1.194/252 192.168.1.193/252 S 0

Router A Router B
E 0 1.33 E 0 1.65
192.168.1.32/ 192.168.1.64/
255.255.255.224 255.255.255.224
(Config)# ip routing
(Config-Router)# router OSPF 6573
(Config-Router)# network 192.168.1.32 0.0.0.31 area 1
(Config-Router)# area 1 range 192.168.1.32
255.255.255.224
(Config-Router)# network 192.168.1.192 0.0.0.3 area 1
(Config-Router)# area 1 range 192.168.1.192
255.255.255.224
Configuration of Router B
--------------------------------

(Config)# ip routing
(Config-Router)# router OSPF 6573
(Config-Router)# network 192.168.1.32 0.0.0.31 area 1
(Config-Router)# area 1 range 192.168.1.64
255.255.255.224
(Config-Router)# network 192.168.1.195 0.0.0.3 area 1
(Config-Router)# area 1 range 192.168.1.195
255.255.255.252
OSPF under Different Areas

Area 0
Area 2
Area 1
Router A Router B

E0 E0

1.50 5.50
192.168.1.0 192.168.5.0
Configuration of Router A
--------------------------------
(Config)# ip routing
(Config-Router)# router OSPF 6573
(Config-Router)# network 192.168.1.0 0.0.0.255 area 1
(Config-Router)# area 1 range 192.168.1.0 255.255.255.0
(Config-Router)# network 172.16.0.0 0.0.255.255 area 0
(Config-Router)# area 0 range 172.16.0.0 255.255.0.0
Configuration of Router B
--------------------------------

(Config)# ip routing
(Config-Router)# router OSPF 6573
(Config-Router)# network 192.168.5.0 0.0.0.255 area 2
(Config-Router)# area 2 range 192.168.5.0 255.255.255.0
(Config-Router)# network 172.16.0.0 0.0.255.255 area 0
(Config-Router)# area 0 range 172.16.0.0 255.255.0.0
Access Control List
It is also called Network Traffic Control
Management (NTCM). We can provide restrictions to
individual users, subnets and services etc.
ACL

Standard ACL Extended ACL
Any access list is identified by its number.

S. A. L 1 – 99
Ex. A. L 100 - 199
Rules for creating and implementing
Access List
1. Access list must begin with the Deny Statements (If
exists) then Permit Statements must follow.
2. There must be at least one Permit Statement as an
Implicit “Deny All” always exists.
3. While Implementation of Access list, There must be
only one Access list per Interface, per direction and
per protocol.
Standard Access List

S 0 172.16.1.1 172.16.1.2 S 0
Router A Router B

E 0 1.50 E 0 5.50
5.4 5.1
1.4 1.1
5.3 5.2
1.3 1.2

Syntax
Router(config)# Access-list ALNO P/D Src Src-WCM
Router(config)# Int <name of interface>
Router(Config-if)#Ip Access-Group <Direction>
Configuration Standard Access-list For
Router A
Restricting particular user
(Config)# Access-list 1 deny 192.168.1.3 0.0.0.0
(Config)# Access-list 1 permit 0.0.0.0
255.255.255.255
or
Access-list 1 permit any
Restricting a Network
(Config)# Access-list 1 deny 192.168.3.0 0.0.0.255
(Config)# Access-list 1 permit any
Extended Access List

S 0 172.16.1.1 172.16.1.2 S 0

Router A Router B
E 0 1.50 E 0 5.50
1.4 1.1 5.4 5.1
1.3 1.2 5.3 5.2

1.20
Configuration of Router A

(Config)# Access-list 101 deny TCP 192.168.5.0 0.0.0.255
192.168.1.20 0.0.0.0 eq FTP
(Config)# Access-list 101 permit IP any any

Implementation
(Config)#int E0
(config-if)# IP Access-group 101 Out
NAT(Network Address Translation)

S 0 172.16.1.1 172.16.1.2 S 0

Router B
Router A
E 0 1.50 E 0 5.50
1.4 1.1 5.4 5.1
192.168.1.3 1.2 5.3 5.2

Note : 192.168.1.3 is denied from entering the network of 5.0.So it will enter
with mask.
Configuration of Router A
--------------------------------
# Config t
(Config)# int E 0
(Config-if)# ip address 192.168.1.50 255.255.255.0
(Config-if)# no shut
(Config-if)# exit

(Config)# int S 0
(Config-if)# ip address 172.16.1.1 255.255.0.0
(Config-if)# clock rate 56000
(Config-if)# bandwidth 64
(Config-if)# no shut
(Config-if)# exit

(Config)# ip routing
(Config-Router)# ip route 192.168.5.0 255.255.255.0 172.16.1.2

(Config)# int E 0
(Config-if)# ip nat inside
(Config)# int S 0
(Config-if)# ip nat outside

(Config)# access-list 1 permit 192.168.1.3 0.0.0.0
(Config)# ip nat inside source list 1 int S 0 overload

Configuration of Router B
--------------------------------
# Config t
(Config)# int E 0
(Config-if)# ip address 192.168.5.50 255.255.255.0
(Config-if)# no shut
(Config-if)# exit

(Config)# int S 0
(Config-if)# ip address 172.16.1.2 255.255.0.0
(Config-if)# clock rate 56000
(Config-if)# bandwidth 64
(Config-if)# no shut
(Config-if)# exit
(Config)# ip routing
(Config-Router)# ip route 192.168.1.0 255.255.255.0 172.16.1.1

(Config)# access-list 10 deny 192.168.1.3 0.0.0.0
(Config)# access-list 10 permit any

(Config)# int E 0
(Config-if)# ip access-group 10 out

Note : Only Public IP can go to the Internetworking world.
A Scenario of providing Net access to the IP's of Router B

172.16.1.1 172.16.1.2
Routing

1.50 Router A 5.50 Router B
5.0
Routing

Switch

Leased line 192.168.1.99

Natting
Configuration of Router A
--------------------------------

# Config t
(Config)# int E 0
(Config-if)# ip address 192.168.1.50 255.255.255.0
(Config-if)# no shut
(Config-if)# exit

(Config)# int S 0
(Config-if)# ip address 172.16.1.1 255.255.0.0
(Config-if)# clock rate 56000(for DCE)
(Config-if)# bandwidth 64
(Config-if)# no shut
(Config-if)# exit

(Config)# ip routing
(Config-Router)# ip route 0.0.0.0 0.0.0.0 192.168.1.99
(Config)# int E 0
(Config-if)# ip nat outside
(Config-if)# no shut
(Config-if)# exit

(Config)# int S 0
(Config-if)# ip nat inside
((Config-if)# exit

(Config)# access-list 10 permit 172.16.0.0 0.0.255.255
(Config)# ip nat inside source list 10 int E 0 overload

Configuration of Router B
--------------------------------
# Config t
(Config)# int E 0
(Config-if)# ip address 192.168.5.50 255.255.255.0
(Config-if)# no shut
(Config-if)# exit
(Config)# int S 0
(Config-if)# ip address 172.16.1.2 255.255.0.0
(Config-if)# clock rate 56000
(Config-if)# bandwidth 64
(Config-if)# no shut
(Config-if)# exit

(Config)# int E 0
(Config-if)# ip nat inside
(Config-if)# no shut
(Config-if)# exit

(Config)# int S 0
(Config-if)# ip nat outside
(Config-if)# exit

(Config)# ip routing
(Config-Router)# ip route 0.0.0.0 0.0.0.0 172.16.1.1

(Config)# access-list 10 permit 192.168.5.0 0.0.0.255
(Config)# ip nat inside source list 10 int E 0 overload
PPP(Point-to-Point) using PAP protocol

Internet based leased line

S 0 172.16.1.1 172.16.1.2 S 0

Router A Router B
(ISDN) (Zoom)
E 0 1.50 E 0 5.50
1.4 1.1 5.4 5.1
1.3 1.2 5.3 5.2

NOTE : Passwords of both should be same.
Configuration of Router A
--------------------------------
# Config t
(Config)# int E 0
(Config-if)# ip address 192.168.1.50 255.255.255.0
(Config-if)# no shut
(Config-if)# exit

(Config)# int S 0
(Config-if)# ip address 172.16.1.1 255.255.0.0
(Config-if)# clock rate 56000(for DCE)
(Config-if)# bandwidth 64
(Config-if)# no shut
(Config-if)# exit

(Config)# ip routing
(Config-Router)# ip route 192.168.5.0 255.255.255.0 172.16.1.2

(Config)# int S 0
(Config-if)# encapsulation ppp
(Config-if)# ppp authentication PAP
(Config-if)# ppp PAP sent-username zoom password cisco
Configuration of Router B
--------------------------------
# Config t
(Config)# int E 0
(Config-if)# ip address 192.168.5.50 255.255.255.0
(Config-if)# no shut
(Config-if)# exit

(Config)# int S 0
(Config-if)# ip address 172.16.1.2 255.255.0.0
(Config-if)# clock rate 56000(for DCE)
(Config-if)# bandwidth 64
(Config-if)# no shut
(Config-if)# exit

(Config)# ip routing
(Config-Router)# ip route 192.168.1.0 255.255.255.0 172.16.1.1

(Config)# int S 0
(Config-if)# encapsulation ppp
(Config-if)# ppp authentication PAP
(Config-if)# ppp PAP sent-username ISP password cisco
PPP(Point-to-Point) using CHAP protocol

Internet based leased line

S 0 172.16.1.1 172.16.1.2 S 0

Router A Router B
(ISDN) (Zoom)
E 0 1.50 E 0 5.50
1.4 1.1 5.4 5.1
1.3 1.2 5.3 5.2

NOTE : Passwords of both should be same.
Configuration of Router A
--------------------------------
# Config t
(Config)# int E 0
(Config-if)# ip address 192.168.1.50 255.255.255.0
(Config-if)# no shut
(Config-if)# exit

(Config)# int S 0
(Config-if)# ip address 172.16.1.1 255.255.0.0
(Config-if)# clock rate 56000(for DCE)
(Config-if)# bandwidth 64
(Config-if)# no shut
(Config-if)# exit

(Config)# ip routing
(Config-Router)# ip route 192.168.5.0 255.255.255.0 172.16.1.2

(Config)# int S 0
(Config-if)# encapsulation ppp
(Config-if)# ppp authentication CHAP
(Config-if)# ppp CHAP hostname zoom
(Config-if)# ppp CHAP password cisco
Configuration of Router B
--------------------------------
# Config t
(Config)# int E 0
(Config-if)# ip address 192.168.5.50 255.255.255.0
(Config-if)# no shut
(Config-if)# exit

(Config)# int S 0
(Config-if)# ip address 172.16.1.2 255.255.0.0
(Config-if)# clock rate 56000(for DCE)
(Config-if)# bandwidth 64
(Config-if)# no shut
(Config-if)# exit

(Config)# ip routing
(Config-Router)# ip route 192.168.1.0 255.255.255.0 172.16.1.1

(Config)# int S 0
(Config-if)# encapsulation ppp
(Config-if)# ppp authentication CHAP
(Config-if)# ppp CHAP hostname ISP
(Config-if)# ppp CHAP password cisco
DDR(Dial on Demand Routing)
ISP

S 0 172.16.1.1 172.16.1.2 S 0

Router A Router B
E 0 1.50 E 0 5.50
1.4 1.1 5.4 5.1
1.3 1.2 5.3 5.2
# Config t
(Config)# isdn switch-type basic-net 3

(Config)# int E 0/1
(Config-if)# ip address 192.168.1.50 255.255.255.0
(Config-if)# no shut
(Config-if)# exit

(Config)# int Bri 1/0
(Config-if)# no ip address
(Config-if)# encapsulation ppp
(Config-if)# no cdp enable
(Config-if)# no shut
(Config-if)# exit

(Config)# int dialer 1
(Config-if)# ip address negotiated
(Config-if)# encapsulation ppp
(Config-if)# no cdp enable
(Config-if)# ppp authentication CHAP PAP callin
(Config-if)# ppp CHAP hostname unicomin@hd2
(Config-if)# ppp CHAP password password
(Config-if)# ppp PAP sent-username unicomin@hd2 password password
(Config-if)# dialer in-band
(Config-if)# dialer string 3328400
(Config-if)# dialer idle-time out 180
(Config-if)# dialer hold-queue 10
(Config-if)# exit

(Config)# access-list 1 permit 192.168.1.0 0.0.0.255
(Config)# dialer-list 1 protocol ip permit

((Config)# int bri 1/0
(Config-if)# dialer rotary-group 1
(Config-if)# no shut
(Config-if)# exit

(Config)# int dialer 1
(Config-if)# dialer-group 1
(Config-if)# exit

(Config)# ip routing
(Config-router)# ip route 0.0.0.0 0.0.0.0 dialer 1 2
(Config)# ip name-server 202.54.30.2
(Config)# ip name-server 202.54.2.30

(Config)# int E 0
(Config-if)# ip nat inside
(Config-if)# no shut
(Config-if)# exit

(Config)# int Bri 1/0
(Config-if)# ip nat outside
(Config-if)# no shut
(Config-if)# exit

(Config)# int dialer 1
(Config-if)# ip nat outside
(Config-if)# exit

(Config)# ip nat inside source list 1 int dialer 1 overload
Backup Interface for a Leased Line

ISP

S 0 172.16.1.1 172.16.1.2 S 0
Bri 0
ISP CPE/DTE
E 0 1.50 E 0 5.50
1.4 1.1 5.4 5.1
1.3 1.2 5.3 5.2

CPE -Customer Premises Equipment

DTE -Data Communications & Circutary end
# Config t
(Config)# isdn switch-type basic-net 3

(Config)# int E 0/1
(Config-if)# ip address 192.168.1.50 255.255.255.0
(Config-if)# no shut
(Config-if)# exit

(Config)# int S 0
(Config-if)# ip address 172.16.1.1 255.255.0.0

(Config)# int Bri 1/ 0
(Config-if)# no ip address
(Config-if)# encapsulation ppp
(Config-if)# no cdp enable
(Config-if)# no shut
(Config-if)# exit
(Config)# int dialer 1
(Config-if)# ip address negotiated
(Config-if)# encapsulation ppp
(Config-if)# no cdp enable
(Config-if)# ppp authentication CHAP PAP callin
(Config-if)# ppp CHAP hostname zoom
(Config-if)# ppp CHAP password cisco
(Config-if)# ppp PAP sent-username isp password cisco
(Config-if)# dialer in-band
(Config-if)# dialer string 3328400
(Config-if)# dialer ideal-time out 180
(Config-if)# dialer hold-queue 10
(Config-if)# exit

(Config)# access-list 1 permit 192.168.1.0 0.0.0.255
(Config)# dialer-list 1 protocol ip permit

((Config)# int bri 1/ 0
(Config-if)# dialer rotary-group 1
(Config-if)# no shut
(Config-if)# exit
(Config)# int dialer 1
(Config-if)# dialer-group 1
(Config-if)# exit

(Config)# ip routing
(Config-router)# ip route 0.0.0.0 0.0.0.0 S 0
(Config-router)# ip route 0.0.0.0 0.0.0.0 dialer 1 2

(Config)# ip name-server 202.54.30.1
(Config)# ip name-server 202.54.1.30

(Config)# int E 0
(Config-if)# ip nat inside
(Config-if)# no shut
(Config-if)# exit

(Config)# int Bri 1/ 0
(Config-if)# ip nat outside
(Config-if)# no shut
(Config-if)# exit
(Config)# int dialer 1
(Config-if)# ip nat outside
(Config-if)# exit

(Config)# Access-list 2 permit 4 public 10
(Config)# ip nat inside source list 2 int dialer 1 overload

(Config)# int S 0
(Config-if)# backup interface bri 1/0
(Config-if)# backup delay 30 60
Frame Relay

Point - to - Point
frame-relay Network

S 0 172.16.1.1 172.16.1.2 S 0
Dlci 101 Dlci 102 Router B
Router A PVC

Fr-Switch Fr-Switch
E 0 1.50 E 0 5.50
1.4 1.1 5.4 5.1
1.3 1.2 5.3 5.2
Config t
(Config)# int S 0
(Config-if)# no ip address
(Config-if)# encapsulation frame-relay
(Config-if)# no shut
(Config-if)# exit

(Config)# int S 0.1 point-to-point
(Config-if)# bandwidth 64
(Config-if)# ip address 172.16.1.1 255.255.0.0
(Config-if)# frame-relay interface DLC1 102
(or)
(Config-if)# frame-relay map ip 172.16.1.2 102 broadcast
(Config-if)# no shut
(Config-if)# exit

(Config)# ip routing
(Config)# ip route 192.168.5.0 255.255.255.0 172.16.1.2
Point - to - Multi Point

4.0
10.0.0.1

D

1.0 10.0.0.4 103 10.0.0.2 3.0

104 102
A C
101

B 10.0.0.3

2.0
Configuration of Router A
--------------------------------
Config t
(Config)# int S 0
(Config-if)# no ip address
(Config-if)# encapsulation frame-relay
(Config-if)# no shut
(Config-if)# exit

(Config)# int S 0.1 multipoint
(Config-if)# bandwidth 64
(Config-if)# ip address 10.0.0.4 255.0.0.0
(Config-if)# frame-relay map ip 10.0.0.1 103 broadcast
(Config-if)# frame-relay map ip 10.0.0.2 102 broadcast
(Config-if)# frame-relay map ip 10.0.0.3 101 broadcast
(Config-if)# no shut
(Config-if)# exit

(Config)# ip routing
(Config)# ip route 192.168.2.0 255.255.255.0 10.0.0.3
(Config)# ip route 192.168.4.0 255.255.255.0 10.0.0.1
(Config)# ip route 192.168.5.0 255.255.255.0 10.0.0.2
Point-to-Point - Point-to-Point

172.16.1.2 4.0

1.0 10.0.0.2 3.0
172.16.1.1 103
104
10.0.0.1 102
161.16.1.1

101

10.0.0.3

2.0
Configuration of Router A
--------------------------------

Config t
(Config)# int S 0
(Config-if)# no ip address
(Config-if)# encapsulation frame-relay
(Config-if)# no shut
(Config-if)# exit

(Config)# int S 0.1 point-to-point
(Config-if)# bandwidth 64
(Config-if)# clockrate 56000
(Config-if)# ip address 172.16.1.1 255.255.0.0
(Config-if)# frame-relay map ip 172.16.1.2 103
broadcast
(Config-if)# no shut
(Config-if)# exit
(Config)# int S 0.2 point-to-point
(Config-if)# ip address 161.16.1.1 255.255.0.0
(Config-if)# no shut

(Config-if)# bandwidth 64
(Config-if)# clock rate 56000
(Config-if)# frame-relay map ip 161.16.1.2 102
broadcast
(Config-if)# exit

(Config)# int S 0.3 point-to-point
(Config-if)# bandwidth 64
(Config-if)# clockrate 56000
(Config-if)# ip address 10.0.0.1 255.0.0.0
(Config-if)# frame-relay map ip 10.0.0.2 101 broadcast
(Config-if)# no shut
(Config-if)# exit

(Config)# ip routing
(Config)# ip route 172.16.0.0 255.255.0.0
Iso
International organization for standardization
Iso has designed a reference model called osi reference model
(open system interconnection). It has 7 layers. It says that
Any n/w for comunication needs 7 layers
1. Application layer
The user uses application layer to send the data. The protocols
@ this layer are ftp,http,smtp(e-mail) telenet etc.
2. Presentation layer
Presentation layer takes the data from application layer and present
In different formats for securing reason. The services offered @
This layer are
Compression – decompression
Coding – decoding
Encryption - decryption
3. Session layer
Establishing the session or the conectivity n/w n/w 1 & n/w 2 is done
By the session layer.
It 1. Establishes a session
2. maintains it &
3. Terminates it b/w the application

4. Transport layer
End-end connectivity during a session b/w two application is done
By the transport layer. It also decides the type of connection like tcp
or udp i.e. connection oriented or connection less.
Services:
Sequencing
Flow ctrl, error detection & correction
Transport layer info + data is called segment.
5. Netwrok layer
Logical addressing is done at thenetwork layer i.e. source address &
destination address are attached to the data.
Protocols @network layer

Routed protocols routing protocols
Eg: ip,ipx eg: rip,igrp,ospf

Routed protocols: they always carry the data along with them
Routing protocol: they identify the path for routed protocol to
carry the data
At this layer routers & layer 3 switches forms packets.
Data link layer

MAC LLC
Media access control logical link control framing of
data

Ip address is lik the pincode & MAC address is like house number.
Here layer2 switches are used.
Wab protocols used at this layer are PPP,HDLC,FP,X.25 etc.
Here error checking CRC bits are added to the packets
DLL info+ packets --> frames
7 physical layer
Takes care of physical connectivity i.e connector,cable etc. here
Frames are converted to bits (1’s & 0’s).
The devices like hubs, repeaters,cables & connectors are used at
this layer.

I P Addressing
Now a days ip ver4 is followed. It is a 32-bit addressing scheme.
32bits are divided into 4 octets of 8 bits each.
i.e 8-8-8-8. i.e (1’s & 0’s)-(1’s & 0s)-(1’s & 0’s)-(1’s & 0’s).
(binary format). The ip address is maximum of 255 & min of 0.
In future ip ver 6 is expected. It is 128 bit scheme.
Ip adresses are clsassified into different classes.
Class A 0 - 127
Class B 128 - 191
Class C 192 - 223
Class D 224 - 239
Class E 240 - 255

8-8-8-8
M.S.O Most Significant Ocate considering MSO
Through out class A, the MSB ‘0’ is constant in class B the
Msbs are ‘101’ constant through out.
Class D & E are not used for internetworking class D is used for
Multicast network.
“ E “ “ “ research.
class A
0-0-0-0 should not be assigned for any divice
127-0-0-0 is reserved for loopback
127-0-0-1
127-0-0-”
127-0-0-” usually reserved for loopback
127-0-0-”
127-255-255-254
Hence 0 & 127 cannot be used for adressing so actual range will be
1 to 126.
All ip addresses are divided into two.
1.network I.d
2.host I.d
in class a address there is 1n\w I.d postion & 3 host I.d postion I,e
N-H-H-H..
Class A N-H-H-H
Class B N-N-H-H
Class C N-N-N-H

Network Ids are represented by 1s & host ids are by 0s.
Types of ip adresses
IP address

public ip address private ip address

Public network: the public address is defined with routing over the
Internet it is given by I.S.P & routing table is created on the internet.

Private network: for internal network I,e intranet, all the ip addresses
Are governed by a body called INTERNIC. If we are a part of asia
Pacefic then it is governed by APNIC.

We can run our private network with any ip addresses of our choice
But it should not be connected to internet.
Range of addresses for private network
Class A 10.0.0.0 to 10.255.255.255
Class B 172.16.0.0 to 172.31.255.255
Class C 192.168.0.0 to 192.168.255.255

Private ip addresses donot have routing.
To meet the demand of no.of networks, the network is broken
Into smaller networks called subnets.
Eg: find no.of subnets, hosts/s.n subnet mask & valid ip
addresses
For a class c address.
192.168.1.0/24
‘24’ shows the network bits
24= 3 octate position bits are enough, therefore no need to
borrow
Any bits from host position.
=24 network & no host
Switch
An essential component of lan. Switches are of different types like
Layer 2 layer 3, layer 4, layer 5…..
Layer 2 switch :
Switch hub
•Layer 2 layer 1
•b.w is equal @ all ports b.w is shared
•Identifies source with MAC cannot identifiy the source
•Broad cast occur, till mac table alwaysbroad cast
Is built
•Collision occur when both A&B Many collisions
Wants to reach D.
•1 broad cast domain 4 collision 1 broad cast domain 1 collision
Domains domain
Switches

Access layer Distribution layer Core layer

Access layer swithc: catalyst 1912
Catalyst – manufacturer, but it is now owned by cisco.
12 port switch
Switch

standard edition enterprise edition

To configure VLANS,go for enterprose edition as standard edition
Will not support VLAN.
For uplinking or cascading 100mbps is minimum required.

Functions of switch
1. Adress learning
2. Filter & forwarding
3. Loop avoidance

1. Address learning
Booting 1.blocking state (15 secs)
2.Listening state (15 secs)
3.Learning stage (20 secs)
4.Forwarding stage (20 secs)
The switch will always learn the MAC address from the source itself
The source should atleast communicate once to learn the MAC address

2. Filter & forwarding :
store & forward
cut through
fragment free
On access layer the default is fragment free we can change to any
Of the3 mentioned above.
1.store & forward: it stores the whole information (1500 bytes
Ethernet) into buffer, then checks for errors, looks for destination
In MAC table and then forward.
2. Cut through: no error checking.as soon as a packet arrives
It looks into MAC table & forward.
3.loop avridance: consider a seenario whr pci wants to communicate
To pc2. Switch a makes entry of pc1 in its MAC table as it is a new
Switch. This looping is before the mac table I s made. This is called
nitial flood or broad cast storm.
STP: spanning tree protocol. To avoid loops in case of a cascaded
Switch stp is enabled by default.
Parameters to select a switch
1. Bridge priority (32768) default.(1-655355)
2. MAC address
Bridge id is calculated. Bridge id=bridge priority + mac address.
Which ever the switch having least bridge ID will be elcted as root
Bridge and others are non-root bridge. On root bridge the ports used
For cascading are called designated ports. All the designated ports
Will be at forwadingf state . In non root bridge from the two ports
one will be selected as root port. This will be depending on the
ost speed).least cost path (faster transmission) the other port
will be blocked.
The “hello” packets that are sent by root bridge for every 2 sec to inform
that it is working properly are called BPDUS;
(bridge protocol data limits). If non root bridge do no receive
10 BPDUs for next 20secs then it is clear that the root bridge has
Failed.
20secs – max age time
Then a new root bridge is selected.
In the above eg:if switch A is selected as root bridge and ports A & B
Of switch A are designated ports. Depending on the shortest paths
For high speed & low cost one port of switch B is selected as root port
& the other will be blocked.
ISDN
Integreted services digital network.
It is a circuit switching technology approved by CCITT.
ISDN PSTN
•Digital analog
•More bandwidth less
•Multiple services like,
•Voice,data,video etc.
ISDN
BRI PRI
(Basic rate interface
2b channels & id chennel)
european standard north american
standard
30 bchannels 23 bchannels
& &
id channel id channel
‘B’channel – it is a bearer channel for data.
‘D’channel – it is a delta channel for synchronization
In bri each B channel = 64 kbps
d channel = 16kbps
Max 128 kbps BW in isdn
In PRI both B & D channels _= 64kbps.
European – 2mbps
North american – 1.54 mbps
ISDN will have a voltage of 90-110v
SPID number : (service profile identifier) to identify the link.
Types of ISDN switches
Euro-basic net3
U.S-basic 5 ess-at&t standard
U.K-basic net3 & basic net5
France-vn3 & vn4

Ss7 (signalling system7)
Will be configured at the back bone side.

telco
vn3/vn4 ss7 basic net3
France India
E-series, I-series & Q-series
E-tells about telephone network & ISDN network
I-tells about concepts & interfaces of ISDN
Q-tells about signalling & switching of ISDN

DDR
Dail on Demand Routing
The main feature of ISDN is it dials & connects on request &
Discounects when no data transfer is taking place.
nat (network address translation
IP NAT inside
IP NAT out side
overload
IPNAT inside: any request from th internal network will be NATED
To public Ip address sending the request from internal network
To Bri interface is overloading.
When ever NAT is enable, the router will maintain a nat table.
Nat table:

When nat t able is enabled nau request will be allocated a port
Number after 1024. Above 1024 port numbers are reserved for other
Services. This allocation of port numbers is dynamic.
Configuring a DDR for ISDN
Config#int e0
Config#ip adress 192.168.5.150 255.255.255.0
Config#ip nat inside
Config#exit
Config-if#int bri 0
Config-if#ip address negotiated
Config-if#encapsulation PPP
Config-if#PPP authenticaiton PAP chap collin
Config-if#PPP chap hostname (username)
Config-if#PPP chap password (password)
Config-if#dialer string (tel.no.)
Config-if#dialer idle timeout (time in secs)
Config-if#dialer group
Config-if#ip nat outside
Config-if#exit
Ip address negotialted : this is when an ip adress is fetched kdynamicall
From ISP 7 donot have a permanent public I.P adress
Dialer – list range 1-10
to configure router as a DHCP server
Config#ip pool <name> staring ip end ip.

Some ISDN command
Sh int bri0
Sh isdn status
(layer 1 should be active. If not physical conectivity is lost)

Sh isdn active
Sh isdn history
Sh ip network translaiton