You are on page 1of 24

Cisco Unified Communications Manager Express

Introduction to CUCME
CUCME is Call Agent running Cisco IOS routers.
Supports up to 450 IP Phones.
Suitable for small offices and enterprise branches.
Supports two types of deployments: Single Site & Multisite.
IP Phones can controlled using either SCCP or SIP
WAN

PSTN

Single Site Deployment

WAN

PSTN

Multi-Site Deployment

CUCME Functions

Call processing.

Signaling and device control.

Dial plan administration.

Phone feature administration.

Directory services.

Direct access to gateway features and modules.

CUCME Features
Phone Features
Support for the complete line of Cisco single-line and multiline IP phones
Support for analog phones and fax machines on the router analog voice ports and on the Cisco Analog
Telephone
Adaptor (ATA)
Media encryption using Secure Real-Time Transport Protocol (SRTP)
Cisco Extension Mobility
XML services on Cisco IP PhonesXML-based directory services

Call handling:

CUCME Features (Cont..)


System Features
Multiple administration methods:
CLI
Web-based embedded GUI for moves, adds, and changes
Cisco Configuration Professional (CCP)

Cisco Unified Survivable Remote Site Telephony (SRST)

Hardware and software conferencing capabilities.

Music on hold (MOH)

Paging.

Intercom.

Distinctive ringinginternal versus external.

Cisco Unified IP Interactive Voice Response (IVR) Auto


Attendant.

Class of restriction to restrict calling capabilities.

Integration with Cisco Unity voice mail

Integration with Cisco Unity Express voice mail

CUCME Features (Cont..)

Trunking Features
Direct Inward Dialing (DID) and Direct Outward Dialing
(DOD)
Basic Rate Interface (BRI) and Primary Rate Interface (PRI)
support
Analog: Foreign Exchange Office (FXO), DID
Digital trunk support: T1 and E1
WAN link support: Frame Relay, ATM, Multilink PPP (MLP),
and DSL

CUCME Endpoints Requirements


CDP: Cisco Discovery Protocols is used to send the voice VLAN information and
QoS related information to the IP phones from Cisco switches
Power over Ethernet: Cisco IP Phones can be powered from switches using
power over Ethernet technologies.
VLAN: Segregates data and voice traffics-improves security and provides QoS.
DHCP: Provides IP configuration parameters to the IP Phones with the help of
DHCP server.
TFTP: CUCME generates device specific configuration files and stores it in TFTP
server. Cisco IP phones downloads these configuration files from the TFTP server.
IP Phones get the IP address of the TFTP server through DHCP.
NTP: Use to synchronize time across multiple network devices.

Cisco IP Phone Registration Process


1. The 802.3af PoE switch sends a small DC voltage on the
Ethernet cable, detects an unpowered 802.3af device, and
supplies power to the line.
2. The switch delivers voice VLAN information to the Cisco IP
Phone using Cisco Discovery Protocol (CDP).
3. The IP Phone sends a Dynamic Host Configuration Protocol
(DHCP) request on its voice VLAN. The DHCP server replies
with IP addressing information, including DHCP Option 150,
which directs the IP phone to the TFTP server.
4. The IP phone contacts the TFTP server and downloads its
configuration file and firmware.
5. Based on the IP address listed in the configuration file, the
IP phone contacts the call processing server (the CME RYDGW, in this case), which supports VoIP functions.

Power over Ethernet


Cisco IP Phones support the following options for power:
Power over Ethernet: Switches provide power to the IP Phones through the
twisted pair cables. There are two standards Cisco Inline Power (pre-standard) and
IEEE 802.3af (Industry standard)
Midspan Power Injection: Used when the switches are not supporting PoE.
Midspan Power Injector sits between the switch and the IP phone and inject the
power.
Wall power: Wall power needs a DC converter for connecting the Cisco IP Phone to
a wall outlet.

Configuring and Verifying PoE

Switch(config)# interface FastEthernet 0/1


Switch(config-if)#power inline {auto | never}
Switch# show power inline

Voice VLAN

Voice VLAN helps the traffic from IP Phones and attached PC (daisy chained) to flow in different VLANs

Switch(config)#interface FastEthernet0/1
Switch (config-if)#switchport mode access
Switch (config-if)#switchport voice vlan 10
Switch (config-if)#switchport access vlan 20
Switch (config-if)#spanning-tree portfast
Switch# show vlan brief
Switch#show interfaces fa0/1 switchport

DHCP
DHCP provide IP parameters to the IP Phones.
IP Phones get the following configuration parameters from a DHCP server:
IP Address
Subnet Mask
Default Gateway
IP address of DNS server(s)
Domain Name
IP address (option 150) or Name (option 66) of the TFTP server

Configuring Router Based DHCP


Router(config)#interface FastEthernet0/0
Router(config-if)# ip address 192.168.1.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.20
Router(config)# ip dhcp pool VOICE
Router(dhcp-config)# network 192.168.1.0 255.255.255.0
Router(dhcp-config)# default-router 92.168.1.1
Router(dhcp-config)# option 150 ip 192.168.1.1
Router#show ip dhcp binding

Network Time Protocol (NTP)


NTP is used synchronize time across the network devices

Router(config)# clock timezone AST 3


Router(config)# ntp server 10.1.1.1
prefer
Router(config)# ntp server 10.2.2.2

Configures router as an NTP client.


10.1.1.1 is the preferred NTP server. If
10.1.1.1 is not available the router sycn
the time with 10.2.2.2

Router(config)# clock timezone AST 3


Router#clock set 18:00:00 4 Nov 2014
Router(config)# ntp master

Configures router as an NTP server

TFTP Server
TFTP server hosts the device specific configuration file and firmware (image) file for the
IP Phones
IP Phones get the IP address (or name ) of the TFTP server from the DHCP server.
IP Phones download the configuration file first in which it will be listed parameters to
connect to the CUCME or CUCM and the firmware files required
Then IP Phones download the firmware files from the TFTP server

Configuring Router Based TFTP Server


Step 1: Get the firmware file to the router flash.
Router# archive tar /xtract tftp://<ip address of TFTP server>/<filename.tar> flash:
Router# dir flash:
Router# show flash:
Step 2: Configure router to serve the firmware files using TFTP
Router(config)# tftp-server flash:/phone/7940-7960/P00308000500.bin alias P00308000500.bin
Router(config)# tftp-server flash:/phone/7940-7960/loads alias P00308000500.loads
Router(config)# tftp-server flash:/phone/7940-7960/P00308000500.sb2 alias P00308000500.sb2
Router(config)# tftp-server flash:/phone/7940-7960/P00308000500.sbn alias P00308000500.sbn

Note: the alias command is required if the firmware files are stored in sub directories in the flash

Configuring Router for CUCME (SCCP)


Router(config)#telephony-service
Enters the configuration mode for system wide parameters for SCCP IP phones in CUCME.
Router(config-telephony)#ip source-address 192.168.1.1 port 2000
The IP address to which the IP phones will register with.
Router(config-telephony)#load 7960-7940 P00308000500
The load command updates the CUCME configuration file for the specified type of Cisco IP Phone to add the
name of the firmware file to be loaded by a particular phone type.
A separate load command is needed for each type of phone.
CME(config-telephony)#max-ephones 10
An SCCP endpoint is defined within CUCME as an ephone . The max-ephones command is set to 0 by default to
conserve system memory
CME(config-telephony)#max-dn 30
Specifies Maximum number of directory numbers
CME(config-telephony)#date-format mm-dd-yy
CME(config-telephony)#time-format 12
CME(config-telephony)#create cnf-files
The create cnf-files command in telephony-service configuration mode builds the XML

Ephone and Ephone-dn

Ephone
Ephone represents a Cisco IP Phone which is registered with CUCME.
Each ephone is created using a tag number to identify in the configuration.
Ephone is associated with physical phone using MAC address.

Ephone-dn
Ephone-dn is the directory number that is associated with an IP Phone.
Each ephone-dn is created using a tag and given number to provide the reachability.
There are three different types of ephone-dns:
Single Line: One active call at a time.
Dual Line: Two active call at a time. Used for features like call waiting, consultative transfer,

and conference.
OctoLine: Eight calls at the same time.

Configuring Ephone-dn
Dual Line Ephone-dn
Router(config)# ephone-dn 1 dual-line
Router(config-ephone-dn)# number 1001 secondary 4911001
Router(config-ephone-dn)#name Abdul Rasheed
Router(config-ephone-dn)#label Abdul Rasheed x1001
Router(config-ephone-dn)#description 4911001

Single Line Ephone-dn


Router(config)# ephone-dn 2
Router(config-ephone-dn)# number 1002 secondary 4911002
Router(config-ephone-dn)#name Phone User2
Router(config-ephone-dn)#label Phone User2 x1002
Router(config-ephone-dn)#description 4911002

Configuring Ephone
Router(config)#ephone 1
Router(config-ephone)#mac-address 000F.2470.F8F1
Router(config-ephone)#button 1:1
Router(config-ephone)#reset
1:1 Associating ephone-dn 1 to the first button of this phone (the first 1 is the button
number, : is the separator, and second 1 is the ephone-dn tag

Verifying CUCME Configuration for SCCP Phones


Router#show ephone
Router#show ephone summary
Router#show ephone registered
Router#show telephone-service
Router#show telephone-service tftp-binding
Router#show ephone [summary]
Router#show ephone-dn [summary]
Router#debug tftp-events
Router#debug ephone [detail]

Configuring CUCME for SIP Phones


Router(config)#voice service voip
Router(conf-voi-serv)# allow-connections sip to sip
Router(conf-voi-serv)# sip
Router(conf-serv-sip)# bind all source-interface FastEthernet0/0
Router(conf-serv-sip)# registrar server expires max 3600 min 60
Router(config)# voice register global
Router(config-register-global)#mode cme
Router(config-register-global)#source-address 172.16.10.1 port 5060
Router(config-register-global)#max-dn 20
Router(config-register-global)#max-pool 10
Router(config-register-global)#load 7965 SIP45.8-5-4S
Router(config-register-global)#tftp-path flash:
Router(config-register-global)#file text
Router(config-register-global)#create profile
Note: Before this configuration, make sure that required firmware files for all SIP phones (that you
want to provision) is copied to the flash and server using TFTP.

Configuring SIP Phones & Directory Numbers


Directory Number
Router(config)#voice register dn 1
Router(config-register-dn)#number 1005
Router(config-register-dn)#name Abdul Rasheed
Router(config-register-dn)#label Abdul Rasheed

SIP Phones
Router(config)#voice register pool pool-tag
Router(config-register-pool)#voice register pool 1
Router(config-register-pool)# id mac 8CB6.4F56.9230
Router(config-register-pool)# type 7965
Router(config-register-pool)# number 1 dn 1
Router(config-register-pool)# username 1005 password cisco

Verifying CUCME Configuration for SIP Phones


Router#show voice register pool
Router#show voice register dn
Router#show voice register global
Router#debug voice register events
Router#debug tftp-events
Router#debug ccsipmessages