You are on page 1of 138

Cisco IOS

Copyright eLearnCisco 2010 1


Se connecter
lquipement
Connexion physique du port
CONSOLE

Copyright eLearnCisco 2010 2


Mthodes
Plusieurs manires de se connecter un
switch ou un routeur :
via le port CONSOLE OUTBAND
via un port TELNET INBAND
via une interface PHYSIQUE INBAND

Copyright eLearnCisco 20 3
Le port CONSOLE
Cest un port RJ45.
Tous les quipements CISCO ont un port
CONSOLE et toujours un seul port
console.

Copyright eLearnCisco 20 4
Le port COM
Cest un port DB9

Copyright eLearnCisco 20 5
Le cable CONSOLE
Cest un cable ROLLOVER
1 8
2 7
3 6
4 5
5 4
6 3
7 2
8 1

Copyright eLearnCisco 20 6
Connexion
Connecter le cable console entre le port
console et le port COM du PC :

Copyright eLearnCisco 20 7
Le port USB
Certains PC nont pas de port COM.
Utiliser une adaptateur USB :

Copyright eLearnCisco 20 8
Se connecter
lquipement
Connexion logicielle

Copyright eLearnCisco 2010 9


Le Logiciel
On peut utiliser HyperTerminal
install sur XP
activer sur Vista ou Windows 7
On peut aussi prendre :
Putty
TeratermPro
CRT

Copyright eLearnCisco 20 10
1. Lancer HyperTerminal

Copyright eLearnCisco 20 11
2. Nommer la connexion

Copyright eLearnCisco 20 12
3. Choisir le port COM

Copyright eLearnCisco 20 13
4. Paramtres par dfaut

Copyright eLearnCisco 20 14
5. Interface de connexion

Copyright eLearnCisco 20 15
6. Le hostname

Copyright eLearnCisco 20 16
7. Le prompt

Copyright eLearnCisco 20 17
Les modes daccs
Command Line Interface
CLI

Copyright eLearnCisco 2010 18


DEUX modes
Le mode USER :
Le prompt est >
Seulement certaines commandes sont
disponibles
Le mode PRIVILEGIE :
Le prompt est #
Toutes les commandes sont disponibles

Copyright eLearnCisco 20 19
Basculer entre les 2 modes
Utiliser les commandes enable et disable :
Router>enable
Router#
Router#
Router#
Router#disable
Router>
Par dfaut, il ny a pas de mot de passe pour
basculer en mode privilgi.

Copyright eLearnCisco 20 20
Les contextes du mode privilgi
Le mode privilgi contient plusieurs
contextes :
le contexte de consultation
le contexte de configuration globale
les contextes de configuration spcifique
spcifique une interface
spcifique une ligne
spcifique un protocole de routage
etc..

Copyright eLearnCisco 20 21
Le contexte de consultation
Il permet dinterroger le routeur ou le switch pour lui
demander dafficher les paramtres configurs :
quelle adresse IP as-tu sur telle interface ?
quels sont les quipements voisins que tu as dtects ?
etc
Il permet deffectuer les commandes de sauvegarde de
la configuration :
copier la configuration dans la mmoire
Il permet de lancer des commandes ICMP :
pinger un autre quipement du rseau
dcouvrir le chemin emprunt par le traffic entre 2 points du
rseau

Copyright eLearnCisco 20 22
Le contexte de consultation
Il est identifiable par :
Hostname#
Les commandes de consultation commencent souvent
par show :
show ip interface brief
show cdp neighbor
show running-configuration
Mais pas toujours :
copy running-config startup-config
write memory
write
ping
traceroute

Copyright eLearnCisco 20 23
Le contexte de configuration globale

Il permet de configurer un paramtre


global du routeur ou du switch :
son hostname
le mot de passe du mode privilgi
etc..
Il permet aussi de basculer dans un mode
de configuration spcifique

Copyright eLearnCisco 20 24
Le contexte de configuration globale
Il est identifi par :
Hostname(config)#
Pour rentrer dans le contexte de
configuration globale :
taper la commande configure terminal
Pour quitter le contexte de configuration
globale :
taper la commande exit
ou la combinaison de touches [Ctrl] + Z

Copyright eLearnCisco 20 25
Ncessit des contextes
Chaque commande ne fonctionne que
dans son contexte :
Une commande de configuration ne
fonctionne pas dans le contexte de
consultation.
Et inversement :
Une commande de consultation ne fonctionne
pas dans le contexte de configuration.
On peut toutefois forcer la commande de consultation avec le prefix do.

Copyright eLearnCisco 20 26
Exemple 1 : changer le hostname
Router>
Router>enable
Router#
Router#
Router#configure terminal
Router(config)#
Router(config)#hostname TOTO
TOTO(config)#
TOTO(config)#exit
TOTO#
TOTO#disable
TOTO>
Copyright eLearnCisco 20 27
Mode USER
Router>
Router>enable
Router#
Router#
Router#configure terminal
Router(config)#
Router(config)#hostname TOTO
TOTO(config)#
TOTO(config)#exit
TOTO#
TOTO#disable
TOTO>
Copyright eLearnCisco 20 28
Mode PRIVILEGIE
Router>
Router>enable
Router#
Router#
Router#configure terminal
Router(config)#
Router(config)#hostname TOTO
TOTO(config)#
TOTO(config)#exit
TOTO#
TOTO#disable
TOTO>
Copyright eLearnCisco 20 29
Contexte de consultation
Router>
Router>enable
Router#
Router#
Router#configure terminal
Router(config)#
Router(config)#hostname TOTO
TOTO(config)#
TOTO(config)#exit
TOTO#
TOTO#disable
TOTO>
Copyright eLearnCisco 20 30
Contexte de configuration globale
Router>
Router>enable
Router#
Router#
Router#configure terminal
Router(config)#
Router(config)#hostname TOTO
TOTO(config)#
TOTO(config)#exit
TOTO#
TOTO#disable
TOTO>
Copyright eLearnCisco 20 31
Exemple 2 : refus de la commande
hostname
Router>
Router>hostname TOTO
^
% Invalid input detected at '^' marker.

Router>enable
Router#
Router#hostname TOTO
^
% Invalid input detected at '^' marker.

Router#configure terminal
Enter configuration commands,one per line.End with CNTL/Z.
Router(config)#hostname TOTO
TOTO(config)#

Copyright eLearnCisco 20 32
Exemple 3 : refus dune commande
show
TOTO#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down

TOTO#conf t
Enter configuration commands, one per line. End with CNTL/Z.
TOTO(config)#show ip interface brief
^
% Invalid input detected at '^' marker.

TOTO(config)#do show ip interface brief


Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down

TOTO(config)#

Copyright eLearnCisco 20 33
Les contextes de configuration
spcifique
Il permet de configurer un paramtre
spcifique du routeur ou du switch :
ladresse IP dune interface
le mot de passe de la ligne console
le mot de passe dun protocole de routage

Copyright eLearnCisco 20 34
Les contextes de configuration
spcifique
Il sont identifis par :
Hostname(config-X)#
Pour rentrer dans le contexte de configuration
spcifique :
il faut dabord passer en contexte de configuration
globale
puis taper la commande du contexte spcifique
Pour quitter le contexte de configuration
spcifique :
taper la commande exit

Copyright eLearnCisco 20 35
Exemples
TOTO>
TOTO>enable
TOTO#
TOTO#configure terminal
TOTO(config)#
TOTO(config)#interface fastEthernet 0/0
TOTO(config-if)#no shutdown
TOTO(config-if)#ip address 10.0.0.1 255.255.255.0
TOTO(config-if)#exit
TOTO(config)#
TOTO(config)#line console 0
TOTO(config-line)#password Z3Y6
TOTO(config-line)#exit
TOTO(config)#
TOTO(config)#router ospf 1
TOTO(config-router)#area 0 authentication
TOTO(config-router)#exit
TOTO(config)#
TOTO(config)#ip access-list standard TEST
TOTO(config-std-nacl)#permit host 10.0.0.1
TOTO(config-std-nacl)#exit
TOTO(config)#
TOTO(config)#exit
TOTO#
Copyright eLearnCisco 20 36
Contexte de configuration globale
TOTO>
TOTO>enable
TOTO#
TOTO#configure terminal
TOTO(config)#
TOTO(config)#interface fastEthernet 0/0
TOTO(config-if)#no shutdown
TOTO(config-if)#ip address 10.0.0.1 255.255.255.0
TOTO(config-if)#exit
TOTO(config)#
TOTO(config)#line console 0
TOTO(config-line)#password Z3Y6
TOTO(config-line)#exit
TOTO(config)#
TOTO(config)#router ospf 1
TOTO(config-router)#area 0 authentication
TOTO(config-router)#exit
TOTO(config)#
TOTO(config)#ip access-list standard TEST
TOTO(config-std-nacl)#permit host 10.0.0.1
TOTO(config-std-nacl)#exit
TOTO(config)#
TOTO(config)#exit
TOTO#
Copyright eLearnCisco 20 37
Contexte de configuration
spcifique une interface
TOTO>
TOTO>enable
TOTO#
TOTO#configure terminal
TOTO(config)#
TOTO(config)#interface fastEthernet 0/0
TOTO(config-if)#no shutdown
TOTO(config-if)#ip address 10.0.0.1 255.255.255.0
TOTO(config-if)#exit
TOTO(config)#
TOTO(config)#line console 0
TOTO(config-line)#password Z3Y6
TOTO(config-line)#exit
TOTO(config)#
TOTO(config)#router ospf 1
TOTO(config-router)#area 0 authentication
TOTO(config-router)#exit
TOTO(config)#
TOTO(config)#ip access-list standard TEST
TOTO(config-std-nacl)#permit host 10.0.0.1
TOTO(config-std-nacl)#exit
TOTO(config)#
TOTO(config)#exit
TOTO#
Copyright eLearnCisco 20 38
Contexte de configuration
spcifique une ligne
TOTO>
TOTO>enable
TOTO#
TOTO#configure terminal
TOTO(config)#
TOTO(config)#interface fastEthernet 0/0
TOTO(config-if)#no shutdown
TOTO(config-if)#ip address 10.0.0.1 255.255.255.0
TOTO(config-if)#exit
TOTO(config)#
TOTO(config)#line console 0
TOTO(config-line)#password Z3Y6
TOTO(config-line)#exit
TOTO(config)#
TOTO(config)#router ospf 1
TOTO(config-router)#area 0 authentication
TOTO(config-router)#exit
TOTO(config)#
TOTO(config)#ip access-list standard TEST
TOTO(config-std-nacl)#permit host 10.0.0.1
TOTO(config-std-nacl)#exit
TOTO(config)#
TOTO(config)#exit
TOTO#
Copyright eLearnCisco 20 39
Contexte de configuration
spcifique un protocole de
TOTO>
TOTO>enable
routage
TOTO#
TOTO#configure terminal
TOTO(config)#
TOTO(config)#interface fastEthernet 0/0
TOTO(config-if)#no shutdown
TOTO(config-if)#ip address 10.0.0.1 255.255.255.0
TOTO(config-if)#exit
TOTO(config)#
TOTO(config)#line console 0
TOTO(config-line)#password Z3Y6
TOTO(config-line)#exit
TOTO(config)#
TOTO(config)#router ospf 1
TOTO(config-router)#area 0 authentication
TOTO(config-router)#exit
TOTO(config)#
TOTO(config)#ip access-list standard TEST
TOTO(config-std-nacl)#permit host 10.0.0.1
TOTO(config-std-nacl)#exit
TOTO(config)#
TOTO(config)#exit
TOTO#
Copyright eLearnCisco 20 40
Contexte de configuration
spcifique une access-list
TOTO>
TOTO>enable
TOTO#
TOTO#configure terminal
TOTO(config)#
TOTO(config)#interface fastEthernet 0/0
TOTO(config-if)#no shutdown
TOTO(config-if)#ip address 10.0.0.1 255.255.255.0
TOTO(config-if)#exit
TOTO(config)#
TOTO(config)#line console 0
TOTO(config-line)#password Z3Y6
TOTO(config-line)#exit
TOTO(config)#
TOTO(config)#router ospf 1
TOTO(config-router)#area 0 authentication
TOTO(config-router)#exit
TOTO(config)#
TOTO(config)#ip access-list standard TEST
TOTO(config-std-nacl)#permit host 10.0.0.1
TOTO(config-std-nacl)#exit
TOTO(config)#
TOTO(config)#exit
TOTO#
Copyright eLearnCisco 20 41
Quitter un contexte de configuration
spcifique
TOTO>
TOTO>enable
TOTO#
TOTO#configure terminal
TOTO(config)#
TOTO(config)#interface fastEthernet 0/0
TOTO(config-if)#no shutdown
TOTO(config-if)#ip address 10.0.0.1 255.255.255.0
TOTO(config-if)#exit
TOTO(config)#
TOTO(config)#line console 0
TOTO(config-line)#password Z3Y6
TOTO(config-line)#exit
TOTO(config)#
TOTO(config)#router ospf 1
TOTO(config-router)#area 0 authentication
TOTO(config-router)#exit
TOTO(config)#
TOTO(config)#ip access-list standard TEST
TOTO(config-std-nacl)#permit host 10.0.0.1
TOTO(config-std-nacl)#exit
TOTO(config)#
TOTO(config)#exit
TOTO#
Copyright eLearnCisco 20 42
Quitter la fois un contexte de
configuration spcifique et le contexte
de configuration globale
Utiliser la combinaison de touche [Ctrl] + Z :

TOTO>
TOTO>enable
TOTO#
TOTO#configure terminal
TOTO(config)#
TOTO(config)#interface fastEthernet 0/0
TOTO(config-if)#no shutdown
TOTO(config-if)#^Z
TOTO#
TOTO#

Copyright eLearnCisco 20 43
Les sauvegardes

Copyright eLearnCisco 2010 44


DEUX configurations
Les switch et les routeurs ont deux types de
configurations :
la running-configuration RAM
la startup-configuration NVRAM

Les switch et les routeurs ont deux types de


mmoire :
RAM volatile est efface (*)
NVRAM non-volatile est conserve (*)
(*) suite une coupure de courant

Copyright eLearnCisco 20 45
Modification des config. 1/4
NVRAM RAM
startup-config. running-config.
vide vide

Cas dun routeur ou dun switch neuf :


au dmarrage, les 2 configurations sont vides

Copyright eLearnCisco 20 46
Modification des config. 2/4
NVRAM RAM
startup-config. running-config.
vide hostname TOTO

Je saisis les commandes suivantes :


enable
configure terminal
hostame TOTO
exit
Ces paramtres sont automatiquement enregistrs
seulement dans la running-config.

Copyright eLearnCisco 20 47
Modification des config. 3/4
NVRAM RAM
startup-config. running-config.
vide vide

Suite une coupure de courant :


toutes les configurations sont perdues
car au dmarrage, lquipement charge les
paramtres de la startup-configuration sauvegards
dans la NVRAM.

Copyright eLearnCisco 20 48
Modification des config. 4/4
NVRAM RAM
startup-config. running-config.
hostname TOTO hostname TOTO

Je saisis les commandes suivantes :


enable
configure terminal
hostame TOTO
exit
copy running-config startup-config
Ces paramtres sont maintenant enregistrs la fois
dans la running-config. et la startup-config.

Copyright eLearnCisco 20 49
Sauvegarde
NVRAM RAM
startup-config. running-config.
hostname TOTO hostname TOTO

Ces 3 commandes sont quivalentes :


copy running-config startup-config
write
write memory
Copyright eLearnCisco 20 50
Sauvegarde
TOTO#
TOTO#copy running-config startup-config
Destination filename [startup-config]? taper sur la touche Entre
Building configuration...
[OK]

TOTO#
TOTO#write
Building configuration...
[OK]

TOTO#
TOTO#write memory
Building configuration...
[OK]

TOTO#
TOTO#dir nvram:
Directory of nvram:/

124 -rw- 445 <no date> startup-config


125 ---- 24 <no date> private-config
1 -rw- 0 <no date> ifIndex-table

129016 bytes total (127471 bytes free)

Copyright eLearnCisco 20 51
Modification de la running-config
On ne peut pas modifier la startup-
configuration.
on ne peut que copier la run dans la start

A chaque fois quon saisit une commande,


elle ira modifier la running-config.
on modifie donc la config dans la RAM.

Copyright eLearnCisco 20 52
Modification de la running-config.
NVRAM RAM
startup-config. running-config.

configure terminal
Copyright eLearnCisco 20 53
Modification de la startup-config.
NVRAM RAM
startup-config. running-config.

copy run start


Copyright eLearnCisco 20 54
Au dmarrage
Le switch ou le routeur ira chercher la
startup-config dans la NVRAM :
si elle est prsente, il charge cette statup-
config dans la running-config
si elle nest pas prsente (*), il vous propose
un dialogue de configuration

(*) cas dun quipement neuf ou dun quipement dont le registre de configuration a
t modifi

Copyright eLearnCisco 20 55
Le dialogue de configuration
Rpondre no :

--- System Configuration Dialog ---

Would you like to enter the initial configuration


dialog? [yes/no]: no

Copyright eLearnCisco 20 56
Le dialogue de configuration
Si vous avez rpondu yes :

--- System Configuration Dialog ---


Would you like to enter the initial configuration dialog?
[yes/no]: yes

At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system
Would you like to enter basic management setup? [yes/no]: yes
Configuring global parameters:
Enter host name [Router]: toto
etc
A tout moment, vous pouvez quitter ce dialogue avec [Ctrl] + C

Copyright eLearnCisco 20 57
Le dialogue de configuration
Pour lancer le dialogue, taper setup en mode privilgi :

Router#setup

--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: yes

At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.

Basic management setup configures only enough connectivity


for management of the system, extended setup will ask you
to configure each interface on the system

Would you like to enter basic management setup? [yes/no]: etc

Copyright eLearnCisco 20 58
Vrifier les config.
NVRAM RAM
startup-config. running-config.
Router>show startup-config Router>show running-config
^ ^
% Invalid input detected at '^' marker. % Invalid input detected at '^' marker.

Router>enable Router>enable
Router#
Router#show startup-config Router#
Router#show running-config
Using 447 out of 129016 bytes Building configuration...
!
version 12.4 Current configuration : 447 bytes
service timestamps debug datetime msec !
service timestamps log datetime msec version 12.4
no service password-encryption service timestamps debug datetime msec
! service timestamps log datetime msec
hostname Router no service password-encryption
! !
etc hostname Router
etc..

Copyright eLearnCisco 20 59
Les aides de la CLI
Utiliser la touche ?

Copyright eLearnCisco 2010 60


?
Pour obtenir toutes les commandes qui
commencent par certaines lettres.
Exemples :
TOTO(config)#h?
help hostname http
Dans le contexte de configuration globale, il existe trois
commandes qui commencent par h.

TOTO(config)#ho?
hostname
Dans le contexte de configuration globale, il nexiste quune
seule commande qui commence par ho.

Copyright eLearnCisco 20 61
sh?
TOTO#sh?
show
Dans le contexte de consultation, il nexiste quune
seule commande qui commencent par sh.

Copyright eLearnCisco 20 62
show ip ?
TOTO#sh? pas despace avant ?
show

TOTO#show ip ? un espace avant ?


access-lists List IP access lists
accounting The active IP accounting database
aliases IP alias table
arp IP ARP table
as-path-access-list List AS path access lists
bgp BGP information
cache IP fast-switching route cache
casa display casa information
cef Cisco Express Forwarding
community-list List community-list
ddns Dynamic DNS
dfp DFP information
dhcp Show items in the DHCP database
director Director agent
dns Show DNS zone information
drp Director response protocol
dvmrp DVMRP information
eigrp IP-EIGRP show commands
explicit-paths Show IP explicit paths
extcommunity-list List extended-community list
flow NetFlow switching
helper-address helper-address table
--More--

Copyright eLearnCisco 20 63
--More--
Signifie que lquipement a plusieurs
pages afficher.

Trois possibilits :
appuyer sur Entre afficher 1 ligne supplmentaire
appuyer sur Barre despace afficher 1 page supplmentaire
appuyer sur toute autre touche arrter laffichage

Copyright eLearnCisco 20 64
show ip i?
TOTO#show ip i? trois commandes disponibles
igmp interface irdp

TOTO#show ip interface ? nombreuses commandes disponibles


Async Async interface
BVI Bridge-Group Virtual Interface
CDMA-Ix CDMA Ix interface
CTunnel CTunnel interface
Dialer Dialer interface
FastEthernet FastEthernet IEEE 802.3
Lex Lex interface
Loopback Loopback interface
MFR Multilink Frame Relay bundle interface
Multilink Multilink-group interface
Null Null interface
Port-channel Ethernet Channel of interfaces
Tunnel Tunnel interface
Vif PGM Multicast Host interface
Virtual-PPP Virtual PPP interface
Virtual-Template Virtual Template interface
Virtual-TokenRing Virtual TokenRing
brief Brief summary of IP status and configuration
| Output modifiers
<cr>

TOTO#show ip interface brief

Copyright eLearnCisco 20 65
Les aides de la CLI
Utiliser la touche tabulation

Copyright eLearnCisco 2010 66


Auto-compltion
Lquipement complte automatiquement
la fin de chaque mot-clef dune commande
sil nexiste quune seule commande avec
les lettres dj saisies.
Exemple :
configure terminal
Cette commande peut tre simplement saisie avec :
conf t
car il nexiste pas dautre commande qui commence avec ces mmes
lettres.

Copyright eLearnCisco 20 67
Trois possibilits
Saisir toute la commande :
configure terminal
Ne saisir que les lettres minimales :
conf t
Saisir les lettres minimales + appuyer sur
tabulation aprs chaque mot-clef
conf[tabulation] t[tabulation]
sil nexiste quune seule commande qui commence par les
lettres saisies, lquipement affichera la commande
complte
sil trouve plusieurs possibilits, il met un BIP

Copyright eLearnCisco 20 68
Exemple 1
TOTO#configure terminal
TOTO(config)#^Z
TOTO#
TOTO#
TOTO#conf t
TOTO(config)#^Z [tabulation]
TOTO#
TOTO# [tabulation]
TOTO#conf
TOTO#configure t
TOTO#configure terminal
TOTO(config)#^Z
TOTO#

Copyright eLearnCisco 20 69
Exemple 2
Lauto-completion permet dviter les erreur de frappe.

Exemple :
TOTO#sh
TOTO#show ip in
TOTO#show ip interface br
TOTO#show ip interface brief

en vert les caractres saisis par ladministrateur


en rouge les caractres rajouts par lquipement
[tabulation]

Copyright eLearnCisco 20 70
Les aides de la CLI
Positionner le curseur

Copyright eLearnCisco 2010 71


Comment corriger une commande
shpw ip interface brief

1re mthode :
utiliser les flches de dplacement

2me mthode :
utiliser les touches de dplacement rapide

Copyright eLearnCisco 20 72
[Ctrl] + a
shpw ip interface brief

Positionne le curseur en dbut de ligne

Copyright eLearnCisco 20 73
[Ctrl] + e
shpw ip interface brief

Positionne le curseur en fin de ligne

Copyright eLearnCisco 20 74
[Echap] + b
shpw ip interface brief

Recule le curseur dun mot

Copyright eLearnCisco 20 75
[Echap] + f
shpw ip interface brief

Avance le curseur dun mot

Copyright eLearnCisco 20 76
[Ctrl] + w
shpw ip interface brief

Efface toutes les lettres


entre le mot courant et le curseur

Copyright eLearnCisco 20 77
[Ctrl] + x
shpw ip interface brief

Efface toutes les lettres


entre le dbut de la ligne et le curseur.

Copyright eLearnCisco 20 78
Les aides de la CLI
Rappeler de commandes

Copyright eLearnCisco 2010 79


Flches haut et bas
Elles permettent de rappeler une commande saisie prcdemment.
Par dfaut, lquipement mmorise les 10 dernires commandes.
enable
configure terminal
history size 30
taille entre 0 et 256
terminal history size 30
taille entre 0 et 256
uniquement pour la session courante
history
activer la mmorisation de commande (par dfaut)
no history
dsactiver cette mmorisation
exit
show history
afficher toutes les commandes dj saisies

Copyright eLearnCisco 20 80
Exemple : inefficace
Pour activer 4 interfaces :
TOTO#enable
TOTO#configure terminal
TOTO(config)#interface fastEthernet 0
TOTO(config-if)#no shutdown
TOTO(config)#interface fastEthernet 1
TOTO(config-if)#no shutdown
TOTO(config)#interface fastEthernet 2
TOTO(config-if)#no shutdown
TOTO(config)#interface fastEthernet 3
TOTO(config-if)#no shutdown

en vert les caractres saisis par ladministrateur


en rouge les caractres rajouts par lquipement

Copyright eLearnCisco 20 81
Exemple : efficace
Pour activer 4 interfaces :
TOTO#enable
TOTO#configure terminal
TOTO(config)#interface fastEthernet 0
TOTO(config-if)#no shutdown
TOTO(config)# interface fastEthernet 1
TOTO(config-if)# no shutdown
TOTO(config)# interface fastEthernet 2
TOTO(config-if)# no shutdown
TOTO(config)# interface fastEthernet 3
TOTO(config-if)# no shutdown

en vert les caractres saisis par ladministrateur


en rouge les caractres rajouts par lquipement

Copyright eLearnCisco 20 82
Exemple : efficace + +
Pour activer 4 interfaces :
TOTO#en able
TOTO#conf igure t erminal
TOTO(config)#int erface fa stEthernet 0
TOTO(config-if)#no sh utdown
TOTO(config)# interface fastEthernet 1
TOTO(config-if)# no shutdown
TOTO(config)# interface fastEthernet 2
TOTO(config-if)# no shutdown
TOTO(config)# interface fastEthernet 3
TOTO(config-if)# no shutdown

en vert les caractres saisis par ladministrateur


en rouge les caractres rajouts par lquipement
[tabulation]
[flche haut]

Copyright eLearnCisco 20 83
Configurations de base
Configurations globales

Copyright eLearnCisco 2010 84


Hostname
Par dfaut :
Router sur un routeur
Switch sur un switch
Il est modifi ds quil est configur :
TOTO>enable
TOTO#conf t
TOTO(config)#hostname TATA
TATA(config)#

Copyright eLearnCisco 20 85
Le mot de passe PRIVILEGIE
Par dfaut, il ny a pas de mot de passe.
Deux manires de le configurer :
ancienne commande :
TATA#conf t
TATA(config)#enable password Z3R4
nouvelle commande :
TATA#conf t
TATA(config)#enable secret R4Z3
est systmatiquement crypt
cryptage plus robuste
Si les 2 commandes sont saisies, seule le mot de
passe de la nouvelle commande sera demand.

Copyright eLearnCisco 20 86
Passage reserv
Par dfaut, pas de mot de passe pour passer en mode
privilgi :
tout individu qui a accs lquipement peut modifier sa
configuration
Avec un mot de passe :
seuls les personnes ayant ce mot de passe peuvent passer en
mode privilgi
trois tentatives, proposes en boucle :
TATA>enable
Password:
Password:
Password:
% Bad secrets

TATA>

Copyright eLearnCisco 20 87
Cryptage du mot de passe
TATA#sh run
Building configuration...

Current configuration : 536 bytes


!
version 12.4
service timestamps debug datetime msec Par dfaut, le mot de passe de
service timestamps log datetime msec
la commande enable secret
no service password-encryption
!
est crypt.
hostname TATA
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$d0zE$eXCaA5LldbmNPeAsQR8Nn1
enable password Z3R4
Par dfaut, le mot de passe de
la commande enable
password
Copyright eLearnCisco 20 nest
88 pas crypt.
Activer le cryptage
Un service permet dactiver le cryptage de
TOUT mot de passe :

TATA#conf t
TATA(config)#service password-encryption

Ce service est rtro actif :


les mots de passe dj configurs seront
crypts, ainsi que tout nouveau mot de passe
Copyright eLearnCisco 20 89
Cryptage activ
TATA#show run
Building configuration...

Current configuration : 541 bytes


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
Service de cryptage activ.
service password-encryption
!
hostname TATA
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$d0zE$eXCaA5LldbmNPeAsQR8Nn1
enable password 7 003E403450
! Maintenant, le mot de passe
de la commande enable
Copyright eLearnCiscopassword
20 est
90aussi crypt.
Les messages
Ces messages sont affichs la console.
Exemple :
une interface vient de tomber
un protocole de routage vient de dcouvrir un voisin
etc..
Ces messages sont affichs mme si
ladministrateur est en train de saisir une
commande :
Interfrences entre les messages affichs par
lquipement et les commandes saisies par
ladministrateur
Copyright eLearnCisco 20 91
Exemple dinterfrence
Je monte une interface, puis je configure son adresse IP :

TATA#conf t
TATA(config)#int fa0/0
TATA(config-if)#no shut
TATA(config-if)#ip add 10.0.0
*Mar 1 03:56:47.891: %LINK-3-UPDOWN: Interface
FastEthernet0/0, changed state to up
*Mar 1 03:56:48.891: %LINEPROTO-5-UPDOWN: Line protocol
on Interface FastEthernet0/0, changed state to up.1
255.255.255.0
TATA(config-if)#

Le message a t affich
au milieu de ma commande !

Copyright eLearnCisco 20 92
Eviter les interfrences
TATA#conf t
TATA(config)#line console 0
TATA(config-line)#logging synchronous

Les messages seront toujours


affichs en temps rel,

mais la commande de ladministrateur


sera rpte aprs le message
pour que ladministrateur puisse terminer de la
saisir.
Copyright eLearnCisco 20 93
Message affich sans interfrence
Je monte une interface, puis je configure son adresse IP :

TATA#conf t
TATA(config)#int fa0/0
TATA(config-if)#no shut
TATA(config-if)#ip add 10.0.0
*Mar 1 03:56:47.891: %LINK-3-UPDOWN: Interface
FastEthernet0/0, changed state to up
*Mar 1 03:56:48.891: %LINEPROTO-5-UPDOWN: Line protocol
on Interface FastEthernet0/0, changed state to up
TATA(config-if)#ip add 10.0.0.1 255.255.255.0
TATA(config-if)#

Le dbut de ma commande
a t rpte aprs le message.

Copyright eLearnCisco 20 94
Configurations de base
Configurer une interface

Copyright eLearnCisco 2010 95


Spcifier une interface
enable
conf t
interface [TYPE] [NUMERO]
Ethernet
FastEthernet
GigabitEthernet
Serial
Loopback
Tunnel
Token Ring
FDDI
etc
Exemples :
interface Ethernet 0
interface Fasthethernet 1
interface Serial 0

Copyright eLearnCisco 20 96
Slots

slot 4
slot 3
slot 2
slot 1
slot 0

Copyright eLearnCisco 20 97
Slectionner une interface
interface Fastethernet 0/3
dans le slot n0 : interface n3

interface Fastethernet 2/15


dans le slot n2 : interface n15

Copyright eLearnCisco 20 98
Activer une interface
Par dfaut :
sur un switch : toutes les interfaces sont dj actives
sur un routeur : toutes les interfaces sont inactives

Passer dabord en mode de configuration globale :


TOTO#conf t

Passer ensuite en mode de configuration spcifique :


TOTO(config)#interface fastEthernet 0/0

Activer linterface :
TOTO(config-if)#no shutdown

Des messages sont affichs pour indiquer que linterface est bien monte :
TOTO(config-if)#
*Mar 1 02:53:21.119: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed
state to up
*Mar 1 02:53:22.119: %LINEPROTO-5-UPDOWN: Line protocol on Interface
FastEthernet0/0, changed state to up
TOTO(config-if)#

Copyright eLearnCisco 20 99
Dsactiver une interface
TOTO#conf t
TOTO(config)#interface fastEthernet 0/0
TOTO(config-if)#
TOTO(config-if)#shutdown
TOTO(config-if)#
*Mar 1 02:53:32.143: %LINK-5-CHANGED: Interface
FastEthernet0/0, changed state to administratively down
*Mar 1 02:53:33.143: %LINEPROTO-5-UPDOWN: Line protocol
on Interface FastEthernet0/0, changed state to down

Copyright eLearnCisco 20 100


Configurer une adresse IP sur une
interface
Passer dabord en mode de configuration globale :
TOTO#conf t

Passer ensuite en mode de configuration spcifique :


TOTO(config)#interface fastEthernet 0/0

Configurer ladresse IP de linterface :


TOTO(config-if)#ip address 10.0.0.1 255.255.255.0

Chaque nouvelle adresse crase ladresse prcdente :


TOTO(config-if)#ip address 10.0.0.2 255.255.255.0

Supprimer ladresse IP de linterface :


TOTO(config-if)#no ip address

Copyright eLearnCisco 20 101


Vrifier le statut de linterface
Plusieurs commandes disponibles :
show ip interface brief
show interfaces
show interfaces status [switch]

Deux informations utiles :


le statut de linterface
le statut de la ligne

Copyright eLearnCisco 20 102


show ip interface brief
TOTO#show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.0.0.1 YES manual up up

le statut de
le statut de
linterface
la ligne

Copyright eLearnCisco 20 103


show interfaces
TOTO#show interfaces
FastEthernet0/0 is up, line protocol is up
Hardware is AmdFE, address is cc01.1524.0000 (bia
cc01.1524.0000)
Internet address is 10.0.0.1/8
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, 100BaseTX/FX
etc
le statut de
le statut de
linterface
la ligne

Copyright eLearnCisco 20 104


show interfaces status
Uniquement sur un switch :

Switch#show interfaces status

Port Name Status Vlan Duplex Speed Type


Fa0/0 notconnect 1 auto auto 10/100BaseTX
Fa0/1 connected 1 a-full a-100 10/100BaseTX
Fa0/2 notconnect 1 auto auto 10/100BaseTX
Fa0/3 notconnect 1 auto auto 10/100BaseTX
Fa0/4 notconnect 1 auto auto 10/100BaseTX
Fa0/5 notconnect 1 auto auto 10/100BaseTX
Fa0/6 notconnect 1 auto auto 10/100BaseTX
etc

un cable
est
connect
Copyright eLearnCisco 20 105
Dcrire une interface
Configurer :
TATA#conf t
TATA(config)#int fa0/0
TATA(config-if)#description VersBatimentA

Vrifier sur un routeur ou un switch :


TATA#sh interface
FastEthernet0/0 is up, line protocol is up
Hardware is AmdFE, address is cc01.1524.0000 (bia cc01.1524.0000)
Description: VersBatimentA
Internet address is 10.0.0.1/8
etc

Vrifier sur un switch :


Sw1#show interfaces status
Port Name Status Vlan Duplex Speed Type
Fa0/0 VersBatimentA notconnect 1 auto auto 10/100BaseTX
Fa0/1 connected 1 a-full a-100 10/100BaseTX
etc

Copyright eLearnCisco 20 106


Status
le statut de le statut
linterface de la
ligne
linterface est dsactive administratively down
down
pas de cable connect down down
la carte de linterface est dfectueuse
lquipement distant ne fonctionne pas up down
correctement
les protocoles dencapsulation sont
diffrents
le traffic passe correctement up up

Copyright eLearnCisco 20 107


CDP
Cisco Discovery Protocol

Copyright eLearnCisco 2010 108


CDP
Protocole propritaire Cisco

Objectifs :
dcouvrir des informations sur mes voisins
envoyer des informations mes voisins

Lquipement Cisco envoie ces informations :


toutes les 60 secondes
en multicast
ladresse 0100.0ccc.cccc
quelque soit le type dencapsulation configur sur linterface

Copyright eLearnCisco 20 109


Contenu des messages CDP
Hostname
Adresse IP
Capabilit de lquipement
switching, routing, multicast
Numro de linterface
Nom de limage IOS
Pour une switchport :
Nom de domaine VTP
si CDP
N du VLAN natif version 2
Type dencapsulation (access, 802.1Q, ISL)
Mode full ou half-duplex
Copyright eLearnCisco 20 110
Validit des messages CDP
Sur rception dun message CDP,
lquipement le considre valide pendant
une dure limite :
HOLD timer par dfaut 180 sec

Lquipement envoie des messages CDP


sur toutes les interfaces o CDP est
active, frquence fixe :
HELLO timer par dfaut 60 sec

Copyright eLearnCisco 20 111


Activer CDP
Par dfaut, CDP est activ sur les interfaces Ethernet, PPP, HDLC, mais pas Frame-
relay :

R1#show cdp
Global CDP information:
Sending CDP packets every 60 seconds
Sending a holdtime value of 180 seconds
Sending CDPv2 advertisements is enabled

R1#show cdp interface


Serial0/1 is administratively down, line protocol is down
Encapsulation HDLC
Sending CDP packets every 60 seconds
Holdtime is 180 seconds
Serial0/2 is up, line protocol is down
Encapsulation PPP
Sending CDP packets every 60 seconds
Holdtime is 180 seconds
FastEthernet0/0 is up, line protocol is up
Encapsulation ARPA
Sending CDP packets every 60 seconds
Holdtime is 180 seconds
Copyright eLearnCisco 20 112
Activer CDP
R1#configure terminal
R1(config)#no cdp run activer CDP globalement
R1(config)#cdp run dsactiver CDP globalement

R1(config)#int s0/0
R1(config-if)#cdp enable activer CDP sur linterface
R1(config-if)#no cdp enable dsactiver CDP sur linterface

Copyright eLearnCisco 20 113


Configurer CDP
R1#configure terminal
R1(config)#cdp timer 30 modifier le timer HELLO 30 s.
R1(config)#cdp holdtime 200 modifier le timer HOLD 200 s.
R1(config)#cdp advertise-v2 activer la version 2

Copyright eLearnCisco 20 114


Analyser CDP
R1#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater

Device ID Local Intrfce Holdtme Capability Platform Port ID


RouterA Fas 0/1 174 R S I 3640 Fas 0/0
SwitchB Fas 0/1 174 R S I 3640 Fas 0/0

hostname des interface o le dure de vie capabi- type interface


voisins message CDP restante du lits des dqui- o le
a t reu message voisins pement message
CDP reu CDP a t
envoy

Copyright eLearnCisco 20 115


Analyser les timers CDP
R1#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater

Device ID Local Intrfce Holdtme Capability Platform Port ID


RouterA Fas 0/1 174 R S I 3640 Fas 0/0
SwitchB Fas 0/1 174 R S I 3640 Fas 0/0

Si aucun message CDP nest


perdu, quelles sont les
valeurs min et max de cette
colonne ?

Copyright eLearnCisco 20 116


Analyser les timers CDP
R1#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater

Device ID Local Intrfce Holdtme Capability Platform Port ID


RouterA Fas 0/1 174 R S I 3640 Fas 0/0
SwitchB Fas 0/1 174 R S I 3640 Fas 0/0

MAX = 180
MIN = 180 60
MIN = 120

Copyright eLearnCisco 20 117


Exercice
Fa0/0 Fa0/1
gauche droite

gauche#show cdp neighbors


Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater

Device ID Local Intrfce Holdtme Capability Platform Port ID


? ? 174 R S I 3550 ?

Copyright eLearnCisco 20 118


Solution
Fa0/0 Fa0/1
gauche droite

gauche#show cdp neighbors


Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater

Device ID Local Intrfce Holdtme Capability Platform Port ID


droite Fa0/0 174 R S I 3550 Fa0/1

Copyright eLearnCisco 20 119


Analyse approfondie de CDP
Sw1#sh cdp neighbors detail OU sh cdp entry detail

-------------------------
Device ID: TOTO
Entry address(es):
IP address: 10.0.0.1
Platform: Cisco 3640, Capabilities: Router Switch IGMP
Interface: FastEthernet0/1, Port ID (outgoing port): FastEthernet0/0
Holdtime : 121 sec

Version :
Cisco IOS Software, 3600 Software (C3640-JS-M), Version 12.4(13f), RELEASE
SOFTW
ARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Wed 09-Apr-08 18:12 by prod_rel_team

advertisement version: 2
VTP Management Domain: ''
Duplex: full

Copyright eLearnCisco 20 120


Intrts de CDP
Connatre mes voisins immdiats.

Dcouvrir toute la topologie du rseau :


utiliser CDP
utiliser TELNET

Copyright eLearnCisco 20 121


DHCP

Copyright eLearnCisco 2010 122


Mcanisme DHCP
4 tapes :
CLIENT SERVER
1. DISCOVER
IP src 0.0.0.0
IP dest 255.255.255.255
discover 2. OFFER
une adresse IP
masque
offer l@ IP de passerelle
l@ IP des serveurs DNS
request le lease time
etc
3. REQUEST
ack intention daccepter loffre
4. ACK
confirmation fin du processus
Copyright eLearnCisco 20 123
Router = server DHCP
conf t
ip dhcp excluded-address 192.168.10.250
192.168.10.254
ip dhcp pool TOTO
domain-name X
network 192.168.10.0 255.255.255.0
network 192.168.10.0 /24
default-router 192.168.10.254
dns-server 192.160.1.1
Copyright eLearnCisco 20 124
Activer la fonction DHCP
Pas de commande IOS
La fonction DHCP est automatiquement
active ds quune adresse IP est
attribue une interface du routeur, dans
la plage de pool
conf t
int fa0/0
ip address 192.168.10.254 255.255.255.0
Copyright eLearnCisco 20 125
Architecture interne

Copyright eLearnCisco 2010 126


Architecture interne

ROM FLASH

RAM NVRAM

Copyright eLearnCisco 20 127


ROM
Instructions du POST,
Power On Self Test
Programme FLASH
damorage

RAM NVRAM

Copyright eLearnCisco 20 128


FLASH

ROM Image = IOS

RAM NVRAM

Copyright eLearnCisco 20 129


NVRAM

ROM FLASH

RAM Startup- configuration

Copyright eLearnCisco 20 130


RAM

ROM FLASH

Running-config
Table d@MAC
RAM
Table de routage NVRAM
Paquets etc.

Copyright eLearnCisco 20 131


write

ROM FLASH

RAM
RAM NVRAM
Running-config Startup-config

Copyright eLearnCisco 20 132


Au dmarrage

ROM Flash

RAM NVRAM

Copyright eLearnCisco 20 133


Choisir une autre image
Si plusieurs images IOS dans la flash
Laquelle prendre ?
Le choix sera fait selon le dernier chiffre
du registre de configuration
0x2100 ne prendre aucune image
0x2101 prendre la 1re image de la Flash
0x2102 se refrer aux commandes
boot system

Copyright eLearnCisco 20 134


Commandes boot system
Conf t
Boot system flash:xxxxx.bin
Boot system tftp://10.0.0.1/xxx.bin

Pour vrifier la valeur du registre de


configuration :
Show version

Copyright eLearnCisco 20 135


Quelle image charger ?

ROM Flash

Startup-
RAM configuration

Ncessit daller voir la start-up configuration


pour savoir quel IOS charger !

Copyright eLearnCisco 20 136


Quel fichier de conf charger ?
Le choix sera fait selon lavant-dernier
chiffre du registre de configuration
0x2102 prendre la startup de la NVRAM
0x2142 ne pas charger de startup

Quelle utilit de modifier ce registre ?

Copyright eLearnCisco 20 137


Perte de mot de passe
1. Squence break
1. TeraTerm Alt+b
2. HyperTerminal Ctrl+Pause
2. Rommon 1>confreg 0x2142
3. Rommon 2>reset
4. .
5. Enable
6. Copy start run
7. Conf t
8. Enable secret TOTO
9. Config-register 0x2102
10. End
11. write
Copyright eLearnCisco 20 138