You are on page 1of 12
Fuente: www.slideshare.net

Fuente: www.slideshare.net

Fuente: www.slideshare.net
Fuente: www.slideshare.net
Fuente: www.slideshare.net
Fuente: www.slideshare.net
Ejercicios con Array’s
Ejercicios con
Array’s

2

Hacer un programa que Desarrolle una Calculadora Científica.

Proceso Prueba Definir num como entero;

TAMANIO=5;

Dimension num[TAMANIO];

num[1]=5;

num[2]=10;

num[3]=15;

num[4]=20;

num[5]=25;

Para i<-1 Hasta TAMANIO Con Paso 1 Hacer Escribir "Escribe un valor para el indice ",i; leer num[i]; Fin Para Para i<-1 Hasta TAMANIO Con Paso 1 Hacer escribir num[i]; Fin Para FinProceso

Hacer un

programa en C

que lea 10 números por

teclado, los

almacene en un array y muestre la

suma, resta,

multiplicación y división de todos.

#include <stdio.h> #include <stdlib.h>

int main(void)

{

 

int x,tabla[10];

int sum,res,mul,div;

for (x=0;x<10;x++) { printf("Introduzca número\n");

scanf("%d",&tabla[x]);

}

sum=tabla[0];

res=tabla[0];

mul=tabla[0];

div=tabla[0];

for (x=1;x<10;x++)

{

sum=sum+tabla[x];

res=res-tabla[x];

mul=mul*tabla[x];

div=div/tabla[x];

}

printf("Suma: %d\n",sum); printf("Resta: %d\n",res);

printf("Multiplicación: %d\n",mul);

printf("División: %d\n",div);

system("PAUSE"); return 0;

}

EJERCICIOS CON ARREGLOS UNIDIMENSIONALES.

  • 1. Que rellene un array con los números primos comprendidos entre 1 y 100 y los muestre en pantalla en orden ascendente.

  • 2. Que rellene un array con los números impares comprendidos entre 1 y 100 y los muestre en pantalla en orden ascendente.

  • 3. Que rellene un array con los números pares comprendidos entre 1 y 100 y los muestre en pantalla en orden descendente.

  • 4. Que se ingresen “n” números enteros y que los imprima:

    • a. Tal y como se ingresaron

    • b. Ordenados en forma ascendente

    • c. Ordenados en forma descendente

EJERCICIOS CON ARREGLOS BIDIMENSIONALES.

  • 1. Hacer programa que calcule la suma de dos matrices.

  • 2. Hacer algoritmo que calcule la multiplicación de 2 matrices.

  • 3. Hacer un algoritmo que calcule la transpuesta de una matriz.

  • 4. Haga un ejercicio en el que aplique operaciones con arreglos uni y bidimensionales.

En este método la información ingresa de forma desorganizada; lo que realiza este ordenamiento es que

En este método la información ingresa de forma desorganizada; lo que realiza este ordenamiento es que vector mueve el elemento mayor hasta la ultima casilla esto se realizaría en la siguiente manera:

Índice cero del vector a acomoda este elemento hasta la

ultima posición para que de forma escalada se organiza de

mayor a menor

En este método la información ingresa de forma desorganizada; lo que realiza este ordenamiento es que
Como lo muestra la siguiente gráfica en la casilla 0 correspondiente a seis que es el

Como lo muestra la siguiente gráfica en la casilla 0 correspondiente a seis que es el ordenado paso a la ultima posición y se observa que esta secuencia traslada el valor a la primera posición.

Este proceso seguirá así hasta que halla ordenado todas las casillas del vector.

Una de las desventaja de este método

es que

hace duplicidad de la

organización cuando esto ya no es

necesario.

Como lo muestra la siguiente gráfica en la casilla 0 correspondiente a seis que es el