You are on page 1of 3

ROUTER 1

R1(config)#int s1/0
R1(config-if)#ip address 50.0.0.1 255.255.255.0
R1(config-if)#no shut
R1(config)#int loop 1
R1 (config-if)#ip address 10.1.1.1 255.255.255.0
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.1.1.0
R1(config-router)#network 50.0.0.0
R1(config-router)#no auto-summary

R1(config)#crypto isakmp policy 7
R1(config-isakmp)#authentication pre-share
R1(config-isakmp)#encryption aes 128
R1(config-isakmp)#group 2
R1(config-isakmp)#hash sha
R1(config-isakmp)#lifetime 100
R1(config-isakmp)#ex
R1(config)#crypto isakmp key 0 vpnkey address 192.168.1.1 no-xauth
R1(config)#crypto ipsec transform-set vpntrans esp-aes 128 esp-sha-hmac
R1(config)#ip access-list extended vpn-acl
R1(config-ext-nacl)# permit ip 50.0.0.0 0.0.0.255 172.16.0.0 0.0.255.255







R1(config)#crypto map vpn-map 10 ipsec-isakmp
R1(config-crypto-map)#set peer 192.168.1.1
R1(config-crypto-map)#match address vpn-acl
R1(config-crypto-map)#set transform-set vpntrans

R1(config)#int s1/0
R1(config-if)#cry
R1(config-if)#crypto map vpn-map


ROUTER 2
R2#conf t
R2(config)#int s1/0
R2(config-if)#ip add 50.0.0.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#ex
R2(config)#int s1/1
R2(config-if)#ip add 192.168.1.2 255.255.255.0
R2(config-if)#no shut
R2(config)#router ri
R2(config-router)#version 2
R2(config-router)#network 50.0.0.0
R2(config-router)#network 192.168.1.0
R2(config-router)#no auto-summary






ROUTER 3
R3#conf t
R3(config)#crypto isakmp policy 7
R3(config-isakmp)# authentication pre-share
R3(config-isakmp)#encryption aes 128
R3(config-isakmp)# group 2
R3(config-isakmp)# lifetime 100
R3(config-isakmp)#crypto isakmp key 0 vpnkey address 50.0.0.1 no-xauth
R3(cfg-crypto-trans)#ex
R3(config)#crypto ipsec transform-set vpntrans esp-aes esp-sha-hmac
R3(config)#ip access-list extended vpn-acl
R3(config-ext-nacl)# permit ip 172.16.0.0 0.0.255.255 50.0.0.0 0.0.0.255
R3(config-ext-nacl)#ex

R3(cfg-crypto-trans)#crypto map vpn-map 10 ipsec-isakmp
R3(config-crypto-map)# set peer 50.0.0.1
R3(config-crypto-map)# set transform-set vpntrans
R3(config-crypto-map)# match address vpn-acl
R3(config)#interface Serial1/0
R3(config-if)#crypto map vpn-map

You might also like