You are on page 1of 4

R1

interface Serial0/0/0
ip address 10.10.10.9 255.255.255.252
no shutdown
interface Serial0/2/0
bandwidth 128
ip address 10.2.2.5 255.255.255.252
no shutdown
interface Serial0/2/1
bandwidth 512
ip address 10.2.2.2 255.255.255.252
ip ospf hello-interval 5
ip ospf dead-interval 20
router ospf 1
network 10.2.2.0 0.0.0.3 area 0
network 10.2.2.4 0.0.0.3 area 0
default-information originate
ip route 0.0.0.0 0.0.0.0 Serial0/0/0
--------------------------------------------------------------------------------------------------------------------------------R2
interface FastEthernet0/0
ip address 10.10.10.17 255.255.255.248
ip ospf priority 255
no shutdown
interface FastEthernet0/1
ip address 172.30.30.1 255.255.255.0
no shutdown
interface Serial0/2/0
bandwidth 512
ip address 10.2.2.1 255.255.255.252
ip ospf hello-interval 5
ip ospf dead-interval 20
no shutdown
router ospf 1
passive-interface FastEthernet0/1
network 10.2.2.0 0.0.0.3 area 0
network 10.10.10.16 0.0.0.7 area 0
network 172.30.30.0 0.0.0.255 area 0
no shutdown
------------------------------------------------------------------------------------------------------------------------------------------------R3
interface FastEthernet0/0

ip address 200.200.32.33 255.255.240.0


no shutdown
interface FastEthernet0/1
ip address 10.10.10.19 255.255.255.248
ip ospf priority 100
no shutdown
interface Serial0/2/0
bandwidth 128
ip address 10.2.2.6 255.255.255.252
router ospf 1
redistribute static
network 10.2.2.4 0.0.0.3 area 0
network 10.10.10.16 0.0.0.7 area 0
ip
ip
ip
ip

route
route
route
route

172.16.16.0 255.255.255.0 FastEthernet0/0


172.100.128.0 255.255.128.0 FastEthernet0/0
192.168.132.0 255.255.255.240 FastEthernet0/0
192.168.0.0 255.255.252.0 FastEthernet0/0

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------R4
interface FastEthernet0/0
ip address 10.10.10.18 255.255.255.248
ip ospf priority 0
no shutdown
router ospf 1
network 10.10.10.16 0.0.0.7 area 0
no shutdown
----------------------------------------------------------------------------------------------------------------------------------------------R5
interface FastEthernet0/0
ip address 200.200.32.34 255.255.240.0
no shutdown
interface Serial0/2/0
bandwidth 512
ip address 192.168.132.9 255.255.255.252
no shutdown
interface Serial0/2/1
bandwidth 384
ip address 192.168.132.1 255.255.255.252
clock rate 128000
no shutdown
router eigrp 1
redistribute static
network 192.168.132.0 0.0.0.3
network 192.168.132.8 0.0.0.3

network 200.200.32.0 0.0.15.255


ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
----------------------------------------------------------------------------------------------------------------------------------------------R6
interface Serial0/2/0
bandwidth 512
ip address 192.168.132.5 255.255.255.252
ip summary-address eigrp 1 172.100.128.0 255.255.128.0 5
clock rate 128000
no shutdown
interface Serial0/2/1
bandwidth 384
ip address 192.168.132.2 255.255.255.252
ip summary-address eigrp 1 172.100.128.0 255.255.128.0 5
no shutdown
router eigrp 1
network 192.168.132.4
network 192.168.132.0
network 172.100.160.0
network 172.100.192.0
network 172.100.224.0
no auto-summary

0.0.0.3
0.0.0.3
0.0.31.255
0.0.31.255
0.0.31.255

----------------------------------------------------------------------------------------------------------------------------------------------R7
interface FastEthernet0/0
ip address 172.16.16.1 255.255.255.0
no shutdown
interface Serial0/2/0
bandwidth 512
ip address 192.168.138.10 255.255.255.252
ip summary-address eigrp 1 192.168.0.0 255.255.0.0 5
clock rate 128000
no shutdown
interface Serial0/2/1
bandwidth 512
ip address 192.168.132.6 255.255.255.252
ip summary-address eigrp 1 192.168.0.0 255.255.0.0 5
no shutdown
router eigrp 1
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
network 172.16.16.0 0.0.0.255
network 192.168.132.4 0.0.0.3
network 192.168.132.8 0.0.0.3
no auto-summary

--------------------------------------------------------------------------------------------------------------------------------------------------------------ISP
interface FastEthernet0/0
ip address 209.165.200.33 255.255.255.240
no shutdown
interface Serial0/2/0
ip address 10.10.10.10 255.255.255.252
no shutdown
ip route 0.0.0.0 0.0.0.0 Serial0/2/0

You might also like