You are on page 1of 6

(config)#router rip

(config-router)# version 2
(config-router)# network 192.168.1.0
(config-router)# network 10.0.0.0
(config)#router ospf 1
(config-router)# network 192.168.1.1 0.0.0.0 area 0
! En donde 0.0.0.0 es el inverso de la mascara y 0 es el area donde se encuentra
esa interfaz
(config)#router eigrp 1
(config-router)#network 192.168.10.4 0.0.0.3
*******************************************************
Ruta por defecto en OSPF
El enrutamiento OSPF asegura rutas sin bucles para cada red dentro del dominio.
Para alcanzar las redes fuera del dominio, OSPF debe conocer la red u OSPF debe
tener una ruta por defecto. Tener una entrada para cada red del mundo requerira e
normes recursos para cada router.
Una alternativa prctica es agregar una ruta por defecto al router OSPF conectado
a la red externa. Esta ruta se puede redistribuir a cada router en el AS mediant
e las actualizaciones OSPF normales.
Un router utiliza la ruta por defecto configurada para generar un gateway de ltim
o recurso. La sintaxis de configuracin de la ruta esttica por defecto utiliza la d
ireccin de red 0.0.0.0 y una mscara de subred 0.0.0.0:
Router(config)#ip route 0.0.0.0 0.0.0.0 [interface | next-hop address]
Esto se conoce como la ruta quad-zero y la coincidencia con cualquier direccin de
red se basa en la siguiente regla. El gateway de red se determina haciendo AND
al destino de paquete con la mscara de subred.
La siguiente sentencia de configuracin propagar esta ruta hacia todos los routers
en un rea de OSPF normal:
Router(config-router)#default-information originate
Todos ls routers del rea OSPF aprendern una ruta por defecto siempre y cuando la i
nterfaz del router lmite hacia el gateway por defecto est activa.
Las actividades de laboratorio ayudarn a los estudiantes a configurar una red OSF
P y luego a configurar una ruta por defecto.
**PBR (indicar que camino seguir a ciertos paquetes)
Cambiar trafico por otra interfaz
R1(config)# access-list 101 permit ip 192.168.12.1 0.0.0.0 4.4.4.4 0.0.0.0 (orig
en y destino)
R1(config)# route-map ESPECIAL permit 10
R1(config-route-map)#match ip address 101
R1(config-route-map)#set ip next-hop 192.168.25.5 (IP siguiente salto por donde
desea que salga)
R1(config-route-map)#set metric 1 (para influenciar el trafico que vuelve)****
R1(config)#inter f0/0
R1(config-if)#ip policy route-map ESPECIAL

**IP SLA
R1(config)# ip sla 1
R1(config-ip-sla)# icmp-echo 192.168.100.3(ip para monitorear)
R1(config-ip-sla-echo)#frequency 3
R1(config-ip-sla-echo)#
Luego activamos cada SLA de la siguiente manera:
R1(config)# ip sla schedule 1 start-time now life forever
Track para El SLA
R1(config)#track 100 ip sla 1 state
R1(config-track)#delay down 10 up 10
Combinar con la ruta statica.
R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.4.4 track 100
///////////////////////////////////////////////////////////////
DENTRO DEL ROUTE MAP SET METRIC-TYPE 1 o 2 PARA OSPF E1 o E2
///////////////////////////////////////////////////////////////
**Redistribuir protocolos
Rip CONECTADAS
R1(config-router)#router rip
R1(config-router)#redistribute connected metric 1
Con route map
R1(config)#route-map CONECTtoRIP permit 10
R1(config-route-map)#match interface ethernet 0/1
R1(config-route-map)#set metric 10 (RIP)
CoN TAG
R1(config-route-map)#set tag 10
R1(config)#router rip
R1(config-router)#redistribute connected route-map CONECTtoRIP
RIP STATIC
R1(config-router)#ip route 1.1.1.0 255.255.255.255 10.0.3.2
R1(config-router)#router rip
R1(config-router)#redistribute static metric 1
Con route map
R1(config)#access-list "1" permit 1.1.1.1 0.0.0.0 ("" se usara para match) por c
ada ACL es un permit extra
R1(config)#route-map STATICtoRIP permit 10
R1(config-route-map)#match ip address 1
R1(config-route-map)# set tag 20
R1(config)#router rip
R1(config-router)#redistribute static route-map STATICtoRIP metric 5
RIP EIGRP
R1(config)#router rip
R1(config-router)#redistribute eigrp 10 metric 10

con route map


R1(config)#route-map EIGRPtoRIP permit 10
R1(config-route-map)#match ip address 1 (Puede ser con el tag en caso que vengan
marcados)
R1(config-route-map)# set tag 20
R1(config)#router rip
R1(config-router)#redistribute eigrp 10 metric 10 EIGRPtoRIP
------------EIGRP CONECTADAS
R1(config-router)#router eigrp 10
R1(config-router)#redistribute connected metric 1000 10 255 1 1500
Con route map
R1(config)#route-map CONECTtoEIGRP permit 10
R1(config-route-map)#match interface ethernet 0/1
R1(config-route-map)#set metric 1000 10 255 1 1500
CoN TAG
R1(config-route-map)#set tag 20
R1(config)#router eigrp 10
R1(config-router)#redistribute connected route-map CONECTtoEIGRP
EIGRP STATIC
R1(config-router)#router eigrp 10
R1(config-router)#redistribute static metric 1000 10 255 1 1500
Con route map
R1(config)#access-list "1" permit 1.1.1.1 0.0.0.0 ("" se usara para match) por c
ada ACL es un permit extra
R1(config)#route-map STATICtoEIGRP permit 10
R1(config-route-map)#match ip address 1
R1(config-route-map)#set metric 1000 10 255 1 1500
CoN TAG
R1(config-route-map)#set tag 20
R1(config-router)#router eigrp 10
R1(config-router)#redistribute static route-map STATICtoEIGRP
EIGRP RIP
R1(config-router)#router eigrp 10
R1(config-router)#redistribute rip metric 10000 10 255 1 1500
con route map
SIMILAR A RIP
---------------OSPF CONECTADAS
R1(config-router)#router ospf 1
R1(config-router)#redistribute connected subnets (quedan como "O E2")
R1(config-router)#redistribute connected subnets metric-type 1 (quedan como "O E
1")
Con route map
R1(config)#route-map CONECTtoOSPF permit 10
R1(config-route-map)#match interface ethernet 0/1

R1(config-route-map)#set metric 100 (no importa mucho)


R1(config-route-map)#set tag 15
R1(config-route-map)#set metric-type type 1
R1(config-router)#router ospf 1
R1(config-router)#redistribute connected route-map CONECTtoOSPF subnets
OSPF STATIC
R1(config-router)#router ospf 1
R1(config-router)#redistribute static subnets
Con route map
R1(config)#access-list "1" permit 1.1.1.1 0.0.0.0 ("" se usara para match) por c
ada ACL es un permit extra
R1(config)#route-map STATICtoOSPF permit 10
R1(config-route-map)#match ip address 1
R1(config-route-map)#set metric 100 (no importa mucho)
R1(config-route-map)#set tag 15
R1(config-route-map)#set metric-type type 1 (en caso de querer "O E1")
R1(config-router)#router ospf 1
R1(config-router)#redistribute static route-map STATICtoOSPF subnets
con route map
SIMILAR A RIP
////////////////////////////////////////////
Comprobar si alguna IP esta con tag
show ip route XX.XX.XX.XX (IP)
////////////////////////////////////////////////
DENEGAR EN ROUTE MAP EL TAG
R1(config)#route-map BLOQUEO deny 10
R1(config-route-map)#match tag 10
Ejemplos
R1(config-router)#redistribute static route-map BLOQUEO subnets
R1(config-router)#redistribute rip route-map BLOQUEO subnets
R1(config-router)#redistribute ospf 1 metric 1 route-map BLOQUEO
***************************************
TELNET
Router>enable
Router#configure terminal
Router(config)#line vty 0 4
Router(config-line)#password cisco
Router(config-line)#login
Router(config-line)#exit
Router(config)#enable secret cisco
ceder al router;cisco es la contrasea

//Configuracion TELNET
//cisco es la contrasea
//Configuracion de password para ac

**************************************************************
**Configurar vecinos en BGP
R1(config)#router bgp 100
R1(config-router)#neighbor 172.16.46.6 remote-as 200
R1(config-router)#neighbor 10.14.0.1 remote-as 100
R1(config-router)#network 10.14.0.0 mask 255.255.255.0

R1(config-router)#network 4.4.4.4 mask 255.255.255.255


R1(config-router)#network 1.1.1.1 mask 255.255.255.255
BGP:
habilitar proceso:
router(config)#:router bgp 100
Configuracion de neighbor
Direccion IP del router remoto y su respectivo as configurado
router(config-router)#neighbor 1.2.3.4 remote-as 200
Forzar la version de bgp a utilizar en la session
router(config-router)#neighbor 1.2.3.4 version 4
Por seguridad colocar contrasea a la session en los dos routers
router(config-router)#neighbor 1.2.3.4 password miCr0ntrac3na2
Configuracion General
router(config-router)#no synchronization
router(config-router)#no auto-summary
Configuracion de ID del proceso
router(config-router)#bgp router-id 1.2.3.1
Anuncio de redes
network 192.168.0.0 mask 255.255.255.0
network 172.16.0.0 mask 255.255.255.0
verificar conexion de neighbor y detalles de la session.
router#sh ip bgp summary
Filtrar para solo mostrar los neighbor
router#sh ip bgp summary | be Ne
Informacion detallada de las sessiones
router#sh ip bgp neighbors
Ver rutas anunciadas de a un neighbor
router#sh ip bgp neighbors 1.2.3.4 routes
Como mejores practicas con route-map filtrar las rutas que se anuncian por segur
idad y control.
Configuracin de los reflector.
R1===>R2<====R3
R2 posee la conexin hacia los dos routers que no estan directamente conectados.
router bgp 100
neighbor 172.24.1.18
neighbor 172.24.1.18
neighbor 192.168.1.5
neighbor 192.168.1.5
neighbor 192.168.1.5

remote-as 100
route-reflector-client
remote-as 100
route-reflector-client
prefix-list especifica out

Confederation
del 1 al 2 al 3 al 4 al 1
R1

router bgp 65500


no synchronization
bgp router-id 1.1.1.1
bgp log-neighbor-changes
bgp confederation identifier 100
bgp confederation peers 65515 65534
neighbor 10.10.12.2 remote-as 65515
neighbor 10.10.13.3 remote-as 65534
no auto-summary
R2
router bgp 65515
no synchronization
bgp router-id 2.2.2.2
bgp log-neighbor-changes
bgp confederation identifier 100
bgp confederation peers 65500 65534
bgp scan-time 5
neighbor 10.10.12.1 remote-as 65500
neighbor 10.10.24.4 remote-as 65534
no auto-summary
R3
router bgp 65534
no synchronization
bgp router-id 3.3.3.3
bgp log-neighbor-changes
bgp confederation identifier 100
bgp confederation peers 65500
bgp scan-time 5
neighbor 10.10.13.1 remote-as 65500
neighbor 10.10.34.4 remote-as 65534
no auto-summary
R4
router bgp 65534
no synchronization
bgp router-id 4.4.4.4
bgp log-neighbor-changes
bgp confederation identifier 100
bgp confederation peers 65515
bgp scan-time 5
neighbor 10.10.24.2 remote-as 65515
neighbor 10.10.34.3 remote-as 65534
neighbor 10.10.34.3 next-hop-self
neighbor 77.56.10.1 remote-as 200
no auto-summary

You might also like