You are on page 1of 36

Command Manual VLAN

Quidway S3500-EA Series Ethernet Switches

Table of Contents

Table of Contents
Chapter 1 VLAN Configuration Commands................................................................................ 1-1
1.1 VLAN Configuration Commands........................................................................................ 1-1
1.1.1 description ............................................................................................................... 1-1
1.1.2 display interface Vlan-interface ............................................................................... 1-2
1.1.3 display vlan.............................................................................................................. 1-3
1.1.4 interface Vlan-interface ........................................................................................... 1-4
1.1.5 ip address................................................................................................................ 1-5
1.1.6 shutdown ................................................................................................................. 1-6
1.1.7 vlan.......................................................................................................................... 1-7
1.2 Port-Based VLAN Configuration Commands .................................................................... 1-8
1.2.1 port .......................................................................................................................... 1-8
1.2.2 port access vlan ...................................................................................................... 1-9
1.2.3 port hybrid pvid vlan .............................................................................................. 1-10
1.2.4 port hybrid vlan...................................................................................................... 1-11
1.2.5 port link-type.......................................................................................................... 1-12
1.2.6 port trunk permit vlan ............................................................................................ 1-13
1.2.7 port trunk pvid vlan................................................................................................ 1-14
1.3 IP-Subnet-Based VLAN Configuration Commands ......................................................... 1-15
1.3.1 display ip-subnet-vlan interface............................................................................. 1-15
1.3.2 display ip-subnet-vlan vlan.................................................................................... 1-15
1.3.3 ip-subnet-vlan........................................................................................................ 1-16
1.3.4 port hybrid ip-subnet-vlan vlan .............................................................................. 1-17
Chapter 2 Voice VLAN Configuration Commands ..................................................................... 2-1
2.1 Voice VLAN Configuration Commands ............................................................................. 2-1
2.1.1 display voice vlan oui .............................................................................................. 2-1
2.1.2 display voice vlan state ........................................................................................... 2-2
2.1.3 voice vlan ................................................................................................................ 2-3
2.1.4 voice vlan aging....................................................................................................... 2-4
2.1.5 voice vlan enable .................................................................................................... 2-5
2.1.6 voice vlan mac-address .......................................................................................... 2-5
2.1.7 voice vlan mode auto .............................................................................................. 2-7
2.1.8 voice vlan security enable ....................................................................................... 2-7
Chapter 3 GVRP Configuration Commands ............................................................................... 3-1
3.1 GARP Configuration Commands....................................................................................... 3-1
3.1.1 display garp statistics .............................................................................................. 3-1
3.1.2 display garp timer .................................................................................................... 3-1
3.1.3 garp timer ................................................................................................................ 3-2
Huawei Proprietary and Confidential
Copyright (c) Huawei Technologies Co., Ltd

Table of Contents

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

3.1.4 garp timer leaveall ................................................................................................... 3-4


3.1.5 reset garp statistics ................................................................................................. 3-4
3.2 GVRP Configuration Commands....................................................................................... 3-5
3.2.1 display gvrp statistics .............................................................................................. 3-5
3.2.2 display gvrp status .................................................................................................. 3-6
3.2.3 gvrp ......................................................................................................................... 3-7
3.2.4 gvrp registration....................................................................................................... 3-7

ii

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 1 VLAN Configuration Commands

Chapter 1 VLAN Configuration Commands


1.1 VLAN Configuration Commands
1.1.1 description
Syntax
description text
undo description

View
VLAN view/VLAN interface view

Parameter
text: A string that describes the current VLAN or VLAN interface (Space can be
included), case sensitive.
z

Under VLAN view, this is a string of 1 to 32 characters, defaults to the VLAN ID of


the current VLAN, for example, VLAN 0001".

Under VLAN interface view, this is a string of 1 to 80 characters, defaults to the


interface name of the current VLAN interface, for example, Vlan-interface1
Interface.

Description
Use the description command to configure the descriptive string of the current VLAN
or VLAN interface.
Use the undo description command to restore the default descriptive string of a
specified VLAN or VLAN interface.
For a VLAN, the default descriptive string is the VLAN ID, for example, VLAN 0001";
for a VLAN interface, the default descriptive string is the VLAN interface name, for
example, Vlan-interface1 Interface

Example
# Assign a descriptive string RESEARCH for VLAN 1.
<Sysname> system-view
System View: return to User View with Ctrl+Z.
[Sysname] vlan 1
[Sysname-vlan1] description RESEARCH

# Assign a descriptive string VLAN-INTERFACE-2 for VLAN interface 2


Huawei Proprietary and Confidential
Copyright (c) Huawei Technologies Co., Ltd

1-1

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 1 VLAN Configuration Commands


<Sysname> system-view
[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2] description VLAN-INTERFACE-2

1.1.2 display interface Vlan-interface


Syntax
display interface Vlan-interface [ vlan-interface-id ]

View
Any view

Parameter
vlan-interface-id: VLAN interface ID.

Description
Use the display interface vlan-interface command to display the information of a
VLAN interface.
Execution of the command with the parameter included will display the information of a
specified VLAN interface; otherwise, information on all created VLAN interfaces will be
displayed.
Related command: interface Vlan-interface.

Example
# Display the information of VLAN-interface 2.
<Sysname> display interface vlan-interface 2
Vlan-interface2 current state: DOWN
Line protocol current state: DOWN
Description: Vlan-interface2 Interface
The Maximum Transmit Unit is 1500
Internet Address is 10.1.1.1/24 Primary
IP Packet Frame Type: PKTFMT_ETHNT_2,

Hardware Address: 00e0-fc00-0001

IPv6 Packet Frame Type: PKTFMT_ETHNT_2,

Hardware Address: 00e0-fc00-0001

Table 1-1 Description on the fields of the display interface Vlan-interface interface
Field

1-2

Description

Vlan-interface2 current state

The physical state of a VLAN interface

Line protocol current state

The link layer protocol state of a VLAN interface

Description

The description of a VLAN interface

The Maximum Transmit Unit

The MTU of a VLAN interface

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 1 VLAN Configuration Commands

Field

Description

Internet Address

IP address of the VLAN interface. Primary


indicates the address is the primary IP address
of the current interface.

IP Packet Frame Type

IPv4 outgoing frame format

Hardware Address

MAC address corresponding to a VLAN


interface

IPv6 Packet Frame Type

IPv6 outgoing frame format

1.1.3 display vlan


Syntax
display vlan [ vlan-id1 [ to vlan-id2 ] | all | dynamic | static | reserved]

View
Any view

Parameter
vlan-id1: Displays information of a VLAN specified by the VLAN ID, which is in the
range of 1 to 4,094.
vlan-id1 to vlan-id2: Displays the information of a range of VLANs specified by a VLAN
ID range. vlan-id1 and vlan-id2 are VLAN IDs, in the range of 1 to 4094.
all: Displays all current VLAN information except for the reserved VLAN.
dynamic: Displays the information of dynamically created VLANs
static: Displays statically created VLAN information.
reserved: Displays information of the reserved VLANs. Protocol modules determine
reserved VLANs according to function implementation, and reserved VLANs serve
protocol modules. Reserved VLANs cannot be modified.

Description
Use the display vlan command to display VLAN information.
Related command: vlan.

Example
# Display VLAN 2 information.
<Sysname> display vlan 2
VLAN ID: 2
VLAN Type: static
Route interface: configured

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

1-3

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 1 VLAN Configuration Commands


IP Address: 10.1.1.1
Subnet Mask: 255.255.255.0
Description: VLAN 0001
Tagged

Ports: none

Untagged Ports:
Ethernet1/0/1

Ethernet1/0/2

Ethernet1/0/3

Table 1-2 Description on the fields of the display vlan command


Field

Description

VLAN ID

VLAN ID

VLAN Type

VLAN type (static or dynamic)

Route interface

Whether the VLAN interface is configured for the


VLAN: not configured or configured

Description

VLAN descriptive string

IP Address

IP address of the VLAN interface (not displayed if


the VLAN interface has no IP address configured)

Subnet Mask

Subnet mask of the IP address (not displayed if the


VLAN interface has no IP address configured)

Tagged Ports

Ports through which packets are forwarded with


tags unchanged

Untagged Ports

Port through which packets are forwarded with tags


stripped

1.1.4 interface Vlan-interface


Syntax
interface Vlan-interface vlan-interface-id
undo interface Vlan-interface vlan-interface-id

View
System view

Parameter
vlan-interface-id: VLAN interface ID, in the range of 1 to 4,094.

Description
Use the interface Vlan-interface command to enter the specified VLAN interface view.
Use the undo interface Vlan-interface command to delete the specified VLAN
interface. The VLAN interface must be created first before entering its view

1-4

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 1 VLAN Configuration Commands

Before creating a VLAN interface, make sure the corresponding VLAN has been
created; otherwise, the VLAN interface cannot be created.
Related command: display interface Vlan-interface.

Example
# Create VLAN interface 2.
<Sysname> system-view
System View: return to User View with Ctrl+Z.
[Sysname] vlan 2
[Sysname-vlan2] quit
[Sysname] interface Vlan-interface 2
[Sysname-Vlan-interface2]

1.1.5 ip address
Syntax
ip address ip-address { mask | mask-length } [ sub ]
undo ip address [ ip-address { mask | mask-length } [ sub ] ]

View
VLAN interface view

Parameter
ip-address: IP address of a VLAN interface, in dotted decimal format.
mask: Subnet mask that corresponds to the IP address of a VLAN interface, in dotted
decimal format.
mask-length: Length of a sub-net mask, that is, the number of 1s in the subnet mask in
binary notation.
sub: Indicates the address is a sub-IP address of the VLAN interface.

Description
Use the ip address command to specify the IP address and subnet mask for a VLAN
interface.
Use the undo ip address command to remove the IP address and sub-net mask for a
VLAN interface.
By default, IP addresses of all VLAN interfaces are not configured.
An interface normally has one IP address. To enable a device to connect to multiple
subnets, a maximum of 5 IP addresses can be configured on a VLAN interface, in
which only one is the main IP address and all the rest are sub-IP addresses. Their
relationship is illustrated as follows:
Huawei Proprietary and Confidential
Copyright (c) Huawei Technologies Co., Ltd

1-5

Chapter 1 VLAN Configuration Commands

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

A newly configured main IP address will replace the original one, if there is one.

Execution of the undo ip address command without any parameter indicates that
all IP addresses will be deleted from the VLAN interface.

Use the undo ip address ip-address { mask | mask-length } command to delete


the main IP address.

Use the undo ip address ip-address { mask | mask-length } sub command to


delete a sub-interface.

Note that before deletion of the main IP address you must first delete the sub-IP
address.
Related command: display ip interface (refer to IP Address - IP Performance part).

Example
# Specify the IP address as 129.12.0.1, the sub-net mask as 255.255.255.0 for the
VLAN interface 1.
<Sysname> system-view
[Sysname] interface Vlan-interface 1
[Sysname-Vlan-interface1] ip address 129.12.0.1 255.255.255.0

1.1.6 shutdown
Syntax
shutdown
undo shutdown

View
VLAN interface view

Parameter
None

Description
Use the shutdown command to shut down a VLAN interface.
Use the undo shutdown command to bring up a VLAN interface.
By default, the VLAN interface is down if all ports in the VLAN are down, as long as one
port in the VLAN is up, the VLAN interface will be up
You can use the undo shutdown command to bring up a VLAN interface after
configurations of the related parameter and protocol. When there is a fault in a VLAN
interface, you can use the shutdown command to shut down the interface and then
bring it up using the undo shutdown command. In this way, the interface will probably
resume.

1-6

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 1 VLAN Configuration Commands

Shutting down/bringing up a VLAN interface does not affect any Ethernet ports in the
VLAN. The state of an Ethernet port does not change with the VLAN interface state.

Example
# Shut down the VLAN interface 2 and then bring it up.
<Sysname> system-view
[Sysname] interface Vlan-interface 2
[Sysname-Vlan-interface2] shutdown
[Sysname-Vlan-interface2] undo shutdown

1.1.7 vlan
Syntax
vlan { vlan-id1 [ to vlan-id2 ] | all }
undo vlan { vlan-id1 [ to vlan-id2 ] | all }

View
System view

Parameter
vlan-id1: VLAN ID, in the range of 1 to 4,094. This parameter means creating/deleting a
specified VLAN or entering the specified VLAN interface view.
vlan-id1 to vlan-id2: VLAN ID range. vlan-id1 and vlan-id2 are VLAN IDs in the range of
1 to 4,094, and vlan-id2 cannot be less than vlan-id1.
all: Creates or deletes all VLANs except for reserved VLANs.

Description
Use the vlan command to create one or more VLANs.
Use the vlan vlan-id command to enter VLAN view. If the specified VLAN does not exist,
the command creates the VLAN and enters its view.
Use the vlan vlan-id1 to vlan-id2 command to create a range of VLANs from vlan-id1 to
vlan-id2 in a bulk, except for the reserved VLANs.
Use the undo vlan command to delete VLAN(s).

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

1-7

Chapter 1 VLAN Configuration Commands

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Note:
z

As the default VLAN, VLAN 1 cannot be created, or removed.

You cannot create/remove reserved VLANs that are reserved for specific function
implementation.

A VLAN configured with QoS policies cannot be removed.

Related command: display vlan.

Example
# Enter the VLAN interface view of VLAN 1.
<Sysname> system-view
[Sysname] vlan 1

# Create VLAN 4 to VLAN 100.


<Sysname> system-view
[Sysname] vlan 4 to 100
Please wait............. Done.

1.2 Port-Based VLAN Configuration Commands


1.2.1 port
Syntax
port interface-list
undo port interface-list

View
VLAN interface view

Parameter
interface interface-list: Ethernet interface list, in the format of { interface-type
interface-number [ to interface-type interface-number ] }&<1-10>, where &<1-10>
indicates that you can specify up to 10 port ranges.

Description
Use the port command to add one Access port or a group of Access ports to a VLAN.
Use the undo port command to remove one Access port or a group of Access ports
from a VLAN.
Note:
z

1-8

This command is only applicable to Access ports.


Huawei Proprietary and Confidential
Copyright (c) Huawei Technologies Co., Ltd

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches
z

Chapter 1 VLAN Configuration Commands

All ports have their default link type configured as Access, however, users can
manually configure the port type. For more information, refer to port link-type.

Related command: display vlan.

Example
# Add the ports from Ethernet 1/0/1 to Ethernet 1/0/3 to VLAN 2.
<Sysname> system-view
[Sysname] vlan 2
[Sysname-vlan2] port Ethernet 1/0/1 to Ethernet 1/0/3

1.2.2 port access vlan


Syntax
port access vlan vlan-id
undo port access vlan

View
Ethernet port view/port group view

Parameter
vlan-id : VLAN ID, in the range of 1 to 4,094.

Description
Use the port access vlan command to add the current Access port to a specified
VLAN.
Use the undo port access vlan command to add the current Access port to the default
VLAN.
After executing the undo vlan command on an Access port to remove the default
VLAN, VLAN 1 will become the default VLAN.
Execution of the above command under Ethernet port view will apply the configurations
to the current port only whereas under port group view will apply the configurations to
all ports in the port group. (For related configurations on port group, refer to Port
Correlation Configurations part).
Ensure the VLAN specified by the vlan-id parameter exists before issuing the above
commands.

Example
# Add Ethernet 1/0/1 to VLAN 3.
<Sysname> system-view
[Sysname] vlan 3

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

1-9

Chapter 1 VLAN Configuration Commands

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

[Sysname-vlan3] quit
[Sysname] interface Ethernet 1/0/1
[Sysname-Ethernet1/0/1] port access vlan 3

1.2.3 port hybrid pvid vlan


Syntax
port hybrid pvid vlan vlan-id
undo port hybrid pvid

View
Ethernet port view/port group view

Parameter
vlan-id : VLAN ID, in the range of 1 to 4,094.

Description
Use the port hybrid pvid vlan command to configure the default VLAN ID of the
Hybrid port.
Use the undo port hybrid pvid command to restore the default, VLAN 1.
The default VLAN ID of local Hybrid port must be consistent with that of the peer;
otherwise, packets cannot be forwarded properly.
Execution of the undo vlan command on a Hybrid port to remove a default VLAN does
not affect the default VLAN configurations. That is to say, a non-existent VLAN can still
be a default VLAN.
Execution of the above commands under Ethernet port view will apply to the current
port only whereas under port group view will apply to all ports in the port group view.
(For related configurations on port group, refer to Port Correlation Configurations part)
Related command: port link-type.

Example
# Configure the default VLAN ID for the Hybrid port Ethernet 1/0/1 to be 100.
<Sysname> system-view
[Sysname] interface Ethernet 1/0/1
[Sysname-Ethernet1/0/1] port link-type hybrid
[Sysname-Ethernet1/0/1] port hybrid pvid vlan 100

1-10

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 1 VLAN Configuration Commands

1.2.4 port hybrid vlan


Syntax
port hybrid vlan vlan-id-list { tagged | untagged }
undo port hybrid vlan vlan-id-list

View
Ethernet port view/port group view

Parameter
vlan-id-list: The range of VLANs that the Hybrid ports will be added to, vlan-id-list =
[ vlan-id1 [ to vlan-id2 ] ]&<1-10>, where vlan-id1 and vlan-id2 range from 1 to 4,094,
and vlan-id2 cannot be smaller than vlan-id1. &<1-10> indicates that you can specify
up to 10 VLANs or 10 VLAN ranges.
tagged: Specifies to tag the packets of the specified VLAN (s).
untagged: Specifies not to tag the packets of the specified VLAN(s).

Description
Use the port hybrid vlan command to add the current Hybrid port to the specified
VLAN(s).
Use the undo port hybrid vlan command to remove the current Hybrid port from the
specified VLAN(s).
The Hybrid port may belong to multiple VLANs. Repetitive execution of the port hybrid
vlan command will yield a set VLANs, to which the Hybrid port belongs.
Execution of the above commands in Ethernet port view will apply to the current port
only whereas under port group view will apply to all ports in the port group. (For related
configurations on port group, refer to Port Correlation Configuration part).
Related command: port link-type.

Example
# Add the Hybrid port Ethernet1/0/4 to VLAN 2, VLAN 4, and the range of VLANs from
VLAN 50 to VLAN 100 (these VLANs all exist). Configure to keep the VLAN tags of all
packets of these VLANs when the packets are sent from Ethernet1/0/4.
<Sysname> system-view
[Sysname] interface Ethernet 1/0/4
[Sysname-Ethernet1/0/4] port link-type hybrid
[Sysname-Ethernet1/0/4] port hybrid vlan 2 4 50 to 100 tagged
Please wait... Done.

# Add Hybrid ports of port group 2 (including port Ethernet 1/0/1 to Ethernet 1/0/6) to
VLAN 2. Packets are untagged.
Huawei Proprietary and Confidential
Copyright (c) Huawei Technologies Co., Ltd

1-11

Chapter 1 VLAN Configuration Commands

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

<Sysname> system-view
[Sysname] vlan 2
[Sysname-vlan2] quit
[Sysname] port-group manual 2
[Sysname-port-group-manual-2] group-member Ethernet 1/0/1 to Ethernet 1/0/6
[Sysname-port-group-manual-2] port link-type hybrid
[Sysname-port-group-manual-2] port hybrid vlan 2 untagged
Configuring Ethernet1/0/1... Done.
Configuring Ethernet1/0/2... Done.
Configuring Ethernet1/0/3... Done.
Configuring Ethernet1/0/4... Done.
Configuring Ethernet1/0/5... Done.
Configuring Ethernet1/0/6... Done.

1.2.5 port link-type


Syntax
port link-type { access | hybrid | trunk }
undo port link-type

View
Ethernet port view/port group view

Parameter
access: Configures the link type of a port as Access.
hybrid: Configures the link type of a port as Hybrid.
trunk: Configures the link type of a port as Trunk.

Description
Use the port link-type command to configure the link type of a port.
Use the undo port link-type command to restore the default link type of a port, which
is Access by default.
Execution of the above commands in Ethernet port view will apply to the current port
only whereas under port group view will apply to all ports in the port group. (For related
configurations on port group, refer to Port Correlation Configuration part).

1-12

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 1 VLAN Configuration Commands

Note:
The Trunk and Hybrid ports cannot be converted to each other directly. You can convert
either to the Access port, and then to the other type. For example, convert a Trunk port
to an Access port, and then to a Hybrid port.

Example
# Configure Ethernet 1/0/1 to be a Trunk port.
<Sysname> system-view
[Sysname] interface Ethernet 1/0/1
[Sysname-Ethernet1/0/1] port link-type trunk

1.2.6 port trunk permit vlan


Syntax
port trunk permit vlan { vlan-id-list | all }
undo port trunk permit vlan { vlan-id-list | all }

View
Ethernet port view/port group view

Parameter
vlan-id-list: The range of VLANs that the Trunk ports will be added to, in the format of
vlan-id-list = [ vlan-id1 [ to vlan-id2 ] ]&<1-10>, where vlan-id1 and vlan-id2 range from
1 to 4,094 and vlan-id2 cannot be smaller than vlan-id1. &<1-10> indicates that you can
specify up to 10 VLANs or VLAN ranges.
all: Adds the Trunk port to all VLANs.

Description
Use the port trunk permit vlan command to add a Trunk port to a specified VLAN, a
selection of VLANs, or all VLANs.
Use the undo port trunk permit vlan command to remove the Trunk port from a
specified VLAN, a selection of VLANs, or all VLANs.
The Trunk port may belong to multiple VLANs. Repetitive execution of the port trunk
permit vlan command will yield a set of vlan-id-list, to which the Trunk port belongs.
Execution of the above commands in Ethernet port view will apply to the current port
only whereas under port group view will apply to all ports in the port group view. (For
related configurations on port group, refer to Port Correlation Configuration part)
Related command: port link-type.
Huawei Proprietary and Confidential
Copyright (c) Huawei Technologies Co., Ltd

1-13

Chapter 1 VLAN Configuration Commands

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Example
# Configure the Trunk port Ethernet1/0/4 to permit packets of VLAN2, VLAN4, VLAN50
through VLAN100 (these VLANs already exist) to pass.
<Sysname> system-view
[Sysname] interface Ethernet 1/0/4
[Sysname-Ethernet1/0/4] port link-type trunk
[Sysname-Ethernet1/0/4] port trunk permit vlan 2 4 50 to 100
Please wait........... Done.

1.2.7 port trunk pvid vlan


Syntax
port trunk pvid vlan vlan-id
undo port trunk pvid

View
Ethernet port view/port group view

Parameter
vlan-id : VLAN ID, in the range of 1 to 4,094

Description
Use the port trunk pvid vlan command to configure the default VLAN ID for a Trunk
port.
Use the undo port trunk pvid command to restore the default.
By default, the default VLAN on a Trunk port is VLAN 1.
Execution of the undo vlan command on a Trunk port to remove a default VLAN does
not affect the default VLAN configurations. That is to say, a non-existent VLAN can still
be a default VLAN.
Execution of the above commands in Ethernet port view will apply to the current port
only whereas under port group view will apply to all ports in the port group view. (For
related configurations on port group, refer to Port Correlation Configuration part).
You must configure the same default VLAN ID for the Trunk ports on the local and
remote devices. Otherwise, packets of the default VLAN on the local end cannot be
transmitted correctly to the remote end.
Related command: port link-type.

Example
# Configure the default VLAN ID for the Trunk port Ethernet 1/0/4 as 100.
<Sysname> system-view

1-14

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 1 VLAN Configuration Commands

[Sysname] interface Ethernet 1/0/4


[Sysname-Ethernet1/0/4] port link-type trunk
[Sysname-Ethernet1/0/4] port trunk pvid vlan 100

1.3 IP-Subnet-Based VLAN Configuration Commands


1.3.1 display ip-subnet-vlan interface
Syntax
display ip-subnet-vlan interface { interface-list | all }

View
Any view

Parameter
interface-list: Ethernet interface list to be displayed, in the format of { interface-type
interface-number [ to interface-type interface-number ] }&<1-10>, where interface-type
interface-number represents the port type and port number, &<1-10> indicates that you
can specify up to 10 port ranges.
all: Specifies to display information about all the ports that have associated with the
IP-subnet-based VLAN.

Description
Use the display ip-subnet-vlan interface command to display the IP-subnet-based
VLAN information and IP subnet ID on a specified port.

Example
# Display the IP-subnet-based VLAN information and IP subnet index on Ethernet
1/0/1.
<Sysname> display ip-subnet-vlan interface Ethernet 1/0/1
Interface: Ethernet1/0/1
VLAN ID

Subnet-Index

IP ADDRESS

NET MASK

=======================================================
3

192.168.1.0

255.255.255.0

1.3.2 display ip-subnet-vlan vlan


Syntax
display ip-subnet-vlan vlan { vlan-id [ to vlan-id ] | all }

View
Any view
Huawei Proprietary and Confidential
Copyright (c) Huawei Technologies Co., Ltd

1-15

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 1 VLAN Configuration Commands

Parameter
vlan-id: VLAN ID, in the range of 1 to 4,094.
to: Specifies VLAN range, the value after this parameter must be greater than or equal
to that before it.
all: Display the IP subnet information and IP subnet index of all VLAN(s)..

Description
Use the display ip-subnet-vlan vlan command to display the IP subnet information
and IP subnet index on the specified VLAN(s).
Related command: display vlan.

Example
# Display the IP subnet information of all VLANs.
<Sysname> display ip-subnet-vlan vlan all
VLAN ID:

Subnet Index

IP Address

Subnet Mask

====================================================
0

192.168.1.0

255.255.255.0

1.3.3 ip-subnet-vlan
Syntax
ip-subnet-vlan [ ip-subnet-index ] ip ip-address [ mask ]
undo ip-subnet-vlan { ip-subnet-index [ to ip-subnet-end ] | all }

View
VLAN view

Parameter
ip-subnet-index: IP subnet Index, in the range of 0 to 11. This value can be configured
by users, or automatically numbered by system based on the order in which the IP
subnet or IP address is associated with the VLAN.
ip-address : Source IP address or network address based on which the subnet-based
VLANs are classified, in dotted decimal format.
mask: The subnet mask of the source IP address or network address, in dotted decimal
format with a default value of 255.255.255.0.
ip-subnet-end: The last index value of the IP subnet, in the range of 0 to 11, must be
greater than or equal to the ip-subnet-index value.
all: Removes the associations between the current VLAN and all the IP subnet indexes.

1-16

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 1 VLAN Configuration Commands

Description
Use the ip-subnet-vlan command to associate the current VLAN with a specified IP
subnet or IP address.
Use the undo ip-subnet-vlan command to delete the association.
Note that the IP subnet or IP address cannot be a multicast network segment or a
multicast address.
Related command: display ip-subnet-vlan vlan.

Example
# Configure VLAN 3 to be an IP-subnet-based VLAN. Associate it with the
192.168.1.0/24 network segment.
<Sysname> system-view
[Sysname] vlan 3
[Sysname-vlan3] ip-subnet-vlan ip 192.168.1.0 255.255.255.0

1.3.4 port hybrid ip-subnet-vlan vlan


Syntax
port hybrid ip-subnet-vlan vlan vlan-id
undo port hybrid ip-subnet-vlan { vlan vlan-id | all }

View
Ethernet port view/port group view

Parameter
vlan-id: VLAN ID, in the range of 1 to 4,094.
all: Remove the associations between the current port and all the IP-subnet-based
VLANs.

Description
Use the port hybrid ip-subnet-vlan vlan command to associate the current Ethernet
port with an IP-subnet-based VLAN.
Use the undo port hybrid ip-subnet-vlan vlan command to remove the association
between the current Ethernet port and an IP-subnet-based VLAN.
Execution of the above commands in Ethernet port view will apply the configurations to
the current port only whereas under port group view will apply the configurations to all
ports in the port group. (For related configurations on port group, refer to Port
Correlation Configuration part).

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

1-17

Chapter 1 VLAN Configuration Commands

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Note that only the Hybrid port supports the above feature at the moment. Before issuing
this command, ensure that the port has been added to the IP-subnet-based VLAN to be
associated with. Otherwise, the port cannot be associated with the VLAN.
Related command: display ip-subnet-vlan interface.

Example
# Associate Ethernet 1/0/8 with the IP-subnet-based VLAN 2.
<Sysname> system-view
[Sysname] interface Ethernet 1/0/8
[Sysname-Ethernet1/0/8] port link-type hybrid
[Sysname-Ethernet1/0/8] port hybrid vlan 2 tagged
Please wait... Done.
[Sysname-Ethernet1/0/8] port hybrid ip-subnet-vlan vlan 2

1-18

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 2 Voice VLAN Configuration Commands

Chapter 2 Voice VLAN Configuration Commands


2.1 Voice VLAN Configuration Commands
2.1.1 display voice vlan oui
Syntax
display voice vlan oui

View
Any view

Parameter
None

Description
Use the display voice vlan oui command to display the Organizationally Unique
Identifier (OUI) address(es), the OUI address mask, and the descriptive string currently
supported by system.
Related command: voice vlan, voice vlan enable.

Note:
As the first 24 bits of a MAC address (in binary format), an OUI address is a globally
unique identifier assigned to a vendor by IEEE.

Example
# Display the OUI address of a voice VLAN.
<Sysname> display voice vlan oui
Oui Address

Mask

Description

0001-e300-0000

ffff-ff00-0000

Siemens phone

0003-6b00-0000

ffff-ff00-0000

Cisco phone

00d0-1e00-0000

ffff-ff00-0000

Pingtel phone

00e0-7500-0000

ffff-ff00-0000

Polycom phone

00e0-bb00-0000

ffff-ff00-0000

3com phone

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

2-1

Chapter 2 Voice VLAN Configuration Commands

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Table 2-1 Description on the fields of the display voice vlan oui command
Field

Description

Oui Address

OUI address currently supported by system

Mask

OUI address mask currently supported by system

Description

Descriptive string of the OUI address currently


supported by system

2.1.2 display voice vlan state


Syntax
display voice vlan state

View
Any view

Parameter
None

Description
Use the display voice vlan state command to display the voice VLAN configuration.
Related command: voice vlan and voice vlan enable.

Example
# Display the voice VLAN configurations.
<Sysname> display voice vlan state
Voice VLAN status: ENABLE
Voice VLAN ID: 2
Voice VLAN security mode: Security
Voice VLAN aging time: 1440 minutes
Voice VLAN enabled port and its mode:
PORT

MODE

--------------------------------------------------------------

2-2

Ethernet1/0/2

MANUAL

Ethernet1/0/3

MANUAL

Ethernet1/0/4

MANUAL

Ethernet1/0/5

AUTO

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 2 Voice VLAN Configuration Commands

Table 2-2 Description on the fields of the display voice vlan state command
Field

Description

Voice VLAN status

The current voice VLAN status, that is, whether


it is enabled or disabled.

Voice VLAN ID

ID of a voice VLAN

Voice VLAN security mode

Security mode of a voice VLAN

Voice VLAN aging time

Aging time of a voice VLAN

Current voice vlan enabled port


and its mode

The port that is currently enabled with the voice


VLAN feature and its working mode

PORT

port ID

MODE

Voice VLAN
automatic.

working

mode:

manual

or

2.1.3 voice vlan


Syntax
voice vlan vlan-id enable
undo voice vlan enable

View
System view

Parameter
vlan-id: ID of the VLAN to be enabled with the voice VLAN feature, in the range of 2 to
4,094.

Description
Use the voice vlan command to enable the voice VLAN feature globally.
Use the undo voice vlan enable command to disable the voice VLAN feature globally.
z

At one particular moment, only one VLAN of a certain device can have the voice
VLAN feature enabled.

Ensure that a VLAN exists before enabling its voice VLAN feature and that it is not
VLAN 1. Otherwise, the configurations will fail.

If a VLAN to be deleted has the voice VLAN feature enabled, you need to disable
the voice VLAN feature first before deleting the VLAN.

Related command: display voice vlan state.

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

2-3

Chapter 2 Voice VLAN Configuration Commands

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Note:
When configuring voice VLAN (under automatic mode and manual mode), note that:
z

Only one static VLAN of a device can have the voice VLAN feature enabled at a time.
A dynamic VLAN cannot be configured as a voice VLAN.

You are not recommended to configure both voice VLAN and Q-in-Q (including
basic Q-in-Q and selective Q-in-Q) on a device. Otherwise, the voice VLAN cannot
work properly.

Example
# Enable the voice VLAN feature on VLAN 2(assuming that VLAN 2 already exists).
<Sysname> system-view
[Sysname] voice vlan 2 enable

2.1.4 voice vlan aging


Syntax
voice vlan aging minutes
undo voice vlan aging

View
System view

Parameter
minutes: Aging time of a voice VLAN, in the range of 5 to 43,200 minutes.

Description
Use the voice vlan aging command to configure the aging time of a voice VLAN.
Use the undo voice vlan aging command to restore the aging time of a voice VLAN.
By default, the aging time of a voice VLAN is 1,440 minutes..
Under automatic mode, the system will decide whether to add a port to a voice VLAN
based on the source MAC address contained in its inbound voice packets. After adding
a port to the voice VLAN, the system will start the aging timer at the same time. If within
the aging time, no voice packets is received from the port, it will be removed from the
voice VLAN when the aging time expires.
Related command: display voice vlan state.

Example
# Configure the aging time of the voice VLAN as 100 minutes.
2-4

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 2 Voice VLAN Configuration Commands

<Sysname> system-view
System View: return to User View with Ctrl+Z.
[Sysname] voice vlan aging 100

2.1.5 voice vlan enable


Syntax
voice vlan enable
undo voice vlan enable

View
Ethernet port view

Parameter
None

Description
Use the voice vlan enable command to enable the voice VLAN feature on an Ethernet
port.
Use the undo voice vlan enable command to disable the voice VLAN feature on an
Ethernet port.
No voice VLAN is enabled on a port by default.
z

Under automatic mode, only The Trunk or Hybrid port can be configured with the
voice VLAN feature. The Access port cannot be configured with this feature.

Before enabling the voice VLAN feature on a port, ensure that its is enabled
globally first

Only after the voice VLAN feature is enabled under both system view and Ethernet
port view will it functions properly.

Example
# Enable the voice VLAN feature on the port Ethernet 1/0/2.
<Sysname> system-view
[Sysname] voice vlan 2 enable
[Sysname] interface Ethernet 1/0/2
[Sysname-Ethernet1/0/2] voice vlan enable

2.1.6 voice vlan mac-address


Syntax
voice vlan mac-address oui mask oui-mask [ description text ]
undo voice vlan mac-address oui
Huawei Proprietary and Confidential
Copyright (c) Huawei Technologies Co., Ltd

2-5

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 2 Voice VLAN Configuration Commands

View
System view

Parameter
oui: MAC address, in the format of H-H-H, such as 1234-1234-1234.. The OUI address
cannot be a broadcast, multicast or address of all 0s or all fs.
oui-mask: Valid length of the OUI address, represented in mask, in the format of H-H-H,
from left to right are consecutive fs and 0s, for example, ffff-ff00-0000.
text: A case sensitive string that describes the OUI address, in the range of 1 to 30
characters.

Description
Use the voice vlan mac-address command to make a specified OUI address
identified by the voice VLAN.
Use the undo voice vlan mac-address command to remove an OUI address from
being identified by the voice VLAN.
A maximum of 16 OUI addresses can be identified.
By default, there are 5 default OUI addresses, which can be removed or then added, as
illustrated in the following table.
Table 2-3 Default OUI addresses
Number

OUI

Description

0001-e300-0000

Siemens phone

0003-6b00-0000

Cisco phone

00d0-1e00-0000

Pingtel phone

00e0-7500-0000

Polycom phone

00e0-bb00-0000

3com phone

Related command: display voice vlan oui.

Example
# Set the OUI address to 00AA-BB00-0000, the OUI address mask to ffff-ff00-0000,
and the descriptive string to ABC.
<Sysname> system-view
[Sysname]

voice

vlan

mac-address

00aa-bb00-0000

description ABC

# Display OUI address information.


[Sysname] display voice vlan oui

2-6

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

mask

ffff-ff00-0000

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 2 Voice VLAN Configuration Commands

Oui Address

Mask

Description

0001-e300-0000

ffff-ff00-0000

Siemens phone

0003-6b00-0000

ffff-ff00-0000

Cisco phone

00aa-bb00-0000

ffff-ff00-0000

ABC

00d0-1e00-0000

ffff-ff00-0000

Pingtel phone

00e0-7500-0000

ffff-ff00-0000

Polycom phone

00e0-bb00-0000

ffff-ff00-0000

3com phone

2.1.7 voice vlan mode auto


Syntax
voice vlan mode auto
undo voice vlan mode auto

View
Ethernet port view

Parameter
None

Description
Use the voice vlan mode auto command to configure the voice VLAN working mode
on a port to be automatic.
Use the undo voice vlan mode auto command to configure the voice VLAN working
mode on a port to be manual.
By default, the voice VLAN working mode is automatic.

Example
# Configure the voice VLAN working mode on Ethernet 1/0/1 to be manual.
<Sysname> system-view
[Sysname] interface Ethernet 1/0/1
[Sysname-Ethernet1/0/1] undo voice vlan mode auto

2.1.8 voice vlan security enable


Syntax
voice vlan security enable
undo voice vlan security enable

View
System view
Huawei Proprietary and Confidential
Copyright (c) Huawei Technologies Co., Ltd

2-7

Chapter 2 Voice VLAN Configuration Commands

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Parameter
None

Description
Use the voice vlan security enable command to enable the security mode for voice
VLAN.
Use the undo voice vlan security enable command to disable the security mode for
voice VLAN.
By default, the security mode of voice VLAN is enabled.
With the security mode enabled, voice packets with source MAC addresses not listed in
the OUI address list will be filtered out on the incoming port. However, this feature does
not affect other VLANs.

Example
# Disable the security mode of the voice VLAN.
<Sysname> system-view
[Sysname] undo voice vlan security enable

2-8

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 3 GVRP Configuration Commands

Chapter 3 GVRP Configuration Commands


3.1 GARP Configuration Commands
3.1.1 display garp statistics
Syntax
display garp statistics [ interface interface-list ]

View
Any view

Parameter
interface-list: Ethernet port list, in the format of { interface-type interface-number [ to
interface-type interface-number ] }&<1-10>, where &<1-10> indicates that you can
specify up to 10 port ranges. A port range defined without the to interface-type
interface-number portion comprises only one port.

Description
Use the display garp statistics command to display statistics about GARP for
specified or all ports.

Example
# Display statistics about GARP for port Ethernet 1/0/1.
<Sysname> display garp statistics interface Ethernet1/0/1
GARP statistics on port Ethernet1/0/1

Number of GVRP Frames Received

: 0

Number of GVRP Frames Transmitted

: 0

Number of Frames Discarded

: 0

3.1.2 display garp timer


Syntax
display garp timer [ interface interface-list ]

View
Any view

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

3-1

Chapter 3 GVRP Configuration Commands

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Parameter
interface-list: Ethernet port list, in the format of { interface-type interface-number [ to
interface-type interface-number ] }&<1-10>, where &<1-10> indicates that you can
specify up to 10 port ranges. A port range defined without the to interface-type
interface-number portion comprises only one port.

Description
Use the display garp timer command to display GARP timers.
Related command: garp timer, garp timer leaveall.

Example
# Display GARP timers on port Ethernet 1/0/1.
<Sysname> display garp timer interface Ethernet1/0/1
GARP timers on port Ethernet1/0/1

Garp Join Time

: 20 centiseconds

Garp Leave Time

: 60 centiseconds

Garp LeaveAll Time

: 1000 centiseconds

Garp Hold Time

: 10 centiseconds

3.1.3 garp timer


Syntax
garp timer { hold | join | leave } timer-value
undo garp timer { hold | join | leave }

View
Ethernet port view, port-group view

Parameter
hold: Sets the hold timer. When a GARP application entity receives the first registration
request, it starts a hold timer and collects succeeding requests. When the timer expires,
the entity sends all these requests in one Join message, thus saving bandwidth.
join: Sets the join timer. Each GARP application entity sends a Join message twice for
reliability sake and uses a join timer to set the sending interval.
leave: Sets the leave timer. This timer starts upon receipt of a Leave message. When
this timer expires, the GARP application entity removes attribute information as
requested.

3-2

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 3 GVRP Configuration Commands

timer-value: Assigns a timer value, in centiseconds, and in steps of five. The default is
10 centiseconds for the hold timer, 20 centiseconds for the join timer, and 60
centiseconds for the leave timer.

Description
Use the garp timer command to set a GARP timer for an Ethernet port or all ports in a
port-group.
Use the undo garp timer command to restore the default value of a GARP timer.
The default value is 10 centiseconds for the hold timer, 20 centiseconds for the join
timer, and 60 centiseconds for the leave timer.
Configured in Ethernet port view, the setting takes effect on the current port only;
configured in port group view, the setting takes effect on all ports in the port group.
Note that:
z

The values of all timers must be multiples of five centiseconds, and the value
range of a timer changes if that of other timers changes. If a timer value you want
to set is beyond the configured range, you can set the value otherwise by
changing the values of related timers.

If you want to restore the default value of all timers, follow this order: hold, join,
leave, and leaveall.

When setting a GARP timer, make sure that the setting is in compliance with the
dependencies shown in Table 3-1.

The undo garp timer command will not take effect if the default setting of the
timer does not satisfy the dependencies shown in Table 3-1.

Table 3-1 Dependencies of GARP timers


Timer

Lower limit

Upper limit

Hold

10 centiseconds

Not greater than half of the join timer


setting

Join

Not less than two times the


hold timer setting

Less than half of the leave timer


setting

Leave

Greater than two times the join


timer setting

Less than the leaveall timer setting

Leaveall

Greater than the leave timer


setting

32,765 centiseconds

Related command: display garp timer.

Example
# Set the join timer to 25 centiseconds on Ethernet1/0/1 (assume that both hold and
leave timers use the default value).

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

3-3

Chapter 3 GVRP Configuration Commands

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

<Sysname> system-view
[Sysname] interface Ethernet 1/0/1
[Sysname-Ethernet1/0/1] garp timer join 25

3.1.4 garp timer leaveall


Syntax
garp timer leaveall timer-value
undo garp timer leaveall

View
System view

Parameter
timer-value: Sets a Leaveall timer value in the range 65 to 32,765 centiseconds in steps
of 5. This value must be greater than the leave timer value.

Description
Use the garp timer leaveall command to set the leaveall timer.
Use the undo garp timer leaveall command to restore the default leaveall timer. This
may fail if the default is less than the current leave timer value.
By default, the leaveall timer is 1000 centiseconds.
A leaveall timer starts upon the start of a GARP application entity. When this timer
expires, the entity sends a LeaveAll message so that other entities can re-register its
attribute information and starts another leaveall timer at the same time.
A GARP application entity may send LeaveAll messages at the interval set by its
LeaveAll timer or the leaveall timer of another GARP application entity on the network,
whichever is smaller.
Related command: display garp timer.

Example
# Set the leaveall timer to 100 centiseconds (assume the leave timer is set to 60
centiseconds).
<Sysname> system-view
[Sysname] garp timer leaveall 100

3.1.5 reset garp statistics


Syntax
reset garp statistics [ interface interface-list ]

3-4

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 3 GVRP Configuration Commands

View
User view

Parameter
interface-list: Ethernet port list, in the format of { interface-type interface-number [ to
interface-type interface-number ] }&<1-10>, where &<1-10> indicates that you can
specify up to 10 port ranges. A port range defined without the to interface-type
interface-number portion comprises only one port.

Description
Use the reset garp statistics command to clear statistics about GARP on the specified
or all ports.
Related command: display gvrp statistics.

Example
# Clear statistics about GARP on all ports.
<Sysname> reset garp statistics

3.2 GVRP Configuration Commands


3.2.1 display gvrp statistics
Syntax
display gvrp statistics [ interface interface-list ]

View
Any view

Parameter
interface-list: Ethernet port list, in the format of { interface-type interface-number [ to
interface-type interface-number ] }&<1-10>, where &<1-10> indicates that you can
specify up to 10 port ranges. A port range defined without the to interface-type
interface-number portion comprises only one port.

Description
Use the display gvrp statistics command to display statistics about GVRP for
specified or all trunk ports.
Note that:
z

Without interface interface-list specified, this command displays the GVRP


statistics on all trunk ports.

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

3-5

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 3 GVRP Configuration Commands


z

With interface interface-list specified, this command displays the GVRP statistics
on the specified trunk port.

Example
# Display statistics about GVRP for trunk port Ethernet 1/0/1.
<Sysname> display gvrp statistics interface Ethernet1/0/1
GVRP statistics on port Ethernet1/0/1

GVRP Status

: Enabled

GVRP Running

: YES

GVRP Failed Registrations

: 0

GVRP Last Pdu Origin

: 0000-0000-0000

GVRP Registration Type

: Normal

Table 3-2 Description on the fields of the display gvrp statistics command
Field

Description

GVRP Status

Indicates the state of GVRP is enabled or disabled.

GVRP Running

Indicates whether GVRP is running.

GVRP Failed Registrations

Indicates the number of GVRP registration failures

GVRP Last Pdu Origin

Indicates the source MAC address in the last GVRP


PDU.

GVRP Registration Type

Indicates the GVRP registration type on the port

3.2.2 display gvrp status


Syntax
display gvrp status

View
Any view

Parameter
None

Description
Use the display gvrp status command to display the global enable/disable state of
GVRP.

3-6

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

Chapter 3 GVRP Configuration Commands

Example
# Display the global GVRP enable/disable state.
<Sysname> display gvrp status
GVRP is enabled

3.2.3 gvrp
Syntax
gvrp
undo gvrp

View
System view, Ethernet port view, port-group view

Parameter
None

Description
Use the gvrp command to enable GVRP globally, on a port, or on all ports in a
port-group.
Use the undo gvrp command to disable GVRP globally, on a port, or on all ports in a
port group.
By default, GVRP is disabled.
Note that the port where you enable GVRP must be a trunk, and before doing that you
must enable GVRP globally.
Related command: display gvrp status.

Example
# Enable GVRP globally.
<Sysname> system-view
[Sysname] gvrp
GVRP is enabled globally.

3.2.4 gvrp registration


Syntax
gvrp registration { fixed | forbidden | normal }
undo gvrp registration

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

3-7

Chapter 3 GVRP Configuration Commands

Command Manual VLAN


Quidway S3500-EA Series Ethernet Switches

View
Ethernet interface view, port-group view

Parameter
fixed: Sets the registration type to fixed.
forbidden: Sets the registration type to forbidden.
normal: Sets the registration type to normal.

Description
Use the gvrp registration command to configure the GVRP registration type on a port
or all ports in a port-group.
Use the undo gvrp registration command to restore the default GVRP registration
type on a port or all ports in a port-group.
The default GVRP registration type is normal.
If configured in Ethernet port view, the setting takes effect on the current port only; if
configured in port group view, the setting takes effect on all ports in the port group.
GVRP provides the following three registration types on a port:
z

Normal Enables a port to dynamically register/deregister VLANs, and to


propagate both dynamic and static VLAN information.

Fixed Disables the port to dynamically register VLANs or propagate dynamic


VLAN information, but allows the port to propagate static VLAN information. A
trunk port with fixed registration type thus allows only manually configured VLANs
to pass through even though it is configured to carry all VLANs.

Forbidden Disables the port to dynamically register VLANs, and to propagate


VLAN information except for VLAN 1. A trunk port with forbidden registration type
thus allows only VLAN 1 to pass through even though it is configured to carry all
VLANs.

Note that this command is only available on trunk ports.


Related command: display gvrp statistics.

Example
# Set the GVRP registration type to fixed on port Ethernet 1/0/1.
<Sysname> system-view
[Sysname] interface Ethernet 1/0/1
[Sysname-Ethernet1/0/1] port link-type trunk
[Sysname-Ethernet1/0/1] port trunk permit vlan all
[Sysname-Ethernet1/0/1] gvrp registration fixed

3-8

Huawei Proprietary and Confidential


Copyright (c) Huawei Technologies Co., Ltd

You might also like