12

8 . สร้างปุ ่มควบค่ม

1. คลิกที่รูปสามเหลี่ยมเล็ก ๆ ที่ แถบเครื่องมือ และเลือก

แถบเครื่องมือปุ ่มสี่เหลี่ยม
จะได้ดังรูป

2. สังเกต ตรง Outline ด้านซ้ายมือจะปรากฏ ปุ ่ม
3. คลิกที่ปุ่ม รูปสี่เหลี่ยมให้ Active แล้วคลิกที่เมนู Modify ->

Convert  Convert to Button

4. สังเกต ตรง Outline ด้านซ้ายมือจะเปลี่ยนเป็ นปุ ่ม Button

5. ให้คลิกที่เครื่องหมาย บวก + หน้า รูปดวงตาจะปรากฏ
ดังนี้

13

6. คลิกที่ UP/Over/Down/Hit State
7. คลิกที่ Insert Text พิมพ์คำาวุา ทดสอบปุ ่ม

จะปรากฏข้อความอยุูตรงกลาง ปุ ่ม ดังนี้

14

8. นำาเมาส์ไปคลิกที่ Button ตรง Outline

9. สังเกต ดูค่ณสมบัติด้านขวามือจะปรากฏ
10.

ให้คลิกที่ ตรงกลาง กรอบสี่เหลี่ยม จะปรากฏ

11.

สังเกต Outline ด้านซ้ายมือ จะปรากฏ

เครื่องหมายถูกสีเขียว

Up State คือ สถานะที่ปุ่มอยุูในภาวะปกติ

15
Over State คือ สถานะที่นำาเมาส์ไปชี้ท่ีปุ่ม

Down State คือ สถานะที่นำาเมาส์คลิกที่ปุ่ม

12.

เราสามารถเปลี่ยนสีปุ่มได้ตามต้องการ โดยการนำา

เมาส์ ไปคลิกที่ Rounded Button

ที่เราต้องการเปลี่ยน ถ้าต้องการเปลี่ยนปุ ่มตรง Up State

ให้นำาเมาส์ไปคลิกที่ Rounded Button ด้านลุาง ทดสอบปุ ่ม
ตรง Up State ด้านขวามือจะปรากฏ ให้เปลี่ยนสี

คลิกที่ สี่เหลี่ยม หรือ
ตามใจชอบ

สามเหลี่ยมเล็กๆ ตรง Fill เลือกสี

13.

ทดสอบ ปุ ่ม โดยให้คลิกที่

14.

นำาเมาส์ ชี้ท่ีปุ่มดูการเปลี่ยนแปลง

16

9. การสร้างการเชื่อมโยงไปแฟ้ มข้อมูล HTML

1.ให้ผู้เรียนสร้างปุ ่มขึ้นมา 1 ปุ ่มสำาหรับใช้ทำาการเชื่อมโยง

กลาง State

2. เลือกปุ ่มที่จะทำาการเชื่อมโยง
3. แล้วคลิกที่ แท็บ Script

17

4. แล้วคลิกที่ Add Script Browser getURL ดังภาพ

5.จะปรากฏ พื้ นที่ให้ใสุคำาสัง่ ดังนี้

18

6.ตรงชุอง URL ให้พิมพ์ไฟล์ท่ีเราต้องการจะเชื่อมโยง เชุน
index.html

7.ตรงชุอง Windows ให้คลิกตรงสามเหลี่ยมหัวลง จะมีคำาสัง่ ให้
เลือก

8. เมื่อพิมพ์เสร็จข้อความที่พิมพ์ จะไปปรากฏตรงคำาสัง่ ด้านบน

9.ให้คลิกไปหน้าที่สร้างการเชื่อมโยง โดยคลิกที่ Layout :Scene 1

10. ทดสอบการเคลื่อนไหว คลิกที่ Control  Playmovie

19
หรือปุ ่ม

หย่ดคลิกที่

10. การสร้างการเชื่อมโยงในแตุละ Secne

1. สร้างปุ ่มพิมพ์ข้อความ “คลิกไปหน้าตุอไป”

2. คลิก Insert Secne

3. จะได้หน้าจอใหมุ

20

4.

5.

สร้างปุ ่มข้อความ “กลับหน้าเดิม”

คลิกที่ปุ่ม “กลับหน้าเดิม”ให้ Active คลิกที่แท็บ Script
คลิก Add Script  Movie Control

gotoAndPlay  gotoAndPlay(FRAME)

21

6.

จะเห็นโปรแกรมคำาสัง่ ในการเชื่อมโยง

22
7.

ที่ชุองด้านลุางตรง Target คลิกตรงสามเหลี่ยมหัวลง

เลือกคลิก “Scene_1” เพื่อสร้างการเชื่อมโยงไป
Scene_1 จะปรากฏคำาสัง่ โปรแกรม
on (release) {

gotoSceneAndPlay("Scene_1",1);

ในชุอง
8.

Add Script

}

คลิกที่ Scene_2 ตรงด้าน Outline

Script

คลิกที่แท็บ

คลิก Add Script  Movie Control Stop()

9.

คลิกที่แท็บ Layout กลับไปที่หน้าจอ Scene_2
10.

คลิกที่ Scene_1 ตรงด้าน Outline เพื่อกลับไปหน้า

จอ Scene_1
11.

คลิกที่ปุ่ม “คลิกไปหน้าตุอไป” เพื่อสร้างการเชื่อม

โยงไป Scene_2

23

12.

คลิกที่แท็บ Script

คลิก Add Script  Movie Control gotoAndPlay
 gotoAndPlay(FRAME)

24

13. จะเห็นโปรแกรมคำาสัง่ ในการเชื่อมโยง

14.

ที่ชุองด้านลุางตรง Target คลิกตรงสามเหลี่ยมหัวลง

เลือกคลิก “Scene_2”

เพื่อสร้างการเชื่อมโยงไป Scene_2 จะปรากฏ

คำาสัง่ โปรแกรม

on (release) {

gotoSceneAndPlay("Scene_2",1);
ในชุอง

15.

}

Add Script

คลิกที่ Scene_2 ตรงด้าน Outline คลิกที่แท็บ

Script

25
คลิก Add Script  Movie Control Stop()

16. คลิกที่แท็ป Layout กลับไปที่หน้าจอ Scene_1

ทดสอบ การทำางานการเชื่อมโยง
ของปุ ่ม

11. การแทรกเสียง
การแทรกเสียงสามารถทำาได้ 2 กรณี คือ
1. แทรกเสียงจาก TimeLine

2. แทรกเสียงโดยควบควบกับปุ ่ม Play หรือ Stop
1. การแทรกเสียงจาก TimeLine
มีข้ ันตอนดังนี้

1. คลิกเมาส์ทางขวาที่ TimeLine ใน

ตำาแหนุง Frame ที่ต้องการเลือกคำาสัง่

26
Sound Play Sound กรณี ให้ใช้

เสียง หรือ StopSound () กรณี ให้หย่ดเสียง

2. ที่ Actions คลิก Import เพลงที่

ต้องการ

3. เมื่อสัง่ Play จะมีเพลงดังตลอดจนจบ

เพลงไมุมีปุ่มควบค่มการทำางาน

2. แทรกเสียงโดยควบควบกับปุ ่ม Play หรือ Stop
1.

สร้างปุ ่มสำาหรับ Play และปุ ่ม Stop ดังนี้

27

2. ใสุคำาสัง
่ โปรแกรมสำาหรับ Play โดย คลิกที่ปุ่มลูกศร คลิก

ที่แท็ป Script

คลิก Add Script  Sound Playsound()

จะปรากฏ คำาสัง่ ที่ชุอง AddScript ดังนี้
on (release) {

playSound();

28
}

3. ให้คลิกที่ ปุ ่ม Import ด้านลุางเลือกไฟล์เสียงที่ต้องการ

แล้วคลิก Open

4. คลิกเลือกเสียงที่อยุูชุองหลังปุ ่ม Import จะปรากฏคำาสัง

โปรแกรมที่ชุอง Add Script ดังนี้
on (release) {

playSound("a1.mp3");
}

5. ใสุคำาสัง
่ โปรแกรมสำาหรับ Stop โดย คลิกที่ปุ่มสี่เหลี่ยม

คลิกที่แท็บ Script

29
คลิก Add Script  Sound StopSound() แล้วคลิก
เลือกเสียงที่จะหย่ด

หรือ StopAllSound() กรณี ให้หย่ดท่กเสียง

6. คลิกที่แท็ป Layout กลับไปที่หน้าจอ Scene_1 ทดสอบ

การทำางานการเชื่อมโยงของปุ ่ม

12. การเพิ่ม Scene

การแทรกฉาก (Scene) ใหมุลงในชิ้นงาน

การแทรกฉากใหมุในชิ้นงาน มีวิธีการดังนี้

1. คลิ้กที่เมนู Insert-->Scene หรือ คลิกที่ปุ่มรูปฉาก ดัง

ภาพ

30

2. ที่ Outline Panel จะมี Scene เพิ่มขึ้น

31

13. การหย่ด Scene

การหย่ด Scene เพื่อให้ Scene หย่ดรอคำาสัง่ เชุน คลิก
ไป Scene ตุอไป

1. คลิกที่ Scene ที่ต้องการหย่ด คลิกที่แท็ป Script
2. คลิกที่ Add Script Movie control Stop

3. เมื่อใสุคำาสัง่ Stop Sence ในสุวน Script จะ

ปรากฏดังนี้

32

Sign up to vote on this title
UsefulNot useful