Turbo C Environment

Parts of the Turbo C IDE 
   Main Menu Editor status line and window The compiler message window The hot-key quick reference line hot-

In the Main Menu 
File ± Loads and saves files, handles directories, invokes DOS, and exits Turbo C  Edit ± Invokes the Turbo C editor  Run ± Compiles, links and runs the program currently loaded in the environment  Compile ± Compiles the program currently in the environment  Project ± Manages multi-file project multi Options ± Sets various compiler, linker and environmental options  Debug ± Set various debug options  Break/watch ± Manages debugger watch expressions and break points

File Menu 
Load ± prompts you for a filename and then loads that file into editor  Pick ± displays a menu that contains a list of the last eight files you have edited.  New ± lets you edit a new file  Save ± saves the file currently in the editor  Write To ± lets you save the file in a different filename.  Directory ± displays the current working directory and lets you choose a file to edit  Change Dir ± changes the default directory to the one you specify.  OS shell ± loads the DOS command processor and lets you execute DOS commands  Quit ± quits Turbo C

Run Menu 
Run ± executes and compiles the current program  Program reset ± terminates your program when it is being run in debug mode.  Go to cursor ± executes your program until it reaches the line of code where the cursor is positioned.  Trace into ± executes the next line or statement.  Step over ± executes the next line of code, but it does not trace into subroutines that may be called.

Compile Menu
The first option allows you to compile the file currently in the editor to an .OBJ file, which is ready to be linked into an .EXE file which is an executable file. The second option will compile your program directly into an executable file. The third option lets you link your current program. The Build All, recompiles all the files related to your program. The Primary C file option lets you specify a filename that will be compiled when you select one of the earlier options, ignoring whatever file is currently being edited. Get info ± displays information about your program and the environment, including how much free memory is available and the length of the file.

Project
- Is used to aid the development and maintenance of large, multi-file programs. multi-

Options
Compiler Linker Environment Directories Arguments - Save Options - Retrieve Options

Debug
- Lets you control the way Turbo C¶s integrated debugger operates

Break/watch
- Lets you set break points in your program and define variables and expressions to be watched while your program executes.

The Message Window
- Used to display various compiler or linker messages. When a program is running, the message window becomes gthe watch window, which is use to display debug information.

The hot Keys
- Hot keys are shortcut keys using your keyboard to navigate into the program. They are ready for use whenever you need them

Hot Keys 
        F1 - Online help F2 - Saves the current file being edited F3 - Loads a file F5 - Zooms the window F6 - Switches between the window F7 - Trace F8 - Step F9 - Compiles and links your program F10 - Toggles between the main menu and the editor

Hot Keys 
Alt-F1 ± last help screen Alt Alt-F3 ± allows you to pick a file to load Alt Alt-F5 ± switches between environment Altscreen and output screen  Alt-F7 ± previous error Alt Alt-F8 ± next error Alt Alt-F9 ± compiles file to .OBJ Alt Alt-C ± Compile menu Alt Alt-D ± Debug menu Alt-

Hot Keys
AltAlt-E ± Edit menu AltAlt-F ± File Menu AltAlt-O ± Option Menu AltAlt-P ± Program Menu AltAlt-R ± Run Menu AltAlt-X ± Quits Turbo C CtrlCtrl-F1 ± requests help about the item which contains in the cursor  Ctrl-F9 ± Runs the program Ctrl      

Sign up to vote on this title
UsefulNot useful