You are on page 1of 5

The Bryant Advantage Ultimate CCNA Lab Workbook

Chris Bryant, CCIE #12933 - www.thebryantadvantage.com

Back To Index

EIGRP

You must have the Frame Relay cloud up and running before beginning
this lab. R2 and R3 should have connectivity via their Ethernet interfaces
as well. (For clarity, only one switch is shown.)
Configure EIGRP AS 100 on R1, R2, and R3 over the Frame Relay cloud.
Disable EIGRPs automatic summarization with the no auto-summary
command. (If you need to review why EIGRP auto-summary is usually
turned off when configured, there is an illustrated example in The Bryant
Advantage Ultimate CCNA Study Guides EIGRP chapter.)
R1#conf t
R1(config)#router eigrp 100
R1(config-router)#no auto-summary
R1(config-router)#network 172.12.123.0 0.0.0.255
R2#conf t
R2(config)#router eigrp 100
R2(config-router)#no auto-summary
R2(config-router)#network 172.12.123.0 0.0.0.255
R3#conf t
R3(config)#router eigrp 100
R3(config-router)#no auto-summary
R3(config-router)#network 172.12.123.0 0.0.0.255

On R1, run show ip eigrp neighbor.


R1#show ip eigrp neighbor
IP-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq Type
(sec) (ms) Cnt Num
1 172.12.123.3 Se0/0 11 00:02:45 1 5000 0 1
0 172.12.123.2 Se0/0 161 00:03:01 1 5000 0 1


On each router, add the loopback address to the EIGRP process.
R1#conf t
R1(config)#router eigrp 100
R1(config-router)#network 1.1.1.1 0.0.0.0
R2#conf t
R2(config)#router eigrp 100
R2(config-router)#network 2.2.2.2 0.0.0.0
R3#conf t
R3(config)#router eigrp 100
R3(config-router)#network 3.3.3.3 0.0.0.0

On each router, run show ip route eigrp. R1 has a route for both R2s and
R3s loopback. R2 and R3 will only see R1s loopback address, and not
each others. Why?
R1#show ip route eigrp
2.0.0.0/24 is subnetted, 1 subnets
D 2.2.2.0 [90/2297856] via 172.12.123.2, 00:03:19, Serial0/0
3.0.0.0/24 is subnetted, 1 subnets
D 3.3.3.0 [90/2297856] via 172.12.123.3, 00:03:04, Serial0/0
R2#show ip route eigrp
1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/2297856] via 172.12.123.1, 00:03:40, Serial0/0.123
R3#show ip route eigrp
1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/2297856] via 172.12.123.1, 00:05:17, Serial0/0.31

EIGRP uses Split Horizon by default to prevent routing loops. In this lab,
though, it prevents full network reachability. R2 and R3 both form
neighbor relationships with R1s Serial physical interface. R2 advertises
its loopback address to R1s Serial interface, as does R3. Split Horizon
does not allow a route to be advertised back out the same interface it was
received on. This prevents R1 from advertising R2s loopback to R3, or
R3s loopback to R2.
Split Horizon must be disabled to allow full network reachability in this lab.
To do so, run no ip split-horizon eigrp 100 on R1s Serial interface. When
Split Horizon is disabled, that will cause the neighbor relationships to fail,
and then reestablish.
Run show ip route eigrp 100 on both R2 and R3. The appropriate route to
the remote loopback address will now appear. From each router, ping the
other routers loopbacks. All pings will succeed.
R1#conf t
R1(config)#int serial0
R1(config-if)#no ip split-horizon eigrp 100
10:02:23:
(Serial0/0)
10:02:23:
(Serial0/0)

%DUAL-5-NBRCHANGE:
IP-EIGRP
down: split horizon changed
%DUAL-5-NBRCHANGE:
IP-EIGRP
down: split horizon changed

100:

Neighbor

172.12.123.2

100:

Neighbor

172.12.123.3

10:02:27:
(Serial0/0)
10:02:54:
(Serial0/0)

%DUAL-5-NBRCHANGE:
ip: new adjacency
%DUAL-5-NBRCHANGE:
ip: new adjacency

IP-EIGRP

100:

Neighbor

172.12.123.3

IP-EIGRP

100:

Neighbor

172.12.123.2

The adjacencies come down after Split Horizon is changed, but are back
within 30 seconds. The routes may need a minute or so to show up on
R2 and R3.
R2#show ip route eigrp
1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/2297856] via 172.12.123.1, 00:00:06, Serial0/0.123
3.0.0.0/24 is subnetted, 1 subnets
D 3.3.3.0 [90/2809856] via 172.12.123.1, 00:00:06, Serial0/0.123
R3#show ip route eigrp
1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/2297856] via 172.12.123.1, 00:00:12, Serial0/0.31
2.0.0.0/24 is subnetted, 1 subnets
D 2.2.2.0 [90/2809856] via 172.12.123.1, 00:00:12, Serial0/0.31

Add the Ethernet segment between R2 and R3 to EIGRP AS 100.


R2#conf t
R2(config)#router eigrp 100
R2(config-router)#network 172.23.23.0 0.0.0.255
R3#conf t
R3(config)#router eigrp 100
R3(config-router)#network 172.23.23.0 0.0.0.255

Run show ip eigrp neighbor on each router.


R2#show ip eigrp neighbor
IP-EIGRP neighbors for process 100
H Address InterfaceHold Uptime SRTT RTO Q Seq Type
(sec) (ms) Cnt Num
1 172.23.23.3 Et0/0 12 00:03:29 4 200 0 15
0 172.12.123.1Se0/0.123 126 00:11:16 40 240 0 15
R3#show ip eigrp neighbor
IP-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq Type
(sec) (ms) Cnt Num
1 172.23.23.2Et0/0 11 00:03:34 1529 5000 0 14
0 172.12.123.1 Se0/0.31 176 00:11:24 40 240 0 16

Run show ip eigrp topology to look at the Successor and Feasible


Successor routes on R1.
R1#show ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID(150.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 1.1.1.0/24, 1 successors, FD is 128256
via Connected, Loopback1
P 2.2.2.0/24, 1 successors, FD is 2297856
via 172.12.123.2 (2297856/128256), Serial0/0
via 172.12.123.3 (2323456/409600), Serial0/0
P 3.3.3.0/24, 1 successors, FD is 2297856
via 172.12.123.3 (2297856/128256), Serial0/0
via 172.12.123.2 (2323456/409600), Serial0/0
P 172.23.23.0/27, 2 successors, FD is 2195456
via 172.12.123.3 (2195456/281600), Serial0/0

via 172.12.123.2 (2195456/281600), Serial0/0


P 172.12.123.0/24, 1 successors, FD is 2169856
via Connected, Serial0/0

According to the code list at the top of this command output, the P code
stands for Passive, and all these routes have a P next to them. Is this
good? Yes. A passive EIGRP route means that it is not currently being
calculated by DUAL. An active EIGRP route means that it is being
calculated. A route that stays in active state cannot be used to transport
packets; such a route is said to be SIA, or stuck in active.
R1 has two Successor routes for the Ethernet network. Why? First, the
EIGRP process checks to see if the routes meet the Feasibility Condition.
The Feasible Distance, the best metric the router has for that destination,
is 2195456.
That happens to be the same metric for both possible routes, and since
the Advertised Distance (281600) for both routes is less than the Feasible
Distance, both routes are Feasible Successors. Since the metric for both
paths is exactly the same, equal-cost load balancing will occur, and both
routes are placed into the topology table as Successors, and both will be
placed into the EIGRP routing table.
Consider R1s two possible routes to R2s loopback and R3s loopback
from the EIGRP topology table:
R1#show ip eigrp topology
P 2.2.2.0/24, 1 successors, FD is 2297856
via 172.12.123.2 (2297856/128256), Serial0/0
via 172.12.123.3 (2323456/409600), Serial0/0
P 3.3.3.0/24, 1 successors, FD is 2297856
via 172.12.123.3 (2297856/128256), Serial0/0
via 172.12.123.2 (2323456/409600), Serial0/0

The Feasible Distance for this route is 2297856; that is the best metric the
router has for the route. The first route in the list has this FD, and will be
the Successor (primary route).
The second route must meet the Feasibility Condition. Is its Advertised
Distance lower than the Feasible Distance (FD) of the Successor? Yes.
The routes Advertised Distance is 409600, the FD is 2297856. The route
meets the Feasibility Condition and is placed into the topology table.
It is now a Feasible Successor. It can be used if the Successor fails, but
by default, it will not participate in load-sharing. The same can be said for
the two paths to R3s loopback.
Configure the EIGRP network to load-balance over these two possible
paths to each loopback address with the appropriate variance command.
Recall that the variance command is a multiplier; the router will multiply
the Feasible Distance by this value. If a feasible successor has a metric
less than that of this equation, the route will be placed into the EIGRP

routing table and used for load-balancing.


The Feasible Distance in each case is 2297856, and the metric for the
Feasible Successor in each case is 2323456. Since thats barely higher
than the Feasible Distance, a variance value of 2 will do the job.
Configure variance 2 under the EIGRP process on R1, clear the routing
table with clear ip route *, and run show ip route eigrp.
Before using variance to configure unequal-cost load-sharing:
R1#show ip route eigrp
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/2297856] via 172.12.123.2, 00:12:53, Serial0
3.0.0.0/24 is subnetted, 1 subnets
D 3.3.3.0 [90/2297856] via 172.12.123.3, 00:12:53, Serial0
R1#conf t
R1(config)#router eigrp 100
R1(config-router)#variance 2
R1#clear ip route *
R1#show ip route eigrp
2.0.0.0/24 is subnetted, 1 subnets
D 2.2.2.0 [90/2297856] via 172.12.123.2, 00:00:04, Serial0/0
[90/2323456] via 172.12.123.3, 00:00:04, Serial0/0
3.0.0.0/24 is subnetted, 1 subnets
D 3.3.3.0 [90/2297856] via 172.12.123.3, 00:00:04, Serial0/0
[90/2323456] via 172.12.123.2, 00:00:04, Serial0/0
172.23.0.0/27 is subnetted, 1 subnets
D 172.23.23.0 [90/2195456] via 172.12.123.3, 00:00:04, Serial0/0
[90/2195456] via 172.12.123.2, 00:00:04, Serial0/0

The variance command allows any feasible successor with a metric of


less than (2297856 x 2) to participate in load-balancing. R1 can now use
both routes to R2s and R3s loopback network.
After the variance command:
R1#show ip route eigrp
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/2297856] via 172.12.123.2,
[90/2323456] via 172.12.123.3,
3.0.0.0/24 is subnetted, 1 subnets
D 3.3.3.0 [90/2297856] via 172.12.123.3,
[90/2323456] via 172.12.123.2,

00:00:03, Serial0
00:00:03, Serial0
00:00:05, Serial0
00:00:05, Serial0

Back To Index

Copyright 2011 The Bryant Advantage. All Rights Reserved.

You might also like