You are on page 1of 46

2015

DISEO DE UNA RED


LAN

PROYECTO FINAL DE TELEMATICA


JOSE LUIS BASTIDAS
SAUL MAZA
JUAN CARLOS SILVA

INFORME
Objetivos:
Aplicar los conocimientos adquiridos en la teora Telemtica y el Laboratorio de
Telemtica I, con el objeto de desarrollar un proyecto real, en los que se incluyan
conceptos de conmutacin, enrutamiento y diseo de redes LAN.
Este proyecto final contiene las siguientes actividades:
Disear y documentar un esquema de direccionamiento y enrutamiento, de
acuerdo al diagrama y la descripcin correspondiente.
Efectuar la configuracin de los routers, switches y estaciones de trabajo.
Configurar enrutamiento esttico entre routers ISPs
Crear y activar VLANs.
Crear y activar listas de control de acceso en los routers e interfaces apropiadas.
Diagnosticar fallas y comprobar todas las interconexiones y listas de control de
acceso.
Proveer de documentacin detallada, tal como se indica en las tareas que se
deben entregar.

DESCRIPCIN DEL PROYECTO


La informacin proporcionada es la topologa mostrada en la siguiente figura y el
direccionamiento se dio a partir de las direcciones del mismo grfico

Esquema de direccionamineto:IPV4
Protocolo de enrutamiento: EIGRP SA=200

USO DEL PROTOCOLO DE ENRUTAMIENTO EIGRP


Tiene su raz en el IGRP, y fue desarrollado para solucionar el conteo de saltos limitados
de RIP V1.
Es un protocolo de vector distancia, que usa para su funcionamiento mtricas tales
como: ancho de banda, retraso, confiabilidad y carga.

El formato de los mensajes EIGRP, posee un encabezado, con una porcin para la
trama de enlace de datos, con la direccin MAC de origen y de destino. Su encabezado
IP, contiene la direccin IP de origen y la de destino. Adems, un aspecto importante es
la inclusin de un nmero de sistema autnomo que le permite a la red diferenciarse de
otras.
En general la forma del mensaje EIGRP tiene la siguiente forma:

El encabezado de paquete EIGRP contiene:


Campo de cdigo de operacin
Nmero de sistema autnomo

Los parmetros EIGRP


contienen:
Pesos
Tiempo en hold

TLV: IP interna contiene:


Campo de mtrica
Campo de mscara
subred
Campo de destino

de

TLV: IP externa contiene:


Los campos usados cuando las rutas externas se importan al proceso
de enrutamiento de EIGRP

Se
plantea
la
necesidad de un protocolo de transporte confiable (RTP). Cuya funcin es la de
transmitir y recibir paquetes EIGRP.
El envo confiable requiere el reconocimiento del destino.
EL envo no confiable no requiere el reconocimiento del destino.
Cuenta con 5 tipos de paquetes, que le permiten tener la informacin de la topologa
total de la red. Estos son:
Paquete de saludo: Se usan para detectar vecinos y formar adyacencias con ellos
Paquete de actualizacin: Se usan para difundir la informacin de enrutamiento
Paquete de reconocimiento: Se usan para reconocer la recepcin de los paquetes de
actualizacin, consulta y respuesta
Paquete de consulta, paquete de respuesta: DUAL los usa para la bsqueda de redes.
Paquetes de consulta
- Pueden usar:
Unicast
Multicast
Paquetes de respuesta
- Usan solamente:
Unicast
Implementada en base al algoritmo de actualizacin difusa (DUAL), que proporciona
convergencia rpida mediante el mantenimiento de una lista de rutas de respaldo sin
bucles.
Mencionadas las generalidades correspondientes a nuestro protocolo de enrutamiento
asignado, vamos a realizar un anlisis del funcionamiento del EIGRP en nuestra
infraestructura de red.

Con la presentacin de la topologa, se facilitar de alguna manera el proceso de


descripcin del funcionamiento del protocolo de enrutamiento.
Se realizara el direccionamiento mediante VLSM que se presenta a continuacin
REGION 1
B1-R1: 32000 HOST
B2-R1: 16000 HOST
B3-R1: 8000 HOST
REGION 2
B1-R2: 4000 HOST
B2-R2: 2000 HOST
B3-R1: 1000 HOST
ENLASE SERIAL B1-R1 CON R1: 2 HOST
ENLASE SERIAL B2-R1 CON R1: 2 HOST
ENLASE SERIAL B3-R1 CON R1: 2 HOST
ENLASE SERIAL B1-R2 CON R1: 2 HOST
ENLASE SERIAL B2-R2 CON R1: 2 HOST
ENLASE SERIAL B3-R2 CON R1: 2 HOST
ENLASE SERIAL R1 CON ISP R1: 2 HOST
ENLASE SERIAL R2 CON ISP R2: 2 HOST
ENLASE SERIAL ISP R1 CON ISP R2: 2 HOST

ASIGANACIN DE DIRECCIONES IP
Tomando en cuenta todos los host que se requieren para el dimensionamiento de la
red se procedi a hacer los respectivos clculos y los resultados se muestran en las
siguientes tablas

DIRECCIONAMIENTO
DISPOSITIVO

INTERFAZ

DIRECCION IP

R1

Se 0/1
Se 0/2
Se 0/3
Se 0/0
Se 0/0
Fa 0/0
Fa 0/1
Fa 1/0
Fa 1/1
Se 0/0
Fa 0/0
Fa 0/1
Fa 1/0
Fa 1/1
Se 0/0
Fa 0/0
Fa 0/1
Fa 1/0
Fa 1/1
Se 0/1
Se 0/0
Fa 0/0

10.1.224.1
10.1.224.5
10.1.224.9
209.165.201.2
10.1.224.2
10.1.0.1
10.1.32.1
10.1.64.1
10.1.96.1
10.1.224.6
10.1.128.1
10.1.144.1
10.1.160.1
10.1.176.1
10.1.224.10
10.1.192.1
10.1.200.1
10.1.208.1
10.1.216.1
209.165.201.1
209.165.201.5
209.165.200.225

B1-R1

B2-R1

B3-R1

ISP-R1

DISPOSITIVO INTERFAZ

DIRECCION IP

R2

209.165.201.9
172.20.28.1
172.20.28.5
172.20.28.9
172.20.28.2
172.20.0.1
172.20.4.1
172.20.8.1
172.20.12.1
172.20.28.6
172.20.16.1
172.20.18.1
171.20.20.1
172.20.22.1
172.20.28.10
172.20.24.1
172.20.25.1
172.20.26.1
172.20.27.1
209.165.201.10
209.165.201.6
209.165.200.229

B1-R2

B2-R2

B3-R2

ISP-R2

Se 0/0
Se 0/1
Se 1/0
Se 1/1
Se 0/0
Fa 0/0
Fa 0/1
Fa 1/0
Fa 1/1
Se 0/0
Fa 0/0
Fa 0/1
Fa 1/0
Fa 1/1
Se 0/0
Fa 0/0
Fa 0/1
Fa 1/0
Fa 1/1
Se 0/1
Se 0/0
Fa 0/0

MASCARA
SUBRED
255.255.255.252
255.255.255.252
255.255.255.252
255.255.255.252
255.255.255.252
255.255.224.0/19
255.255.224.0/19
255.255.224.0/19
255.255.224.0/19
255.255.255.252
255.255.240.0/20
255.255.240.0/20
255.255.240.0/20
255.255.240.0/20
255.255.255.252
255.255.248.0/21
255.255.248.0/21
255.255.248.0/21
255.255.248.0/21
255.255.255.252
255.255.255.252
255.255.255.252

MASCARA
SUBRED
255.255.255.252
255.255.255.252
255.255.255.252
255.255.255.252
255.255.255.252/30
255.255.252.0/22
255.255.252.0/22
255.255.252.0/22
255.255.252.0/22
255.255.255.252/30
255.255.254.0/23
255.255.254.0/23
255.255.254.0/23
255.255.254.0/23
255.255.255.252/30
255.255.255.0/24
255.255.255.0/24
255.255.255.0/24
255.255.255.0/24
255.255.255.252/30
255.255.255.252/30
255.255.255.252/30

PREFIJO
30
30
30
30
30
22
22
22
22
30
23
23
23
23
30
24
24
24
24
30
30
30

ROUTER
B1-R1 Fa 0/0

NUMERO DE DIRECCION
SUBRED
SUBRED
0
10.1.0.0

DE MASCARA
SUBRED
255.255.224.0/19

B1-R1 Fa 0/1

10.1.32.0

255.255.224.0/19

B1-R1 Fa 1/0

10.1.64.0

255.255.224.0/19

B1-R1 Fa 1/1

10.1.96.0

255.255.224.0/19

ROUTER
B2-R1 Fa 0/0

NUMERO DE DIRECCION
SUBRED
SUBRED
0
10.1.128.0

B2-R1 Fa 0/1

10.1.144.0

255.255.240.0/20

B2-R1 Fa 1/0

10.1.160.0

255.255.240.0/20

B2-R1 Fa 1/1

10.1.176.0

255.255.240.0/20

ROUTER
B3-R1 Fa 0/0

NUMERO DE DIRECCION
SUBRED
SUBRED
0
10.1.192.0

B3-R1 Fa 0/1

10.1.200.0

255.255.248.0/21

B3-R1 Fa 1/0

10.1.208.0

255.255.248.0/21

B3-R1 Fa 1/1

10.1.216.0

255.255.248.0/21

ROUTER
B1-R2 Fa 0/0

NUMERO DE DIRECCION
SUBRED
SUBRED
0
172.20.0.0

B1-R2 Fa 0/1

172.20.4.0

255.255.252.0/22

B1-R2 Fa 1/0

172.20.8.0

255.255.252.0/22

B1-R2 Fa 1/1

172.20.12.0

255.255.252.0/22

ROUTER
B2-R2 Fa 0/0

NUMERO DE DIRECCION
SUBRED
SUBRED
0
172.20.16.0

B2-R2 Fa 0/1

172.20.18.0

255.255.254.0/23

B2-R2 Fa 1/0

172.20.20.0

255.255.254.0/23

B2-R2 Fa 1/1

172.20.22.0

255.255.254.0/23

DE MASCARA
SUBRED
255.255.240.0/20

DE MASCARA
SUBRED
255.255.248.0/21

DE MASCARA
SUBRED
255.255.252.0/22

DE MASCARA
SUBRED
255.255.254.0/23

DE

DE

DE

DE

DE

ROUTER
B3-R2 Fa 0/0

NUMERO DE DIRECCION
SUBRED
SUBRED
0
172.20.24.0

DE MASCARA
SUBRED
255.255.255.0/24

B3-R2 Fa 0/1

172.20.25.0

255.255.255.0/24

B3-R2 Fa 1/0

172.20.26.0

255.255.255.0/24

B3-R2 Fa 1/1

172.20.27.0

255.255.255.0/24

DE

VLANs y Listas de control de acceso


En la red LAN de cada ciudad, se deben configurar 3 VLANs, las cuales son las
siguientes:

VLAN Jefes (VLAN 40)


VLAN Tcnicos (VLAN 50)
VLAN Secretarias (VLAN 60)

La cantidad de puertos que se asignan a cada VLAN deben ser por lo menos 3.

CONFIGURACIN DE LAS INTERFACES VLAN


Se debe realizar la asignacin de cantidad de host considerando la existencia en un
mayor nmero de secretarias, y una menor existencia de tcnicos y jefes.
Se debe considerar la cantidad de host que se tiene en cada una de las redes LAN que
se utilizara para la asignacin de host a cada una de las VLAN.
VLAN
SWITCH
S1

NOMBRE
VLAN
JEFES

NUMERO
VLAN
40

DIRECCION
IP
10.1.192.1

DIRECCION
SUBRED
10.1.192.0/23

INTERFAZ
B3-R1
Fa 0/0.40

S1

TECNICOS

50

10.1.194.1

10.1.192.0/23

Fa 0/0.50

S1

SECRETARIAS 60

10.1.196.1

10.1.192.0/23

Fa 0/0.60

SWITCH
S2

NOMBRE
VLAN
JEFES

NUMERO
VLAN
40

DIRECCION
IP
10.1.200.1

DIRECCION
SUBRED
10.1.200.0/23

INTERFAZ
B3-R1
Fa 0/1.40

S2

TECNICOS

50

10.1.202.1

10.1.200.0/23

Fa 0/1.50

S2

SECRETARIAS 60

10.1.204.1

10.1.200.0/23

Fa 0/1.60

SWITCH
S3

NOMBRE
VLAN
JEFES

NUMERO
VLAN
40

DIRECCION
IP
10.1.208.1

DIRECCION
SUBRED
10.1.192.0/23

INTERFAZ
B3-R1
Fa 1/0.40

S3

TECNICOS

50

10.1.210.1

10.1.192.0/23

Fa 1/0.50

S3

SECRETARIAS 60

10.1.212.1

10.1.192.0/23

Fa 1/0.60

SWITCH
S4

NOMBRE
VLAN
JEFES

NUMERO
VLAN
40

DIRECCION
IP
10.1.216.1

DIRECCION
SUBRED
10.1.216.0/23

INTERFAZ
B3-R1
Fa 1/1.40

S4

TECNICOS

50

10.1.218.1

10.1.218.0/23

Fa 1/1.50

S4

SECRETARIAS 60

10.1.220.1

10.1.220.0/23

Fa 1/1.60

SWITCH
S1B3R2

NOMBRE
VLAN
JEFES

NUMERO
VLAN
40

DIRECCION IP DIRECCION
SUBRED
172.20.24.1
172.20.24.0/24

INTERFAZ
B3-R2
Fa 0/0.40

S1B3R2

TECNICOS

50

172.20.25.1

172.20.25.0/25

Fa 0/0.50

S1B3R2

SECRETARIAS 60

172.20.25.129

172.20.25.128/25 Fa 0/0.60

SWITCH
S2B3R2

NOMBRE
VLAN
JEFES

NUMERO
VLAN
40

DIRECCION IP DIRECCION
SUBRED
172.20.25.1
172.20.25.0/24

INTERFAZ
B3-R2
Fa 0/1.40

S2B3R2

TECNICOS

50

172.20.26.1

172.20.26.0/25

Fa 0/1.50

S2B3R2

SECRETARIAS 60

172.20.26.129

172.20.26.128/25 Fa 0/1.60

SWITCH
S3B3R2

NOMBRE
VLAN
JEFES

NUMERO
VLAN
40

DIRECCION IP DIRECCION
SUBRED
172.20.26.1
172.20.26.0/24

INTERFAZ
B3-R2
Fa 1/0.40

S3B3R2

TECNICOS

50

172.20.27.1

172.20.27.0/25

Fa 1/0.50

S3B3R2

SECRETARIAS 60

172.20.27.129

172.20.27.128/25 Fa 1/0.60

SWITCH
S4B3R2

NOMBRE
VLAN
JEFES

NUMERO
VLAN
40

DIRECCION IP DIRECCION
SUBRED
172.20.27.1
172.20.27.0/24

INTERFAZ
B3-R2
Fa 1/1.40

S4B3R2

TECNICOS

50

172.20.28.1

172.20.28.0/25

Fa 1/1.50

S4B3R2

SECRETARIAS 60

172.20.28.129

172.20.28.128/25 Fa 1/1.60

Aplicacin del comando show VLAN


En lo que tiene que ver con los switches y su configuracin, presentamos la
informacin de las vlans.
Una VLAN es una subred IP separada de manera lgica. Las VLAN permiten que
redes de IP y subredes mltiples existan en la misma red conmutada. Para que las
computadoras se comuniquen en la misma VLAN, cada una debe tener una direccin
IP y una mscara de subred consistente con esa VLAN.

En el switch deben darse de alta las VLAN y cada puerto asignarse a la VLAN
correspondiente. Un puerto de switch con una VLAN singular configurada en el mismo
se denomina puerto de acceso.
SW1

En los switches restantes la informacin que arroje el comando ser la misma, de igual
manera, presentamos los resultados.
SW2
El cambio que observamos con respecto al SW1, es la asignacin de los puestos a cada
vlan.

SW3

SW4

Todas las direcciones han sido codificadas con la letra C, la cual las identifica como
rutas directamente conectadas, las misma que corresponden a las subredes que llegan
al router a travs de la interfaz fastethernet 0/0.
10.1.192.0/23: vlan Secretarias.
10.1.194.0/23: vlan Tcnicos.
10.1.196.0/23: vlan Jefes.

CONFIGURACIN DE LAS INTERFACES VLAN


La configuracin de las interfaces VLAN se la realiza a travs de comandos que nos
permiten crear las mismas, asignarles un nombre y posteriormente se debe asignar los
puertos del switch a cada una de las VLAN que fueron creadas. Todos estos comandos
y configuracin se realizan en CLI de cada uno de los switches para las distintas
ciudades QUITO, GUAYAQUIL y CUENCA.
Un aspecto importante que se debe tomar en cuenta es el modo en que van a estar
configurados los puertos del switch. Como se ha estudiado en la materia cada puerto
del switch que est conectado a un computador debe estar configurado en modo acceso
para permitir el ingreso y salida de informacin desde y hacia cada computador;
mientras que el puerto del switch que se encuentra directamente conectado al router
debe estar configurado en un modo troncal, puesto que por esta interfaz ingresarn
varias rutas.
Para iniciar la configuracin ingresamos al CLI del switch y a continuacin se detallan
los comando utilizados en cada una de las LAN.

ASIGNACIN DE DIRECCIONES IP A LOS HOST EN CADA VLAN


Una vez concluida la etapa de configuracin de las VLAN en cada switch procedemos
a la asignacin de las direcciones IP a cada una de las computadoras pertenecientes a
las VLAN creadas, como se muestra a continuacin. El Gateway para cada computador
va a ser la direccin IP que se ha configurado como direccin IP de la interfaz VLAN a
la que pertenezca dicho computador.

ASIGNACION DE DIRECIONES IP A LOS HOST EN CADA VLAN


SWITCH S1
VLAN 40 (JEFES)

VLAN 50 (TECNICOS)

VLAN 60

SWITCH S2
VLAN 40 (JEFES)

VLAN 50 (TECNICOS)

VLAN 60

SWITCH S3
VLAN 40 (JEFES)

VLAN 50 (TECNICOS)

VLAN 60

SWITCH S4
VLAN 40 (JEFES)

VLAN 50 (TECNICOS)

VLAN 60

VERIFICACIN:
Lo que se realizar es la inspeccin de las tablas de las VLANs creadas, as como
tambin la asignacin de los puertos de switch a cada una de las VLAN y finalmente n
este punto de la configuracin podemos verificar la conectividad.
SWITCH-1:
Haciendo un show vlan brief para verificar la creacin de las interfaces:

Se puede verificar en la tabla que estn creadas las VLAN (40, 50, 60), para cada uno
de los grupos de trabajo de la empresa como son los jefes, tcnicos, secretarias; en la
columna de la parte derecha como estn asignados los puertos del switch, por ejemplo

la VLAN 40 de jefes tiene asignados los puertos Fa0/1, Fa0/2, Fa0/3, y as


sucesivamente las VLANs restantes con su respectiva asignacin de puertos.
SWITCH-2:
Haciendo un show vlan brief para verificar la creacin de las interfaces:

SWITCH-3:
Haciendo un show vlan brief para verificar la creacin de las interfaces:

El switch configurado tiene creadas las VLAN requeridas y la asignacin correcta de los
puertos del switch de la misma manera que los otros dos switches; por ejemplo en la
VLAN 50 de tcnicos se tiene asignados los puertos: Fa0/10, Fa0/11, Fa0/12, as
sucesivamente se continua con la asignacin como se puede ver en la tabla.
SWITCH-4:
Haciendo un show vlan brief para verificar la creacin de las interfaces:

PRUEBAS DE CONECTIVIDAD
Finalmente se harn las pruebas de conectividad, esto lo hacemos con un ping para
verificar la existencia de comunicacin de manera independiente, VLAN con VLAN de
una red a otra.
Se va a verificar y mostrar que existe conectividad:

Se prueba que existe conectividad entre computadoras que estn en la misma VLAN.
Como se puede observar al realizar un ping, la conexin es exitosa.
Una vez probada esta conectividad se va a realizar la configuracin del enrutamiento
entre VLANs para poder conseguir una conectividad total en toda la topologa. Entonces:

CONFIGURACIN DE ACLs
LISTAS DE ACCESO
Una Lista de Control de Acceso o ACL es un concepto de seguridad informtica usado
para fomentar la separacin de privilegios. Es una forma de determinar los permisos de
acceso apropiados a un determinado objeto, dependiendo de ciertos aspectos del
proceso que hace el pedido.
Las ACLs permiten controlar el flujo del trfico en equipos de redes, tales como routers
y switches. Su principal objetivo es filtrar trfico, permitiendo o denegando el trfico de
red de acuerdo a alguna condicin. Sin embargo, tambin tienen usos adicionales. Las
listas de control de acceso implementada en cada uno de los router se presentan a
continuacin.

Como se observa, la definicin de las restricciones o permisos se hacen en base a


consideraciones especficas primero y luego se toma en cuenta las condiciones
generales.
De acuerdo a nuestras necesidades, se han implementado una mayora de listas de
acceso extendida, ya que esta nos permite tener un mayor control del trfico en la red.

As mismo vemos en la capturas, que las definiciones de las listas se definen por ejemplo
para trafico tipo tcp, icmp y echo (para realizar ping).

Aplicacin del comando show cdp neighbor


El cisco discoveryprotocol (protocolo CDP) se utiliza para obtener informacin de router
y switches que estn conectados localmente.

El CDP es un protocolo propietario de Cisco, destinado al descubrimiento de vecinos y


es independiente de los medios y del protocolo de enrutamiento. Aunque el CDP
solamente mostrar informacin sobre los vecinos conectados de forma directa, este
constituye una herramienta de gran utilidad.

El Protocolo CDP es un protocolo de Capa 2 que conecta los medios fsicos inferiores
con

los

protocolos

de

red

de

las

capas

superiores,

La lectura del comando show cdpneighbors incluyen la siguiente informacin:


Identificador del dispositivo
Interfaz local
Tiempo de espera
Capacidad
Plataforma
Identificador del puerto

A continuacin, presentamos las tablas relacionadas a cada uno de los routers de la


topologa.
ROUTER R1

Como se observa, tenemos informacin muy valiosa, primero nos indica los dispositivos
conectados directamente (B1-R1, B2-R1, B3-R1), nos presenta las interfaces locales

(S0/1, S0/2, y S0/3), el tiempo de espera (146), la capacidad (Router), la plataforma


utilizada (C2600) y por ltimo la identificacin del puerto (S0/0).
ROUTER B1-R1

Como es de suponerse, la informacin variar de un router a otro, por la posicin y la


funcin que cumple dentro de la red.
ROUTER B2-R1

ROUTER B3-R

ISP-R1

ISP-R2

Router R2

B1-R2

B2-R2

B3-R2

Aplicacin del comando show ip route


Este es el comando que permite visualizar la tabla de enrutamiento del dispositivo.
La tabla de enrutamiento es la lista de todas las redes que el dispositivo puede alcanzar,
su mtrica, y la forma en que accede a ellas. Si todo funciona adecudadamente, cada
dispositivo debiera tener al menos una ruta a cada red que potencialmente sea destino
de trfico.

ROUTER R1

ROUTER R2

Aplicacin del comando show ip protocol


Este comando muestra un nmero de cosas dependiendo de qu protocolo de
enrutamiento est usando.
Timers (para RIP e IGRP solamente)
Mtricas
Origen de Enrutamiento (de cules routers est recibiendo actualizaciones el router
local)
Redes siendo anunciadas por el router local
Informacin de routers utilizados
A diferencia de show ip route, show ip protocols vara dependiendo de los protocolos de
enrutamiento que est usando.
Router R1

1. Comando show ip protocol: Nos muestra los parmetros y estado actual del
proceso de protocolo de enrutamiento activo.
2. y 4. Nos muestra el nmero de sistema autnomo (AS). Es esencial que todos
los routers en el dominio de enrutamiento EIGRP deben usar el mismo nmero
de identificacin de proceso.
3. EIGRP usa los siguientes valores en su mtrica compuesta (ancho de banda,
retraso, confiabilidad y carga). Dada esta mtrica compuesta, se da la frmula
que usa valores de K, desde K1 hasta K5.
Donde K1 y K3 =1, y los dems valores con K=0.
Dicha frmula por defecto:
mtrica = [K1 * ancho de banda + K3*retraso].
Y una frmula completa mediante:
mtrica= [k1*ancho de banda + (K2*ancho de banda)/(256-carga)+K3*retraso]*
[k5/(confiabilidad +k4)].
5. Nos entrega informacin de las redes directamente conectadas al router.
6. Listas de todas las fuentes de enrutamiento del software Cisco IOS se utiliza para
construir
su tabla de enrutamiento. Para cada fuente, ver aparecer el siguiente: direccin IP,
la
distancia administrativa, hora de la ltima actualizacin fue recibida de esta fuente.
Distancias internas y externas del router:
Distancia interna es el grado de preferencia a las rutas internas EIGRP.
Distancia externa es el grado de preferencia a las rutas externas EIGRP.

ROUTER 2

Router ISP-R1

Aplicacin del comando show ip interface


Tan importantes como show interfaces son show ip interface y show ip interface brief.
Este comando provee una cantidad muy importante de informacin sobre la
configuracin y estado del protocolo IP y sus servicios asociados. Show ip interface brief

permite tener una mirada rpida del estado de cada interfaz del dispositivo incluyendo
las direcciones IP, el estado de capa 2 y el estado de capa 3.

Aplicacin del comando show ip eigrp interface

1. Indica la interfaz sobre la que EIGRP est configurada, en nuestro caso,


las interfaces seriales S0/0, S0/1, S0/2 y s0/3.
2. Nmero de vecinos EIGRP directamente conectados.
3. Nmero de paquetes que permanecen en las colas de transmisin fiable
y confiable.
4. Media intervalo de tiempo de ida y vuelta (SRTT, smooth round trip time)
sin problemas (en milisegundos).
5. Tiempo de estimulacin para determinar cuando los paquetes EIGRP
deben ser enviados a la interfaz (paquetes no fiables y confiables).
6. Nmero mximo de segundos en los que el router enviar paquetes
EIGRP multicast.
Nmero de rutas en los paquetes en la cola de transmisin en espera de ser enviado.

Aplicacin del comando show version


Para cumplir con este objetivo, utilizaremos el comando show versin.
Debido a que el modelo de los router en la red es de la serie c2600, solo presentamos
la captura de uno de ellos.
Este comando muestra informacin sobre la versin del

IOS Cisco que se est

ejecutando en un dispositivo de enrutamiento, el monitoreo de la ROM y versiones de


software del bootflash e informacin acerca de la configuracin de hardware, incluyendo
la cantidad de memoria del sistema.

Informacin de switches utilizado


De la misma manera, al igual que en el router, utilizamos el comando show versin.
Nos mostrar la misma informacin que en el router, guardando las proporciones de
cada uno de los dispositivos.

Aplicacin del comando show VLAN


En lo que tiene que ver con los switches y su configuracin, presentamos la informacin de las
vlans.
Una VLAN es una subred IP separada de manera lgica. Las VLAN permiten que redes de IP y
subredes mltiples existan en la misma red conmutada. Para que las computadoras se
comuniquen en la misma VLAN, cada una debe tener una direccin IP y una mscara de subred
consistente con esa VLAN.
En el switch deben darse de alta las VLAN y cada puerto asignarse a la VLAN correspondiente.
Un puerto de switch con una VLAN singular configurada en el mismo se denomina puerto de
acceso.

SW1

En los switches restantes la informacin que arroje el comando ser la misma, de igual
manera, presentamos los resultados.
SW2
El cambio que observamos con respecto al SW1, es la asignacin de los puestos a cada
vlan.

SW3

SW4

Interfaces troncales
Como se mencion, con el comando anterior, verificamos la asignacin de puertos de
acceso a cada una de las vlans y ahora para conocer el estado de los puertos troncales,
utilizaremos el comando, show interfaces trunk.
Un enlace troncal es un enlace punto a punto entre dos dispositivos de red que lleva
ms de una VLAN. Un enlace troncal de VLAN le permite extender las VLAN a travs
de toda una red. Cicso admite IEEE 802.1Q para la coordinacin de enlaces troncales
en interfaces Fast Ethernet y Gigabit Ethernet
SW1

SW2

SW3

SW4

IMPLEMENTACIN COMANDO STARTUP-CONFIG


COMANDO startup-config
B1R1

B1-R1#show startup-config
Using 1117 bytes
!
version 12.2
no service timestamps log datetime
msec
no service timestamps debug datetime
msec
no service password-encryption
!
hostname B1-R1
enable secret 5
$1$mERr$fApKswZezGuFJlqlUx7NR/
enable password Cisco
no ip cef
no ipv6 cef
interface FastEthernet0/0
ip address 10.1.0.1 255.255.224.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.32.1 255.255.224.0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.224.2 255.255.255.252
clock rate 2000000
!
interface Serial0/1
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet1/0
ip address 10.1.64.1 255.255.224.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 10.1.96.1 255.255.224.0
duplex auto
speed auto
!
router eigrp 200

network 10.1.224.0 0.0.0.3


network 10.1.0.0 0.0.31.255
network 10.1.32.0 0.0.31.255
network 10.1.64.0 0.0.31.255
network 10.1.96.0 0.0.31.255
no auto-summary
!
ip classless
!
ip flow-export version 9
!
banner motd ^CGR5^C
!
line con 0
!
line aux 0
!
line vty 0 4
password Cisco
login
!
end

B1-R1#
B2R1
B2-R1#sh startup-config
Using 1127 bytes
!
version 12.2
no service timestamps log datetime
msec
no service timestamps debug datetime
msec
no service password-encryption
!
hostname B2-R1
!
enable secret 5
$1$mERr$fApKswZezGuFJlqlUx7NR/
enable password Cisco
!
no ip cef
no ipv6 cef
!
!
interface FastEthernet0/0
ip address 10.1.128.1 255.255.240.0

duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.144.1 255.255.240.0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.224.6 255.255.255.252
clock rate 2000000
!
interface Serial0/1
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet1/0
ip address 10.1.160.1 255.255.240.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 10.1.176.1 255.255.240.0
duplex auto
speed auto
!
router eigrp 200
network 10.1.224.4 0.0.0.3
network 10.1.128.0 0.0.15.255
network 10.1.144.0 0.0.15.255
network 10.1.160.0 0.0.15.255
network 10.1.176.0 0.0.15.255
no auto-summary
!
ip classless
!
ip flow-export version 9
!
banner motd ^CGR5^C
!
line con 0
!
line aux 0
!
line vty 0 4
password Cisco
login
!
end

B2-R1#
B3-R1
B3-R1#sh startup-config
Using 2380 bytes
!
version 12.2
no service timestamps log datetime
msec
no service timestamps debug datetime
msec
no service password-encryption
!
hostname B3-R1
!
enable secret 5
$1$mERr$fApKswZezGuFJlqlUx7NR/
enable password Cisco
!
no ip cef
no ipv6 cef
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.40
encapsulation dot1Q 40
ip address 10.1.192.1 255.255.254.0
!
interface FastEthernet0/0.50
encapsulation dot1Q 50
ip address 10.1.194.1 255.255.254.0
!
interface FastEthernet0/0.60
encapsulation dot1Q 60
ip address 10.1.196.1 255.255.254.0
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.40
encapsulation dot1Q 40
ip address 10.1.200.1 255.255.254.0
!
interface FastEthernet0/1.50

encapsulation dot1Q 50
ip address 10.1.202.1 255.255.254.0
!
interface FastEthernet0/1.60
encapsulation dot1Q 60
ip address 10.1.204.1 255.255.254.0
!
interface Serial0/0
ip address 10.1.224.10 255.255.255.252
clock rate 2000000
!
interface Serial0/1
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
!
interface FastEthernet1/0.40
encapsulation dot1Q 40
ip address 10.1.208.1 255.255.254.0
!
interface FastEthernet1/0.50
encapsulation dot1Q 50
ip address 10.1.210.1 255.255.254.0
!
interface FastEthernet1/0.60
encapsulation dot1Q 60
ip address 10.1.212.1 255.255.254.0
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
!
interface FastEthernet1/1.40
encapsulation dot1Q 40
ip address 10.1.216.1 255.255.254.0
!
interface FastEthernet1/1.50
encapsulation dot1Q 50
ip address 10.1.218.1 255.255.254.0
!
interface FastEthernet1/1.60
encapsulation dot1Q 60
ip address 10.1.220.1 255.255.254.0
!

router eigrp 200


network 10.1.192.0 0.0.1.255
network 10.1.196.0 0.0.1.255
network 10.1.194.0 0.0.1.255
network 10.1.224.8 0.0.0.3
network 10.1.200.0 0.0.1.255
network 10.1.202.0 0.0.1.255
network 10.1.204.0 0.0.1.255
network 10.1.208.0 0.0.1.255
network 10.1.210.0 0.0.1.255
network 10.1.212.0 0.0.1.255
network 10.1.216.0 0.0.1.255
network 10.1.218.0 0.0.1.255
network 10.1.220.0 0.0.1.255
no auto-summary
!
ip classless
!
ip flow-export version 9
!
banner motd ^CGR5^C
!
line con 0
!
line aux 0
!
line vty 0 4
password Cisco
login
end
B3-R1#

R1
R1#sh startup-config
Using 1332 bytes
!
version 12.2
no service timestamps log datetime
msec
no service timestamps debug datetime
msec
no service password-encryption
!
hostname R1
!
enable secret 5
$1$mERr$fApKswZezGuFJlqlUx7NR/

enable password Cisco


!
no ip cef
no ipv6 cef
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0
ip address 209.165.201.2
255.255.255.252
clock rate 64000
!
interface Serial0/1
ip address 10.1.224.1 255.255.255.252
clock rate 64000
!
interface Serial0/2
ip address 10.1.224.5 255.255.255.252
clock rate 64000
!
interface Serial0/3
ip address 10.1.224.9 255.255.255.252
ip access-group 101 in
clock rate 64000
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
shutdown
!
router eigrp 200
network 209.165.201.0 0.0.0.3
network 10.1.224.0 0.0.0.3

network 10.1.224.4 0.0.0.3


network 10.1.224.8 0.0.0.3
no auto-summary
!
ip classless
!
ip flow-export version 9
!
access-list 101 deny tcp 10.1.196.0
0.0.1.255 any eq telnet
access-list 101 permit ip any any
!
banner motd ^CGR5^C
!
line con 0
!
line aux 0
!
line vty 0 4
password Cisco
login
!
end

R1#
ISP-R1
ISP-R1#sh startup-con
ISP-R1#sh startup-config
Using 1049 bytes
!
version 12.2
no service timestamps log datetime
msec
no service timestamps debug datetime
msec
no service password-encryption
!
hostname ISP-R1
!
enable secret 5
$1$mERr$fApKswZezGuFJlqlUx7NR/
enable password Cisco
!
no ip cef
no ipv6 cef
!
interface FastEthernet0/0

ip address 209.165.200.225
255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0
ip address 209.165.201.5
255.255.255.252
clock rate 64000
!
interface Serial0/1
ip address 209.165.201.1
255.255.255.252
clock rate 64000
!
interface Serial0/2
no ip address
clock rate 2000000
shutdown
!
interface Serial0/3
no ip address
clock rate 2000000
shutdown
!
router eigrp 200
network 209.165.201.0 0.0.0.3
network 209.165.201.4 0.0.0.3
network 209.165.200.224 0.0.0.3
no auto-summary
!
ip classless
!
ip flow-export version 9
!
no cdp run
!
banner motd ^CGR5^C
!
line con 0
!
line aux 0
!
line vty 0 4

password Cisco
login
!
end

ISP-R1#
ISP-R2
ISP-R2#sh startup-config
Using 1052 bytes
!
version 12.2
no service timestamps log datetime
msec
no service timestamps debug datetime
msec
no service password-encryption
!
hostname ISP-R2
!
enable secret 5
$1$mERr$fApKswZezGuFJlqlUx7NR/
enable password Cisco
!
no ip cef
no ipv6 cef
!
!
interface FastEthernet0/0
ip address 209.165.200.229
255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0
ip address 209.165.201.6
255.255.255.252
clock rate 64000
!
interface Serial0/1
ip address 209.165.201.10
255.255.255.252
clock rate 64000

!
interface Serial0/2
no ip address
clock rate 2000000
shutdown
!
interface Serial0/3
no ip address
clock rate 2000000
shutdown
!
router eigrp 200
network 209.165.201.8 0.0.0.3
network 209.165.201.4 0.0.0.3
network 209.165.200.228 0.0.0.3
no auto-summary
!
ip classless
!
ip flow-export version 9
!
no cdp run
!
banner motd ^CGR5^C
!
line con 0
!
line aux 0
!
line vty 0 4
password Cisco
login
!
end
ISP-R2#
R2

R2#sh startup-config
Using 1365 bytes
!
version 12.2
no service timestamps log datetime
msec
no service timestamps debug datetime
msec
no service password-encryption
!
hostname R2
!

enable secret 5
$1$mERr$fApKswZezGuFJlqlUx7NR/
enable password Cisco
!
no ip cef
no ipv6 cef
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0
ip address 209.165.201.9
255.255.255.252
clock rate 2000000
!
interface Serial0/1
ip address 172.20.28.1 255.255.255.252
clock rate 64000
!
interface Serial0/2
no ip address
clock rate 2000000
shutdown
!
interface Serial0/3
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
shutdown
!

interface Serial1/0
ip address 172.20.28.5 255.255.255.252
clock rate 64000
!
interface Serial1/1
ip address 172.20.28.9 255.255.255.252
clock rate 64000
!
router eigrp 200
network 209.165.201.8 0.0.0.3
network 172.20.28.0 0.0.0.3
network 172.20.28.4 0.0.0.3
network 172.20.28.8 0.0.0.3
no auto-summary
!
ip classless
!
ip flow-export version 9
!
no cdp run
!
banner motd ^CGR5^C
!
line con 0
!
line aux 0
!
line vty 0 4
password Cisco
login
!
end
R2#
B1R2

B1-R2#sh startup-con
B1-R2#sh startup-config
Using 1073 bytes
!
version 12.2
no service timestamps log datetime
msec
no service timestamps debug datetime
msec
no service password-encryption
!
hostname B1-R2
!

enable secret 5
$1$mERr$fApKswZezGuFJlqlUx7NR/
enable password Cisco
!
no ip cef
no ipv6 cef
!
interface FastEthernet0/0
ip address 172.20.0.1 255.255.252.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.20.4.1 255.255.252.0
duplex auto
speed auto
!
interface Serial0/0
ip address 172.20.28.2 255.255.255.252
clock rate 2000000
!
interface FastEthernet1/0
ip address 172.20.8.1 255.255.252.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 172.20.12.1 255.255.252.0
duplex auto
speed auto
!
router eigrp 200
network 172.20.28.0 0.0.0.3
network 172.20.0.0 0.0.3.255
network 172.20.4.0 0.0.3.255
network 172.20.8.0 0.0.3.255
network 172.20.12.0 0.0.3.255
no auto-summary
!
ip classless
!
ip flow-export version 9
!
no cdp run
!
banner motd ^CGR5^C
!
line con 0
!
line aux 0

!
line vty 0 4
password Cisco
login
!
end
B1-R2#
B2R2

B2-R2#sh startup-config
Using 1079 bytes
!
version 12.2
no service timestamps log datetime
msec
no service timestamps debug datetime
msec
no service password-encryption
!
hostname B2-R2
!
enable secret 5
$1$mERr$fApKswZezGuFJlqlUx7NR/
enable password Cisco
!
no ip cef
no ipv6 cef
!
interface FastEthernet0/0
ip address 172.20.16.1 255.255.254.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.20.18.1 255.255.254.0
duplex auto
speed auto
!
interface Serial0/0
ip address 172.20.28.6 255.255.255.252
clock rate 2000000
!
interface FastEthernet1/0
ip address 172.20.20.1 255.255.254.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 172.20.22.1 255.255.254.0

duplex auto
speed auto
!
router eigrp 200
network 172.20.28.4 0.0.0.3
network 172.20.16.0 0.0.1.255
network 172.20.18.0 0.0.1.255
network 172.20.20.0 0.0.1.255
network 172.20.22.0 0.0.1.255
no auto-summary
!
ip classless
!
ip flow-export version 9
!
no cdp run
!
banner motd ^CGR5^C
!
line con 0
!
line aux 0
!
line vty 0 4
password Cisco
login
!
end
B2-R2#
B3R2

B1-R2#sh startup-config
Using 1073 bytes
!
version 12.2
no service timestamps log datetime
msec
no service timestamps debug datetime
msec
no service password-encryption
!
hostname B1-R2
!
enable secret 5
$1$mERr$fApKswZezGuFJlqlUx7NR/
enable password Cisco
!
no ip cef
no ipv6 cef

!
interface FastEthernet0/0
ip address 172.20.0.1 255.255.252.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.20.4.1 255.255.252.0
duplex auto
speed auto
!
interface Serial0/0
ip address 172.20.28.2 255.255.255.252
clock rate 64000
!
interface FastEthernet1/0
ip address 172.20.8.1 255.255.252.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 172.20.12.1 255.255.252.0
duplex auto
speed auto
!

router eigrp 200


network 172.20.28.0 0.0.0.3
network 172.20.0.0 0.0.3.255
network 172.20.4.0 0.0.3.255
network 172.20.8.0 0.0.3.255
network 172.20.12.0 0.0.3.255
no auto-summary
!
ip classless
!
ip flow-export version 9
!
no cdp run
!
banner motd ^CGR5^C
!
line con 0
!
line aux 0
!
line vty 0 4
password Cisco
login
!
end

CONCLUSIONES Y RECOMENDACIONES
La elaboracin de este proyecto nos ha permitido aplicar todas las habilidades
que hemos ido adquiriendo en el transcurso del semestre.
Para tener un avance adecuado en el trabajo, se dividieron las actividades,
tomando en cuenta los aspectos ms crticos del proyecto.
Sin ninguna duda, uno de los aspectos fundamentales que permitieron terminar
con xito este estudio, fue definir adecuadamente el direccionamiento de la red,
de no haber sido as, una serie de problemas se hubiera acarreado desde el
inicio del proyecto.
Luego de asignar adecuadamente una subred para cada una de las vlans
indicadas, el siguiente paso a seguir, implementar el protocolo de enrutamiento,
se ve simplificado ya que este realizar su trabajo sin ningn inconveniente,
como se plante en el informe.
Ya con una comunicacin total en el sistema, el punto crtico del proyecto vino
dado por la necesidad de agregar un conjunto de ACLs, que permitan tener un
control adecuado de la red y as lograr un manejo eficiente.

Se debe tener claro el tipo de lista que se va a agregar, si esta es estndar o


extendida, para encontrar la ubicacin adecuada dentro de la red, as como
tambin el tipo de trfico que se desea controlar.
En este tipo de proyectos, es primordial el trabajo en equipo, ya que de esta
manera su desarrollo se facilita y la solucin a un problema es fcilmente
encontrado.