You are on page 1of 3

R0:

enable
configure terminal
interface g0/1
ip address 192.168.1.1 255.255.255.128
no shutdown
interface g0/0
ip address 200.10.10.21 255.255.255.252
no shutdown
end
configure terminal
ip nat inside source static 192.168.1.2 205.5.5.1
ip nat inside source static 192.168.1.3 205.5.5.2
interface g0/1
ip nat inside
int g0/0
ip nat outside
end
configure terminal
access-list 1 permit 192.168.1.0 0.0.0.63
access-list 1 deny 192.168.1.0 0.0.0.3
ip nat pool public-access1 205.5.5.3 205.5.5.28 netmask 255.255.255.224
ip nat inside source list 1 pool public-access1
interface g0/1
ip nat inside
int g0/0
ip nat outside
configure terminal
router ospf 2
network 192.168.1.0 0.0.0.127 area 1
network 200.10.10.20 0.0.0.3 area 0
end
configure terminal
access-list2 permit 192.168.1.64 0.0.0.63
ip nat pool public-access2 205.5.5.29 205.5.5.29 netmask 255.255.255.224
ip nat inside source list 2 pool public-access2 overload
interface g0/1
ip nat inside
int g0/0
ip nat outside

R1:
enable
configure terminal
interface g0/0
ip address 200.10.10.22 255.255.255.252
no shutdown
interface s0/0/0
ip address 200.10.10.1 255.255.255.252
no shutdown
interface s0/0/1
ip address 200.10.10.10 255.255.255.252
no shutdown
exit
router ospf 2
network 200.10.10.0 0.0.0.3 area 0
network 200.10.10.8 0.0.0.3 area 0
network 200.10.10.20 0.0.0.3 area 0
endwrite
R2:
enable
configure terminal
interface g0/0
ip address 200.10.10.17 255.255.255.252
no shutdown
interface s0/0/1
ip address 200.10.10.2 255.255.255.252
no shutdown
interface s0/0/0
ip address 200.10.10.5 255.255.255.252
no shutdown
exit
router ospf 2
network 200.10.10.0 0.0.0.3 area 0
network 200.10.10.4 0.0.0.3 area 0
network 200.10.10.16 0.0.0.3 area 0
end

R3:
enable
configure terminal
interface g0/0
ip address 210.2.3.1 255.255.255.0
no shutdown
interface s0/0/0
ip address 200.10.10.13 255.255.255.252
no shutdown
interface s0/0/1
ip address 200.10.10.6 255.255.255.252
no shutdown
exit
router ospf 2
network 200.10.10.4 0.0.0.3 area 0
network 200.10.10.12 0.0.0.3 area 0
network 210.2.3.0 0.0.0.255 area 0
end
configure terminal
ip dhcp pool dinamic
network 210.2.3.0 255.255.255.0
default-router 210.2.3.1
ip dhcp excluded-address 210.2.3.1

R4:
enable
configure terminal
interface g0/0
ip address 200.1.2.1 255.255.255.0
no shutdown
interface g0/1
ip address 200.10.10.18 255.255.255.252
no shutdown
interface s0/0/0
ip address 200.10.10.9 255.255.255.252
no shutdown
interface s0/0/1
ip address 200.10.10.14 255.255.255.252
no shutdown
exit
router ospf 2
network 200.10.10.8 0.0.0.3 area 0
network 200.10.10.16 0.0.0.3 area 0
network 200.10.10.12 0.0.0.3 area 0
network 210.1.2.0 0.0.0.255 area 0
end

You might also like