You are on page 1of 4

R1

conf t
ipv6 unicast-routing
interface Serial0/1
no ip address
ipv6 address 2001:5555::1/64
ipv6 address FE80::1 link-local
no shut
!
interface Serial0/2
no ip address
ipv6 address 2001:1111::1/64
ipv6 address FE80::1 link-local
no shut
!
interface Serial0/3
no ip address
ipv6 address 2001:2222::1/64
ipv6 address FE80::1 link-local
no shut
router bgp 200
no synchronization
bgp router-id 1.1.1.1
bgp log-neighbor-changes
neighbor 2001:1111::2 remote-as 100
neighbor 2001:2222::3 remote-as 300
no auto-summary
!
address-family ipv6
neighbor 2001:1111::2 activate
neighbor 2001:2222::3 activate
redistribute connected
redistribute static
network 2001:8888::0/64
no synchronization
exit-address-family
!
ipv6 route 2001:8888::0/64 2001:5555::5

R2
conf t
ipv6 unicast-routing
interface Serial0/1
no ip address
ipv6 address 2001:4444::2/64
ipv6 address FE80::2 link-local
no shut
!
interface Serial0/2
no ip address
ipv6 address 2001:1111::2/64
ipv6 address FE80::2 link-local
no shut
!
interface Serial0/3
no ip address
ipv6 address 2001:3333::2/64
ipv6 address FE80::2 link-local
no shut
router bgp 100
no synchronization
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 2001:1111::1 remote-as 200
neighbor 2001:3333::3 remote-as 300
no auto-summary
!
address-family ipv6
neighbor 2001:1111::1 activate
neighbor 2001:3333::3 activate
redistribute connected
redistribute static
network 2001:7777::0/64
no synchronization
exit-address-family
!
ipv6 route 2001:7777::0/64 2001:4444::4

R3
conf t
ipv6 unicast-routing
interface Serial0/2
no ip address
ipv6 address 2001:3333::3/64
ipv6 address FE80::3 link-local
no shut
!
interface Serial0/3
no ip address
ipv6 address 2001:2222::3/64
ipv6 address FE80::3 link-local
no shut
!
interface Serial0/1
no ip address
ipv6 address 2001:6666::3/64
ipv6 address FE80::3 link-local
no shut
router bgp 300
no synchronization
bgp router-id 3.3.3.3
bgp log-neighbor-changes
neighbor 2001:2222::1 remote-as 200
neighbor 2001:3333::2 remote-as 100
no auto-summary
!
address-family ipv6
neighbor 2001:2222::1 activate
neighbor 2001:3333::2 activate
redistribute connected
redistribute static
network 2001:9999::0/64
no synchronization
exit-address-family
!
ipv6 route 2001:9999::0/64 2001:6666::6

R4
conf t
ipv6 unicast-routing
interface Serial0/1
no ip address
ipv6 address 2001:4444::2/64
ipv6 address FE80::4 link-local
no shut
!
interface f0/0
no ip address
ipv6 address 2001:7777::1/64
ipv6 address FE80::4 link-local
no shut
!
ipv6 route ::/0 2001:4444::2

R5
conf t
ipv6 unicast-routing
interface Serial0/1
no ip address
ipv6 address 2001:5555::5/64
ipv6 address FE80::5 link-local
no shut
!
interface f0/0
no ip address
ipv6 address 2001:8888::1/64
ipv6 address FE80::5 link-local
no shut
!
ipv6 route ::/0 2001:5555::1

R6
conf t
ipv6 unicast-routing
interface Serial0/1
no ip address
ipv6 address 2001:6666::6/64
ipv6 address FE80::6 link-local
no shut
!
interface f0/0
no ip address
ipv6 address 2001:9999::1/64
ipv6 address FE80::6 link-local
no shut
!
ipv6 route ::/0 2001:6666::3

You might also like