You are on page 1of 4

/* Problem 2 (1 / 5)

.
.
,
, ,
(postoi
nepostoi). /24,
8 .
, ,
, .
10.10.10.0,
(10.10.10.1- 10.10.10.254).
, IP ,
IP .
.
IP
.
:RoutingHashJava

Sample input
2
23.3.3.3
10.10.10.0
192.168.1.1
20.2.2.0
2
192.168.1.1
20.2.2.1
13.13.3.3
192.2.2.2
Sample output
postoi
ne postoi
*/

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Scanner;

class MapEntry<K extends Comparable<K>,E> implements Comparable<K> {

// Each MapEntry object is a pair consisting of a key (a Comparable


// object) and a value (an arbitrary object).
K key;
E value;

public MapEntry (K key, E val) {


this.key = key;
this.value = val;
}

public int compareTo (K that) {


// Compare this map entry to that map entry.
@SuppressWarnings("unchecked")
MapEntry<K,E> other = (MapEntry<K,E>) that;
return this.key.compareTo(other.key);
}
public String toString () {
return "<" + key + "," + value + ">";
}
}
class SLLNode<E> {
protected E element;
protected SLLNode<E> succ;

public SLLNode(E elem, SLLNode<E> succ) {


this.element = elem;
this.succ = succ;
}

@Override
public String toString() {
return element.toString();
}
}
class CBHT<K extends Comparable<K>, E> {

// An object of class CBHT is a closed-bucket hash table, containing


// entries of class MapEntry.
private SLLNode<MapEntry<K,E>>[] buckets;

@SuppressWarnings("unchecked")
public CBHT(int m) {
// Construct an empty CBHT with m buckets.
buckets = (SLLNode<MapEntry<K,E>>[]) new SLLNode[m];
}

private int hash(K key) {


// Translate key to an index of the array buckets.
return Math.abs(key.hashCode()) % buckets.length;
}

public SLLNode<MapEntry<K,E>> search(K targetKey) {


// Find which if any node of this CBHT contains an entry whose key is
// equal
// to targetKey. Return a link to that node (or null if there is none).
int b = hash(targetKey);
for (SLLNode<MapEntry<K,E>> curr = buckets[b]; curr != null; curr =
curr.succ) {
if (targetKey.equals(((MapEntry<K, E>) curr.element).key))
return curr;
}
return null;
}

public void insert(K key, E val) { // Insert the entry <key, val> into
this CBHT.
MapEntry<K, E> newEntry = new MapEntry<K, E>(key, val);
int b = hash(key);
for (SLLNode<MapEntry<K,E>> curr = buckets[b]; curr != null; curr =
curr.succ) {
if (key.equals(((MapEntry<K, E>) curr.element).key)) {
// Make newEntry replace the existing entry ...
curr.element = newEntry;
return;
}
}
// Insert newEntry at the front of the 1WLL in bucket b ...
buckets[b] = new SLLNode<MapEntry<K,E>>(newEntry, buckets[b]);
}

public void delete(K key) {


// Delete the entry (if any) whose key is equal to key from this CBHT.
int b = hash(key);
for (SLLNode<MapEntry<K,E>> pred = null, curr = buckets[b]; curr !=
null; pred = curr, curr = curr.succ) {
if (key.equals(((MapEntry<K,E>) curr.element).key)) {
if (pred == null)
buckets[b] = curr.succ;
else
pred.succ = curr.succ;
return;
}
}
}

public String toString() {


String temp = "";
for (int i = 0; i < buckets.length; i++) {
temp += i + ":";
for (SLLNode<MapEntry<K,E>> curr = buckets[i]; curr != null; curr
= curr.succ) {
temp += curr.element.toString() + " ";
}
temp += "\n";
}
return temp;
}

public class PodeliListaProsek {

public static void main(String[] args) throws IOException{

BufferedReader input = new BufferedReader(new


InputStreamReader(System.in));

int N = Integer.parseInt(input.readLine());
CBHT<String,String> tabela = new CBHT<>(N/2+1);
for(int i=0;i<N;i++)
{
String ruter = input.readLine();
String mreza = input.readLine();

tabela.insert(ruter, mreza);

}
int M = Integer.parseInt(input.readLine());
for(int i=0;i<M;i++)
{
String ruter = input.readLine();
SLLNode<MapEntry<String,String>> eli = tabela.search(ruter);
String mreza = input.readLine();

if(eli!=null)
{
String m[] = mreza.split("\\.");
String e[] = eli.element.value.split("\\.");

if(m[0].equals(e[0]) && m[1].equals(e[1]) && m[2].equals(e[2]))


{
System.out.println("postoi");

}
else
{
System.out.println("ne postoi");
}
}
else
{
System.out.println("ne postoi");
}
}
}

You might also like