You are on page 1of 43

vlan dot1q tag native

port-channel load-balanc src-dst-mac


int range f0/19 - 24
swit trun encaps dot1
swi mo trun
swi nonegotiate

On S1
int range f 0/19 - 20
channel-group 13 mode desir
int range f 0/21 - 22
channel-group 14 mode desir
int range f 0/23 - 24
channel-group 12 mode desir
ON s2
int range f 0/19 - 20
channel-group 24 mode desir
int range f 0/21 - 22
channel-group 23 mode desir
int range f 0/23 - 24
channel-group 21 mode desir
On S3
int range f 0/19 - 20
channel-group 31 mode desir
int range f 0/21 - 22
channel-group 32 mode desir
int range f 0/23 - 24
channel-group 34 mode desir
On S4
int range f 0/19 - 20
channel-group 42 mode desir
int range f 0/21 - 22
channel-group 41 mode desir
int range f 0/23 - 24
channel-group 43 mode desir

ip access-list extended ACL


per tcp any any eq www
per tcp any eq www any
per tcp any any eq smtp
per tcp any eq smtp any
per udp any any eq domain
per udp any eq domain any
exit

vlan access-map V500


action forward
match ip ad ACL
EXIT
vlan filter V500 vlan-list 500

int range f0/1 - 5


swi block unicast
swi block multica
swi mo acc
swi acc vlan 500
swi protec
spann portfast
no sh

int range f0/1 - 5


swi mo acc
swi acc vlan 500
spann portfast
swi port-security
swi port-security maximu 1 vlan
swi port-security violation shutdown
swi block unicast
swi block multica
swi mo protected
no sh

errdisable recovery cause psecure-violation


errdisable recovery 600

spanni portfast bpduguard default


errdisable recovery cause bpduguard
errdiable recovery interval 600

int f0/18
swi acc vlan 500

swi port-security
swi port-security mac aaaa.bbbb.cccc
swi port-security violat shutdown
swi port-security aging static
swi port-security aging time 10
swi port-security aging type inactivity
swi port-security
exit

errdisable recovery cause psecure-violation


errdisable recovery interval 600

sw1 2 3 4

vlan 2000
private-vlan isolated
exit

vlan 500
private-vlan primary
private-vlan association 2000
exit

span mst confi


instance 2 vlan 2000
exit

int range f0/16 - 17


no swi acc vlan 999
switchport mode private-vlan host
switc private-vlan host 500 2000
no sh
exit
int f0/18
no swi acce vlan 500
swi mo private-vlan promi
swi private-vlan map 500 2000
no sh
exit
interface FastEthernet0/16
no switchport private-vlan host-association 500 2000
no switchport mode private-vlan host
!
interface FastEthernet0/17
no switchport private-vlan host-association 500 2000
no switchport mode private-vlan host
!
interface FastEthernet0/18
no switchport private-vlan mapping 500 2000
no switchport mode private-vlan promiscuous
!

r5
frame-relay switching
int s0/0/0
encapsulation frame-relay
frame-relay intf-type dce
no sh
int s0/0/0.100 point-to-po
ip add 10.154.15.5 255.255.255.0
fram interface-dlci 100
int s0/0/0.54 point-to-po
ip add 10.54.15.5 255.255.255.0
fram interface-dlci 154

interface Serial0/0/1
ip address 10.154.35.5 255.255.255.0
encapsulation frame-relay
clock rate 2000000
frame-relay intf-type dce
!
interface Serial0/0/1.54 point-to-point
ip address 10.54.15.5 255.255.255.0
frame-relay interface-dlci 154
!
interface Serial0/0/1.100 point-to-point
ip address 10.154.15.5 255.255.255.0
frame-relay interface-dlci 100
!
R1
interface Serial0/0/1
no ip address
encapsulation frame-relay
!
interface Serial0/0/1.54 point-to-point
ip address 10.54.15.1 255.255.255.0
frame-relay interface-dlci 154
!
interface Serial0/0/1.100 point-to-point
ip address 10.154.15.1 255.255.255.0
frame-relay interface-dlci 100

int s0/0/0
ip add 10.54.14.1 255.255.255.0
en fr
fram map ip 10.54.14.4 200 br
fram map ip 10.54.14.1 200
no sh

int s0/0/1
encapsulation frame-relay
no sh
INT S0/0/1.54
ip add 10.54.15.1 255.255.255.0
fram interface-dlci 154
int s0/0/1.100
ip add 10.154.15.1 255.255.255.0
fram interface-dlci 100
r4

fr sw
int s0/0/0
ip add 10.54.14.4 255.255.255.0
en fr
fram intf-type dce
fram map ip 10.54.14.4 200
fram map ip 10.54.14.1 200 br

int s0/0/1
ip add 10.54.24.4 255.255.255.0
en fr
fram intf-type dce
fram map ip 10.54.24.4 154
fram map ip 10.54.24.2 154 br

R2
int s0/0/0
ip add 10.54.24.2 255.255.255.0
en fr
fram intf-type dce
fram map ip 10.54.24.4 154 br
fram map ip 10.54.24.2 154

interface Serial0/0/0
ip address 10.54.14.4 255.255.255.0
encapsulation frame-relay
no fair-queue
clock rate 125000
frame-relay map ip 10.54.14.1 200 broadcast
frame-relay map ip 10.54.14.4 200
frame-relay intf-type dce
!
interface Serial0/0/1
ip address 10.54.24.4 255.255.255.0
encapsulation frame-relay
clock rate 125000
frame-relay map ip 10.54.24.2 154 broadcast
frame-relay map ip 10.54.24.4 154
frame-relay intf-type dce
!

R1
mpls ldp router-id loopback 0 force
mpls label protocol ldp
router ospf 200
router-id 154.1.1.1
network 10.154.15.1 0.0.0.0 area 1
net 10.154.16.1 0.00.0.0 ar 1
net 154.1.1.1 0.0.0.0 ar 1
area 1 nssa
int f0/0
ip ospf priorty 0
int s0/0/1.100
mpls ip

R5
mpls ldp router-id loopback 0 force
mpls label protocol ldp
router ospf 200
router-id 154.5.5.5
net 154.5.5.5 0.0.0.0 area 1
net 10.154.15.5 0.0.0.0 ar 1
net 10.154.35.5 00.0.0.0 ar 1
area 1 nssa
int s0/0/0
mpls ip
int s0/0/1.100
mpls ip

R3
mpls ldp router-id loopback 0 force
mpls label protocol ldp
router ospf 200
router-id 154.3.3.3
net 10.154.35.3 0.0.0.0 area 1
net 10.154.36.3 0.0.0.0 ar 1
net 154.3.3.3 0.0.0.0 ar 1
area 1 nssa
int f0/0
ip ospf priority 0
int s0/0/0
mpls ip

SW1
ip routing
router ospf 200
router-id 154.6.6.6
net 154.6.6.6 0.0.0.0 ar 0
net 10.154.36.6 0.0.0.0 ar 1
net 10.154.16.6 0.0.0.0 ar 1
net 10.154.68.6 0.0.0.0 ar 0
area 1 nssa default-information-o
int vlan 36
ip ospf priority 255
int vlan 68
ip ospf priority 255
int vlan 16
ip ospf priority 255
exit

SW3
ip routing
router ospf 200
router-id 154.8.8.8
net 10.154.68.8 0.0.0.0 ar 0
net 154.8.8.8 0.0.0.0 ar 0
net 10.154.188.0 0.0.0.0 ar 500
passive-interfac vlan 500

on sw1 & 3
router ospf 200
area 0 filter-list prefix fv5 out
exit
ip prefix-list fv5 seq 5 deny 10.154.188.0/24
ip prefix-list fv5 seq 10 per 0.0.0.0/0 le 32

R1
router eigrp 54
net 10.54.18.1 0.0.0.0
net 10.54.15.1 0.0.0.0
net 10.54.14.1 0.0.0.0
no auto
exit

int s0/0/1.54
mpls ip
int s0/0/0
mpls ip

R2
ip cef
mpls ldp router-id loopback 0 force
mpls label protocol ldp
router eigrp 54
net 10.54.24.2 0.0.00.0
net 10.54.28.2 0.0.0.0
net 154.2.2.2 0.0.0.0
no auto

int s0/0/0
mpls ip

r4
ip cef
mpls ldp router-id loopback 0 force
mpls label protocol ldp
router eigrp 54
net 10.54.24.4 0.0.0.0
net 10.54.14.4 0.0.0.0
net 10.54.45.4 0.0.0.0
net 154.4.4.4 0.0.0.0
no auto
exit
int s0/0/1
mpls ip
int s0/0/0
mpls ip
int f0/1
delay 10000
mpls ip

r5
mpls ldp router-id loopback 0 force
mpls label protocol ldp
router eigrp 54
net 10.54.45.5 0.0.0.0
net 10.54.15.5 0.0.0.0
no auto
int f0/1
delay 10000
mpls ip
int s0/0/1.54
mpls ip

sw3
ip routing
router eigrp 54
net 10.54.18.8 0.0.00.0
net 10.54.28.8 0.0.0.0
no auto
sw4
router eigrp 100
net 150.3.54.9 0.0.0.0
no auto

sw
router rip
redistribute ospf metric 5

R1

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack69R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
ipv6 unicast-routing
ipv6 cef
mpls label protocol ldp
frame-relay switching
!
!
archive
log config
hidekeys
!
!
!
!
!
!
interface Loopback0
ip address 154.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.154.16.1 255.255.255.0
ip ospf priority 0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.54.18.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
ip address 10.54.14.1 255.255.255.0
encapsulation frame-relay
mpls ip
no fair-queue
frame-relay map ip 10.54.14.1 200
frame-relay map ip 10.54.14.4 200 broadcast
!
interface Serial0/0/1
no ip address
encapsulation frame-relay
!
interface Serial0/0/1.54 point-to-point
ip address 10.54.15.1 255.255.255.0
mpls ip
frame-relay interface-dlci 154
!
interface Serial0/0/1.100 point-to-point
ip address 10.154.15.1 255.255.255.0
mpls ip
frame-relay interface-dlci 100
!
router eigrp 54
network 10.54.14.1 0.0.0.0
network 10.54.15.1 0.0.0.0
network 10.54.18.1 0.0.0.0
no auto-summary
!
router ospf 200
router-id 154.1.1.1
log-adjacency-changes
area 1 nssa
network 10.154.15.1 0.0.0.0 area 1
network 10.154.16.1 0.0.0.0 area 1
network 154.1.1.1 0.0.0.0 area 1
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
mpls ldp router-id Loopback0 force
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
password cisco
logging synchronous
line aux 0
line vty 0 4
privilege level 15
password cisco
login
transport input all
!
scheduler allocate 20000 1000
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice
!
end

R2
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack69R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
ipv6 unicast-routing
ipv6 cef
mpls label protocol ldp
!
!
!
!
!
!
!
!
interface Loopback0
ip address 154.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.54.28.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.27.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
ip address 10.54.24.2 255.255.255.0
encapsulation frame-relay
mpls ip
no fair-queue
frame-relay map ip 10.54.24.2 154
frame-relay map ip 10.54.24.4 154 broadcast
!
interface Serial0/0/1
no ip address
shutdown
serial restart-delay 0
clock rate 2000000
!
router eigrp 54
network 10.54.24.2 0.0.0.0
network 10.54.28.2 0.0.0.0
network 154.2.2.2 0.0.0.0
no auto-summary
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
mpls ldp router-id Loopback0 force
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
password cisco
logging synchronous
line aux 0
line vty 0 4
privilege level 15
password cisco
login
transport input all
!
scheduler allocate 20000 1000
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice
!
end

R3

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack69R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 15
ip cef
!
!
!
!
no ip domain lookup
!
ipv6 unicast-routing
ipv6 cef
mpls label protocol ldp
!
!
!
!
!
!
!
!
interface Loopback0
ip address 154.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 10.154.36.3 255.255.255.0
ip ospf priority 0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.37.3 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0
ip address 10.154.35.3 255.255.255.0
mpls ip
no fair-queue
!
interface Serial0/0/1
no ip address
shutdown
!
router ospf 200
router-id 154.3.3.3
log-adjacency-changes
area 1 nssa
network 10.154.35.3 0.0.0.0 area 1
network 10.154.36.3 0.0.0.0 area 1
network 154.3.3.3 0.0.0.0 area 1
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
mpls ldp router-id Loopback0 force
!
control-plane
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
password cisco
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
line vty 0 4
privilege level 15
password cisco
login
transport input all
!
scheduler allocate 20000 1000
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice
!
end

R4

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack69R4
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
memory-size iomem 15
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
multilink bundle-name authenticated
frame-relay switching
!
!
!
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 154.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 150.1.54.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.54.45.4 255.255.255.0
delay 10000
duplex auto
speed auto
mpls ip
!
interface Serial0/0/0
ip address 10.54.14.4 255.255.255.0
encapsulation frame-relay
mpls ip
no fair-queue
clock rate 125000
frame-relay map ip 10.54.14.4 200
frame-relay map ip 10.54.14.1 200 broadcast
frame-relay intf-type dce
!
interface Serial0/0/1
ip address 10.54.24.4 255.255.255.0
encapsulation frame-relay
mpls ip
clock rate 125000
frame-relay map ip 10.54.24.4 154
frame-relay map ip 10.54.24.2 154 broadcast
frame-relay intf-type dce
!
router eigrp 54
network 10.54.14.4 0.0.0.0
network 10.54.24.4 0.0.0.0
network 10.54.45.4 0.0.0.0
network 154.4.4.4 0.0.0.0
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
mpls ldp router-id Loopback0 force
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
password cisco
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
line vty 0 4
privilege level 15
password cisco
login
transport input all
!
exception data-corruption buffer truncate
scheduler allocate 20000 1000
end

R5

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack69R5
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
memory-size iomem 5
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
multilink bundle-name authenticated
frame-relay switching
!
!
!
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 154.5.5.5 255.255.255.255
!
interface FastEthernet0/0
ip address 150.2.54.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.54.45.5 255.255.255.0
delay 10000
duplex auto
speed auto
mpls ip
!
interface Serial0/0/0
ip address 10.154.35.5 255.255.255.0
mpls ip
clock rate 2000000
!
interface Serial0/0/1
ip address 10.154.35.5 255.255.255.0
encapsulation frame-relay
clock rate 2000000
frame-relay intf-type dce
!
interface Serial0/0/1.54 point-to-point
ip address 10.54.15.5 255.255.255.0
mpls ip
frame-relay interface-dlci 154
!
interface Serial0/0/1.100 point-to-point
ip address 10.154.15.5 255.255.255.0
mpls ip
frame-relay interface-dlci 100
!
router eigrp 54
network 10.54.15.5 0.0.0.0
network 10.54.45.5 0.0.0.0
no auto-summary
!
router ospf 200
router-id 154.5.5.5
log-adjacency-changes
area 1 nssa
network 10.154.15.5 0.0.0.0 area 1
network 10.154.35.5 0.0.0.0 area 1
network 154.5.5.5 0.0.0.0 area 1
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
mpls ldp router-id Loopback0 force
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
password cisco
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
line vty 0 4
privilege level 15
password cisco
login
transport input all
!
exception data-corruption buffer truncate
scheduler allocate 20000 1000
end

SW1
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack69SW1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
system mtu routing 1500
vtp domain CCIE
vtp mode transparent
ip subnet-zero
ip routing
no ip domain-lookup
!
!
!
crypto pki trustpoint TP-self-signed-2863982976
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2863982976
revocation-check none
rsakeypair TP-self-signed-2863982976
!
!
crypto pki certificate chain TP-self-signed-2863982976
certificate self-signed 01
30820242 308201AB A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 32383633 39383239 3736301E 170D3933 30333031 30303434
35315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 38363339
38323937 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100CB7E B81E901E D62E7C19 AD458CFB 83E7B292 4AFA2AD0 222F0C87 46D7863C
126B4433 FD8E7566 82DB1E50 1FC0E9D0 8E5B7258 2768B202 3E462257 D2123144
8F0FA46F A6F5146C 1DF4EA1A D4ED5B57 FD686342 581246BC B52B828A D3AF8124
C96E0CAE 884FE8F9 0A4F2E42 2C30729C D38D30C8 39188653 B36F1AC1 98D307A0
8B730203 010001A3 6A306830 0F060355 1D130101 FF040530 030101FF 30150603
551D1104 0E300C82 0A526163 6B363953 57312E30 1F060355 1D230418 30168014
9404EDB3 F8CB50B2 463CBD79 52A94E71 F7B36D31 301D0603 551D0E04 16041494
04EDB3F8 CB50B246 3CBD7952 A94E71F7 B36D3130 0D06092A 864886F7 0D010104
05000381 8100629A 0B8A54F9 1556154E 6CF6829C E82AF07D 0BBE205D 731A3438
B95DC68C 79F1E084 764C6E98 E78DC355 3F03B583 B058D3B4 96B92CD5 42C353D8
709BFC0D A077F087 B823209C C720D823 2E76E0E1 384D59A0 8FA2035B 4E8E7AF6
B5323673 24928366 E987E26A 5B8312E1 1B748DB6 FFDA2D56 438C77D1 E302BE20
7AF58379 DECA
quit
!
!
!
errdisable recovery cause psecure-violation
errdisable recovery interval 600
port-channel load-balance src-dst-mac
!
!
!
spanning-tree mode mst
spanning-tree extend system-id
!
spanning-tree mst configuration
name cisco
revision 1
instance 1 vlan 45, 69, 89, 999
instance 2 vlan 16, 18, 28, 36, 68, 100, 200, 300, 500, 2000
instance 3 vlan 1-15, 17, 19-27, 29-35, 37-44, 46-67, 70-88, 90-99, 101-199
instance 3 vlan 201-299, 301-499, 501-998, 1000-1999, 2001-4094
!
spanning-tree mst 0-1 priority 24576
spanning-tree mst 2 priority 28672
!
vlan internal allocation policy ascending
vlan dot1q tag native
!
vlan 16
name VLAN_16_R1-SW1
!
vlan 18
name VLAN_18_R1-SW3
!
vlan 28
name VLAN_28_R2-SW3
!
vlan 36
name VLAN_36_R3-SW1
!
vlan 45
name VLAN_45_R4-R5
!
vlan 68
name VLAN_68_SW1-SW3
!
vlan 69
name VLAN_69_SW1-SW4
!
vlan 89
name VLAN_89_SW3-SW4
!
vlan 100
name VLAN_100_BB1
!
vlan 200
name VLAN_200_BB2
!
vlan 300
name VLAN_300_BB3
!
vlan 500
name VLAN_500_Clients
private-vlan primary
private-vlan association 2000
!
vlan 999
name Unused_Ports
!
vlan 2000
private-vlan isolated
!
!
!
!
interface Loopback0
ip address 154.6.6.6 255.255.255.255
!
interface Port-channel12
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface Port-channel13
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface Port-channel14
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/1
switchport access vlan 16
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 28
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 36
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 100
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 200
switchport mode access
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
switchport access vlan 100
switchport mode access
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
switchport private-vlan host-association 500 2000
switchport mode private-vlan host
!
interface FastEthernet0/17
switchport private-vlan host-association 500 2000
switchport mode private-vlan host
!
interface FastEthernet0/18
switchport private-vlan mapping 500 2000
switchport mode private-vlan promiscuous
switchport port-security aging time 10
switchport port-security aging type inactivity
switchport port-security aging static
!
interface FastEthernet0/19
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 13 mode desirable
!
interface FastEthernet0/20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 13 mode desirable
!
interface FastEthernet0/21
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 14 mode desirable
!
interface FastEthernet0/22
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 14 mode desirable
!
interface FastEthernet0/23
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 12 mode desirable
!
interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 12 mode desirable
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan16
ip address 10.154.16.6 255.255.255.0
ip ospf priority 255
!
interface Vlan36
ip address 10.154.36.6 255.255.255.0
ip ospf priority 255
!
interface Vlan68
ip address 10.154.68.6 255.255.255.0
ip ospf priority 255
!
interface Vlan69
ip address 10.154.69.6 255.255.255.0
!
router ospf 200
router-id 154.6.6.6
log-adjacency-changes
area 0 filter-list prefix fv5 out
area 1 nssa default-information-originate
network 10.154.16.6 0.0.0.0 area 1
network 10.154.36.6 0.0.0.0 area 1
network 10.154.68.6 0.0.0.0 area 0
network 154.6.6.6 0.0.0.0 area 0
!
router rip
version 2
redistribute ospf 200 metric 5
passive-interface default
no passive-interface Vlan69
network 10.0.0.0
no auto-summary
!
ip classless
no ip http server
ip http secure-server
!
!
!
ip prefix-list fv5 seq 5 deny 10.154.188.0/24
ip prefix-list fv5 seq 10 permit 0.0.0.0/0 le 32
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
password cisco
logging synchronous
line vty 0 4
privilege level 15
password cisco
login
transport input all
line vty 5 15
login
!
end

SW2

!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Rack69SW2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
system mtu routing 1500
vtp domain CCIE
vtp mode transparent
ip subnet-zero
no ip domain-lookup
!
!
!
crypto pki trustpoint TP-self-signed-231516160
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-231516160
revocation-check none
rsakeypair TP-self-signed-231516160
!
!
crypto pki certificate chain TP-self-signed-231516160
certificate self-signed 01
30820240 308201A9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 32333135 31363136 30301E17 0D393330 33303130 30343833
365A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3233 31353136
31363030 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
B6A01315 9AE91723 1C867EED D91E0AAA 1214A394 4763D862 668DD21C 4D812358
5FBC933A FB2E94D0 928459D4 64F6C9C9 8AE37FC6 A0CC85F8 C8EEB857 CC844202
5DD6219B 816C56F9 61435D65 A43C19DB 9E8F5246 0F718EEB 82758FD6 021E3990
44E9E097 9978D1FB 2747DDB8 894C13A1 A4CF5104 B9CB4071 3B7D0C25 EF413CB7
02030100 01A36A30 68300F06 03551D13 0101FF04 05300301 01FF3015 0603551D
11040E30 0C820A52 61636B36 39535732 2E301F06 03551D23 04183016 8014E9AF
82166FEE 5386B4C7 61013D9D 8D43CD95 0D1B301D 0603551D 0E041604 14E9AF82
166FEE53 86B4C761 013D9D8D 43CD950D 1B300D06 092A8648 86F70D01 01040500
03818100 897FBE45 96BAAC61 60A5B5DE B9615B9E 8F0D022E F34B7449 33EC268E
7C96171F D9F6C023 B7EC854D F4B08292 1011201B 0708B392 A4A1B260 50B140DB
78B93616 D4B9CDB0 90D82FCF FFF73BAD 0B509024 6E751741 1F4EFCF5 B8E2993B
19C5731E DB239727 7DD59458 AE4D6765 7F9D5599 04A01342 20FB4E0A 15FC1DEC 43FCC244
quit
!
!
!
port-channel load-balance src-dst-mac
!
!
!
spanning-tree mode mst
spanning-tree extend system-id
!
spanning-tree mst configuration
name cisco
revision 1
instance 1 vlan 45, 69, 89, 999
instance 2 vlan 16, 18, 28, 36, 68, 100, 200, 300, 500
instance 3 vlan 1-15, 17, 19-27, 29-35, 37-44, 46-67, 70-88, 90-99, 101-199
instance 3 vlan 201-299, 301-499, 501-998, 1000-4094
!
spanning-tree mst 0-1 priority 28672
spanning-tree mst 2 priority 24576
!
vlan internal allocation policy ascending
vlan dot1q tag native
!
vlan 16
name VLAN_16_R1-SW1
!
vlan 18
name VLAN_18_R1-SW3
!
vlan 28
name VLAN_28_R2-SW3
!
vlan 36
name VLAN_36_R3-SW1
!
vlan 45
name VLAN_45_R4-R5
!
vlan 68
name VLAN_68_SW1-SW3
!
vlan 69
name VLAN_69_SW1-SW4
!
vlan 89
name VLAN_89_SW3-SW4
!
vlan 100
name VLAN_100_BB1
!
vlan 200
name VLAN_200_BB2
!
vlan 300
name VLAN_300_BB3
!
vlan 500
name VLAN_500_Clients
!
vlan 999
name Unused_Ports
!
!
!
!
interface Loopback0
ip address 154.7.7.7 255.255.255.255
!
interface Loopback71
ip address 71.71.71.71 255.255.255.255
!
interface Loopback72
ip address 72.72.72.72 255.255.255.255
!
interface Port-channel21
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface Port-channel23
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface Port-channel24
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/1
switchport access vlan 18
switchport mode access
!
interface FastEthernet0/2
no switchport
ip address 172.16.27.7 255.255.255.0
!
interface FastEthernet0/3
no switchport
ip address 172.16.37.7 255.255.255.0
!
interface FastEthernet0/4
switchport access vlan 45
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 45
switchport mode access
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
switchport access vlan 200
switchport mode access
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 24 mode desirable
!
interface FastEthernet0/20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 24 mode desirable
!
interface FastEthernet0/21
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 23 mode desirable
!
interface FastEthernet0/22
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 23 mode desirable
!
interface FastEthernet0/23
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 21 mode desirable
!
interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 21 mode desirable
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
ip classless
no ip http server
ip http secure-server
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
password cisco
logging synchronous
line vty 0 4
privilege level 15
password cisco
no login
transport input all
line vty 5 15
login
!
end

SW3

!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack69SW3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
system mtu routing 1500
vtp domain CCIE
vtp mode transparent
ip subnet-zero
ip routing
no ip domain-lookup
!
!
!
!
crypto pki trustpoint TP-self-signed-3565810688
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3565810688
revocation-check none
rsakeypair TP-self-signed-3565810688
!
!
crypto pki certificate chain TP-self-signed-3565810688
certificate self-signed 01
30820242 308201AB A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 33353635 38313036 3838301E 170D3933 30333031 30303439
34315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 35363538
31303638 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100A737 50BCB2FD A4C14E90 4A48EF3D 2B92E542 9E6C4A10 789638FA 6278ABFB
65D37C86 D2339A44 B0701CDF ED7C7552 0CB59DA0 85EE465B F3478AE8 42BA3960
821AC329 1023E8C2 372381D9 44E2AD6B 1AE5AB2E 96025559 976420B3 D44BA38D
CD5FA53B ABDC68A9 EA345607 D965A169 4F680BDA 17C4BFA2 1AA257BD 9F02B446
61E50203 010001A3 6A306830 0F060355 1D130101 FF040530 030101FF 30150603
551D1104 0E300C82 0A526163 6B363953 57332E30 1F060355 1D230418 30168014
91B3E18A 4EF6A42F 5A93C0BB AAE0B443 5197B391 301D0603 551D0E04 16041491
B3E18A4E F6A42F5A 93C0BBAA E0B44351 97B39130 0D06092A 864886F7 0D010104
05000381 8100456D 3F919B40 A6AE5701 B975C7E2 D51C35A3 1ADE2B73 D9F40724
03A8A5BC 413299E5 BCF121EF 8EEB1B7C AF1A5B19 62DE9E88 53A173F0 91230964
7D07B5BF F76CECF9 DD22FE95 2DC216FB E8879141 FB62C4B8 A22563C9 84A00EBE
134D849E E98F419B 192E38E0 2D62DFE8 44601CEC 0AD84272 6CD35223 9D3507A8
CCFFC3E0 613D
quit
!
!
!
port-channel load-balance src-dst-mac
!
!
!
spanning-tree mode mst
spanning-tree extend system-id
!
spanning-tree mst configuration
name cisco
revision 1
instance 1 vlan 45, 69, 89, 999
instance 2 vlan 16, 18, 28, 36, 68, 100, 200, 300, 500
instance 3 vlan 1-15, 17, 19-27, 29-35, 37-44, 46-67, 70-88, 90-99, 101-199
instance 3 vlan 201-299, 301-499, 501-998, 1000-4094
!
!
!
vlan access-map V500 10
action forward
match ip address ACL
vlan access-map V500 20
action forward
match ip address ACL
vlan access-map V500 30
action forward
match ip address ACL
!
vlan filter V500 vlan-list 500
vlan internal allocation policy ascending
vlan dot1q tag native
!
vlan 16
name VLAN_16_R1-SW1
!
vlan 18
name VLAN_18_R1-SW3
!
vlan 28
name VLAN_28_R2-SW3
!
vlan 36
name VLAN_36_R3-SW1
!
vlan 45
name VLAN_45_R4-R5
!
vlan 68
name VLAN_68_SW1-SW3
!
vlan 69
name VLAN_69_SW1-SW4
!
vlan 89
name VLAN_89_SW3-SW4
!
vlan 100
name VLAN_100_BB1
!
vlan 200
name VLAN_200_BB2
!
vlan 300
name VLAN_300_BB3
!
vlan 500
name VLAN_500_Clients
!
vlan 999
name Unused_Ports
!
!
!
!
interface Loopback0
ip address 154.8.8.8 255.255.255.255
!
interface Port-channel31
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface Port-channel32
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface Port-channel34
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
switchport access vlan 300
switchport mode access
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 31 mode desirable
!
interface FastEthernet0/20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 31 mode desirable
!
interface FastEthernet0/21
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 32 mode desirable
!
interface FastEthernet0/22
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 32 mode desirable
!
interface FastEthernet0/23
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 34 mode desirable
!
interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 34 mode desirable
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
!
interface Vlan18
ip address 10.54.18.8 255.255.255.0
!
interface Vlan28
ip address 10.54.28.8 255.255.255.0
!
interface Vlan68
ip address 10.154.68.8 255.255.255.0
!
interface Vlan89
ip address 10.154.89.8 255.255.255.0
!
interface Vlan500
ip address 10.154.188.8 255.255.255.0
!
!
router eigrp 54
no auto-summary
network 10.54.18.8 0.0.0.0
network 10.54.28.8 0.0.0.0
!
router ospf 200
router-id 154.8.8.8
log-adjacency-changes
area 0 filter-list prefix fv5 out
passive-interface Vlan500
network 10.154.68.8 0.0.0.0 area 0
network 10.154.188.0 0.0.0.0 area 500
network 154.8.8.8 0.0.0.0 area 0
!
ip classless
no ip http server
ip http secure-server
!
!
ip access-list extended ACL
permit tcp any any eq www
permit tcp any eq www any
permit tcp any any eq smtp
permit tcp any eq smtp any
permit udp any any eq domain
permit udp any eq domain any
!
!
ip prefix-list fv5 seq 5 deny 10.154.188.0/24
ip prefix-list fv5 seq 10 permit 0.0.0.0/0 le 32
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
password cisco
logging synchronous
line vty 0 4
privilege level 15
password cisco
login
transport input all
line vty 5 15
login
!
end

SW4
Current configuration : 5493 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack69SW4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
system mtu routing 1500
vtp domain CCIE
vtp mode transparent
ip subnet-zero
ip routing
no ip domain-lookup
!
!
!
!
crypto pki trustpoint TP-self-signed-798018432
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-798018432
revocation-check none
rsakeypair TP-self-signed-798018432
!
!
crypto pki certificate chain TP-self-signed-798018432
certificate self-signed 01
30820240 308201A9 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 37393830 31383433 32301E17 0D393330 33303130 30353030
365A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3739 38303138
34333230 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
CAEAEBBC 9C9AC793 DFAFC8E8 6F850CFF 7CA9C908 CF5E9A50 C057A6F3 E2FBE9BC
CD8D594A 1327B08C E819EF20 A0EB6382 74E3C5E9 832A0115 7C57E57B EDAD4AE0
ADB601D5 F9F013DF 350AA4E2 C65FA71E 455332F4 829E188D 755E328E 484CB4B5
6B0FBB91 5534ACB0 B9A60617 D7959CBF 8FD350E0 01B826B5 62D340FE A235B8F1
02030100 01A36A30 68300F06 03551D13 0101FF04 05300301 01FF3015 0603551D
11040E30 0C820A52 61636B36 39535734 2E301F06 03551D23 04183016 80142055
0F864C27 F35D0170 89F5F0BE 0F1C31C9 3CE4301D 0603551D 0E041604 1420550F
864C27F3 5D017089 F5F0BE0F 1C31C93C E4300D06 092A8648 86F70D01 01040500
03818100 5B012EBF B7E924B9 56743CC6 8BEE735E 5E61E0D5 22506866 6F5E7B8F
3707F35D AC0423BC 17C7E20F 5A55D5CD 2FEDF7C7 7F41ADB3 471BBA3E 7306F63D
5EB710B9 CC3901EF F9753CD0 DB9E4611 FA5C50EA 33714B02 BD892E87 B69FE2F6
22CCF9ED FD92ABD3 A5CC3CDB 3006DD2B D30E79A8 35C8705E 50BD79C5 F02B69AE 39654561
quit
!
!
!
port-channel load-balance src-dst-mac
!
!
!
spanning-tree mode mst
spanning-tree extend system-id
!
spanning-tree mst configuration
name cisco
revision 1
instance 1 vlan 45, 69, 89, 999
instance 2 vlan 16, 18, 28, 36, 68, 100, 200, 300, 500
instance 3 vlan 1-15, 17, 19-27, 29-35, 37-44, 46-67, 70-88, 90-99, 101-199
instance 3 vlan 201-299, 301-499, 501-998, 1000-4094
!
!
vlan internal allocation policy ascending
vlan dot1q tag native
!
vlan 16
name VLAN_16_R1-SW1
!
vlan 18
name VLAN_18_R1-SW3
!
vlan 28
name VLAN_28_R2-SW3
!
vlan 36
name VLAN_36_R3-SW1
!
vlan 45
name VLAN_45_R4-R5
!
vlan 68
name VLAN_68_SW1-SW3
!
vlan 69
name VLAN_69_SW1-SW4
!
vlan 89
name VLAN_89_SW3-SW4
!
vlan 100
name VLAN_100_BB1
!
vlan 200
name VLAN_200_BB2
!
vlan 300
name VLAN_300_BB3
!
vlan 500
name VLAN_500_Clients
!
vlan 999
name Unused_Ports
!
!
!
!
interface Loopback0
ip address 154.9.9.9 255.255.255.255
!
interface Port-channel41
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface Port-channel42
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface Port-channel43
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 42 mode desirable
!
interface FastEthernet0/20
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 42 mode desirable
!
interface FastEthernet0/21
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 41 mode desirable
!
interface FastEthernet0/22
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 41 mode desirable
!
interface FastEthernet0/23
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 43 mode desirable
!
interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 43 mode desirable
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
!
interface Vlan69
ip address 10.154.69.9 255.255.255.0
!
interface Vlan89
ip address 10.154.89.9 255.255.255.0
!
interface Vlan300
ip address 150.3.54.1 255.255.255.0
!
!
router eigrp 100
redistribute rip metric 1500 1 255 255 1500
no auto-summary
network 150.3.54.1 0.0.0.0
!
router rip
version 2
redistribute eigrp 100 metric 4
passive-interface default
no passive-interface Vlan69
no passive-interface Vlan89
no passive-interface Loopback0
network 10.0.0.0
network 154.0.0.0
no auto-summary
!
ip classless
no ip http server
ip http secure-server
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
password cisco
logging synchronous
line vty 0 4
privilege level 15
password cisco
login
transport input all
line vty 5 15
login
!
end

bb1
hostname BB1
!
!
memory-size iomem 15
ip subnet-zero
ip cef
!
!
no ip domain-lookup
!
!
!
!
interface Loopback197
description BGP Network
ip address 197.68.22.254 255.255.255.0 secondary
ip address 197.68.21.254 255.255.255.0 secondary
ip address 197.68.5.254 255.255.255.0 secondary
ip address 197.68.4.254 255.255.255.0 secondary
ip address 197.68.1.254 255.255.255.0
!
interface Loopback199
description RIP Networks
ip address 199.172.16.254 255.255.255.0 secondary
ip address 199.172.15.254 255.255.255.0 secondary
ip address 199.172.14.254 255.255.255.0 secondary
ip address 199.172.13.254 255.255.255.0 secondary
ip address 199.172.12.254 255.255.255.0 secondary
ip address 199.172.11.254 255.255.255.0 secondary
ip address 199.172.10.254 255.255.255.0 secondary
ip address 199.172.9.254 255.255.255.0 secondary
ip address 199.172.8.254 255.255.255.0 secondary
ip address 199.172.7.254 255.255.255.0 secondary
ip address 199.172.6.254 255.255.255.0 secondary
ip address 199.172.5.254 255.255.255.0 secondary
ip address 199.172.4.254 255.255.255.0 secondary
ip address 199.172.3.254 255.255.255.0 secondary
ip address 199.172.2.254 255.255.255.0 secondary
ip address 199.172.1.254 255.255.255.0
!
interface Ethernet0/0
ip address 150.1.54.254 255.255.255.0
half-duplex
!
router rip
version 2
network 150.1.0.0
network 150.100.0.0
network 199.172.1.0
network 199.172.2.0
network 199.172.3.0
network 199.172.4.0
network 199.172.5.0
network 199.172.6.0
network 199.172.7.0
network 199.172.8.0
network 199.172.9.0
network 199.172.11.0
network 199.172.12.0
network 199.172.13.0
network 199.172.14.0
network 199.172.15.0
network 199.172.16.0
no auto-summary
!
router bgp 254
no synchronization
bgp log-neighbor-changes
network 197.68.1.0
network 197.68.4.0
network 197.68.5.0
network 197.68.21.0
network 197.68.22.0
neighbor 150.1.6.1 remote-as 6
neighbor 150.1.6.1 send-community
neighbor 150.1.6.1 route-map ASPERP out
neighbor 150.1.54.1 remote-as 54
neighbor 150.1.54.1 send-community
neighbor 150.1.54.1 route-map ASPERP out
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 150.1.6.1
no ip http server
!
!
ip prefix-list NET145 seq 5 permit 197.68.1.0/24
ip prefix-list NET145 seq 10 permit 197.68.4.0/24
ip prefix-list NET145 seq 15 permit 197.68.5.0/24
!
ip prefix-list NET2122 seq 5 permit 197.68.21.0/24
ip prefix-list NET2122 seq 10 permit 197.68.22.0/24
route-map ASPERP permit 10
set as-path prepend 253
set community 254
!
route-map BGG permit 10
match ip address prefix-list NET145
set community 100 300 additive
!
route-map BGG permit 20
match ip address prefix-list NET2122
set community 100 200
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
password cisco
login
transport input pad v120 telnet rlogin udptn
!
end

BB2
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BB2
!
!
memory-size iomem 15
ip subnet-zero
ip cef
!
!
!
!
!
!
interface Loopback197
description BGP Networks
ip address 197.68.22.254 255.255.255.0 secondary
ip address 197.68.21.254 255.255.255.0 secondary
ip address 197.68.5.254 255.255.255.0 secondary
ip address 197.68.4.254 255.255.255.0 secondary
ip address 197.68.1.254 255.255.255.0
!
interface Ethernet0/0
ip address 150.2.54.254 255.255.255.0
duplex auto
speed auto
!
router bgp 254
no synchronization
bgp log-neighbor-changes
network 197.68.1.0
network 197.68.4.0
network 197.68.5.0
network 197.68.21.0
network 197.68.22.0
neighbor 150.2.54.1 remote-as 54
neighbor 150.2.54.1 send-community
neighbor 150.2.54.1 route-map ASCOMM out
no auto-summary
!
ip classless
no ip http server
!
!
ip prefix-list NET145 seq 5 permit 197.68.1.0/24
ip prefix-list NET145 seq 10 permit 197.68.4.0/24
ip prefix-list NET145 seq 15 permit 197.68.5.0/24
!
ip prefix-list NET2122 seq 5 permit 197.68.21.0/24
ip prefix-list NET2122 seq 10 permit 197.68.22.0/24
route-map ASCOMM permit 10
set community 254
!
route-map BGG permit 10
match ip address prefix-list NET145
set community 100 200 additive
!
route-map BGG permit 20
match ip address prefix-list NET2122
set community 100 300
!
!
line con 0
exec-timeout 0 0
privilege level 15
password cisco
logging synchronous
line aux 0
line vty 0 4
privilege level 15
password cisco
login
transport input pad v120 telnet rlogin udptn mop
!
end

BB3
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BB3
!
!
memory-size iomem 15
ip subnet-zero
ip cef
!
!
!
!
!
!
interface Loopback4
description EIGRP NETWORK
ip address 4.1.1.254 255.255.255.0
!
interface Loopback128
description EIGRP NETWORK
ip address 128.28.2.254 255.255.255.0 secondary
ip address 128.128.1.254 255.255.255.0
!
interface Loopback198
description EIGRP NETWORK
ip address 198.198.22.254 255.255.255.0 secondary
ip address 198.198.21.254 255.255.255.0 secondary
ip address 198.198.5.254 255.255.255.0 secondary
ip address 198.198.4.254 255.255.255.0 secondary
ip address 198.198.1.254 255.255.255.0 secondary
ip address 198.2.1.254 255.255.255.0 secondary
ip address 198.2.3.254 255.255.255.0 secondary
ip address 198.2.5.254 255.255.255.0 secondary
ip address 198.1.1.5 255.255.255.252
!
interface FastEthernet0/0
ip address 150.3.54.254 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
shutdown
no fair-queue
!
interface Serial0/1
no ip address
shutdown
!
router eigrp 100
redistribute connected
network 150.3.0.0
auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 150.3.6.1
ip http server
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
password cisco
login
transport input pad v120 telnet rlogin udptn mop
!
end

You might also like