You are on page 1of 32

PE1

hostname PE1

boot-start-marker

boot-end-marker

no aaa new-model

ip cef

no ip domain lookup

ip vrf Customer-1

rd 1:100

route-target export 1:100

route-target export 1:300

route-target import 1:100

route-target import 1:300

ip vrf Customer-2

rd 1:200

route-target export 1:200

route-target import 1:200

!
ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

mpls label protocol ldp

interface Loopback0

ip address 1.1.1.1 255.255.255.255


!

interface FastEthernet0/0

no ip address

shutdown

duplex half

interface GigabitEthernet1/0

ip address 10.1.1.2 255.255.255.252

negotiation auto

mpls ip

interface GigabitEthernet2/0

ip vrf forwarding Customer-2

ip address 172.16.1.1 255.255.255.252

negotiation auto

interface GigabitEthernet3/0

ip vrf forwarding Customer-1

ip address 192.168.1.1 255.255.255.252

negotiation auto

router ospf 20 vrf Customer-1

log-adjacency-changes

redistribute bgp 100 subnets

network 192.168.1.0 0.0.0.3 area 1

router ospf 30 vrf Customer-2


log-adjacency-changes

redistribute bgp 100 subnets

network 172.16.1.0 0.0.0.3 area 2

router ospf 10

log-adjacency-changes

network 1.1.1.1 0.0.0.0 area 0

network 10.1.1.0 0.0.0.3 area 0

router bgp 100

no synchronization

bgp log-neighbor-changes

neighbor 2.2.2.2 remote-as 100

neighbor 2.2.2.2 update-source Loopback0

no auto-summary

address-family vpnv4

neighbor 2.2.2.2 activate

neighbor 2.2.2.2 send-community extended

exit-address-family

address-family ipv4 vrf Customer-2

redistribute ospf 30 vrf Customer-2 match internal external 1 external 2

no synchronization

exit-address-family

address-family ipv4 vrf Customer-1


redistribute ospf 20 vrf Customer-1 match internal external 1 external 2

no synchronization

exit-address-family

ip forward-protocol nd

no ip http server

no ip http secure-server

mpls ldp router-id Loopback0

control-plane

gatekeeper

shutdown

line con 0
exec-timeout 0 0

logging synchronous

stopbits 1

line aux 0

stopbits 1

line vty 0 4

End
PE2

hostname PE2

boot-start-marker

boot-end-marker

no aaa new-model

ip cef

no ip domain lookup

ip vrf Customer-1

rd 1:100

route-target export 1:100

route-target import 1:100

ip vrf Customer-2

rd 1:200

route-target export 1:200

route-target export 1:300

route-target import 1:200

route-target import 1:300

!
ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

mpls label protocol ldp

interface Loopback0

ip address 2.2.2.2 255.255.255.255


!

interface FastEthernet0/0

no ip address

shutdown

duplex half

interface GigabitEthernet1/0

ip address 10.1.1.6 255.255.255.252

negotiation auto

mpls ip

interface GigabitEthernet2/0

ip vrf forwarding Customer-1

ip address 192.168.2.1 255.255.255.252

negotiation auto

interface GigabitEthernet3/0

ip vrf forwarding Customer-2

ip address 172.16.2.1 255.255.255.252

negotiation auto

router ospf 20 vrf Customer-1

log-adjacency-changes

redistribute bgp 100 subnets

network 192.168.2.0 0.0.0.3 area 1

router ospf 30 vrf Customer-2


log-adjacency-changes

redistribute bgp 100 subnets

network 172.16.2.0 0.0.0.3 area 2

router ospf 10

log-adjacency-changes

network 2.2.2.2 0.0.0.0 area 0

network 10.1.1.4 0.0.0.3 area 0

router bgp 100

no synchronization

bgp log-neighbor-changes

neighbor 1.1.1.1 remote-as 100

neighbor 1.1.1.1 update-source Loopback0

no auto-summary

address-family vpnv4

neighbor 1.1.1.1 activate

neighbor 1.1.1.1 send-community extended

exit-address-family

address-family ipv4 vrf Customer-2

redistribute ospf 30 vrf Customer-2 match internal external 1 external 2

no synchronization

exit-address-family

address-family ipv4 vrf Customer-1


redistribute ospf 20 vrf Customer-1 match internal external 1 external 2

no synchronization

exit-address-family

ip forward-protocol nd

no ip http server

no ip http secure-server

mpls ldp router-id Loopback0

control-plane

gatekeeper

shutdown

line con 0
exec-timeout 0 0

logging synchronous

stopbits 1

line aux 0

stopbits 1

line vty 0 4

End
P
!

hostname P

boot-start-marker

boot-end-marker

no aaa new-model

ip cef

no ip domain lookup

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

mpls label protocol ldp

!
!

interface Loopback0

ip address 10.10.10.10 255.255.255.255

interface FastEthernet0/0

no ip address

shutdown

duplex half

interface GigabitEthernet1/0

ip address 10.1.1.1 255.255.255.252

negotiation auto

mpls ip

interface GigabitEthernet2/0
ip address 10.1.1.5 255.255.255.252

negotiation auto

mpls ip

router ospf 10

log-adjacency-changes

network 10.1.1.0 0.0.0.3 area 0

network 10.1.1.4 0.0.0.3 area 0

network 10.10.10.10 0.0.0.0 area 0

ip forward-protocol nd

no ip http server

no ip http secure-server

mpls ldp router-id Loopback0

control-plane

!
!

gatekeeper

shutdown

line con 0

exec-timeout 0 0

logging synchronous

stopbits 1

line aux 0

stopbits 1

line vty 0 4

End
CE11
hostname CE11

boot-start-marker

boot-end-marker

no aaa new-model

ip cef

no ip domain lookup

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!
!

interface Loopback0

ip address 11.11.11.11 255.255.255.255

interface FastEthernet0/0

no ip address

shutdown

duplex half

interface GigabitEthernet1/0

ip address 192.168.1.2 255.255.255.252

negotiation auto

router ospf 20

log-adjacency-changes

network 11.11.11.11 0.0.0.0 area 1

network 192.168.1.0 0.0.0.3 area 1


!

ip forward-protocol nd

no ip http server

no ip http secure-server

control-plane

gatekeeper

shutdown

line con 0

exec-timeout 0 0

logging synchronous

stopbits 1

line aux 0
stopbits 1

line vty 0 4

End
CE12

hostname CE12

boot-start-marker

boot-end-marker

no aaa new-model

ip cef

no ip domain lookup

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!
!

interface Loopback100

ip address 12.12.12.12 255.255.255.255

interface FastEthernet0/0

no ip address

shutdown

duplex half

interface GigabitEthernet1/0

ip address 192.168.2.2 255.255.255.252

negotiation auto

router ospf 20

log-adjacency-changes

network 12.12.12.12 0.0.0.0 area 1


network 192.168.2.0 0.0.0.3 area 1

ip forward-protocol nd

no ip http server

no ip http secure-server

control-plane

gatekeeper

shutdown

line con 0

exec-timeout 0 0

logging synchronous

stopbits 1
line aux 0

stopbits 1

line vty 0 4

end
C21
!

hostname CE21

boot-start-marker

boot-end-marker

no aaa new-model

ip cef

no ip domain lookup

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!
!

interface Loopback0

ip address 21.21.21.21 255.255.255.255

interface FastEthernet0/0

no ip address

shutdown

duplex half

interface GigabitEthernet1/0

ip address 172.16.1.2 255.255.255.252

negotiation auto

router ospf 30

log-adjacency-changes
network 21.21.21.21 0.0.0.0 area 2

network 172.16.1.0 0.0.0.3 area 2

ip forward-protocol nd

no ip http server

no ip http secure-server

control-plane

gatekeeper

shutdown

line con 0

exec-timeout 0 0

logging synchronous
stopbits 1

line aux 0

stopbits 1

line vty 0 4

End
CE22
hostname CE22

boot-start-marker

boot-end-marker

no aaa new-model

ip cef

no ip domain lookup

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!
!

interface Loopback50

ip address 22.22.22.22 255.255.255.255

interface FastEthernet0/0

no ip address

shutdown

duplex half

interface GigabitEthernet1/0

ip address 172.16.2.2 255.255.255.252

negotiation auto

router ospf 30

log-adjacency-changes

network 22.22.22.22 0.0.0.0 area 2

network 172.16.2.0 0.0.0.3 area 2


!

ip forward-protocol nd

no ip http server

no ip http secure-server

control-plane

gatekeeper

shutdown

line con 0

exec-timeout 0 0

logging synchronous

stopbits 1

line aux 0
stopbits 1

line vty 0 4

end

You might also like