You are on page 1of 6

CCNPv7 ROUTE

Chapter 2 Lab 2-2, EIGRP Stub Routing Instructor Version

Topology

Objectives
• Configure basic EIGRP.
• Configure EIGRP stub routing options.
• Verify EIGRP stub routing options

Backgroun
To ipro!e net"or# stabi$ity an% re%uce resource uti$i&ation on the '( n et"or# you ha!e %eci%e% to configure one of
the branch routers, R2 as an EIGRP stub router.
Note! This $ab uses Cisco ) *+) routers "ith Cisco IS Re$ease ).+ "ith IP ase. The s"itches are Cisco /S-
C2*01-2+TT-L "ith ast Ethernet interfaces, therefore the router "i$$ use routing etrics associate% "ith a )11 3b4s
interface. 5epen%ing on the router or s"itch o%e$ an% Cisco IS Soft"are !ersion, the coan%s a!ai$ab$e an%
output pro%uce% ight !ary fro "hat is sho"n in this $ab.

Re"uire Resources
• 6 routers 7Cisco IS Re$ease ).2 o r coparab$e8
• 6 s"itches 7L9: interfaces8

; 21)+ Cisco an%4or its affi$iates. 9$$ rights reser!e%. This %ocuent is Cisco Pub$ic. Page ) of )2
CCNPv7 ROUTE Lab 2-2, EIGRP Stub Routing

• Seria$ an% Ethernet cab$es

#tep $! #uggeste starting con%igurations&


a. 9pp$y the fo$$o"ing configuration to each rou ter a$ong "ith the appropriate 'ostna(e. The e)ec*ti(eout $ $
coan% shou$% on$y be use% in a $ab en !ironent.
Router(config)# no ip domain-lookup
Router(config)# line con 0
Router(config-line)# logging synchronous
Router(config-line)# exec-timeout 0 0

#tep +! Con%igure t'e aressing an serial links&


a. <sing the a%%ressing schee in the %iagra, configure the interfaces on each ro uter.
R1(config)# interface gigabitethernet 0/0
R1(config-if)# ip address 10.1.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# interface serial 0/0/0
R1(config-if)# ip address 10.2.2.1 255.255.255.252
R1(config-if)# clock rate 6000
R1(config-if)# no shutdown
R1(config-if)# exit

R2(config)# interface serial 0/0/0


R2(config-if)# ip address 10.2.2.2 255.255.255.252
R2(config-if)# no shutdown
R2(config-if)# exit
R2(config)# interface gigabitethernet 0/0
R2(config-if)# ip address 10.!.!.1 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# exit
R2(config)# interface serial 0/0/1
R2(config-if)# ip address 10...1 255.255.255.252
R2(config-if)# clockrate 6000
R2(config-if)# no shutdown
R2(config-if)# exit
R2(config)# interface "oopback1
R2(config-if)# ip address 1#2.16$.1.1 255.255.255.252
R2(config-if)# exit
R2(config)# interface "oopback2
R2(config-if)# ip address 1#2.16$.2.1 255.255.255.252
R2(config-if)# exit
R2(config)# interface "oopback!
R2(config-if)# ip address 1#2.16$.!.1 255.255.255.252
R2(config-if)# exit
R2(config)# interface "oopback
R2(config-if)# ip address 1#2.16$..1 255.255.255.252
R2(config-if)# exit

R3(config)# interface serial 0/0/1


R3(config-if)# ip address 10...2 255.255.255.252
R3(config-if)# no shutdown
R3(config-if)# exit
R3(config)# interface gigabitethernet 0/0
R3(config-if)# ip address 10.1.5.1 255.255.255.0
R3(config-if)# no shutdown

; 21)+ Cisco an%4or its affi$iates. 9$$ rights reser!e%. This %ocuent is Cisco Pub$ic. Page 2 of )2
CCNPv7 ROUTE Lab 2-2, EIGRP Stub Routing

R3(config-if)# exit

b. Verify connecti!ity by pinging across each of the $oca$ net" or#s connecte% to each ro uter.

c. Issue the s'o, ip inter%ace brie% coan% on each router. This coan% %isp$ays a brief $isting of the
interfaces, their status, an% their IP a%%resses. Router R2 is sho"n as an e=ap$e.
R2# show ip interface brief
Interface IP-Address OK? Method tatus Protocol
!"edded-er$ice-!ngine%&% unassigned '! unset ad"inistrati$el don don
*igait!thernet%&% 1%+3+3+1 '! "anual u, u,
erial%&%&%
erial%&%&1 1%+2+2+2
1%+++1 '!
'! "anual
"anual u,
u, u,
u,
R2#

#tep -! Con%igure EI.RP&


a. Enab$e EIGRP 9S )11 for a$$ interfaces on R) an% R2. or your reference, these are the coan%s "hich can be
use%>
R1(config)# router eigrp 100
R1(config-router)# network 10.0.0.0

R2(config)# router eigrp 100


R2(config-router)# network 10.0.0.0
R2(config-router)# network 1#2.16$.0.0 0.0.255.255

b. Suari&e R2?s $oopbac# interfaces in its EIGRP up%ate to R) using anu a$ suari&ation.
R2(config)# interface serial 0/0/0
R2(config-if)# ip summary-address eigrp 100 1#2.16$.0.0 255.255.2$.0

c. Configure a static route on R2 to R6?s L9:. Configure a %efau$t static route on R6 for"ar%ing a$$ traffic to R2.
R2(config)# ip route 10.1.5.0 255.255.255.0 10...2

R3(config)# ip route 0.0.0.0 0.0.0.0 10...1

%. Verify that R2 an% R6 can ping the other?s L9: intefaces.


R2# ping 10.1.5.1
.,e esca,e se/uence to aort+
ending 0 1%%-te IMP !chos to 1%+1+0+1 ti"eout is 2 seconds
44444
uccess rate is 1%% ,ercent (0&0) round-tri, "in&a$g&"a5 6 27&27&27 "s
R2#

R3# ping
.,e 10.!.!.1
esca,e se/uence to aort+
ending 0 1%%-te IMP !chos to 1%+3+3+1 ti"eout is 2 seconds
44444
uccess rate is 1%% ,ercent (0&0) round-tri, "in&a$g&"a5 6 27&27&27 "s
R3#

; 21)+ Cisco an%4or its affi$iates. 9$$ rights reser!e%. This %ocuent is Cisco Pub$ic. Page 6 of )2
CCNPv7 ROUTE Lab 2-2, EIGRP Stub Routing

e. Verify the EIGRP the neighbor re$ationship bet"een R) an% R2 "ith the s'o, ip eigrp neig'bors coan%.
Verify that R) is recei!ing a suary route for R2?s $oopbac# net"or#s. The output for R2 is as fo$$o"s.
R2# show ip eigrp neighbors
!I*RP-IP$ 8eighors for A(1%%)
9 Address Interface 9old :,ti"e R.. R.O ; e/
(sec) ("s) nt 8u"
% 1%+2+2+1 e%&%&% 12 %%012< 3<3 21=7 % >
R2#

f. E=aine R)?s routing tab$e "ith the s'o, ip route eigrp coan%.
R1# show ip route
odes  -- !I*RP
local !B
 -- connected  - static
!I*RP e5ternal R - IA
O - OPC RIP M - "oile
- OPC @ - @*P
inter area
81 - OPC 8A e5ternal t,e 1 82 - OPC 8A e5ternal t,e 2
!1 - OPC e5ternal t,e 1 !2 - OPC e5ternal t,e 2
i - I-I su - I-I su""ar 1 - I-I le$el-1 2 - I-I le$el-2
ia - I-I inter area D - candidate default : - ,er-user static route
o - OR P - ,eriodic donloaded static route 9 - 89RP l - IP
a - a,,lication route
E - re,licated route F - ne5t ho, o$erride

*atea of last resort is not set

1%+%+%+%&7 is $arial sunetted < sunets 3 "asGs


 1%+1+1+%&2 is directl connected *igait!thernet%&%
 1%+1+1+1&32 is directl connected *igait!thernet%&%
 1%+2+2+%&3% is directl connected erial%&%&%
 1%+2+2+1&32 is directl connected erial%&%&%
 1%+3+3+%&3% H>%&21=21< $ia 1%+2+2+2 %%0207 erial%&%&%
 1%+++%&3% H>%&2<7170< $ia 1%+2+2+2 %%0207 erial%&%&%


R1# 1>2+1<7+%+%&21 H>%&22>=70< $ia 1%+2+2+2 %%=%2 erial%&%&%

5oes R) ha!e a route to R6?s L9:@ /hy or "hy not.


AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA

:o. R6 is not ip$eenting EIGRP an% R) %oes not ha!e a route to the )1.)..142+ net"or#.

#tep /! Con%igure an veri%y EI.RP stub routing&


a. EIGRP stub routing feature enab$e you to $iit the EIGRP (uery essages scope in the net"or#. Routers
configure% as stubs %o not for"ar% EIGRP $earne% routes to other neighbors.
<se the eigrp stub coan% to configure a router as a stub "here the router %irects a$$ IP traffic to a % istribution
router.
The eigrp stub coan% can be o%ifie% "ith se!era$ options, an% these options can be use% in any
cobination e=cept for the receive*only #ey"or%. The receive*only #ey"or% "i$$ restrict the router fro sharing
any of its routes "ith any other router in that EIGRP autonoous syste, an% the receive*only #ey"or% "i$$ not
perit any other option to be specifie% because it pre!ents any type of route fro being sent. The four other
optiona$ #ey"or%s 7connecte, static, su((ary, an% reistribute8 can be use% in any cobination but cannot
be use% "ith the receive*only #ey"or%.

; 21)+ Cisco an%4or its affi$iates. 9$$ rights reser!e%. This %ocuent is Cisco Pub$ic. Page + of )2
CCNPv7 ROUTE Lab 2-2, EIGRP Stub Routing

If any of these fi!e #ey"or%s is use% "ith the eigrp stub coan%, on$y the route types specifie% by the
particu$ar #ey"or%7s8 "i$$ be sent. Route types specifie% by the reaining #ey"or%s "i$$ not be sent.
The connecte #ey"or% perits the EIGRP stub routing feature to sen% connecte% routes. If the connecte%
routes are not co!ere% by a net"or# stateent, it ay be necessary to re%istribute connecte% routes "ith the
re%istribute connecte% coan% un%er the EIGRP process. This option is enabled by default.
The static #ey"or% perits the EIGRP stub routing feature to sen% static routes. /ithout the configuration of this
option, EIGRP "i$$ not sen% any static routes, inc$u%ing interna$ static routes that nora$$y "ou$% be autoatica$$y
re%istribute%. It "i$$ sti$$ be necessary to re%istribute static routes "ith the re%istribute static coan%.
The su((ary #ey"or% perits the EIGRP stub routing feature to sen% suary routes. Suary routes can be

create% anua$$y "ith the suary a%%ress coan% or autoatica$$y at a aBor net"or# bor%er router "ith the
auto-suary coan% enab$e%. This option is enabled by default.
The reistribute #ey"or% perits the EIGRP stub routing feature to sen% other routing protoco$s an%
autonoous systes. /ithout the configuration of this option, EIGRP "i$$ not a%!ertise re%istribute% routes.
Note> There is one ore #ey"or% the leak*(ap option. The leak*(ap #ey"or% perits the EIGRP stub routing
feature to reference a $ea# ap that i%entifies routes that are a$$o"e% to be a%!ertise% on an EIGRP stub router
that "ou$% nora$$y ha!e been suppresse%.

Configure R2 as a stub router using the %efau$t eigrp stub coan%.


R2(config)# router eigrp 100
R2(config-router)# eigrp stub %
connected o ad$ertise connected routes
leaG-"
a, Allo dna"ic ,refi5es ased on the leaG-"a,
recei$e-onl et recei$e onl neighor
redistriuted o ad$ertise redistriuted routes
static o ad$ertise static routes
su""ar o ad$ertise su""ar routes
Jcr
R2(config-router)# eigrp stub
DLul 22 %%1%2+<<= F:A-0-8@R9A8*! !I*RP-IP$ 1%% 8eighor 1%+2+2+1
(erial%&%&%) is don ,eer info changed
R2(config-router)#
DLul 22 %%1%3+7>> F:A-0-8@R9A8*! !I*RP-IP$ 1%% 8eighor 1%+2+2+1
(erial%&%&%) is u, ne adacenc
R2(config-router)

b. E=aine the EIGRP section in R2?s running-config. /hat EIGRP stub options are ip$eente% by %efau$t@
R2# show running-config & section eigrp
i, su""ar-address eigr, 1%% 1>2+1<7+%+% 200+200+27+%
router eigr, 1%%
netorG 1%+%+%+%
netorG 1>2+1<7+%+% %+%+200+200
eigr, stu connected su""ar
R2#

/hat EIGRP stub options are ip$eente% by %efau$t@


AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
y %efau$t, the connecte% an% suary options are use%.

; 21)+ Cisco an%4or its affi$iates. 9$$ rights reser!e%. This %ocuent is Cisco Pub$ic. Page  of )2
CCNPv7 ROUTE Lab 2-2, EIGRP Stub Routing

i, address 1%+++1 200+200+200+202


clocG rate <%%%
no shutdon
4
router eigr, 1%%
netorG 1%+%+%+%
netorG 1>2+1<7+%+% %+%+200+200
redistriute static
eigr, stu recei$e-onl
4
i, route 1%+1+0+% 200+200+200+% 1%+++2
4
end

Router R/
4
hostna"e R3
4
interface erial%&%&1
i, address 1%+++2 200+200+200+202
no shutdon
4
interface *igait!thernet%&%
i, address 1%+1+0+1 200+200+200+%
no shutdon
4
i, route %+%+%+% %+%+%+% 1%+++1
4
end

; 21)+ Cisco an%4or its affi$iates. 9$$ rights reser!e%. This %ocuent is Cisco Pub$ic. Page )2 of )2

You might also like