You are on page 1of 2

WMS1

:local ip [/ip address get [/ip address find interface="wlan1"] address];

:local mac [/interface wireless get [ find default-name=wlan1 ] mac-address];

:local ip [put [:pick $ip 0 [:find $ip "/"]]];

/tool fetch http-method=post http-data="username=adi@freeMS&password=adi"


url=("https://welcome2.wifi.id/wms/auth/authnew/autologin/quarantine.php\?
ipc=$ip&gw_id=WAG-D5-KBL&client_mac=$mac&wlan=NDLNDL00098/TLK-WI32126651-
0001:GILANG%20HOTSPOT") keep-result=no

WIFI-ID

:local ip [/ip address get [/ip address find interface="wlan1"] address];

:local mac [/interface wireless get [ find default-name=wlan1 ] mac-address];

:local ip [put [:pick $ip 0 [:find $ip "/"]]];

/tool fetch http-method=post http-data="username=9106406xxx@spin2&password=ape"


url=("https://welcome2.wifi.id/authnew/login/check_login.php\?ipc=$ip&gw_id=WAG-D5-
KBL&client_mac=$mac&wlan=NDLNDL00098/TLK-WI32126651-0001:%40wifi.id") keep-
result=no;

OPENWRT

#!/bin/bash

# Check ip from isp

ipwan=$(ifconfig | grep -A 2 'wlan0' | awk '/inet addr/{print substr($2,6)}')

# Test Connection

if ping -q -c 1 -W 1 8.8.8.8 >/dev/null;

then

echo "The network is up"

else
echo "The network is down"

# Login

wget --post-data="username=lordkiehl@freeMS&password=pa$$wrd"
"http://welcome2.wifi.id/wms/auth/authnew/autologin/quarantine.php?
ipc="$ipwan"&gw_id=WAG-D4-KBU&client_mac=xx:b4:29:d8:xx:ce&wlan=SLOGLD00371/TLK-
WI31477992-0001:UN%20CHECK" -O /dev/null

fi

WMS2

:local ip [/ip address get [/ip address find interface="wlan1"] address];

:local ip [put [:pick $ip 0 [:find $ip "/"]]]

/tool fetch http-method=post http-data="username=lordkiehl@freeMS&password=pa$$wd"


url=("http://welcome2.wifi.id/wms/auth/authnew/autologin/quarantine.php\?
ipc=$ip&gw_id=WAG-D4-KBU&client_mac=xx:xx:xx:xx:xx:xx&wlan=SLOGLD00371/TLK-
WI31477992-0001:UN%20CHECK") keep-result=no

You might also like