You are on page 1of 26

Casa to ARRIS Command Reference

For Commands Contained in the C100G Lab

May 2016
© 2016 Casa Systems, Inc.
All rights reserved. Licensed software products are owned by Casa Systems or its suppliers and are protected by United States
copyright laws and international treaty provisions.

The information regarding the product in this manual is subject to change without notice. All statements, information, and
recommendations in this manual are believed to be accurate but are presented without warranty of any kind, express of implied.
Users must take full responsibility for their application of the product.

In no event shall Casa or its suppliers be liable for any indirect, special, consequential, or incidental damages, including, without
limitation, lost profits or loss or damage to data arising out of the use or inability to use this manual, even if Casa or its suppliers
have been advised of the possibility of such damages.
Lab Guide CLI Conversion
Table; Casa to ARRIS

Function Casa Command ARRIS Command


show cable modem show cable modem
show ip route show ip route
enable enable
exit exit
ping <ipaddr> ping {ipaddr}
show run show
config configure
{terminal|memory|network|overwrite-
network}
copy <orig> <dest> copy <orig> <dest>
copy run start write [memory|terminal|networkfile|erase]
del <filename> delete <filename>
del startup-config erase startup-configuration
Redundancy
High Availability on by default.
CPU Redundancy SMM HA: (RSM) Redundancy
show current status show system show linecard status
force failover ha module <module #> protect Contact ARRIS Technical Support
show sync status show smm sync-status
I/O Module Redundancy I/O HA: CAM Sparing
show current status show ha configuration show spare-group
show linecard status
force failover ha module <module #> protect configure slot <slot> shutdown
configure slot <slot> no shutdown

Image and File


Management
copy a configuration file copy nvram startup-config nvram copy /system/cfgfiles/<filename>
prep-upgradeX /system/cfgfiles/<newfilename>
show files and directories ls dir
show c:[ all | filesys]
tftp config file to server copy nvram prep-upgradeX tftp copy /system/cfgfiles/<filename>
10.4.1.3 tftp://<tftpserver ip address>/<filename>
show current software show bootdev show version detail < 6 | 7 >
version show image
ftp a new software version copy ftp <your username> 10.4.1.3 copy
to the CCAP ccsi.gz.rel7.7.0.0_build4479 nvram ftp://login:password@ftpserverip/<image
name> /loads/<image name>
apply a service patch to an system patch apply patch install <patch file>
image classpatch_pb31ba.tgz
remove a patch remove patch patch remove <patch file>
classpatch_pb31ba.tgz

1
Casa Command ARRIS Command
configure image to load on system bootdev nvram reload <image file>
next reboot ccsi.gz.rel7.7.0.0_build4479 reload commit
reboot system system reboot reload
view system module status show system

Enable LACP
configure trunking interface trunk <trunk #> configure interface link-aggregate <0-7> min-
<interface> mode active links <1-8>
<interface> mode active configure interface link-aggregate <0-7> lacp
no shutdown mode enable
configure interface Ethernet <6/7>/<0-7>
link-aggregate <0-7>
configure interface link-aggregate <0-7>
shutdown no
view LACP information show lacp summary show lacp [6/7] [{counters \ local \ partner \
sys-id}]

Configure a VLAN with the interface vlan <vlan id>


Trunk as an Interface trunk <trunk #>
ip address <ip address> <mask>
ipv6 address <ipv6 address>/64
bdf interval 100 min_rx 100
multiplier 4
no shutdown

Configure a Loopback interface loopback <#> configure interface loopback <0…13> ip


Interface ip address <loopback ip address> address <ipaddress>/32 shutdown no
255.255.255.255

Configure DHCP Relay for interface ip-bundle <#> configure interface cable-mac <mac> cable
CMs and CPEs ip address <ipaddress> <mask> helper-address <DHCP Server IP address> [
ip address <ip address> <mask> cable-modem | host | cpe | mta | ps | stb |
secondary any ]
cable helper-address <dhcp server
ip address>

ipv6 address <ipv6 address/mask>


cable helper-ipv6-address <dhcp
server ipv6 address>

2
Casa Command ARRIS Command
Configure OSPF v2
create an OSPF routing router ospf 1 configure router ospf vrf default router-id
instance passive-interface ip-bundle 1 <router id>
network <network ip>/30 area 0 configure router ospf [ vrf default ]
network <loopback ip address>/32 network <ip address> <inverse mask>
area 0 area <area id>
network <CM network>/24 area 0 configure router ospf vrf default
network <CPE subnet>/24 area 0 redistribute connected [metric <int>]
area 0 authentication message- [metric-type <type>] [tag <int>]
digest configure router ospf vrf default no
log-adjacency-changes shutdown

assign routing to a VLAN interface vlan <vlan id>


interface ip ospf network point-to-point
ipv6 ospf network point-to-point
ipb6 router ospf 1 area 0.0.0.0
ip ospf authentication message-
digest
ip ospf message-digest-key 1 md5
are2@casa
no shutdown
end

Configure OSPFv3
configure global OSPv3 router ospf6 1 configure ipv6 router ospf router-id
parameters router-id <router id> <router id>
redistribute connected configure ipv6 router ospf redistribute
end connected
end
clear ipv6 ospf process configure ipv6 router ospf shutdown no
yes

Verify BFD
verify BFD show bfd session
show bfd session detail

Verify OSPFv4
verify OSPFv4 show ip ospf show ip ospf
show ip ospf interface vlan <vlan show ip ospf interface
id>
show ip ospf neighbor detail show ip ospf neighbor
show ip ospf database show ip ospf database

3
Casa Command ARRIS Command
Verify OSPFv3
verify OSPFv3 show ipv6 ospf show ipv6 ospf
show ipv6 ospf interface vlan <vlan show ipv6 ospf interface [brief]
id>
show ipv6 ospf neighbor detail show ipv6 ospf neighbor [ip address]
show ipv6 ospf neighbor [detail]
show ipv6 route ospf show ipv6 ospf neighbor
show ipv6 ospf database show ipv6 ospf database

OSPF ASBR Configuration


create a RIP instance interface ip-bundle 1.2
ip address <ip address>/24
exit
router rip configure router rip network <network
network <IP Bundle 1.2 CPE IP address>
address> 255.255.255.0
exit
create an IP Prefix List ip prefix-list redistribute_rip permit configure ip prefix-list <prefix list name>
172.16.1x.1/24 <ip network/mask>
exit
show ip prefix-list detail
create a Route Map route-map connect_rip_to_ospf configure route-map <route map name>
permit 10 permit 10 match ip address prefix-list
match ip address prefix-list <prefix list name>
redistribute_rip
exit
redistribute the RIP route router ospf 1
redistribute connected route-map
connect_rip_to_ospf
show this
check your work show ip ospf database show ip ospf database
show ip route show ip route
show ip ospf show ip ospf
show ip ospf border-routers

4
Casa Commands ARRIS Commands
IBGP/LDP/MPLS
Configuration
create a VRF table vrf definition <vrf name> configure ip vrf <vrf name>
definition rd 1:1 configure vrf <vrf name> route-
distinguisher <rd>
address-family ipv4 configure vrf <vrf name> address-family
ipv4
route-target export 1:1 configure vrf <vrf name> route-target
export <rt>
route-target import 1:1 configure vrf <vrf name> route-target
import <rt>
exit

create a network to interface ip-bundle 1.1 configure interface Ethernet 6/1.1 ip


associate with the VRF vrf forwarding casalabs address <ip address> <mask>
ip address <ip address> configure interface Ethernet 6/1.1 ip vrf
255.255.255.0 forwarding <vrf name>
enable MPLS and LDP on interface vlan <vlan id>
the trunk interface mpls ip configure interface Ethernet 6/2 mpls ip
enable-ldp ipv4 configure mpls ldp shutdown no

5
Casa Commands ARRIS Commands
create the LDP peering to router ldp configure mpls ldp router-id loopback 1
your neighbor router router-id <your loopback address>
transport-address ipv4 <your
loopback address>
exit
configure mpls ldp shutdown no

Verify IBGP/LDP/MPLS
verify BGP/MPLS show ip bgp neighbor show ip bgp neighbor
show ip route vrf casalabs show ip route vrf <vrf name>
show mpls ldp neighbor show mpls ldp neighbors [<IPv4>] [detail]

Configuring EoMPLS
establish LDP targeted configure interface ethernet 6/0 mpls ip
peers configure interface ethernet 7/0 mpls ip
configure l2vpn forwarding enable
configure l2vpn cable-mac 1
configure l2vpn cm capability optional
router ldp configure mpls ldp router-id loopback 0
configure mpls ldp vc description "vc from
%M on Host %H"
targeted-peer ipv4 <peer device IP> configure mpls ldp neighbor <IPv4>
targeted
configure mpls ldp shutdown no
show ldp targeted-peers
exit
create EoMPLS instances mpls vpws <vpws name>
to each targeted peer peer <peer ip address> <virtual configure mpls ldp neighbor <IPv4>
circuit ID> targeted
exit (It appears this command both sets the
show mpls vpws xconnect targeted peer and establishes the VPWS.)
assign cable modem to show cable modem Implement parameters in the CM config
each VPWS cable modem <cm MAC address> file
mpls vpnid <vpws name>
clear cable modem reset
show mpls vpws xconnect

6
Casa command ARRIS command
Configuring VPLS
establish LDP targeted configure interface ethernet 6/0 mpls ip
peers configure interface ethernet 7/0 mpls ip
configure l2vpn forwarding enable
configure l2vpn cable-mac 1
configure l2vpn cm capability optional
router ldp configure mpls ldp router-id loopback 0
configure mpls ldp vc description "vc from
%M on Host %H"
configure mpls ldp neighbor <IPv4>
targeted-peer ipv4 <peer device IP> targeted
configure mpls ldp shutdown no

show ldp targeted-peers


exit
add routers to your BGP configure vrf <name> auto-import disable
instance as neighbors router bgp 64512
neighbor <neighbor IP address> configure router bgp neighbor <neighbor
remote-as 64512 IP address> remote-as 64512
neighbor <neighbor IP address> configure router bgp neighbor <neighbor
update-source loopback 0 IP address> update-source loopback 1
add routers to your L2VPN address-family l2vpn vpls configure router bgp 64512 address-
address family family vpnv4 enable
neighbor <neighbor ip address> configure router bgp 64512 address-
activate family ipv4 neighbor <neighbor ip
address> activate
configure router bgp 64512
address-family vpnv4 neighbor
<neighbor ip address> activate
neighbor <neighbor ip address>
send-community extended
exit-address-family
establish your VPLS name mpls vpls casalab_vpls 1000 configure vrf casalab_vpls auto-import
and instance identifier disable
configure BGP as your signaling bgp ve-id <ve-id>
signaling protocol signaling bgp route-distinguisher configure vrf casalab_vpls rd 100:1
<rd>
signaling bgp route-target <rt> configure vrf casalab_vpls route-
target export 100:1
configure vrf casalab_vpls address-
family ipv4 redistribute
connected
configure vrf casalab_vpls address-
family ipv4 redistribute static
show this
exit
add a BPI-enabled cable cable modem <cm MAC address> configure interface cable-mac 101.2 ip
modem to the VPLS mpls vpnid casalabs_vpls address 195.168.217.254 255.255.255.0

7
configure interface cable-mac 101.2 cable
helper-address 10.10.10.10
configure interface cable-mac 101.2 ip vrf
forwarding CUSTOMER_1
clear cable modem <cm MAC
address>
show mpls vpls casalab_vpls detail

SysAdmin Configurations
enable “Save system reboot confirm
Configuration” message
configure SSH keys ssh-server gen-hostkey ? configure crypto key generate dsa

set system time show timezone list


system timezone <string> configure clock timezone <timezone
name> | <GMT [+ | -hh[ :mm]]
system clock <MMDDhhmmYYYY> configure clock set
<yyyy:mm:dd:hh:mm:ss>
show clock show clock [detail] [GMT] [network]
[timezone]
configure NTP ntp server 10.4.1.3 configure ntp server <ipv4 addr>
[broadcast] [burst] [key] [manycast]
[maxpoll <4-11>] [minpoll
<4-11>] [multicast] [prefer] [version <2-
4>]
configure ntp server <ipv4 addr> [
broadcast | multicast | manycast ]
ntp sync 10.4.1.3
configure DNS nameserver 10.4.1.3 configure ip name-server <server-
address>
configure ip domain-lookup
configure Privileged Mode password <password> configure enable password <password>
password privilege <0-15>
encrypt passwords in service password-encryption This is the default on the E6000
running config
add local user adduser ckent privilege 15 configure username <userid> password
Superman15 <password> privilege <0-15>
delete local user deluser jimmy configure no username <userid>

8
Casa commands ARRIS commands
create CLI aliases alias ccm “clear cable modem” alias ccm clear cable modem
alias cpu “show cpu-process | esc
00:00:00
alias du “show docsis downstream
channel utilization”
alias scgv “show service group alias scgv show cable service group
verbose”
alias scm “show cable modem” alias scm show cable modem
alias scmv “show cable modem
verbose”
alias uptime “show cpuinfo all | i
up”
alias crs “copy running-config
startup-config”

configure local logging show logging all show logging


logging system informational configure logging console 7
logging system errors configure logging console 3
configure Syslog logging host 10.4.1.3 configure logging host <ip address>
logging syslog warning configure logging syslog 3
show syslog show logging syslog
logging source-interface loopback
configure SNMP snmp default
snmp community readmibs ro configure snmp-server community
readmibs security rotesting
snmp community letmewrite rw configure snmp-server community
letmewrite rwtesting
device contact admin@casa- configure snmp-server contact <contact
systems.net information string>
device location training_lab configure snmp-server location
<location>
configure SNMPv2 nmp tgt-addr class-srv2
snmpUDPDomain 10.4.1.4 500 1
TrapV2cSNMPv2cTrapsTagList
TrapV2cSNMPv2cTraps non-
volatile 0.0.0.0 500

snmp inform version 2


snmp notify tapUserTrapTagList
tapUserTrapTagList trap non-
volatile
snmp trap-source loopback 0
device contact admin@www.casa-
systems.net
device location training_lab

9
Casa command ARRIS command
configuring traps interface docsis-mac 1
cm trap configure cable enable-trap
cm trap interval 10
exit
configure SNMP snmp community casaadmin rw configure snmp-server community
communities casaadmin security rwtesting
snmp community casastudent ro configure snmp-server community
casastudent security rotesting

create SNMP community ip access-list limit-snmp


with restricted access to permit snmp 10.4.1.4
the MIB tree 255.255.255.255 <your loopback
IP>
deny snmp any any
exit
show ip access-list limit-snmp

snmp tree-family scout


1.3.6.1.4.1.20858.10.24 – include
non-volatile

snmp access scout-grp – snmpv2c


no-auth exact scout scout scout
non-volatile
snmp security snmpv2c scoutgrp-
usr scout-grp non-volatile
snmp community imagereader ro
security scoutgrp-usr access-group
limit-snmp

configure PIM traps ip pim trap invalid-pim-message


enable
ip pim trap neighbor-change enable
ip pim trap rp-mapping-change
enable

10
Casa commands ARRIS commands
configuring TACACS+ tacacs-server host 10.4.1.4 configure tacacs host 10.4.1.4 key
tacacs-server key bl@hbl@hwh@t3v3r
bl@hbl@hwh@t3v3r

aaa authentication login default


group tacacsplus
aaa authentication enable default
group tacacsplus enable
aaa authentication login
tacacsplus-local
aaa authorization command 0
default if-authenticated
aaa authorization command 15
default if-authenticated
aaa accounting
aaa accounting commands 0
default stop-only
aaa accounting commands 1
default stop-only
aaa accounting commands 15
default stop-only

aaa tacacs-source loopback 0

Access Control Lists


create an access list to ip access-list restrict-telnet configure access-list restrict-telnet deny
restrict telnet remark “deny TELNET access to tcp 10.4.1.4 0.0.0.0 eq 23
class-srv2” configure access-list restrict-telnet
deny telnet 10.4.1.4 remark “deny TELNET access to class-
255.255.255.255 any srv2”
exit
apply the ACL to your interface vlan 200 configure interface Ethernet
VLAN ip access-group restrict-telnet <slot>/<port> ip access-group restrict-
telnet in
remove the ACL no ip access-group configure interface Ethernet
<slot>/<port> no ip access-group restrict-
telnet in

11
Casa commands ARRIS commands
Create a Global Access
Class
create an ACL ip access-list restrict-ssh configure access-list restrict-ssh permit
remark “allow ssh only to the tcp any eq 22 <your loopback IP address>
loopback address” 0.0.0.0
permit ssh any <your loopback IP configure access-list restrict-ssh deny tcp
address> 255.255.255.255 any eq 22 any
deny ssh any any
exit

apply the ACL as an access access-class in restrict-ssh


class
remove the access class no access-class in

Diagnosing NSI Interface


Issues
diagnose interface issues show ip interface brief show ip interface
show controller eth show controllers ethernet
show controller upstream show controllers cable-upstream
show controller qam show controllers cable-downstream
show iftable eth
diagnose memory issues show meminfo show memory
show cpu-memory process list
show gigabit-rx-cpu-rate
show debugging
diagnose DHCP issues show dhcp-trace trace logging dhcp
diagnose High Availability show ha configuration
issues show ha hardware qam 8x96
recovery
show ha switch fault monitor status
diagnose Trunking issues show lacp summary show lacp summary
obtain System Information show bootdev show image committed
show envm show environment
diagnose Initialization show alarm
Processes show dmesg
show log show logging
show tech show tech-support

12
RFI Configurations
Casa commands ARRIS commands
configure Downstream interface qam 0/0
Transmitters (Annex B) no shutdown
power 550 configure interface cable-downstream
0/0 power-level 550
channel 0 description FNB configure interface cable-downstream
0/0/0 description FNB
channel 0 frequency 555000000 8 configure interface cable-downstream
0/0/0 cable frequency 555000000
configure interface cable-downstream
0/0/1 cable frequency 561000000
configure interface cable-downstream
0/0/2 cable frequency 567000000
configure interface cable-downstream
0/0/3 cable frequency 573000000
configure interface cable-downstream
0/0/4 cable frequency 579000000
configure interface cable-downstream
0/0/5 cable frequency 585000000
configure interface cable-downstream
0/0/6 cable frequency 591000000
configure interface cable-downstream
0/0/7 cable frequency 597000000
no channel 0 shutdown 8 configure interface cable-downstream
0/0/0 no shutdown
configure interface cable-downstream
0/0/1 no shutdown
configure interface cable-downstream
0/0/2 no shutdown
configure interface cable-downstream
0/0/3 no shutdown
configure interface cable-downstream
0/0/4 no shutdown
configure interface cable-downstream
0/0/5 no shutdown
configure interface cable-downstream
0/0/6 no shutdown
configure interface cable-downstream
0/0/7 no shutdown

13
Casa commands ARRIS commands
configure Upstream show interface upstream brief
Receivers interface upstream 13/0.0
frequency 20000000 configure interface cable-upstream
13/0/0 cable frequency 20000000
no shutdown configure interface cable-upstream
no logical-channel 0 shut 13/0/0.0 no shutdown

interface upstream 13/0.1 configure interface cable-upstream


frequency 24000000 13/0/1 cable frequency 24000000
no shutdown configure interface cable-upstream
no logical-channel 0 shutdown 13/0/1.0 no shutdown

interface upstream 13/0.2 configure interface cable-upstream


frequency 28000000 13/0/2 cable frequency 28000000
no shutdown configure interface cable-upstream
no logical-channel 0 shutdown 13/0/2.0 no shutdown

interface upstream 13/0.3 configure interface cable-upstream


frequency 32000000 13/0/3 cable frequency 32000000
no shutdown configure interface cable-upstream
no logical-channel 0 shutdown 13/0/3.0 no shutdown

show interface upstream brief


configure Downstream interface qam 0/1
Transmitters (Annex A) no shutdown
annex A install an Annex A DCAM
power 550 configure interface cable-downstream
0/1 power-level 550

channel 0 description FNA configure interface cable-downstream


0/1/0 description FNA

channel 0 frequency 650000000 8 configure interface cable-downstream


0/1/0 cable frequency 655000000
configure interface cable-downstream
0/1/1 cable frequency 663000000
configure interface cable-downstream
0/1/2 cable frequency 671000000
configure interface cable-downstream
0/1/3 cable frequency 679000000
configure interface cable-downstream
0/1/4 cable frequency 687000000
configure interface cable-downstream
0/1/5 cable frequency 695000000
configure interface cable-downstream
0/1/6 cable frequency 703000000

14
configure interface cable-downstream
0/1/7 cable frequency 711000000
no channel 0 shutdown 8 configure interface cable-downstream
0/1/0 no shutdown
configure interface cable-downstream
0/1/1 no shutdown
configure interface cable-downstream
0/1/2 no shutdown
configure interface cable-downstream
0/1/3 no shutdown
configure interface cable-downstream
0/1/4 no shutdown
configure interface cable-downstream
0/1/5 no shutdown
configure interface cable-downstream
0/1/6 no shutdown
configure interface cable-downstream
0/1/7 no shutdown

configure Upstream interface upstream 13/1.0 configure interface cable-upstream


Receivers (Annex A) frequency 20000000 13/1/0 cable frequency 20000000
no shutdown configure interface cable-upstream
no logical-channel 0 shutdown 13/1/0.0 no shutdown
i
nterface upstream 13/1.1 configure interface cable-upstream
frequency 24000000 13/1/1 cable frequency 24000000
no shutdown configure interface cable-upstream
no logical-channel 0 shutdown 13/1/1.0 no shutdown

interface upstream 13/1.2 configure interface cable-upstream


frequency 28000000 13/1/2 cable frequency 28000000
no shutdown configure interface cable-upstream
no logical-channel 0 shutdown 13/1/2.0 no shutdown

interface upstream 13/1.3 configure interface cable-upstream


frequency 32000000 13/1/3 cable frequency 32000000
no shutdown configure interface cable-upstream
no logical-channel 0 shutdown 13//3.0 no shutdown

show interface upstream brief

15
Casa commands ARRIS commands
configure DOCSIS MAC interface docsis-mac 1
interface for Annex B downstream 1 interface qam 0/0/0 configure interface cable-downstream
0/0/0 type docsis cable-mac 1
downstream 2 interface qam 0/0/1 configure interface cable-downstream
0/0/1 type docsis cable-mac 1
downstream 3 interface qam 0/0/2 configure interface cable-downstream
0/0/2 type docsis cable-mac 1
downstream 4 interface qam 0/0/3 configure interface cable-downstream
0/0/3 type docsis cable-mac 1
downstream 5 interface qam 0/0/4 configure interface cable-downstream
0/0/4 type docsis cable-mac 1
downstream 6 interface qam 0/0/5 configure interface cable-downstream
0/0/5 type docsis cable-mac 1
downstream 7 interface qam 0/0/6 configure interface cable-downstream
0/0/6 type docsis cable-mac 1
downstream 8 interface qam 0/0/7 configure interface cable-downstream
0/0/7 type docsis cable-mac 1

upstream 1 interface upstream configure interface cable-upstream


13/0.0/0 13/0/0 cable cable-mac 1
upstream 2 interface upstream configure interface cable-upstream
13/0.1/0 13/0/1 cable cable-mac 1
upstream 3 interface upstream configure interface cable-upstream
13/0.2/0 13/0/2 cable cable-mac 1
upstream 4 interface upstream configure interface cable-upstream
13/0.3/0 13/0/3 cable cable-mac 1

ip bundle 1 configure interface cable-mac 1.0 cable


helper-address x.x.x.x

16
Casa commands ARRIS commands
configure DOCSIS MAC interface docsis-mac 2
interface for Annex A downstream 1 interface qam 0/1/0 configure interface cable-downstream
0/1/0 type docsis cable-mac 2
downstream 2 interface qam 0/1/1 configure interface cable-downstream
0/1/1 type docsis cable-mac 2
downstream 3 interface qam 0/1/2 configure interface cable-downstream
0/1/2 type docsis cable-mac 2
downstream 4 interface qam 0/1/3 configure interface cable-downstream
0/1/3 type docsis cable-mac 2
downstream 5 interface qam 0/1/4 configure interface cable-downstream
0/1/4 type docsis cable-mac 2
downstream 6 interface qam 0/1/5 configure interface cable-downstream
0/1/5 type docsis cable-mac 2
downstream 7 interface qam 0/1/6 configure interface cable-downstream
0/1/6 type docsis cable-mac 2
downstream 8 interface qam 0/1/7 configure interface cable-downstream
0/1/7 type docsis cable-mac 2

upstream 1 interface upstream configure interface cable-upstream


13/2.0/0 13/0/0 cable cable-mac 2
upstream 2 interface upstream configure interface cable-upstream
13/2.1/0 13/0/1 cable cable-mac 2
upstream 3 interface upstream configure interface cable-upstream
13/2.2/0 13/0/2 cable cable-mac 2
upstream 4 interface upstream configure interface cable-upstream
13/2.3/0 13/0/3 cable cable-mac 2

ip bundle 1 configure interface cable-mac 2.0 cable


helper-address x.x.x.x

DOCSIS Security
Configurations
enable Early early-authentication-encryption
Authentication and ranging
Encryption
enable TFTP Proxy/TFTP tftp enforce configure interface cable-mac <mac>
Enforce cable tftp-enforce
configure interface cable-mac <mac>
cable dynamic-secret {block | lock | mark
| reject}
enable BPI enforce cable privacy bpi-enforce configure interface cable-mac <mac>
mandatory cable privacy mandatory
cable privacy bpi-plus-enforce configure interface cable-mac <mac>
mandatory cable privacy mandatory bpi-plus

17
Casa commands ARRIS commands
PHY and DOCSIS MAC Best
Practices
configure Static MAP map-advance static 200
Advance
configure Interleave level interleave 16 configure interface cable-downstream
0/0/0 cable interleave-depth 16
enable pre-equalization logical-channel 0 pre-equalization
auto reset auto-reset

Modulation Profiles
examine current show modulation-profile
Modulation Profiles show interface upstrea 13/0.0 | in
profile
configure a Modulation modulation-profile 6
Profile request atdma qpsk off 64 0 16 338 configure cable modulation profile 6 iuc
0 16 fixed on 1 1536 qpsk0 request mod qpsk prelen 64 diff false fec-
tbytes 16 seed 338 burst-len 0 scrambler
true guard-time-size 16 int-depth 1536
pre-type qpsk0 docsis-mode atdma

initial atdma qpsk off 640 5 34 338 configure cable modulation profile 6 iuc
0 48 fixed on 1 1536 qpsk0 initial mod qpsk prelen 640 diff false fec-
tbytes 5 seed 338 burst-len 0 scrambler
true guard-time-size 48 int-depth 1 int-
blocksize 1536 pre-type qpsk0 docsis-
mode atdma

station atdma qpsk off 384 5 34 338 configure cable modulation profile 6 iuc
0 48 fixed on 1 1536 qpsk0 station mod qpsk prelen 385 diff false fec-
tbytes 5 seed 338 burst-len 0 scrambler
true guard-time-size 48 int-depth 1 int-
blocksize 1536 pre-type qpsk0 docsis-
mode atdma

a-short atdma qpsk off 104 12 75 configure cable modulation profile 6 iuc
338 13 8 shortened on 0 2048 a-short mod qpsk prelen 104 diff false
qpsk1 fec-tbytes 12 seed 338 burst-len 13
scrambler true guard-time-size 8 int-
depth 2048 pre-type qpsk1 docsis-mode
atdma

a-long atdma qpsk off 104 16 223 configure cable modulation profile 6 iuc
338 0 8 shortened on 0 2048 qpsk1 a-long mod qpsk prelen 104 diff false fec-
tbytes 16 seed 338 burst-len 0 scrambler

18
true guard-time-size 8 int-depth 2048
pre-type qpsk1 docsis-mode atdma

ugs atdma qpsk off 104 16 223 338 configure cable modulation profile 6 iuc
0 8 shortened on 0 2048 qpsk1 augs mod qpsk prelen 104 diff false fec-
tbytes 223 seed 338 burst-len 0 scrambler
true guard-time-size 8 int-depth int-
blocksize 2048 pre-type qpsk1 docsis-
mode atdma

configure cable modulation-profile <id>


iuc <interval usage code> [mod <qpsk
|qam8
|qam16|qam32|qam64|qam128>] [pre-
len <preamble len>] [diff <true|false>]
[fec-tbytes <no of bytes>]
[fec-len <FEC code word length>] [seed
<scrambler seed>] [burst-len <max burst
len>] [last-cw
<true|false>] [scrambler <true|false>]
[guard-time-size <0|8–96|no>] [int-depth
<depth>]
[int-blocksize <blocksize>] [pre-type
<preamble type>] [tcm <on|off>] [int-
stepsize <stepsize>]
[spreader <on |off>] [subframe-code
<subframe size>] [docsis-mode <tdma |
atdma | tdma-atdma>]

Small Signal
Compensation
enable Small Signal small-signal-compensation
Compensation

19
Casa commands ARRIS commands
Load Balancing and
Channel Bonding
Configurations
configure Service Groups service group CCAPx_FNA MAC Domain Cable Modem Service
upstream 13/0.0 Groups (MD-CM-SGs) are calculated
upstream 13/0.1 automatically by the E6000 CER based on
upstream 13/0.2 the channel-to-fibernode and channel-to-
upstream 13/0.3 MAC-domain provisioning. The E6000 CER
qam 0/0/0 will automatically create a general load
qam 0/0/1 balancing group for each MAC Domain-
qam 0/0/2 Cable Modem-Service Group (MD-CM-
qam 0/0/3 SG).
qam 0/0/4
qam 0/0/5
qam 0/0/6
qam 0/0/7

enable Load Balancing load-balance enable configure cable load-balance enable


configure cable load-balance general-
group-defaults init-technique ranging
load-balance execution-rule 1
method modem
method utilization dynamic No matching ARRIS capability. Dynamic
threshold load 10 enforce 20 load balancing is based on % of load, not
minimum 20 dynamic minimum 60 on number of modems.

load-balance policy 1
rule execution 1

load-balance general-group default-


settings
enable
initial-tech broadcast-ranging
policy-id 1
clear cable modem reset

show load-balance static show cable load-balance

20
Casa commands ARRIS commands
Channel Bonding
confirm Bonding Note: channel bonding is enabled by Note: channel bonding must be explicitly
default in any intersection of a enabled with the commands below.
DOCSIS MAC domain and a service
group. configure interface cable-mac 1
cable dynamic-rcc
configure interface cable-mac 1
cable downstream-bonding-group
dynamic enable
configure interface cable-
upstream 1/0/0 cable supervision
12/0/0-3
configure interface cable-
upstream 1/0/1 cable supervision
12/0/0-3
configure interface cable-
upstream 1/0/2 cable supervision
12/0/0-3
configure interface cable-
upstream 1/0/3 cable supervision
12/0/0-3

show cable modem


show cable modem bonding show cable bonding-group-status
show cable channel-sets
show downstream channel set
show upstream channel set

Partial Service
configure Partial Service cable cm-status-report event-list
best practices 1,4,7,8
show cable modem cm-status log
cable partial-service continue- configure cable global recover-US-
ranging impaired-ack

CCAP/CM Diagnostics
display statistics for RFI show interface qam brief show interface cable
interfaces show interface qam stat show interface cable-mac [<mac>] bit-
rate
show interface upstream brief show interface cable-upstream
show interface upstream stat

21
Casa commands ARRIS commands
Diagnostic Mode Interface
Commands
check gige interface errors show module 0 stat gige
show memory on a show module <module #> stat show memory <slot> detail
downstream module himem
show downstream card show module <module #> stat qam
statistics
show upstream card show interface upstream 13/0.0
statistics stat
enable logging of logging debugging
debugging messges
turn on CM debugging debug cable macaddress <mac trace logging modem <mac address>
address> verbose
clear cable modem <mac address> clear cable modem <mac address>
reset
debug cable
turn off logging and no logging clear logging debug
debugging no debug cable

Cable Modem Show


Commands
show cable modem show cable modem
show cable modem verbose show cable modem detail
show cable modem mac show cable modem summary mac
show cable modem verbose | inc
Stn
show cable modem verbose | inc
US
show cable modem verbose | inc
DS
show cable modem verbose | inc
Online
show cable modem counters
show cable modem errors show cable modem errors
show cable modem dropped show cable modem dropped
show docsis downstream channel
utilization
show cable modem docsis-mac 1
service-group FNA downstream
throughput
show upstream signal-quality
show spectrum upstream 13/0
show upstream burst-noise
show cable modem partial service show cable modem bonded-impaired

22
Casa commands ARRIS commands
Remote Query
perform a Remote Query cable modem remote-query 30 configure cable modem remote-query 30
show cable modem remote-query show cable modem phy
immediate
show cable modem <mac address |
ip address> remote-query verbose
immediate

DOCSIS Ping
issue a DOCSIS ping ping docsis <mac address> ping docsis <mac address>

Cable Flap List


configure the Cable Flap show cable flap-list config show cable flap-list
list cable flap-list power-adjust configure cable flap-list power-adjust
threshold 1 threshold 10
cable flap-list miss threshold 7
cable flap-list insertion-time 90 configure cable flap-list insertion-time 90

23
100 Old River Road Suite 100
Andover, MA 01810 USA
978-688-6706

Casa Educational Services


© 2016 Casa Systems, Inc.
All rights reserved.

You might also like