You are on page 1of 5

LAB GUIDE

VRF FUNDAMENTALS
VIRTUAL ARUBAOS-CX IN GNS3
Important! This guide assumes that the ArubaOS-CX OVA has been installed in VirtualBox and a template has been
created in GNS3.

PART 1 -LAB SETUP

Figure 1. Initial Lab network layout

Setting Up the initial network

In GNS3 create the topology shown in Figure 1.


• Start the network
• Open each console and log in with user “admin” and no password
• Change the switches’ hostname to 8400-1 and 8400-2 respectively
configure
hostname . . .
end

LAYER 2 CONFIGURATION
• On both devices, configure the VLANs and a LAG between the switches
Note: VLANs/SVIs are required to transport VRFs using 802.1Q tags
configure
vlan 101,102
!
interface lag 100
no shutdown
no routing
lacp mode active
vlan trunk allow 101,102
interface 1/1/1
no shutdown
mtu 2048
lag 100
interface 1/1/2
no shutdown
mtu 2048
lag 100
end

• Verify, on switch 8400-1, display the interfaces


show interface brief

The output should be

1
----------------------------------------------------------------------------------
Port Native Mode Type Enabled Status Reason Speed
VLAN (Mb/s)
----------------------------------------------------------------------------------
1/1/1 1 trunk -- yes up 1000
1/1/2 1 trunk -- yes up 1000
1/1/3 -- routed -- no down Administratively down --
1/1/4 -- routed -- no down Administratively down --
1/1/5 -- routed -- no down Administratively down --
1/1/6 -- routed -- no down Administratively down --
lag100 1 trunk -- yes up -- 2000

• Then display LLDP information


show lldp neighbor-info
LLDP Neighbor Information
=========================

Total Neighbor Entries : 2


Total Neighbor Entries Deleted : 0
Total Neighbor Entries Dropped : 0
Total Neighbor Entries Aged-Out : 0

LOCAL-PORT CHASSIS-ID PORT-ID PORT-DESC TTL SYS-NAME


--------------------------------------------------------------------------------
1/1/1 08:00:09:62:94:0e 1/1/1 1/1/1 120 8400-2
1/1/2 08:00:09:62:94:0e 1/1/2 1/1/2 120 8400-2

• LACP aggregation
show lacp aggregates
Aggregate-name : lag100
Interfaces : 1/1/1 1/1/2
Heartbeat rate : slow
Hash : l3-src-dst
Aggregate mode : active

• And interfaces
show lacp interfaces

State abbreviations :
A - Active P - Passive F - Aggregable I - Individual
S - Short-timeout L - Long-timeout N - InSync O - OutofSync
C - Collecting D - Distributing
X - State m/c expired E - Default neighbor state

Actor details of all interfaces:


------------------------------------------------------------------------------
Intf Aggr Port Port State System-id System Aggr Forwarding
Name Id Pri Pri Key State
------------------------------------------------------------------------------
1/1/1 lag100 2 1 ALFNCD 08:00:09:14:23:66 65534 100 up
1/1/2 lag100 3 1 ALFNCD 08:00:09:14:23:66 65534 100 up

Partner details of all interfaces:


------------------------------------------------------------------------------
Intf Aggr Port Port State System-id System Aggr
Name Id Pri Pri Key
------------------------------------------------------------------------------
1/1/1 lag100 2 1 ALFNCD 08:00:09:62:94:0e 65534 100
1/1/2 lag100 3 1 ALFNCD 08:00:09:62:94:0e 65534 100

2
LAYER 3 CONFIGURATION
Configure the VRFs and VLAN interfaces (SVIs).
• On the 8400-1 switch
configure
vrf VRF101
router ospf 11 vrf VRF101
area 0
interface loopback 101
vrf attach VRF101
ip address 1.101.1.1/32
ip ospf 11 area 0
interface vlan 101
vrf attach VRF101
ip address 10.101.1.1/24
ip ospf 11 area 0
!
vrf VRF102
router ospf 12 vrf VRF102
area 0
interface loopback 102
vrf attach VRF102
ip address 1.102.1.1/32
ip ospf 12 area 0
interface vlan 102
vrf attach VRF102
ip address 10.102.1.1/24
ip ospf 12 area 0
!
end

• On the 8400-2 switch


configure
vrf VRF101
router ospf 11 vrf VRF101
area 0
interface loopback 101
vrf attach VRF101
ip address 1.101.1.2/32
ip ospf 11 area 0
interface vlan 101
vrf attach VRF101
ip address 10.101.1.2/24
ip ospf 11 area 0
!
vrf VRF102
router ospf 12 vrf VRF102
area 0
interface loopback 102
vrf attach VRF102
ip address 1.102.1.2/32
ip ospf 12 area 0
interface vlan 102
vrf attach VRF102
ip address 10.102.1.2/24
ip ospf 12 area 0
!
end

• Verify the configuration


o On each switch:
show vrf

3
The output should be:
VRF Configuration:
------------------
VRF Name : default
Interfaces Status
-----------------------------

VRF Name : VRF101


Interfaces Status
-----------------------------
loopback101 up
vlan101 up

VRF Name : VRF102


Interfaces Status
-----------------------------
loopback102 up
vlan102 up

o On the 8400-1
show ip ospf neighbor vrf VRF101

The output should be:


OSPF Process ID 11 VRF VRF101
==============================

Total Number of Neighbors: 1

Neighbor ID Priority State Nbr Address Interface


-------------------------------------------------------------------------
1.101.1.2 1 FULL/BDR 10.101.1.2 vlan101

And
show ip ospf neighbor vrf VRF102

with output
OSPF Process ID 12 VRF VRF102
==============================

Total Number of Neighbors: 1

Neighbor ID Priority State Nbr Address Interface


-------------------------------------------------------------------------
1.102.1.2 1 FULL/BDR 10.102.1.2 vlan102

• Test intra-vrf connectivity using ping. For example, on the 8400-1


ping 10.101.1.2 vrf VRF101

The ping should work.


Repeat for the 8400-2.

4
3333 Scott Blvd. | Santa Clara, CA 95054
1.844.472.2782 | T: 1.408.227.4500 | FAX: 1.408.227.4550 | info@arubanetworks.com

www.arubanetworks.com 5

You might also like